gelöst Speedport W 724V + Routerboard 450G + VDSL (all IP) + Entertain

Mitglied: loggedin

loggedin (Level 1) - Jetzt verbinden

03.02.2015, aktualisiert 17:43 Uhr, 10984 Aufrufe, 6 Kommentare

Hallo, ich habe hier ein kleines Problemchen.

An einen Telekom VDSL-Anschluss, der über ein Speedport W 724V verbunden ist, möchte ich ein Routerboard dranhängen, der das LAN vom Speedport abkoppelt.

Derzeit ist ein Netgear GS108E-100PES ProSafe am Speedport dran, und von dort aus wird alles in's Haus verteilt. Am Switch ist im ersten Port der Speedport verbunden, der MediaReceiver 303 am 2. Port, und andere Geräte an den weiteren Ports.

Klappt alles wunderbar, meistens zumindest, da sich manchmal ein Gigaset 430 IP nicht bei Sipgate registrieren kann. Darum geht es aber nicht.

Nun möchte ich zwischen den Switch und dem Speedport ein Routerboard setzen.

Speedport (192.168.2.1, DHCP aus) <----> Routerboard eth1 (192.168.2.11)

Routerboard eth2 (192.168.10.1) <----> Switch

Im 192.168.10.0/24 Subnet ist ein DHCP-Server, der an alle Geräte IP's im 192.168.10.0/24 Subnet zuweist. Als Gateway gibt dieser den Clients die IP 192.168.10.1 an.

Wenn im Routerboard ein srcnat masquerade auf eth1 aktiv ist, dann klappt auch alles. Alle Geräte können in's Internet, Gigaset kann sich registrieren und auch angerufen werden.

Das einzige Problem ist Entertain. Die Kanäle sind für ca 5 Sekunden empfangbar, dann friert das Bild ein. Soweit ich weiß, liegt es daran, dass der MediaRecevier dann auf Multicast-Empfang wechselt, und dieser Datenstrom kommt einfach nicht dort an. Das Routerboard reicht die Pakete also anscheinend nicht weiter.

Nun habe ich über VLAN8 gelesen, und möchte mich mal Stück für Stück an die Lösung heranarbeiten.

Habe ich es richtig verstanden, wenn ich davon ausgehe, dass der Speedport dem Routerboard die Multicast-Pakete schon untagged weitergibt? Oder haben die Pakete immer noch das VLAN8-Tag dran? Denke mal eher nicht, da die anderen Pakete ja wohl auch nicht getaggt sind, und es sich bei den Speedport-Ethernet-Ports nicht um Trunks handelt.

Löst sich das Problem dann, indem im Routerboard ein IGMP-Proxy eingerichtet wird? Ich hatte leider keine Möglichkeit, das "multicast"-package zu installieren, werde das aber noch nachholen.

Wieso kann das Routerboard die Multicasts nicht einfach so weiterleiten, ohne der Hilfe eines IGMP-Proxies? Ich hatte schlechtes über den Proxy gelesen (10 Sekunden Umschaltzeit), und wenn's ohne gehen würde, würde ich das lieber so machen.

Vielen Dank im Voraus.

Mit freundlichen Grüßen, Daniel
Mitglied: aqui
03.02.2015, aktualisiert um 18:06 Uhr
Du brauchst PIM Routing bzw. Multicast Routing auf dem Router um Entertain zu empfangen. Mit dem Mikrotik funktioniert das wunderbar.
Sinnvoll wäre den 724V nicht als Router sondern als simples Modem laufen zu lassen um das PPPoE direkt auf dem Router zu terminieren und eine Router Kaskade zu vermeiden.
Ansonsten geht es aber auch mit Kaskade allerdings der Entertain Zweig muss dann aktive Multicasting machen.
Hier findest du ein Paar Grundlagen:
Nur Modem an VDSL:
https://www.administrator.de/wissen/preiswerte-vpn-fähige-firewall- ...
https://www.administrator.de/forum/vdsl-einwahl-router-w723v-modem-17521 ...
Multicasting und Entertain:
https://www.administrator.de/wissen/konfiguration-cisco-886va-adsl-vdsl- ...
Ist ursprünglich für einen Cisco Router kann man aber auf andere Multicast fähige Router problemlos übertragen.
Das es mit dem Mikrotik grundsätzlich geht kann man vielen Postings im Netz entnehmen:
http://www.computerbase.de/forum/showthread.php?t=1232558
usw.
Wieso kann das Routerboard die Multicasts nicht einfach so weiterleiten, ohne der Hilfe eines IGMP-Proxies?
Dazu müsste man jetzt hier ein IP Multicasting Kurs mit dir machen was den Rahmen des Forums sprengt. Auf YouTube usw. findest du gute HowTos. (Stormwind)
Bitte warten ..
Mitglied: loggedin
03.02.2015 um 18:26 Uhr
Danke schonmal für die Antwort. Das multicast-package habe ich nun auf dem RouterBoard installiert, allerdings ist das Netzwerk ein paar Kreuzungen von hier entfernt, so dass ich es noch nicht ausprobieren kann. Die Links habe ich mir noch nicht durchgelesen.

Als ich das Problem mit Gigaset VoIP / Sipgate in's extrem hatte, telefonierte ich viel mit der Telekom rum um das Problem zu lösen, und die meinten ich könnte die Firmware des Speedports downgraden, um es dann als Modem zu benutzen, da die aktuellen Versionen dies nicht mehr unterstützen. Einerseits wollte ich das nicht machen, da es ein Mietgerät ist, und anderseits würde dann das WLAN-to-Go nicht mehr nutzbar sein. Auf das WLAN-to-Go möchte ich nicht verzichten. (Firmware downgraden wäre nicht so das Problem, ich hatte zuvor eine FritzBox auf der Freetz lief)

Bei meinem KabelBW-Anschluss betreibe ich schon seit Monaten ein Doppel-NAT ohne Probleme, und möchte das auch so an diesen Telekom-Anschluss machen.

Kannst Du mir kurz sagen, ob an den Ports des Speedports alle Pakete ungetaggt sind, also ohne VLAN-Tags?

Danke für deine Infos.

Viele Grüße,
Daniel
Bitte warten ..
Mitglied: aqui
07.02.2015 um 19:00 Uhr
Das ist schwer zu sagen. Die Speedports verhalten sich da alle unterschiedlich ! Manche taggen, manche nicht da muss das Endgerät taggen.

Um ganz sicher zu gehen solltest du mit einem Wireshark nachsehen...
Bitte warten ..
Mitglied: loggedin
15.02.2015, aktualisiert 05.03.2015
OK, danke.

Ich hatte nun endlich die Möglichkeit das RouterBoard in's zu Netzwerk zu integrieren, und kann bestätigen, dass es mit dem IGMP-Proxy astrein funktioniert, kein Unterschied zur Direktverbindung mit dem Speedport.

---> Wichtig 1: Beim IGMP-Proxy musste ich im Upstream-Interface das Alternative-Subnet 193.158.35.0/24 hinzufügen. Das hatte ich im MFC-Tab als Source gefunden.

---> Wichtig 2: In der Firewall-Regel durfte keine DROP-Input-Regel vom Port an den der Speedport angeschlossen ist aktiv sein, da sonst das Bild alle 150 Sekunden ( 2:30 Minuten ) einfriert (dann kann man den Kanal schalten, um die Sache wieder für 150 Sekunden zum laufen zu bringen). Diese Regel ist irgendwie umzugestalten oder zu deaktivieren, falls das Routerboard in Kaskade läuft.

Bei'm anschauen eines HD-Senders beträgt die CPU Load maximal 1%.

Ich werden demnächst mal checken wie es mit zusätzlichen Clients, etwa mit VLC über WLAN, funktioniert.

Hinter'm Speedport haben die IPTV-Pakete laut dem Packet Sniffer des RouterBoards kein VLAN-Tag mehr dran.

Hier ein Paket:

Time 3.305 s
Interface e1-inet
Direction rx
Src. MAC Address xx:xx:xx:xx:xx
Dst. MAC Address xx:xx:xx:xx:xx
VLAN ID
Src. Address 193.158.35.251
Src. Port 47811
Dst. Address 239.35.10.3
Dst. Port 10000
Protocol 2048 (ip)
IP Protocol 17 (udp)
Size 1370
IP Packet Size 1356
IP
IP Header Size 20
TOS 32
Fragment Offset 0
TTL 25
Identification 0
Bitte warten ..
Mitglied: aqui
15.02.2015, aktualisiert um 16:07 Uhr
Klasse das es klappt ! Dank für dein hilfreiches Feedback !
Hast du mal ein Setup Screenshot vom WebGUI oder der Winbox zum Setup was du hier posten könntest ? Vor allen Dingen die Info ob du den SP nun als dummes nur Modem vor dem MT laufen lässt oder in einer Router Kaskade mit dem MT ?
Dann kann man das mit ins Tutorial aufnehmen als Link.
Bitte warten ..
Mitglied: loggedin
05.03.2015, aktualisiert 06.03.2015
Ich habe es (bewusst) kaskadiert. Den Speedport will ich weilterhin am laufen haben wegen dem "WLAN to Go". Der Router kam hin da ich selber eine Route setzen musste, die für das ganze Intranet gelten soll, und ausserdem hat so ein Routerboard dann ja auch noch tausdende Goodies die das Heimnetz erst richtig interessant machen (Accounting, Queues/QoS, Grafiken usw).

Aber ich schreibe aus einem anderen Grund:

WICHTIG: Per default wird auf dem ersten Port (ether1) eine Firewall-Regel erstellt, die lautet "Chain: input", "In. Interface: ether1", "Action: drop". Das ist insofern sinnvoll, da dies im Normalfall, wenn ether1 an einem reinen Modem hängt, verhindert, dass jemand vom Internet her den Router konfigurieren kann.

Im Falle der Kaskade, mit dem Speedport am ether1, könnte man meinen: was will denn der Speedport schon vom Router. ABER: der IGMP-Proxy braucht das! D.h. diese Regel ist entweder zu deaktivieren, oder irgendwie umzugestalten. DENN: Ich war soeben eine Stunde damit beschäftigt, Entertain zu "reparieren", da alle 150 Sekunden das Bild einfror (Kanalwechsel war dann die Lösung des Problems für die nächsten 150 Sekunden). Als ich dann alles durchging (DHCP-Server, Speedport, usw), sah ich diese DROP-Regel und erinnerte ich mich daran, dass ich diese vor so 2 Tagen mal aktiviert hatte, im Zuge einer abschließenden Netzwerkkonfiguration. War schon komisch an dieser Regel einen 9Mbps-Datenstream komplett gedroppt zu sehen, und Entertain lief trozdem, so halbwegs...

ALSO: Vorsicht vor einer DROP-Input Regel am speedportseitigen Ethernet Port bei eingeschaltenen IGMP-Proxy, denn sonst friert bei Entertain alle 150 Sekunden das Bild ein.
Bitte warten ..
Heiß diskutierte Inhalte
Ubuntu
HAProxy-Wi: Installation des Pakets geht nicht - ich hätte keine enabled Repos
itnirvanaFrageUbuntu37 Kommentare

Hallo, von der Seite möchte ich gerne HAProxy-Wi installieren ich führe das hier aus Dann kommt -> There ar ...

Multimedia
Fernseher im Empfang GEMA-pflichtig?
CaptainDuskyFrageMultimedia27 Kommentare

Guten Tag, wenn ich in einer Firma einen Fernseher im Empfang betreibe, dort aber nur Nachrichten laufen lasse, ist ...

LAN, WAN, Wireless
Wlan Messgerät
gelöst fizlibuzliFrageLAN, WAN, Wireless23 Kommentare

Hallo, gibt es erschwingliche Messgeräte um vorhanden W-Lan ausleuchtungen in ihrer Signalstärke und Bandbreite zu messen. Es sollen einfache ...

Windows Server
PowerShell Script für MailVersand mit Anhang
gelöst klausk94FrageWindows Server20 Kommentare

Hallo Zusammen, ich bin aktuell etwas am verzweifeln an einem PS Script für den Emailversand Das Script funktioniert, jedoch ...

Microsoft
Failover Cluster Network
samreinFrageMicrosoft20 Kommentare

Hallo zusammen, toller Freitag heute vielleicht kann mir jemand unter die Arme greifen. Ich habe einen Failover Cluster gebaut. ...

Router & Routing
Kaufempfehlung WLAN Router mit VLAN Unterstützung
ccreccFrageRouter & Routing18 Kommentare

Hallo zusammen, ich wollte mal nach einer Kaufempfehlung für einen WLAN Access Point mit halbwegs vernünftiger VLAN Unterstützung fragen. ...

Ähnliche Inhalte
MikroTik RouterOS

Speedport W 724V + MikroTik Routerboard 450G + VDSL (all IP) + MagentaTV Entertain v2

loggedinFrageMikroTik RouterOS13 Kommentare

Hallo, ich hatte damals folgendes Problem Speedport W 724V + Routerboard 450G + VDSL (all IP) + Entertain und ...

Router & Routing

Mikrotik DUAL WAN mit Telekom VDSL und Entertain

ITAllrounderFrageRouter & Routing6 Kommentare

Hallo zusammen, hier im Forum gibt es etliche Anleitungen dazu aber ich scheitere wohl schon am Grundgedanken. Folgender IST-Zustand: ...

DSL, VDSL

Cisco IOS Entertain IP-TV Konfig ?

gelöst aquiFrageDSL, VDSL55 Kommentare

Kurze Frage an die Forums Community die einen Cisco IOS Router mit Entertain TV benutzen. Ich habe aktuell einen ...

Router & Routing

Dual-WAN VDSL-Cable mit Telekom Entertain und mieser Verkabelung

gelöst pasu69FrageRouter & Routing10 Kommentare

Hallo zusammen, nach 14 Tage basteln, vielen Erfolgen und noch mehr Rückschlägen brauche ich Hilfe Ich hoffe, die Grafik ...

DSL, VDSL

PfSense 2.4.1 an Telekom Entertain 50MBit VDSL BNG, IPTV funktioniert nicht

gelöst stefanxxFrageDSL, VDSL12 Kommentare

Moin, ich habe mir die bestehenden Beitrag angesehen, habe wohl eher ein grundsätzliches Problem mit den Einstellungen, weiß aber ...

Internet

VDSL-Anbieter mit statischen IP-Adressen

MartinStrasserFrageInternet13 Kommentare

Hallo, ich bin auf der Suche nach einem VDSL-Anbieter, welcher auch statische IP-Adressen mit anbietet. Telefon oder Ähnliches wird ...

Berechtigungs- und IdentitätsmanagementBerechtigungs- und IdentitätsmanagementWebdienste und -serverWebdienste und -serverDatenbankenDatenbankenMonitoring & SupportMonitoring & SupportHybrid CloudHybrid CloudSmall Business ITSmall Business IT