Server 2008 - Netzlaufwerke beim Start per Script

Mitglied: Jorge2

Jorge2 (Level 1)

24.02.2010 um 22:15 Uhr, 9397 Aufrufe, 6 Kommentare

Ich habe einen Server 2008R2 eingerichtet und möchte jetzt, dass jeder Benutzer bei der Anmeldung die Laufwerke zugeordnet bekommt. Ich habe dazu ein Script geschrieben und dem Benutzer im AD unter dem Profil-Reiter abgelegt. Bei der Anmeldung passiert aber nichts. Alle Ordner sind unter "netzwerk" ersichtlich, natürlich kann der angemeldete Benutzer nur die freigegebenen öffnen.
Ich möchte aber, dass die Laufwerke unter "Computer" zu sehen sind, deshalb das Script.

Wer kann mir helfen? Ich habe gehört, dass beim Server 2008 dies nur unter GPO möglich ist, stimmt das und wenn ja wie kann ich das einstellen?

Danke.
Mitglied: Pjordorf
25.02.2010 um 04:17 Uhr
Hallo Jorge2,

poste doch mal dein Laufwerkszuordnungsscript. Mal sehen was daran falsch sein könnte.

Peter
Mitglied: guennie
25.02.2010 um 08:57 Uhr
Guten Morgen,

es geht nicht nur über die Gruppenrichtlinie. Du hast es richtig hinterlegt und zwar im AD unter Benutzer Reiter Profil.

echo %DATE%,%TIME%,%USERNAME%,%COMPUTERNAME% >> \\server\daten\Anmeldungen.csv
net time \\server /set /yes
NET USE * /d/y
Net Use /persistent:no
NET USE L: \\server\daten
NET USE M: \\server\dokumente

usw.

Das ist ein Beispiel für ein Anmeldescript. Du kannst natürlich soviele Laufwerke mappen wie du magst.

Speichern musst du das ganze unter "C:\Windows\Sysvol\sysvol\domaene.local\scripts". Domaene steht hier für den namen deiner Domaene.

So sollte es eigentlich klappen.

mfg
Mitglied: DerWoWusste
25.02.2010 um 23:00 Uhr
Moin.
Und wo melden sich die Herren an? Am Server oder auf Win7-Clients, oder...? Was für ein Skript, .vbs oder .bat?
Seltsamerweise habe ich schon mehrfach gelesen, dass die UAC auf win7 das Verbinden von Netzlaufwerken mit net use verhindert, wenn eingeschaltet - konnte es selbst jedoch noch nicht reproduzieren ->dennoch einen Versuch wert.
Mitglied: Jorge2
26.02.2010 um 09:59 Uhr
Hier mein einfaches Script:

echo off
net use m: \\domaene\kundenagentur
net use n: \\domaene\agenturdaten
net use o: \\domaene\allgemein
exit

Wenn ich einen Client mit XP-Prof ins Netz stelle und ein User sich anmeldet muss ich das script einmal händisch öffnen, dann hat er die Laufwerke bei jeder Anmeldung zugeordnet.

Das Script liegt in \\Servername\SYSVOL\domaene\scripts und auf dem Server habe ich diesen Pfad beim Benutzer unter "Profil-Anmeldescript" hinterlegt.
Mitglied: Pjordorf
26.02.2010 um 10:18 Uhr
Hallo Jorge2,

Zitat von Jorge2:
Hier mein einfaches Script:

echo off
Mach daraus mal ein
01.
rem @echo off
net use m: \\domaene\kundenagentur
net use n: \\domaene\agenturdaten
net use o: \\domaene\allgemein
Und hier noch ein
01.
pause
exit
Dann siehst du was wo falsch läuft.

Wenn ich einen Client mit XP-Prof ins Netz stelle und ein User sich anmeldet muss ich das script einmal händisch öffnen,
dann hat er die Laufwerke bei jeder Anmeldung zugeordnet.
Fehlende Rechte?

Das Script liegt in \\Servername\SYSVOL\domaene\scripts und auf dem Server habe ich diesen Pfad beim Benutzer unter
"Profil-Anmeldescript" hinterlegt.
Welche Endung hat die Datei?

Peter
Mitglied: linguin
21.03.2010 um 03:44 Uhr
Hi,

wir Verbinden Usere Laufwerke auch so .. geht wunderbar ...

rem @echo off
net use x: /delete trennt das laufwerk aber vorher
net use x: \\xx.xxx.xxx.xx\freigabe /user:user passwort
verbindet es wieder ...

wir hatten am anfang auch probleme hat erst richtig gefunz wenn wir das laufwerk beim start trennen. weil man weiß nie wie der user seinen rechner ausschaltet .. manche machen das mit dem kippschalter auf der verteilerdose .. ...
Titel: Server 2008 - Netzlaufwerke beim Start per Script
Content-ID: 136803
Art des Inhalts: Frage
Ausgedruckt am: 21.09.2019 um 08:50:49 Uhr
URL: https://administrator.de/contentid/136803