Bild das über Batch hochgeladen wird ist weiß

Mitglied: Helgon

Helgon (Level 1)

05.10.2011, aktualisiert 08:47 Uhr, 2441 Aufrufe, 3 Kommentare

Hi. Das Problem ist, dass wenn ich ein Bild via Batch Script hochlade, dass Bild zwar physisch auf dem Server liegt, wenn ich es aber aufrufe einfach weiß bleibt.

Das da was ist, ist aber klar. Die URL wird aufgerufen und wenn das Bild zu groß ist, kommt sogar das vergrößern/kleiner Icon an der Maus.
Ich kann das Bild sogar runterladen (speichern). Das Format stimmt auch. Als .jpg hochgeladen sowie runtergeladen.
Wenn ich dann aber das zuvor hochgeladene und dann wieder runtergeladene Bild öffnen möchte klappt das auch aufm PC nicht (nicht nur aufm Webspace nicht).

Als Fehler: "Das Bild kann nicht geöffnet werden, da das Dateiformat [...] nicht unterstützt wird"

wird aufgerufen über:

ftp.exe -n -s:_src\messages.ftp

// *

OPEN ftp.bla.de
USER bla.de
passwordxy

cd /bla/_src
send _src/jquery-1.6.4.min.js
send _src/style.css

cd ../heute
send heute/index.html

cd ../morgen
send morgen/index.html

cd ../_img
send _img/header.jpg


disconnect
bye

Wie gesagt. Hochgeladen wird alles korrekt. Nur das sich die .jpg's irgendwie verändern, sodass ich diese nicht mehr sehen kann

Grüße
3 Kommentare
Mitglied: bastla
05.10.2011 um 10:31 Uhr
Hallo Helgon und willkommen im Forum!

Vielleicht solltest Du zur Sicherheit vor dem Hochladen des Bildes im Script auf
umschalten ...

Grüße
bastla

P.S.: Wenn Du (sicherlich ;-) face-wink) auch Dein Script passend formatiert darstellen möchtest: https://www.administrator.de/helpsystem/detail.php?idx=20#toc28 (geht auch im Nachhinein) ...
Mitglied: Helgon
05.10.2011 um 19:52 Uhr
Hey, das hat tatsächlich geholfen! :) face-smile

Vielen Dank!

Macht es sinn, dass in jeder FTP Datei vor die Uploads zu schreiben?

Grüße
Mitglied: bastla
05.10.2011 um 21:46 Uhr
Hallo Helgon!
Macht es sinn, das in jeder FTP Datei vor die Uploads zu schreiben?
Wenn Du Binärdateien versenden willst: ja.

Grüße
bastla