WDS Netzwerkadapter Treiber wird nicht geladen

Mitglied: xcabur

xcabur (Level 1)

27.08.2013 um 20:25 Uhr, 4164 Aufrufe, 1 Kommentar

Hallo zusammen

Habe nochmals eine Frage zu einem Phänomen beim WDS Server 2012.

Ich habe das boot.wim von einer Windows 8 Ent ISO genommen und mit dism und Add-Driver die NIC Treiber nachgeladen. Das Image im WDS als Startabbild hinzugefügt und daraus ein Aufzeichnungsabbild kreiert. Ich lade das Image via PXE und erhalten keine Netzwerkverbindung im WDS Wizard. Auch das manuelle aufrufen von wpeinit, netcfg -v -winpe oder wpeutil initializenetwork können die Netzwerkverbindung herstellen. ipconfig -all gibt keinen Netzwerkadapter aus.

Ich lade das Boot Image von winpe 4.0 (winpe.wim) und mithilfe von dism und Add-Package erweitere ich es um die WDS-Tools, danach mit Add-Driver die NIC Treiber nachladen. Das Image im WDS als Startabbild hinzugefügt und daraus ein Aufzeichnungsabbild kreiert. Also genau gleich (ausser den WDS-Tools) wie beim boot.wim.
Wenn ich jetzt das Image via PXE starte wird beim Verbinden im WDS Wizard das Netzwerk erfolgreich initialisiert.

Wenn ich übrigens die Treiber dem Aufzeichnungsabbild (Windows 8 ISO boot.wim) via Treiberpaket Manager im WDS hinzufüge, erhalte ich ein Bluescreen beim Laden des Images via PXE.

Kann mir das jemand erklären?
Mitglied: ollioe
03.09.2013 um 14:45 Uhr
Hi,
wenn ich es richtig verstanden habe hast du zuerst Inject Drivers per dism ausgeführt. Mit diesem Startabbild lässt sich kein Client starten?
Stellt sich die Frage ob die Treiber "sauber" entpackt und integriert wurden. Wenn WinPE keinen NIC anzeigt, dann wurden die Treiber nicht geladen.

Nun liest es sich so als würdest du nach dem Driver Inject per Wizard (Aufzeichnungsabbild hat ja bereits die Treiber per dism erhalten) zusätzlich Treiber installieren. Dann ist ein BSOD anzunehmen, da mehrere Versionen eines Treiber installiert wurden.

Einfacher wäre doch: Startabbild hinzufügen, NIC Treiber über die WDS Konsole hinzufügen und dann dem Startabbild zuweisen. Ist definitiv weniger für Fehler anfällig als manuell per dism.
Titel: WDS Netzwerkadapter Treiber wird nicht geladen
Content-ID: 215364
Art des Inhalts: Frage
Ausgedruckt am: 29.02.2020 um 08:14:20 Uhr
URL: https://administrator.de/contentid/215364