gelöst Windows 8 Hyper-V virtueller Switch keine Internetverbindung am Host und in der VM

Mitglied: manuel1985

manuel1985 (Level 2)

16.10.2013 um 21:24 Uhr, 5583 Aufrufe, 6 Kommentare

Guten Abend Mitstreiter,

ich spiele gerade das erste Mal mit der Hyper-V Funktion in Windows 8 herum. Vom Server bereits altbekannt, daher dachte ich "halb so wild, schnell eingerichtet". Problem: Ich richte einen externen virtuellen Switch für die VMs ein, konfiguriere meine WLAN-Karte am Notebook als Schnittstelle zur Außenwelt und sobald der Switch angelegt ist, ist die Verbindung zum Netzwerk/Internet getrennt.
IP wird per DHCP bezogen, die Kabelverbindung kann ich hier baulich bedingt gerade nicht testen.
Notebook ist ein HP EliteBook 8540p.

Hat jemand eine Idee, warum sich die Netzwerk-Config so zerlegt?

Gruß Manuel
Mitglied: hcfel1
16.10.2013 um 22:46 Uhr
poste mal ipconfig /all

hast du statische IPs im netz? ein virtueller switch bekommt eine virtuelle MAC, also eine neue IP vom DHCP....
Mitglied: manuel1985
17.10.2013 um 06:44 Uhr
Moin,

anbei die IP-Konfiguration mit aktiviertem Hyper-V Switch auf der WLAN-Karte:

Windows-IP-Konfiguration

Hostname . . . . . . . . . . . . : KITNB01
Primäres DNS-Suffix . . . . . . . :
Knotentyp . . . . . . . . . . . . : Hybrid
IP-Routing aktiviert . . . . . . : Nein
WINS-Proxy aktiviert . . . . . . : Nein

Ethernet-Adapter Bluetooth-Netzwerkverbindung:

Medienstatus. . . . . . . . . . . : Medium getrennt
Verbindungsspezifisches DNS-Suffix:
Beschreibung. . . . . . . . . . . : Bluetooth-Gerät (PAN)
Physische Adresse . . . . . . . . : 00-27-13-BE-29-C1
DHCP aktiviert. . . . . . . . . . : Ja
Autokonfiguration aktiviert . . . : Ja

Ethernet-Adapter Ethernet:

Medienstatus. . . . . . . . . . . : Medium getrennt
Verbindungsspezifisches DNS-Suffix:
Beschreibung. . . . . . . . . . . : Intel(R) 82577LM Gigabit Network Connecti
on
Physische Adresse . . . . . . . . : 70-5A-B6-A0-07-BF
DHCP aktiviert. . . . . . . . . . : Ja
Autokonfiguration aktiviert . . . : Ja

Tunneladapter Teredo Tunneling Pseudo-Interface:

Medienstatus. . . . . . . . . . . : Medium getrennt
Verbindungsspezifisches DNS-Suffix:
Beschreibung. . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
Physische Adresse . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP aktiviert. . . . . . . . . . : Nein
Autokonfiguration aktiviert . . . : Ja


Und hier die IP-Konfiguration mit Hyper-V Switch auf der LAN-Karte:

Windows-IP-Konfiguration

Hostname . . . . . . . . . . . . : KITNB01
Primäres DNS-Suffix . . . . . . . :
Knotentyp . . . . . . . . . . . . : Hybrid
IP-Routing aktiviert . . . . . . : Nein
WINS-Proxy aktiviert . . . . . . : Nein

Ethernet-Adapter Bluetooth-Netzwerkverbindung:

Medienstatus. . . . . . . . . . . : Medium getrennt
Verbindungsspezifisches DNS-Suffix:
Beschreibung. . . . . . . . . . . : Bluetooth-Gerät (PAN)
Physische Adresse . . . . . . . . : 00-27-13-BE-29-C1
DHCP aktiviert. . . . . . . . . . : Ja
Autokonfiguration aktiviert . . . : Ja

Drahtlos-LAN-Adapter WiFi:

Verbindungsspezifisches DNS-Suffix:
Beschreibung. . . . . . . . . . . : Intel(R) Centrino(R) Advanced-N 6200 AGN
Physische Adresse . . . . . . . . : 00-23-14-36-67-CC
DHCP aktiviert. . . . . . . . . . : Ja
Autokonfiguration aktiviert . . . : Ja
Verbindungslokale IPv6-Adresse . : fe80::c8f5:5588:3236:c290%13(Bevorzugt)
IPv4-Adresse . . . . . . . . . . : 192.168.0.101(Bevorzugt)
Subnetzmaske . . . . . . . . . . : 255.255.255.0
Lease erhalten. . . . . . . . . . : Donnerstag, 17. Oktober 2013 06:42:50
Lease läuft ab. . . . . . . . . . : Freitag, 18. Oktober 2013 06:42:49
Standardgateway . . . . . . . . . : 192.168.0.1
DHCP-Server . . . . . . . . . . . : 192.168.0.1
DHCPv6-IAID . . . . . . . . . . . : 318776084
DHCPv6-Client-DUID. . . . . . . . : 00-01-00-01-19-B4-9D-FE-70-5A-B6-A0-07-BF

DNS-Server . . . . . . . . . . . : 217.0.43.17
217.0.43.49
NetBIOS über TCP/IP . . . . . . . : Aktiviert

Tunneladapter Teredo Tunneling Pseudo-Interface:

Verbindungsspezifisches DNS-Suffix:
Beschreibung. . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
Physische Adresse . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP aktiviert. . . . . . . . . . : Nein
Autokonfiguration aktiviert . . . : Ja
IPv6-Adresse. . . . . . . . . . . : 2001:0:5ef5:79fb:c37:e0b:2619:8657(Bevorz
ugt)
Verbindungslokale IPv6-Adresse . : fe80::c37:e0b:2619:8657%17(Bevorzugt)
Standardgateway . . . . . . . . . : ::
NetBIOS über TCP/IP . . . . . . . : Deaktiviert

Tunneladapter isatap.{167A146F-6BA0-4644-9E15-1F46E22862C9}:

Medienstatus. . . . . . . . . . . : Medium getrennt
Verbindungsspezifisches DNS-Suffix:
Beschreibung. . . . . . . . . . . : Microsoft-ISATAP-Adapter #4
Physische Adresse . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP aktiviert. . . . . . . . . . : Nein
Autokonfiguration aktiviert . . . : Ja


Ein DHCP-Server arbeitet natürlich in meinem Netzwerk, mein Notebook bezieht daher ja seine IP.
MAC-Filter ist nicht aktiviert.

Gruß Manuel
Mitglied: Mantigul
17.10.2013 um 08:38 Uhr
Hi,

weiß nicht, ob es daran liegen kann, aber bei mir am Hyper-V Server hat es erst funktioniert, als ich an den virtuellen Clients auf dem Hyper-V bei den Netzwerkkarten --> veraltete Netzwerkkarte eingestellt hab. Warum genau kann ich leider nicht sagen. Hatte noch keine Zeit mich da intensiv einzulesen.

Viel Glück
Mitglied: manuel1985
17.10.2013 um 09:51 Uhr
OK, werde ich heute Abend mal testen.
Mitglied: manuel1985
17.10.2013 um 18:32 Uhr
Brachte leider keine Änderung.
Was mir auch auffällt, wenn ich in den Switch-Einstellungen von LAN- auf WLAN-Karte wechsel, dauert es ziemlich lange, bis er die Änderungen übernimmt. Beim Wechsel in die andere Richtung geht das ganze ziemlich fix. Scheint also irgendwie mit der WLAN-Karte zusammen zu hängen...
Mitglied: manuel1985
18.10.2013 um 08:04 Uhr
Problem scheint gelöst.
Habe gestern Windows 8.1 installiert und musste dafür die Festplattenverschlüsselung (TrueCrypt) deaktivieren. Seit dem funktioniert es.
Weiß allerdings nicht, ob es nun an 8.1 oder der Verschlüsselung lag
Denke, eher am letzteren.

Gruß Manuel
Titel: Windows 8 Hyper-V virtueller Switch keine Internetverbindung am Host und in der VM
Content-ID: 219569
Art des Inhalts: Frage
Ausgedruckt am: 21.09.2019 um 06:41:22 Uhr
URL: https://administrator.de/contentid/219569