PHP auf Apache

Mitglied: mexx

mexx (Level 2)

07.06.2006, aktualisiert 08.06.2006, 5941 Aufrufe, 23 Kommentare

Hallo,

ich habe folgendes PHP-Script geschrieben und als. connect.php abgespeichert. Meinen Apache habe ich die connect.php als Standart-Seite vergeben und rufe nun meinen Server auf. Statt die Seite dargestellt zu sehen, erhalte ich eine Downloadmöglichkeit der PHP-Datei. Was mache ich falsch?

<html>
<head>
<title>PHP-Test</title>
</head>
<body>
<?php

require("class_fbird.php");
$db= new fbird('192.168.1.170:D:\DataBase\NESTRO_TESTD3.FDB',
'*', '*');

$erg=$db->query("SELECT * from personaldaten_verlust");
$spalte=$db->fetch_row($erg);
while (list($spalte)=$db->fetch_row($erg)) {
echo $spalte;
}


$db->close();

?>
</body>
</html>
Mitglied: Dani
07.06.2006 um 13:12 Uhr
Hi,
allgemein oder nur bei dieser Seite?!


Gruß
Dani
Mitglied: mexx
07.06.2006 um 13:15 Uhr
Ich hatte vorher eine index.html seite laufen, die er ohne Probleme angezeigt hat. Stellen wir mal die Syntacs für den DB-Zugriff zur Seite. Ist denn das HTML/PHP-Script von der Syntacs her richtig?
Mitglied: Dani
07.06.2006 um 13:24 Uhr
Hi,
ok....probier mal das:
01.
<html>
02.
<head>
03.
<title>PHP-Test</title>
04.
</head>
05.
<body>
06.
<?php
07.
echo date("H:i:s");
08.
?>
09.
</body>
10.
</html>

Gruß
Dani
Mitglied: prob
07.06.2006 um 13:40 Uhr
Hast du das Modul php in der apache.conf geladen????
Mitglied: mexx
07.06.2006 um 13:42 Uhr
Da ich nicht weis, wo und wie ich das machen muss, vermute ich mal nicht. Wo muss das wie stehen?
Mitglied: Dani
07.06.2006 um 13:45 Uhr
Hi,
Hast du das Modul php in der apache.conf
geladen????
Die Config-Datei dazu findest du bei Suse Linux X.x unter /etc/apache2/sysconfig.d/loadmodule.conf

01.
LoadModule php4_module    /usr/lib/apache2-prefork/libphp4.so

Gruß
Dani
Mitglied: mexx
07.06.2006 um 13:49 Uhr
War nicht dabei. Selber Zustand, statt die Datei auszuführen bzw. anzuzeigen erfolgt ein Öffnen/Download der Datei.

Diese Datei existiert nicht!
/usr/lib/apache2-prefork/libphp4.so
Mitglied: prob
07.06.2006 um 13:56 Uhr
na dann mal suchen..... oder php nachinstallieren


kann auch libphp5.so heissen, mittlerweile
Mitglied: mexx
07.06.2006 um 14:03 Uhr
Unter der Paktinstallation kann ich eingeben was ich will, kein Suchergebniss für PHP, libphp, oder ähnliches.
Mitglied: Dani
07.06.2006 um 14:12 Uhr
Hi,
hast du "case sensitve" deaktiviert. Suche einfach mal so: *php*
Was hast du für ein OS am laufen??


Gruß
Dani
Mitglied: mexx
07.06.2006 um 14:16 Uhr
*php* hat nox genützt. Wo ändere ich "case sensitve"

deutschsprachriges Suse 9.2
Mitglied: Dani
07.06.2006 um 14:38 Uhr
Hi,
du bist ja bestimmt über den Yast in das Softwaremanagement gegangen. Und wenn du dort Suchen machst ist das vor dem OK - Button. du kannst auch einfach mal in der Commandline "php" eingeben und dann 2x hintereinander die TAB-Taste drücken.


Gruß
Dani
Mitglied: mexx
07.06.2006 um 14:49 Uhr
Langsam verzweifel ich. Es wird einfach kein Paket gefunden, dass was mit PHP etwas zu tun hat. Auch nicht 2x Tab in der Kommandozeile. Gibt es noch einen anderen Weg das PHPLIB zu installieren. Habe schon mal gegoogelt aber nix gefunden.
Mitglied: mexx
07.06.2006 um 15:12 Uhr
Jetzt wird es verrückt. Nun habe ich sämtliche Änderungen zurückgenommen. Die PHP-Datei entfernt und die index.html erneut als DirectoryIndex gesetzt. Dennoch versucht er jetzt die PHP-Seite anzuzeigen.(Wieder mit downloadfenster)
Mitglied: Dani
07.06.2006 um 15:28 Uhr
Hi,
hast du die betroffene Dienste alle wieder neugestart. Somit werden dann auch deine Änderungen übernommen.


Gruß
Dani
Mitglied: mexx
07.06.2006 um 15:31 Uhr
Ja, habe ich. Von einem anderen PC aus, wird die Index.html angezeigt. Bei mir versucht er die PHP, langsam verliere ich meine Lust. Mir ist absolut unklar, wieso ich keinen einzigen Beitrag zu php finde. Nicht mal in der Beschreibung von anderen Paketen. Als ob das ganze System/DVD nix von PHP wüsste! Das gibt es doch nicht!
Mitglied: Dani
07.06.2006 um 15:34 Uhr
Hi,
kommt man auf die Kiste von außen (Internet) drauf??Wenn ja, schick mir mal kurz ne PM mit url,user & pw. Dann schaue ich mir das mal an.


Gruß
Dani
Mitglied: mexx
07.06.2006 um 15:36 Uhr
Leider nein. Da hängt noch was davor, was Dich nicht reinlässt.
Mitglied: mexx
08.06.2006 um 09:37 Uhr
Ok, ich habe mir die PHP Pakete gezogen und manuell istalliert. Die libphp4.so liegt an der richtigen Stelle und wird in der /etc/apache2/sysconfig.d/loadmodule.conf auch geladen. Wenn ich jedoch die Datei index.php mit folgenden Inhalt laden will, erhalte ich Seite kann nicht angezeigt werden.

<html>
<head>
<title>PHP-Test</title>
</head>
<body>
<?php
echo date("hallo");
?>
</body>
</html>
Mitglied: Dani
08.06.2006 um 11:07 Uhr
Hi,
hat die Datei die entsprechenden Rechte bzw. hast du die index.php in der conf bekannt gegeben?!

/etc/apache2/httpd.conf
DirectoryIndex index.html index.htm index.php


Gruß
Dani
Mitglied: mexx
08.06.2006 um 11:10 Uhr
Ja, die conf enthält den Namen der php, die loadmodule.conf enthält die libphp4.so. Wie kann ich Dir mal meine conf zukommen lassen?
Mitglied: Dani
08.06.2006, aktualisiert 24.03.2013
Hi,
..........


Gruß
Dani
Mitglied: mexx
08.06.2006 um 11:29 Uhr
Die Mail kommt von AT|NESTRO, dalls sie im Spam landet.
Titel: PHP auf Apache
Content-ID: 33767
Art des Inhalts: Frage
Ausgedruckt am: 19.11.2019 um 04:05:21 Uhr
URL: https://administrator.de/contentid/33767