ODBC-Verbindung steht, aber MYSql-Selects liefern keine Resultate

Mitglied: Kaubeu

Kaubeu (Level 1)

10.08.2006, aktualisiert 22.09.2006, 3756 Aufrufe, 1 Kommentar

Hallo zusammen,

ich stehe seit gestern vor einem scheinbar unüberwindbaren Problem, das ich mal so detailliert wie möglich zu schildern versuche:

meine in Visual Objects geschriebenen Programme greifen per ODBC über LAN und Internet auf MySQL-Datenbanken zu. Seit gestern erhalten die von meinem persönlichen Rechner (Windows XP, aktuell gepatcht) aus meinen Programmen ausgeführten Selects nur noch unsinnge oder gar keine Ergebnisse. Wenn ich hingegen Abfragen mit MySQL-Front oder anderen SQL-Frontends durchführe, funktioniert alles wie gewohnt. Auf allen anderen Rechnern im Netzwerk laufen die VO-Programm auch problemlos.

Der Gag ist, dass sich die Programme von meinem Rechner aus offensichtlich problemlos mit der Datenbank verbinden können. Ebenso erhalte ich ein OK, wenn ich bei der ODBC-Verwaltung die Verbindung teste. Nur dauert jeder Select unheimlich lange und liefert dann schlussendlich nichts, wahrscheinlich aufgrund eines Timeouts.

Ich habe mittlerweile den MySQL-ODBC-Treiber deinstalliert und verschiedene Versionen wieder installiert und verschiedene Systemwiederherstellungspunkte ausprobiert, leider ohne Erfolg. Hardwareseitig habe ich einen anderen Port am Switch probiert sowie die Netzwerkkarte und das Patchkabel ausgetauscht, aber auch das brachte keine Besserung.

Hat jemand eine Idee, was ich sonst noch machen könnte?
1 Kommentar
Mitglied: Kaubeu
22.09.2006 um 11:15 Uhr
Hallo zusammen,

das Problem hat sich erledigt. Das Userkonto war im Eimer. Wenn ich mich als anderer User angemeldet habe, ging es nämlich wunderbar. Also habe ich das Userkonto gelöscht und neu angelegt und schon klappte es wieder.