gelöst Dateiname zu lang

Mitglied: nooneelsebutme

nooneelsebutme (Level 1)

23.07.2018 um 09:59 Uhr, 1657 Aufrufe, 3 Kommentare, 1 Danke

Hallo,

habe Daten von einem Server 2008 R2 auf einen Server 2016 ES per robocopy migriert. Hat alles Problemlos funktioniert. Einige Ordner-Strukturen sind allerdings sehr tief, wenn die Clients jetzt darauf zugreifen wollen, kommt die Meldung "Dateiname zu lang". Versuchte ich das in der gleichen Struktur auf dem alten Server funktioniert es. Woran kann das liegen? Was auffällt, beim öffnen der Datei auf dem alten Server bricht er den Pfad herunter und es tauchen ~Zeichen darin auf. (Also Applikation in dem Fall ein PDF Reader )(Öffne: W:Pfad\Unterpfad\~weiterer UnterPfad\~noch ein Pfad ..) Beim neuen Server kommt gleich die Fehlermeldung von der explorer.exe.

Woher kommt der Unterschied, die 255 Zeichen Grenze müsste doch auch bei beiden Servern zuschlagen, warum ging/geht es beim alten Server?

Vielen Dank schon mal.
Mitglied: certifiedit.net
23.07.2018 um 10:03 Uhr
Hallo,

ggf. weil der alte Server entweder anders verlinkt hat (Verzeichnisumstellung, er war english ovgl.) Vielleicht war der Zugriff auch anders gelöst. In Gänze kann man aber sagen, dass man sich normalerweise hütet so lange Pfade zu konstruieren.*

VG

*Genaueres kann man ohne genaue Einsicht in deine Systeme zu haben nicht sagen.
Mitglied: dark.cube
LÖSUNG 23.07.2018, aktualisiert um 10:09 Uhr
Prüf doch mal ob auf deinem alten Server die 8.3 file name creation enabled war, soweit ich das gesehen habe, sollte dies bei 2008er Server der Fall sein und bei neuen(2012 aufwärts) nicht. Also könntest du diese auf dem neuen Server einschalten und nach einem Neustart nochmals prüfen oder aber du solltest die Verzeichnistiefe kürzen.

https://support.microsoft.com/de-de/help/121007/how-to-disable-8-3-file- ...

//Nachtrag
das funktioniert wohl leider nur, wenn die Dateien kopiert worden sind, nachdem die 8.3 name creation enabled war.
Mitglied: nooneelsebutme
23.07.2018 um 10:33 Uhr
Hallo,

ja das scheint die Ursache zu sein, komischerweise war das auf dem neuen Server auf C aktiviert, auf der Datenpartition D allerdings nicht. Hab das jetzt mal aktiviert, scheint aber wirklich für die vorhandenen Daten nicht zu funktionieren.
Titel: Dateiname zu lang
Content-ID: 381083
Art des Inhalts: Frage
Ausgedruckt am: 04.06.2020 um 14:07:11 Uhr
URL: https://administrator.de/contentid/381083