Dieser Beitrag ist schon älter. Bitte vergewissern Sie sich, dass die Rahmenbedingungen oder der enthaltene Lösungsvorschlag noch dem aktuellen Stand der Technik entspricht.

Kolab und amavisd Dienst? Mailserver funktioniert nicht

Mitglied: flyingmichael
Guten Morgen Zusammen,

ich habe mir bei Strato einen V-Server gehostet mit Cent-OS 7 . Darauf will ich einen funktionierenden Kolab Server zum laufen bekommen.
Ich folge der Offiziellen Installationsanleitung. Der Server scheint zu funktionieren, ich habe eine Web-Admin Oberfläche, doch sobald ich mich auf Roundcubemail anmelde und Mails verschicke kommen diese nicht an und es werden auch keineu empfangen.

Bei genauerer Prüfung habe ich festgestellt, das der Dienst amavisd nicht startet. Ich finde keine Lösung dafür kann mir evtl. jemand weitrehelfen?

Fehlermeldung: Job for amavisd.service failed. See 'systemctl status amavisd.service' and 'journalctl -xn' for details.
sowie:
Vielen Dank im Voraus!

Content-Key: 257717

Url: https://administrator.de/contentid/257717

Ausgedruckt am: 18.09.2021 um 06:09 Uhr

Mitglied: Frank
Frank 16.12.2014 um 11:23:56 Uhr
Goto Top
Hi,

Schau mal nach, ob dein ClamAV Antivirenscanner überhaupt läuft (ps -ef|grep clam). Der Clam Daemon (/usr/sbin/clamd) muss laufen, sonst verweigert amavis den Start (wenn ClamAV in der Amavis Config unter " = (...)" konfiguriert ist).

P.S nimm bitte aus dem Beitrag den "Realnamen" deine Mailhosts (mail.h....de). Nicht das der sonst missbraucht wird und wir sind Schuld :-) face-smile

Gruß
Frank
Mitglied: flyingmichael
flyingmichael 16.12.2014 aktualisiert um 13:59:20 Uhr
Goto Top
HI,

mit dem Befehl bekomme ich diese Ausgabe:
Dort kann ich nicht viel erkennen..

kannst du mir da vielleicht weiterhelfen?

Sorry ich bin da eher ein Neuling aber will gerne dazu lernen.
Kann ich den AV auch deaktivieren? oder sollte man das nicht machen?

Gruß
Michael
Mitglied: Frank
Frank 16.12.2014 aktualisiert um 14:14:26 Uhr
Goto Top
Hallo Michael,

  • Was passiert, wenn du ein "sudo freshclam" in der Shell ausführst?
  • Was sagt denn das Logfile von ClamAV -> "/var/log/clamav/clamav.log"?
  • Was sagt denn das Logfile von Amavis -> /var/log/mail.log -> aber da bitte nur den Teil, wenn Amavis nicht startet?
  • Was steht denn in der "/etc/clamd.d/amavisd.conf "?
  • Was steht im Amavis Config File ab dem Punkt "" =" (aber nur bitte der ClamAV Bereich)?
Beispiel für die Amavis Config (bei mir):

Gruß
Frank
Mitglied: flyingmichael
flyingmichael 16.12.2014 aktualisiert um 15:07:19 Uhr
Goto Top
Hallo Frank, also mit freshclam führt er updates durch, die sind aber alle up-to-date. keine Fehlermeldung
Das Logfile für ClamAV konnte ich unter diesem Pfad nicht finden den Ordner clamav gibt es unter logs nicht.
Das Amavis Logfile fand ich nur unter /var/log/maillog? also ohne "." dort waren 2 Kleineu Zeilen aber von gestern und kein Fehler oder ähnliches.
In meiner Conf steht folgendes :

und in der Config:

Gruß

Michael
Mitglied: Frank
Frank 16.12.2014 aktualisiert um 15:44:52 Uhr
Goto Top
Hi Michael,

sorry ich übersah, dass es sich hier um ein CentOS 7 handelt. Da werden die Logs natürlich mit "journalctl" angezeigt. CentOS 7 ist ein "Systemd" System.
Gebe doch mal folgendes in einem zweiten Bash Fenster ein:
und dann startest du "amavis" noch einmal neu (alternativ gebe "journalctl -p err" ein um hauptsählich die Fehler zu sehen). Wir brauchen auf jeden Fall etwas mehr Info nach dem Start von Amavis und warum er abbricht.

Ein weitere Idee wäre ein Rechteproblem beim User "clamav". Prüfe mal ob du ein " /var/spool/amavisd" oder ein " /var/spool/amavisd/tmp" hast. Wenn ja prüfe die Grupperechte:
Ist das nicht so bei Dir (bis auf die IDs wie z.B. 117 oder 118), dann kannst du folgendes eingeben:
Dann Amavis noch einmal starten und im zweiten Fenster mit "journalctl -f" schauen, was er ausgibt.

Wenn es nicht funktioniert, poste hier mal die "tmp" Ausgabe von "ls -la /var/lib/amavis". Wichtig sind hier die tmp Rechte:

P.S. benutze auf administrator.de für Log- und Shell-Befehle bitte immer den < code > Tag (siehe Formatierung). Schau mal in deinen Kommentar rein (über "Bearbeiten") wie das hier geht.

Gruß
Frank
Mitglied: flyingmichael
flyingmichael 16.12.2014 um 16:15:13 Uhr
Goto Top
Hallo,

also nach einem versuchten restart kam das:


die beiden Verzeichnisse existieren der User Clamav und die Gruppe jedoch nicht deshalb kam ich eine Fehlermeldung. Ist das evtl. das Problem?

Danke schonmal für die Mühen!

Grüße

Michael
Mitglied: Frank
Frank 16.12.2014 aktualisiert um 17:16:44 Uhr
Goto Top
Hallo Michael,

könnte sein. Du hast also folgendes ausprobiert und dann kam ein Fehler?
Gibt es bei dir denn den User "amavis" oder "clamav" (schau mal in die /etc/shadow)
Wie sieht es mit der Berechtigung des "/var/lib/amavis/tmp" Verzeichnis aus?

Hier ein Auszug der Fehlermeldung NoNewPrivileges:

Der "systemd"-Service dazu sieht dann ungefähr so aus:

Da steht dann auch das "NoNewPrivileges=true" drin. Dieser wird dann ausgelöst, wenn Privileg- bzw. Rechteprobleme entstehen (z.B. durch ClamAV).
Es sieht also alles nach einem Rechteproblem aus.

Gruß
Frank
Mitglied: 16568
16568 16.12.2014 um 22:48:33 Uhr
Goto Top
Zitat von @Frank:
Es sieht also alles nach einem Rechteproblem aus.

Quod errat demonstrandum. (status=227/NO_NEW_PRIVILEGES)
Ursachen dazu gibt es viele.
Beispielsweise SELinux aktiv...?

Lonesome Walker
Heiß diskutierte Beiträge
question
Netzwerkperformance - Mikrotik - Wo ist mein Fehler? gelöst BirdyBVor 1 TagFrageNetzwerke39 Kommentare

Moin zusammen, ich stehe gerade etwas auf dem Schlauch und weiß nicht so recht was mein Fehler ist. Gegeben ist mein heimisches Netzwerk: Also eigentlich ...

info
Hunderttausende MikroTik-Router sind seit 2018 angreifbarkilltecVor 1 TagInformationMikroTik RouterOS24 Kommentare

Mehrere MikroTik Router angreifbar. Hier der Link zu Heise: Hunderttausende MikroTik-Router sind seit 2018 angreifbar Gruß ...

question
Neue Firmennetzwerkstruktur und ein glühender KopfDerWachnerVor 1 TagFrageNetzwerke28 Kommentare

Moin zusammen, nun hab ich jahrelang hier nur mitgelesen, nun stehe ich allerdings selbst vor nem Problem was mir seit Tagen Kopfschmerzen bereitet. Also wir ...

general
Neue Herausforderungen auf unserer englischen SeiteFrankVor 1 TagAllgemeinOff Topic14 Kommentare

Auf unserer englischen Seite gibt es neue Herausforderungen: Find who restarted DB server und Wanted: Network Node Manager 6.4 wer kann helfen? Generell findet ihr ...

question
Windows Server 2012 R2 frisst SSDs (cbs.log)drahtbrueckeVor 1 TagFrageWindows Server14 Kommentare

Hallo, ich habe vor etwa 2 Monaten eine nur etwa 3 Monate alte SSD gegen eine neue getauscht (Samsung OEM Datacenter SSD SM883) in einem ...

question
RDS CALs und normale CALs - Wie richtig lizensierentim.riepVor 1 TagFrageWindows Server19 Kommentare

Hallo liebe User, ich habe eine Frage zur richtigen Lizensierung: Wenn eine natürliche Person zum Beispiel drei Accounts auf einem Windows Server 2016 hat, braucht ...

question
2 Netzwerkkarten für 2 verschieden Netze auf einem Windows-ServerglasscolaVor 18 StundenFrageWindows Server6 Kommentare

Hallo zusammen, im Rahmen meiner Bachelorthesis baue ich ein Labor auf, das folgend aussieht. Ich habe einen Server und auf ihm laufen 2 VMs (1 ...

info
Phishingwelle Volksbanklcer00Vor 1 TagInformationSicherheit10 Kommentare

Hallo zusammen, bei uns häufen sich gerade Phishing-Emails mit Ziel Volks-Raiffeisen-Bank. Geködert wird zum Teil auch mit der Erwähnung der SecureGo Smartphone-App. Grüße lcer ...