Zugriff auf vorgelagerte Subnetze

Mitglied: Snupydoo

Snupydoo (Level 1) - Jetzt verbinden

16.02.2016, aktualisiert 17.02.2016, 1251 Aufrufe, 3 Kommentare

Hallo

Erstmal zum Grundverständniss. Ich habe 4 Subnetze

Subnetz 1 = 192.168.1.0/24 -> admin / server netz
Subnetz 2 = 192.168.2.0/24 -> Nutzer adminrechte / für Eltern
Subnetz 3 = 192.168.3.0/24 -> Kind 1
Subnetz 4 = 192.168.4.0/24 -> Kind 2

Subnetz 5 vom Telekom Speedport = 192.168.178.0/24 (IP Speedport 192.168.178.1)

Anbieter 1 (Internetverein)
Anbieter 2 (Telekom)

So ich habe einen CCR1016 von Mikrotik. Auf eth1 und eth2 liegen direkt von einem Anbieter ein netz Direkt an wo IP direkt
am CCR an stehen. Am eth3 steht das Subnetz des Speedports an also Telekom Netz an. CCR hat auf eth3 192.168.178.2.

Es ist derzeit so das Subnetz 1+2 auf eth1 bzw 2 als GW haben und somit über anbieter 1 das internet beziehen.
Subnetz 3 und 4 gehen über eth3 dann über den Speedport ins Telekom Netz.

Ich kann leider derzeit nicht aus dem Subnetz 1 und Subnetz 2 nicht auf das Subnet 5 zugreifen. Aber ich kann von Subnetz 3
und 4 auf das Subnetz 5 zu greifen da ja auch ihr GW über eth3 dann per NAt auf Subnetz 5 und dann weiter ins Telekom Netz.

Ich würde aber gern von Subnetz 1 und 2 auch auf das Subnetz 5 zugreifen. Hat da jemand ne Ahnung was ich da genau einstellen muss?

Gruss Snupydoo
Mitglied: aqui
LÖSUNG 16.02.2016, aktualisiert 17.02.2016
Auf eth1 und eth2 liegen direkt von einem Anbieter ein netz Direkt an wo IP direkt am CCR an stehen.
Sorry, aber den Satz versteht kein Mensch :-( face-sad
Es ist derzeit so das Subnetz 1+2 auf eth1 bzw 2 als GW haben und somit über anbieter 1 das internet beziehen.
Diese Schlussfolgerung ist Unsinn. Sorry, aber relevant wo die das Internet herbeziehen ist die Default Route auf dem Layer 3 Mikrotik Switch... Oder die PBR Route wenn du mehrere Anwenden hast oder ein Balancing fährst zwischen mehreren ISPs !
Ich kann leider derzeit nicht aus dem Subnetz 1 und Subnetz 2 nicht auf das Subnet 5 zugreifen
Das ist auch logisch das das nicht geht !!! Denk mal etwas nach....!
Die Clients in 1 und 2 senden was an die Clients in 5. Diese haben aber den Speedport Router als Default Gateway.
Sie senden also die Reply Pakets für die Clients in 1 und 2 deshalb an den Speedport als Gateway, weil die ja auch fremde Absender IPs haben (1 + 2) und die geroutet werden müssen !
Diese Pakete kommen nun am Speedport an und hier hast du eine statische Route in die Subnetze 1 und 2 vergessen einzutragen mit Sicherheit.
Was der Speedport dann macht ist diese Pakete an seine Default Route also zum ISP zu schicken wo sie dann im Nirwana verschwinden....
Logisch also das es nicht klappt !
Vermutlich kannst du dir den Versuch das zu korrigieren sparen denn die Speedports sind bekannt so ziemlich der letzte Schrott an Router...nee die Vodafone Easyboxen kommen noch davor ...sorry.
Speedport supporten keine statischen Routen :-( face-sad
Deine einzige Chance ist also allen Clients im Subnetz 5 als Gateway die Mikrotik IP im Subnetz 5 einzutragen und dem Mikrotik dann eine Default Route auf den Speedport.

Damit löst du dann das Problem. Alles lokale wird dann im Mikrotik geroutet und was der nicht kennt, das sendet der dann an den Speedport.
Dafür bracuht man eigentlich nur nachdenken und den gesunden Menschenverstand walten zu lassen. Noch sinnvoller wäre es gewesen du hättest mal einen Wireshark zur Hand genommen, dann wäre der Thread vermutlich überflüssig gewesen.
Bitte warten ..
Mitglied: Snupydoo
17.02.2016 um 08:36 Uhr
Sorry, aber den Satz versteht kein Mensch

Was verstehst du daran nicht? auf eth1 und eth2 ist eine Feste IP (2 IPs auf jeweils 1 Port) von Anbieter 1 der fest im CCR eingetragen ist!

@ Aqui
Dein Lösungsvorschlag hab ich noch NIE angedacht. Kann dir aber sagen das deine these falsch woie richtig ist. Sicher nach deiner Schlussfolgerung sowie Erörterung kann man das machen. Hinzu kommt aber das das vor einer weile so Subnetz 1+2+3+4 noch als GW eth1 von Anbieter 1 hatte konnte ich aus allen 4 Subnetzen auf Subnetz 5 zugreifen ohne das ich an den GW bei den Clients was geändert habe.
auf eth3 liegt eine IP vom Subnetz 5 (ggf DHCP Client aus Subnetz 5 beziehen) an und macht dann SRC-Nat in Subnetze der eigenen Subnetze 1 bis 4 ... Jetzt aber schickte ich Subnetz 3 und 4 als GW eth3 auf Subnetz 5 und somit wieder Nat auf das Telekom netz.

Nach deiner Lösung hätte ja dann Subnetz 3 und 4 vorher auch nicht auf Subnetz 5 zugreifen können was ja aber geht wegen dem zweiten Nat! Nur von Subnetz 1 und 2 komm ich nicht mehr drauf was aber vorher ging bevor ich Subnetz 3 und 4 über eth3 über Nat über Subnetz für wieder Nat ins Telekom Netz schicke.

Hast du / jemand da ein anderen Lösungsweg? Hab mir sagen lassen das ich zusätzliche Routen eintragen muss das er diese kennt für Subnetz eins und zwei. Aber bisher bin ich daran gescheitert.

Snupydoo
Bitte warten ..
Mitglied: aqui
17.02.2016 um 11:44 Uhr
as ich zusätzliche Routen eintragen muss das er diese kennt für Subnetz eins und zwei
Wäre ja Blödsinn, denn wenn der Mikrotik das Gateway für alle an ihm direkt angeschlossenen IP Netze ist "kennt" er diese ja ! Subnetz 1 und 2 sind direkt verbunden, wozu dann überflüssige Routen ?
Der MT kann also entsprechend direkt forwarden.
Es ist ja keinerlei IP Netz bei dir über einen 2ten Router abgetrennt, so das zusätzliche statische Routen ja Unsinn wären.
Vergiss den Ansatz also....
Das es vorher funktionierte kann dann nur so wie oben beschrieben gelöst worden sein, denn der Speedport kann keinerlei statische Routen.
Du solltest dann also dein Augenmerk auf den MT richten, denn so wie es aussieht ist hier ein Konfig Fehler gemacht worden.
Im Zweifel nimm immer einen Wireshark Sniffer und sieh dir an was passiert in deinem Netz !
Möglich auch das schlicht und einfach die lokalen Firewalls der Geräte in 5 nicht angepasst sind und so die IPs blicken aus 1 und 2.
Bitte warten ..
Heiß diskutierte Inhalte
Datenschutz
FAX ist nicht mehr Datenschutzkonform
brammerVor 1 TagInformationDatenschutz49 Kommentare

Hallo, jetzt sollte es jeder begreifen FAX ist nicht mehr Datenschutzkonform brammer

Humor (lol)
Na, kann euer Toaster auch schon WLAN?
ITlerin95Vor 23 StundenAllgemeinHumor (lol)16 Kommentare

Also ich frag mich ja selbst echt oft, ob wirkliche alle technischen Neuerungen auch wirklich notwendig sind. Hintergrund ist, ich brauch einen neuen Toaster. ...

Exchange Server
Exchange 2019 als VM?
Mr.VainVor 1 TagFrageExchange Server9 Kommentare

Hallo zusammen, wir nutzen derzeit Exchange 2013 mit allen Rollen auf einem physischen Server (Ca. 260 Postfächer, Server 2012R2, Xeon E-2603v3 6Core, 16GB RAM, ...

Windows Update
Keine Updates zum Mai-Patchday über WSUS?
gelöst CoreknabeVor 1 TagFrageWindows Update12 Kommentare

Moin, wir laden über unseren WSUS die Windows Updates herunter (Server 2012R2). Jetzt stelle ich gerade verwundert fest, dass es Stand jetzt (19:45 Uhr) ...

Exchange Server
Sicherheitsupdates für Exchange Server 11. Mai 2021
kgbornVor 1 TagInformationExchange Server4 Kommentare

Sicherheitsupdates für Exchange Server 11. Mai 2021 Technet-Beitrag Meine Zusammenstellung: Sicherheitsupdates (KB5003435) für Microsoft Exchange Server (11. Mai 2021)

Netzwerkgrundlagen
Statische Route auf UTM
gelöst Ex0r2k16Vor 11 StundenFrageNetzwerkgrundlagen30 Kommentare

Moin! Ich habe an meiner Sophos UTM an einem physischen Interface einen Switch angeschlossen. Dieser läuft im Netz 10.1.1.0/24. Ich kann von meinem aktuellen ...

Exchange Server
Office 365 ohne lokalen Exchange
RicoPausBVor 1 TagFrageExchange Server8 Kommentare

Moin zusammen wir sind erst vor kurzem ins Office 365 eingestiegen und hatten vorher auch keinen Exchange Server im Einsatz. Ein Hybrid-Setup liegt also ...

SAN, NAS, DAS
Synology-NAS DS1813+: Lebensdauer des Gerätes?
OrmensonVor 1 TagFrageSAN, NAS, DAS10 Kommentare

Hallo Forum! In unserer Firma nutzen wir ein Synology NAS DS1813+ als zentraler Datenspeicherort. Konfiguriert ist er als RAID mit Ausfallsicherheit einer Platte. Die ...