gelöst Öffentliche Ordner Migration 2010 nach 2016

Mitglied: wolf336

wolf336 (Level 1) - Jetzt verbinden

14.08.2020, aktualisiert 14:52 Uhr, 769 Aufrufe, 9 Kommentare, 1 Danke

Hallo Leute,
ich verzweifle gerade an einem Problem, das beharrlich immer wieder auftaucht.
Folgender Vorgang:
Migration der öffentlichen Ordner von einem SBS2011 mit Exch2010 auf einen Server 2016 Std mit Exchange 2016.

Product VersionFileVersion AdminDisplayVersion
14.03.0496.000 14.03.0496.000 Version 14.3 (Build 123.4)
15.01.1591.010 15.01.1591.010 Version 15.1 (Build 1591.10)

Die Sache habe ich mit dieser Anleitung auf den Weg gebracht:
https://docs.microsoft.com/en-us/exchange/collaboration/public-folders/b ...">https://docs.microsoft.com/en-us/exchange/collaboration/public-folders/b ...
Anfängliche Probleme mit Speicherlimits, Send/Receive quota und E-Mail-aktivierten Ordnern habe ich behoben und dafür insgesamt 3 Rollbacks durchgeführt.
Anleitung hier:
https://ehloexchange.com/legacy-public-folder-migration/">https://ehloexchange.com/legacy-public-folder-migration/
Die Umbenennung der E-Mail-aktivierten Ordner erfolgte nach dieser Anleitung (das enthaltene Skript habe ich noch erweitert um alle gemeldeten Zeichenketten abzudecken)
http://exchange-powershell.com/database-management/bulk-public-folder-r ...">http://exchange-powershell.com/database-management/bulk-public-folder-r ...
Anschließend schien die Migration dann zunächst zu funktionieren. Der Status war nach Abschluss zunächst "Synced". Die Migration ließ sich jedoch nicht abschließen. Es stellte sich heraus, dass der Status inzwischen "SyncedWithErrors" war.
Auch im inzwischen siebten Versuch bricht der Vorgang beharrlich ab mit der Meldung im angehängten Screenshot.
migrationsbatch fehler - Klicke auf das Bild, um es zu vergrößern
Dieser Ordner wurde jedoch, wie schon Anfangs erwähnt, umbenannt. Ebenso habe ich die im Verlauf der Migration erstellten csv- und xml-Dateien dahingehend überprüft.
Es gelingt mir nicht, diese Migration zu Ende zu bringen.
Was mache ich falsch? Woher nimmt der Migrationsbatch die Information für diese Fehlermeldung?

Grüße

Wolfgang
Mitglied: Luci0815
LÖSUNG 14.08.2020, aktualisiert um 13:54 Uhr
Leerzeichen oder Sonderzeichen bei öffentlichen Ordnern sind die häufigste Fehlerquelle bei der Migration 2010 -> 2016. Schau mal zusätzlich per ADSI-Edit bei den öffentlichen Ordnern, ob Namen, Aliases etc. stimmen. Ich empfehle auch https://www.frankysweb.de/ als Anlaufstelle. Dort wurde das Thema ausgiebig behandelt.
Bitte warten ..
Mitglied: wolf336
14.08.2020, aktualisiert um 16:34 Uhr
Hallo Luci0815,
vielen Dank schonmal für die Antwort.
Leerzeichen und Sonderzeichen existieren wie oben beschrieben nicht mehr in der Quelldatenbank. Trotzdem erscheint die Fehlermeldung dass sie noch da sind.
Und im ADSI-Editor finden sich nur Hinweise auf die Datenbanken, nicht aber auf die einzelnen Datensätze darin. Aber ich schau da nochmal hin.
Übrigens habe ich die ersten Tests nach der Anleitung bei Frankysweb gemacht. Die war aber für meine Datenmenge (ca. 7000 öffentliche Ordner mit etwas mehr als 100 GB Daten) nicht ausreichend.

Grüße

Wolfgang
Bitte warten ..
Mitglied: Luci0815
14.08.2020 um 16:22 Uhr
Hi,

ich kann leider nicht mehr nachschauen, aber ich musste damals einige Namen per ADSI-Edit korrigieren. Irgendwo im Active Directrory stehen auch die öffentlichen Ordner (ich spreche nicht von der Exchange-Datenbank). Erst danach ging es. Vielleicht den falschen Namenskontext beim Verbinden erwischt? Müsste unter Konfiguration - Services sein.
Bitte warten ..
Mitglied: goscho
LÖSUNG 14.08.2020 um 16:26 Uhr
Mahlzeit,

ich hatte zuletzt ein ähnliches Problem mit der Migration von öffentlichen Ordnern zu Exchange 2016.
Es waren auch keine Leerzeichen oder Sonderzeichen mehr in den Ordnern. Wenn man solch einen Ordner aber im ESM geöffnet hat, wurde genau das reklamiert.

Geholfen hat, die betroffenen Ordner auf nicht mailaktiviert zu stellen.
Habe ich bei sehr vielen gemacht. Es waren über 850 öffentliche Ordner und unzählige davon mailaktiviert, obwohl nur eine handvoll Mails empfangen müssen.
Die dann wieder Mails empfangen sollten, habe ich erneut mailaktiviert und manuell die Mailadressen eingetragen.
War richtig viel Handarbeit.

PS: Ich habe das schon nach dem 1. Rollback gemacht.
Bitte warten ..
Mitglied: wolf336
14.08.2020 um 17:29 Uhr
Hallo nochmal,
bei Konfiguration - Services war ich die ganze Zeit und bin jetzt unter dem Standardmäßigen Namenskotext / MS Exchange Systems Objects fündig geworden (auch Dank meines Kollegen und Google-Spezialisten Christian, den ich hier ausdrücklich lobend erwähnen möchte).
Ich konnte also das Objekt finden und den Namen, den cn, den DisplayName und den mailNickname ändern.
Im Moment läuft also Runde 8 und ich hoffe dass jetzt ein anderer Fehler angezeigt wird oder dass im Idealfall das Ding durchläuft.
Bei einer Laufzeit zwischen 12 und 19 Stunden werde ich es dann erst am Montag wissen.
Schönes Wochenende, Grüße
Wolfgang
Bitte warten ..
Mitglied: wolf336
14.08.2020 um 17:34 Uhr
"Geholfen hat, die betroffenen Ordner auf nicht mailaktiviert zu stellen."

Danke auch dir für die Antwort. Das habe ich auch auf der Agenda. Allerdings mache ich das dann "eins nach dem anderen"...
Grüße
und schönes Wochenende
Wolfgang
Bitte warten ..
Mitglied: wolf336
17.08.2020 um 13:17 Uhr
Hallo zusammen,
eine kurze Rückmeldung. Die Fehlermeldung hat sich jetzt tatsächlich geändert. Es schaut also ganz danach aus, dass mich Luzi0815 auf den richtigen Weg gebracht hat.
Grüße
Wolfgang
Bitte warten ..
Mitglied: wolf336
20.08.2020, aktualisiert um 12:45 Uhr
Hallo zusammen,
der Vollständigkeit wegen hier noch eine kurze Zusammenfassung:
Im Durchlauf 9 hat es jetzt endlich funktioniert.
Hintergrund: Die Suche im ADSI war der richtige Weg. Allerdings waren (oberflächlich betrachtet) alle Ordner korrekt benannt.
Der Fehler kam letztlich in den zugeordneten Attributen zum Vorschein. Die oben beschriebene Meldung bezog sich auf das Attribut mailNickname.
Die Verwendung des ersten Skripts änderte also auf dem (Quell-)Exchange Server die Ordnernamen.
Das zweite Skript musste dann auf einem der DCs ausgeführt werden um die entsprechenden Datensätze zu korrigieren.

Skript 1 (Ordner umbenennen) Link

Skript 2 (AD bearbeiten) Link
Zugunsten dieser Skript-Lösung habe ich den Vorschlag von goscho dann auch nicht weiter verfolgt, auch weil bei meinem Server mehr als 90% der Ordner mailaktiviert sind.
Bitte warten ..
Mitglied: goscho
21.08.2020 um 08:40 Uhr
Moin Wolf336,

danke für die Skripte. Die werde ich gleich mal abspeichern. Ich habe noch mehrere Migrationen vor mir und da kann ich diese sicherlich gebrauchen.
Bitte warten ..
Ähnliche Inhalte
Exchange Server
Migration Exchange 2010 auf 2016
Frage von stefan2k1Exchange Server2 Kommentare

Hallo zusammen, eine kurze Frage. Ich habe mir jetzt einige FAQs zur Migration von Exchange 2010 auf 2016 angesehen. ...

Exchange Server

Migration Exchange 2010 - 2016 WrongCASServerBecauseOfOutOfDateDNSCacheException

gelöst Frage von OniChanExchange Server2 Kommentare

Moin zusammen, ich migriere gerade einen Exchange 2010 zu 2016 und habe ein Brett vorm Kopf. Nachdem ich nun ...

Exchange Server

Exchange 2010 to 2016 CrossForrest Migration

Frage von freshdomiExchange Server6 Kommentare

Hallo, kennt jemand eine gute STEPbySTEP Anleitung für die Migartion eines MS Exchange 2010 Servers auf einen MS Exchange ...

Exchange Server

PublicFolder zugriff nach Migration 2010 auf 2016

Frage von FachSysEgonExchange Server7 Kommentare

Guten Tag Zusammen, ich hoffe mir kann jamend an dieser Stelle helfen. Wir haben die Migration abgewschlossen und es ...

Exchange Server

Exchange 2010 Hybrid Migration zu Exchange 2016

Frage von LubosNovyExchange Server2 Kommentare

Hallo zusammen, ich bin gerade dabei unsere komplette Postfächer über die Hybrid Lösung hochzuladen. Wir haben ein Windows Server ...

Exchange Server

Exchange 2016 migration

Frage von Hanspeter82Exchange Server3 Kommentare

Hallo, bin gerade dabei einen EX2010 auf EX2016 zu migieren. Installation hat soweit funktioniert. Wollte nun ein Testpostfach verschieben ...

Heiß diskutierte Inhalte
Notebook & Zubehör
Macbook oder Surface Book 3?
gelöst Frage von FamousDex089Notebook & Zubehör36 Kommentare

Hallo Zusammen :-), ich bin komplett neu in der IT Admin schiene und neu in diesem Forum. Ich habe ...

Outlook & Mail
Outlook App auf Android
gelöst Frage von PeterGygerOutlook & Mail21 Kommentare

Hallo Folgende Situation: Samsung S3 Samsung S5 Mini Die Microsoft Outlook App kann nicht mehr gestartet werden. Es waren ...

Humor (lol)
So eine Art Jobangebot
Frage von Melvin.van.HorneHumor (lol)17 Kommentare

Moin, ich habe eben eine Zeit damit zugebracht eine GPO für eine Gruppe von Clients zu erstellen. Egal was ...

SAN, NAS, DAS
Probleme mit der GIGABIT Leitung - Finden der Krücke - Wer ist schuld ?
gelöst Frage von daswinimramSAN, NAS, DAS16 Kommentare

Hallo Community , folgender Aufbau : "erfolgreich" umgestellt auf Gigabit Tarif am 26.09.20 Speedtests wurden von allen PCs hinter ...

Windows Server
AD (virtualisiert) und alle angeschlossenen Clients fahren ungeplant herunter
Frage von tobitobsnWindows Server16 Kommentare

Ich habe aktuell ein Problem, dass ein frisch aufgesetzer Hyper-V mit einem virtualisierten AD regelmäßig 1x die Woche herunterfährt ...

Switche und Hubs
Kaufberatung (10G) Switche für Unternehmensnetzwerk
Frage von ipzipzapSwitche und Hubs15 Kommentare

Moin, unsere Firma zieht um und am neu renovierten Standort muss/soll alles neu. Auf drei Etagen stehen Racks, in ...

Berechtigungs- und IdentitätsmanagementBerechtigungs- und IdentitätsmanagementWebdienste und -serverWebdienste und -serverDatenbankenDatenbankenMonitoring & SupportMonitoring & SupportHybrid CloudHybrid CloudSmall Business ITSmall Business IT