Übergabe der Variablen bei Call funktioniert nicht

Mitglied: Supido

Supido (Level 1) - Jetzt verbinden

29.02.2016, aktualisiert 20:19 Uhr, 854 Aufrufe, 2 Kommentare

Hallo,

ich komme mit menem untenstehnden Code nicht weiter.
In :install bekomme ich nicht die richtigen Variablen ("%Pathdriver%" "%Printername%") übergeben und ich sehe nicht, weshalb es nicht funktioniert.
Danke im Voraus für die HIlfe.
René


Mitglied: 126919
126919 (Level 1)
LÖSUNG 29.02.2016, aktualisiert um 20:19 Uhr
Mal wieder jemand der DelayedExpansion zwar in seinem Skript einschaltet aber anscheinend nicht weiß wozu ;-) face-wink.
http://ss64.com/nt/delayedexpansion.html

Bei DelayedExpansion und dem Setzen von Variablen innerhalb eines geklammerten Ausdrucks musst du sie nicht mit Prozentzeichen einschließen sondern mit Ausrufezeichen: !Variable!

Gruß fk

By the way, die Auswahl für den User kannst du per choice wesentlich vereinfachen ;-) face-wink anstatt dafür extra eine FOR-Schleife zu verpulvern...
http://www.robvanderwoude.com/choice.php
Bitte warten ..
Mitglied: Supido
29.02.2016 um 20:19 Uhr
Hi fk,
danke für deine Hinweise, ich habe es jetzt so gelöst:

Bitte warten ..
Heiß diskutierte Inhalte
LAN, WAN, Wireless
Starlink im Unternehmen?
0xFFFFVor 14 StundenFrageLAN, WAN, Wireless36 Kommentare

Guten Morgen Admins, leider leiden wir darunter, dass wir uns hier in DE noch in einem Entwicklungsland was die Internetanbindung angeht, sehr. Nun kam ...

Microsoft
Datenkrake - Browser
DennisWeberVor 1 TagErfahrungsberichtMicrosoft10 Kommentare

Hallo zusammen, ich empfehle euch mal definitiv in "Temp" Verzeichnis eures Browsers zu schauen. Es war für mich erschreckend, wie viele wichtige Dokumente und ...

Off Topic
Klimaanlage im Serverraum
gelöst imebroVor 10 StundenFrageOff Topic19 Kommentare

Hallo, wir haben einen kleinen Serverraum (viell. 5 - 6 m²), in dem ein Serverschrank steht. Der Raum hat kein Fenster!!! Darin befinden sich ...

Netzwerkmanagement
Sicherheitsrisiken Synology DS Admin Konto
RitchtoolsVor 1 TagFrageNetzwerkmanagement6 Kommentare

Hallo Zusammen, ich habe die Pflege von einem Firmen NAS übernommen (Synology) es sind mehrere Rechner im Netzwerk die auf Daten zugreifen. Leider hat ...

Windows 10
Windows 10 hängt bei Neustart immer bei "Bitte warten" über Stunden
gelöst Odde23Vor 11 StundenFrageWindows 1023 Kommentare

Ich habe seit längerem, um genau zu sein seit gut einem Jahr, da wurde der Rechner gekauft, das Problem, dass der Rechner bei einem ...

Windows 10
Windows 10 System Recovery Ordner fast 60 GB - Wie löschen?
Looser27Vor 1 TagFrageWindows 106 Kommentare

Guten Morgen, bei einem unserer Clients funktioniert scheinbar das automatische Aufräumen nach Updates / Upgrades nicht. Wie kann ich dem Kollegen auf die Schnelle ...

Windows 10
Windows 10 verliert die Druckertreiber
KMP1988Vor 1 TagFrageWindows 1010 Kommentare

Servus zusammen, wir haben bei einem Kunden folgende Konstellation: - Server2019 (AD, DNS, DHCP) - Server2019 (Print-Server-Rolle) - W10-Clients Die Drucker werden übers Logon-Scirpt ...

DNS
Opendns.com - Kosten?
cordialVor 1 TagFrageDNS2 Kommentare

Moin, Ich möchte gerne den OpenDNS Dienst mal verstehen. Hab da schon länger einen Account mit Filterung. Die "Free" Edition bei OpenDNS ist doch ...