Überschneidung bei bedingter Formatierung in Excel

Mitglied: Yan2021
Hallo Ihr Lieben,

meine Excel-Datei (siehe vorheriges Thema) ist soweit fertig.
Es ist eine kleine Zeiterfassung für eine MA im Homeoffice. Mein Cheffe meinte, ich könne sowas sicher hinzaubern ;-) face-wink
Ich nutze Excel 2016

Jetzt habe ich mal damit etwas herumgespielt und stellte dann fest, dass es Probleme gibt bei einer Überschneidung bei der bedingten Formatierung.

Ich erkläre es mal:
Der Bereich, auf den sich die bedingte Formatierung bezieht ist A4 bis F34.
Die Angaben zu den Feiertagen stehen im Bereich H3 bis H17.

1) Die Samstage und Sonntage sollen automatisch grau hinterlegt werden und mit der Standardschrift. Das habe ich über die bedingte Formatierung erreicht mit
=WOCHENTAG($A4;2)>=6

2) Die Feiertage sollen automatisch hellgrün mit fetter, grüner Schrift hinterlegt werden. Das geht ebenfalls über die bedingte Formatierung mit
=ZÄHLENWENN($H$3:$H$17;$A4)

Wie gesagt, funktioniert das sehr gut.
Aber wenn ich jetzt mal testweise in meiner Tabelle als Datum einfach den Feiertag (Tag der deutschen Einheit) eintrage, also den 3.10.2021, dann bleibt der Hintergrund grau (weil das ein Sonntag ist) und die Schrift wird fett und grün.

Ich hätte es aber gerne so, dass die Feiertage quasi Vorrang haben.
Diese Zeile sollte also mit hellgrünem Hintergrund und grüner Schrift angezeigt werden.

Geht sowas? :-) face-smile

Grüße von
Yan

Content-Key: 1103262684

Url: https://administrator.de/contentid/1103262684

Ausgedruckt am: 21.09.2021 um 17:09 Uhr

Mitglied: TK1987
Lösung TK1987 30.07.2021 aktualisiert um 12:00:54 Uhr
Goto Top
Moin,

Zitat von @Yan2021:
Aber wenn ich jetzt mal testweise in meiner Tabelle als Datum einfach den Feiertag (Tag der deutschen Einheit) eintrage, also den 3.10.2021, dann bleibt der Hintergrund grau (weil das ein Sonntag ist) und die Schrift wird fett und grün.

Ich hätte es aber gerne so, dass die Feiertage quasi Vorrang haben.
Diese Zeile sollte also mit hellgrünem Hintergrund und grüner Schrift angezeigt werden.

Geht sowas? :-) face-smile
das macht Excel sowieso immer.

Du musst einfach nur in den Bedingten Formatierungen die Regel für die Feiertage in der Reihenfolge über die der Wochenenden legen.
Bei dir ist das momentan eben genau umgekehrt, da aber deine Regel für die Wochenenden die Schrift nicht verändert, greift da dann zusätzlich noch die untergeordnete Regel der Feiertage und ändert die Schriftart.

Gruß Thomas
Mitglied: em-pie
em-pie 30.07.2021 um 12:14:01 Uhr
Goto Top
Moin,

wie @TK1987 schon schrieb: Die Reihenfolge der Regeln ist das entscheidende

Gruß
em-pie
Mitglied: Yan2021
Yan2021 30.07.2021 um 13:00:43 Uhr
Goto Top
WOW... Ihr seid ja klasse.

Habe es genau so gemacht und - siehe da - funktioniert ;-) face-wink

Vielen Dank und genießt Euer Wochenende.

Grüße von
Yan
Mitglied: Yan2021
Yan2021 30.07.2021 um 13:22:28 Uhr
Goto Top
sorry...
Habe zwar schon als gelöst markiert, aber ich wollte jetzt die Angaben der Feiertage in ein extra Tabellenblatt verlegen.
Bisher standen die im Haupt-Tabellenblatt.
Dann wollte ich die Regel entsprechend anpassen... aber da erhalte ich eine Fehlermeldung.

Das Tabellenblatt heißt "Feiertage"
Und die Daten der Feiertage stehen im Bereich A3 bis A17

Hier meine Angabe bei der bedingten Formatierung:
=ZÄHLENWENN(Feiertage!$A$3:Feiertage!$A$17;$A4)

Wie gesagt, kommt ein Fehler.
Wie wäre es richtig?

Grüße von
Yan
Mitglied: TK1987
Lösung TK1987 30.07.2021 aktualisiert um 13:33:05 Uhr
Goto Top
Dann wollte ich die Regel entsprechend anpassen... aber da erhalte ich eine Fehlermeldung.
Das mit den bedingten Formatierungen in anderen Tabellenblättern klappt nur, wenn die Bereiche benannt sind.

Zitat von @Yan2021:
Wie wäre es richtig?
Die Feiertage markieren, dann oben links im Adressbereich einen Namen geben
unbenannt

In der Bedingten Formatierung dann einfach nur noch den Namen angeben statt des Adressbereichs.

Gruß Thomas
Mitglied: Yan2021
Yan2021 30.07.2021 um 13:31:19 Uhr
Goto Top
Oh, das ist ja eigentlich simpel... man muss es nur wissen ;-) face-wink

Danke... hat funktioniert.

Grüße von
Yan
Heiß diskutierte Beiträge
question
Windows PrintServer 2016 - KB5005573 macht Drucken unmöglich - Fehler 0x11bbeidermachtvongreyscullVor 1 TagFrageWindows Server22 Kommentare

Moin Kollegen, verdammt den hatte ich nicht auf dem Schirm. Ich hab gestern Sicherheitsupdates auf unseren 2016ern ausgerollt und heute morgen kann keiner mehr drucken, ...

question
Rechner im Netzwerk frieren nach Neustart einCZF-MarkusVor 1 TagFrageWindows Netzwerk15 Kommentare

Seit einer Woche frieren unsere Rechner (Windows 10) im Firmennetzwerk nach einem Neustart ein. Mal ist es die Outlook.exe, mal die Explorer.exe, mal die .exe ...

question
Macadresse fest auf dem Board ändernDippsVor 1 TagFrageHardware12 Kommentare

Hallo ich habe ein Mainboard was defekt ist. Nun habe ich das Typgleiche geholt und ausgetauscht. Es läuft ein Linux drauf mit einer Software die ...

question
Kauftipp für einfaches KabelmodemTheEPOCHVor 1 TagFrageHardware5 Kommentare

Hallo zusammen, ich bräuchte eine kleine Kaufberatung. Ich suche ein ganz einfaches Kabelmodem. Das Gerät soll vor eine OPNsense und das Internet bereitstellen. DOCSIS 3.0 ...

question
Clonen einer SSD Platte auf eine grösserejensgebkenVor 23 StundenFrageFestplatten, SSD, Raid9 Kommentare

Hallo Gemeinschaft habe in meinem Rechner eine alte SSD 128 und eine neu installierte mit Windows 10 drauf 512 GB nun möchte ich gerne die ...

info
Druckprobleme an PrintServern nach Sept. 2021 UpdatekgbornVor 1 TagInformationWindows Server

FYI: Seit die Sicherheitsupdates vom Patchday 14. September 2021 ausgerollt wurden, stehen Administratoren vor dem Problem, dass Clients eventuell nicht mehr an einem Terminalsever oder ...

question
Aufbau Netzstruktur für CARP mit OPNsense gelöst screemyVor 1 TagFrageLinux Netzwerk6 Kommentare

Guten Abend, wir betreiben auf 2 ProxmoxVE Hosts jeweils eine OPNsense. Diese möchten wir mittels CARP hochverfügbar konfigurieren für die LAN/WAN Schnittstelle. Folgender Aufbau ist ...

question
Fritzbox als VPNClientproton34Vor 1 TagFrageRouter & Routing7 Kommentare

Hallo, ich habe dem letzt gelesen, dass es nicht möglich sein soll eine FritzBox 7490 als VPNClient zu verwenden. Den Beitrag findet ihr hier:. Jetzt ...