Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Apache,PHP,MySql - keine Verbindung zu phpMyAdmin

Mitglied: FELLINGA09

FELLINGA09 (Level 1) - Jetzt verbinden

17.02.2010, aktualisiert 02:23 Uhr, 10383 Aufrufe, 5 Kommentare

Hallo!

kurze Problemerläuterung:
Ich habe Apache PHP und MySql installiert und versuche per phpmyadmin zu Verbinden, doch leider klappt das nicht!

Infos:
*Windows 7 32bit (engl.)

*Apache 2.2.14 (per Installer)
*PHP 5.2.12 (per Zip)
*MySql 5.1.43 (per Installer)
*phpmyadmin 3.2.5 (per Zip)

*Nein ich möchte keine WAMMP XAMMP oder sonst was verwenden!

Mein momentaner Status:
Ich war bereits in hunderten Foren, und habe auch schon nach 2 "Guides" installiert.
Doch immer tritt ein Problem auf.
Momentan läuft der Apache mit PHP einwandfrei. Ich kann also PHP files und alles anzeigen lassen.
Die Phpinfo.php zeigt mir meine Confg an, die Pfade stimmen alle. (soweit ich das beurteilen kann)

In der Phpinfo wird mir angezeigt das MySql mitgeladen wird!!!
Dort steht auch die aktuelle MySql Version: 5.1.43
Wenn ich mich direkt über MySQL einlogge (die Shell) habe ich Zugriff, verwendet wird momentan die mysql database.

Wenn ich jetz auf "localhost/phpmyadmin" gehe kommt das Logininterface, ich gebe die Zugangsdaten ein drücke auf "Login", und nach wenigen Sekunden steht da:

Internet Explorer cannot display the webpage

Firefox bringt:

Fehler: Verbindung unterbrochen
Die Verbindung zum Server wurde zurückgesetzt, während die Seite geladen wurde.

Ich habe mitlerweile sehr viel an der config.inc.php herumgebastelt, mit cookie, http, config, überall das gleiche.


Da mir die PHPinfo anzeigt das MySql geladen wird, denke ich jetzt das es noch an Einstellungen der config.inc.php liegen muss.




Wisst ihr woran ich scheitere?
Vielen Dank schonmal für alle Antworten!

lg
Mitglied: dog
17.02.2010 um 05:00 Uhr
Bitte mal die Ausgabe der error_log posten...
Bitte warten ..
Mitglied: etnobommel1989
17.02.2010 um 07:55 Uhr
Installiere mal Xampp und nicht alle Server einzeln. Müsste funktionieren, hat bei mir auch geklappt und hatte davor desselbe Problem
Bitte warten ..
Mitglied: FELLINGA09
17.02.2010 um 08:08 Uhr
Auszug der error_log von ..\Apache\logs :

[Wed Feb 17 02:14:49 2010] [notice] Parent: child process exited with status 255 -- Restarting.
httpd.exe: Could not reliably determine the server's fully qualified domain name, using 192.168.1.1 for ServerName
[Wed Feb 17 02:14:49 2010] [notice] Apache/2.2.14 (Win32) PHP/5.2.12 configured -- resuming normal operations
[Wed Feb 17 02:14:49 2010] [notice] Server built: Sep 28 2009 22:41:08
[Wed Feb 17 02:14:49 2010] [notice] Parent: Created child process 2772
httpd.exe: Could not reliably determine the server's fully qualified domain name, using 192.168.1.1 for ServerName
httpd.exe: Could not reliably determine the server's fully qualified domain name, using 192.168.1.1 for ServerName
[Wed Feb 17 02:14:49 2010] [notice] Child 2772: Child process is running
[Wed Feb 17 02:14:49 2010] [notice] Child 2772: Acquired the start mutex.
[Wed Feb 17 02:14:49 2010] [notice] Child 2772: Starting 150 worker threads.
[Wed Feb 17 02:14:49 2010] [notice] Child 2772: Starting thread to listen on port 80.
[Wed Feb 17 02:14:50 2010] [notice] Parent: child process exited with status 255 -- Restarting.
httpd.exe: Could not reliably determine the server's fully qualified domain name, using 192.168.1.1 for ServerName
[Wed Feb 17 02:14:50 2010] [notice] Apache/2.2.14 (Win32) PHP/5.2.12 configured -- resuming normal operations
[Wed Feb 17 02:14:50 2010] [notice] Server built: Sep 28 2009 22:41:08
[Wed Feb 17 02:14:50 2010] [notice] Parent: Created child process 1356
httpd.exe: Could not reliably determine the server's fully qualified domain name, using 192.168.1.1 for ServerName
httpd.exe: Could not reliably determine the server's fully qualified domain name, using 192.168.1.1 for ServerName
[Wed Feb 17 02:14:51 2010] [notice] Child 1356: Child process is running
[Wed Feb 17 02:14:51 2010] [notice] Child 1356: Acquired the start mutex.
[Wed Feb 17 02:14:51 2010] [notice] Child 1356: Starting 150 worker threads.
[Wed Feb 17 02:14:51 2010] [notice] Child 1356: Starting thread to listen on port 80.

@etnobommel1989
Ich habe bereits oben erwähnt das ich es nicht verwenden möchte.
Bitte warten ..
Mitglied: nxclass
17.02.2010 um 08:26 Uhr
Das hört sich für mich wie eine unpassende Mysql Konfiguration an. Glaube mich zu erinnern, daß es unter Umständen nicht möglich war sich mit 'localhost' sondern nur mit '127.0.0.1' zu verbinden. ( ... weil Mysql einmal die Pipe und einmal die Netzwerkschnittstelle nutzt ? )

Nein ich möchte keine WAMMP XAMMP oder sonst was verwenden!
Dafür hätte ich mal eine Erklärung. Gut - mir ist das xampp Paket auch viel zu fett, aber es gibt doch auch das xampp-lite. ( http://www.apachefriends.org/de/xampp-windows.html#631 ) Und falls man eine andere PHP version benötigt (zB. php4) dann kann man auch ein 2. PHP's parallel installieren und benutzen.
Bitte warten ..
Mitglied: dog
17.02.2010 um 08:37 Uhr
Der Log nach crasht der Apache Prozess in dem PHP läuft (was ich bereits erwartet hatte).
Bei so einem Problem hilft meist nur andere Versionen verwenden/von vorne anfangen.
Bitte warten ..
Ähnliche Inhalte
Datenbanken

MySQL unter phpMyAdmin richtig vorbereiten?

gelöst Frage von carl7nDatenbanken9 Kommentare

Hallo, ich möchte eine MySQL Datenbank nach diesem Schema aufbauen: ID (auto increment, aber Zahlen manuell änderbar) Aufgabe (Name ...

PHP

PHP MySQL Login

Frage von YanmaiPHP7 Kommentare

Hallo ihr Administratoren, ich habe eine Datenbank, in der alle User des Netzwerkes enthalten sind. Wenn ein User sich ...

PHP

Benutzerregistrierung php, mysql

Frage von zelamediaPHP5 Kommentare

Hallo, kennt jemand ein gutes Tutorial/Anleitung wie ich mit php/mysql eine einfache Benutzer-Registrierung umsetzte mit Benutzerrollen also Administrator/Mitarbeiter usw. ...

PHP

HTML PHP MySQL Webanwendung

Frage von hahaxd3PHP12 Kommentare

Hallo Leute, Ich möchte gerne Meine Datenbank auf einer webseite darstellen. Dabei sollte diese Als normale Tabelle dargestellt sein. ...

Neue Wissensbeiträge
Rechtliche Fragen
Unitymedia siegt vor dem BGH
Information von transocean vor 16 StundenRechtliche Fragen3 Kommentare

Moin, lt. einem aktuellen Urteil darf UM Mietrouter seiner Kunden weiterhin in Hotspots verwandeln. Nachlesen kann man das hier. ...

Router & Routing
Der "768k-Day" kommt
Information von LordGurke vor 1 TagRouter & Routing2 Kommentare

Für Leute, die Router mit BGP-Fulltable betreiben vielleicht ein interessanter Hinweis: Die IPv4-Fulltable erreicht voraussichtlich innerhalb der nächsten 2-3 ...

Debian

Partition angeblich voll, dabei aber noch nicht mal zur Hälfte belegt

Anleitung von diemilz vor 1 TagDebian8 Kommentare

Hallo zusammen, ich habe ein kleines Problem: Ich habe auf einem physischen Debian Linux Server als ZoneMinder-Server (HP ProLiant ...

Windows 7
Updategängelung auf Windows 10, die zweite
Information von Penny.Cilin vor 6 TagenWindows 73 Kommentare

Hallo, da Windows 7 im kommenden Jahr nicht mehr supportet wird, werden Nutzer von Window 7 home premium wieder ...

Heiß diskutierte Inhalte
HTML
Bild hochladen mit html auf die Webseite
gelöst Frage von WorldoftheitHTML63 Kommentare

Will eine Seite entwickeln im Internet aber Das Bild wird nicht angezeigt woran kann das liegen? Wäre für jede ...

Vmware
Terminalserver VM - Videos ruckeln
Frage von easyriderVmware29 Kommentare

Hallo zusammen, wir haben einen (free) ESXi 5.5 auf einem HP DL 380 G8 im Einsatz. Darauf läuft, unter ...

Festplatten, SSD, Raid
Harddisk kaputt, was sagt mir ChrystalDiskInfo
gelöst Frage von InfoSeekerFestplatten, SSD, Raid23 Kommentare

Hallo zusammen, Mein Rechner lahmt. Ich stell mir die Frage woran es liegt und bin der Meinung es ist ...

Backup
Veeam Community Edition
gelöst Frage von dgrebnerBackup23 Kommentare

Hallo Zusammen, kann jemand seine praktischen Erfahrungswerte mit der Veeam-Community Edition mit mir teilen? Es gab dazu ja schon ...