Axis-Webcam CRC-Fehler auf Switchen

Mitglied: Coreknabe

Coreknabe (Level 2) - Jetzt verbinden

27.11.2015 um 10:02 Uhr, 1318 Aufrufe, 11 Kommentare

Moin Wissende,

wir haben diverse Axis M1103-Kameras zur Videoüberwachung im Einsatz. Diese werden über PoE an verschiedenen Switchen betrieben (Netgear GS108Ev3, Dell Powerconnect 5548P). Alle paar Tage mal bekomme ich einen Haufen Infomails, dass die Kameraverbindung unterbrochen wurde, ruckelt sich dann aber wieder zurecht. Schaue ich nun in die Switch-Logs, sehe ich auf den Kameraports teils sehr viele CRC-Fehler.
Erste Amtshandlung: Habe Autonegotiation auf den Switchen deaktiviert, Flow Control ist aktiviert. Auf den Cams sehe ich keine Möglichkeit, Auto Negotiation zu deaktivieren.
Hat gefühlt die Lage etwas entspannt, Fehler treten aber immer noch in unschöner Regelmäßigkeit auf.

Ideen?

Gruß
Mitglied: michi1983
27.11.2015 um 10:10 Uhr
Hallo,

bei meiner AXIS 211A habe ich die Option zur Einstellung von Autonegotiation.

567ad547a91a2eb0b44bdb6a90a3c4fa - Klicke auf das Bild, um es zu vergrößern

Gruß
Bitte warten ..
Mitglied: Coreknabe
27.11.2015 um 10:16 Uhr
Hi Michi,

danke, aber bei der M1103 (FW 5.50.3) hat Axis das nicht mehr drin. Evtl. lässt sich das auf Umwegen konfigurieren (geht z.B. mit der MTU auch, die GUI gibt das nicht her), habe aber dazu nichts im Netz gefunden.

Gruß
Bitte warten ..
Mitglied: aqui
27.11.2015, aktualisiert um 10:51 Uhr
Das generelle Problem ist das aktivierte Flow Control !
Auf Netzwerk Switches gehört das generell deaktiviert. Gerade bei Media Streams. Dein Problem ist das du mit den billigen NetGear und Powerconnect Switches recht schwachbrüstige Store and Forward Switches hast mit sehr geringen Port Buffern. Solche einfachen Access Switches mit billigen Custom Port Asiscs sind ungeeigenet bei multiplen Media Streams wie du hast. Vermutlich wieder aus Unwissenheit nur auf den Preis geschielt ?!
Vermutlich kannst du die Poert Buffer auf diesen Billigteilen auch noch nichtmal customizen um den Kameraports mehr Port Buffer zuzuweisen. (Handbuch ?!)
Deshalb sollte man immer zwingend Flow Controll deaktivieren wie es im allgemeinen bei Ethernet Netzen auch üblich ist.
Damit ist dann die Transportschicht der Übertragungsprotokolle dafür verantwortlich. In der Regel fixt das das Problem...auch bei diesen Billigprodukten.

Einseitig die Autonegotiation zu customizen ist keine so gute Idee, denn das kann gerade auch in solche Probleme eines Speed und Duplex Mismatches führen, weil du die Signalisierung dann einseitig ausgeschaltet hast aber die andere Seite trotzdem auf eine Negotiation wartet.
Meist gehen diese dann automatisch in den max. möglichen Mode wenn das Signal ausbleibt. Bei schlampiger Implementation auf den Endgeräten kannst du dich aber nicht drauf verlassen, insofern ist eine einseitige statische Abschlatung meist auch kontraproduktiv.
Firmware hast du die aktuellste auf beiden Switches UND der Kamera geflasht ???
Bitte warten ..
Mitglied: Coreknabe
27.11.2015 um 13:20 Uhr
Danke für die Rückmeldung, Cisco-Fanboyism mal ausgeblendet.

Wieder was gelernt, habe Flow Control jetzt mal deaktiviert (soweit möglich, geht nicht bei einigen Netgears), einseitige Autonegotiation ist auch wieder zurückgedreht. Firmware ist auf allen beteiligten Geräte auf dem aktuellen Stand.

Dazu noch ein Ticket bei Axis eröffnet, mal sehen, sobald ich Infos habe, poste ich diese hier wieder.

Gruß und schon mal ein schönes Wochenende!
Bitte warten ..
Mitglied: Coreknabe
14.12.2015 um 11:00 Uhr
Moin,

kleines Update: Auf den Axis-Cams lässt sich doch die Auto Negotiation ausblenden, ist nur gut versteckt:
Setup --> System Options --> Advanced --> Plain Config --> Network

Verhalten hat sich insgesamt gebessert, allerdings sehe ich trotz Deaktivierung von Flow Control und Auto Negotiation immer noch CRC-Fehler. Mal sehen, was von Axis noch kommt...

Gruß
Bitte warten ..
Mitglied: michi1983
14.12.2015 um 11:13 Uhr
Zitat von @Coreknabe:

Moin,

kleines Update: Auf den Axis-Cams lässt sich doch die Auto Negotiation ausblenden, ist nur gut versteckt:
Setup --> System Options --> Advanced --> Plain Config --> Network
Also wie in meinem Screenshot nur heißt der letzte Punkt anders ;-) face-wink
Bitte warten ..
Mitglied: aqui
14.12.2015 um 13:35 Uhr
immer noch CRC-Fehler. Mal sehen, was von Axis noch kommt...
Siehst du die Ausschliesslich auf den Axis Ports oder auch auf anderen Ports am Switch.
Das zeugt meist von defekten Kabeln oder Steckern. Oder auch falschen Kabeln oder falsch gecrimpten oder aufgelegten Kabeln.
Auch einen Defekt des oder der Switchports kann man nicht gänzlich ausschliessen.
Ein test ist aber ganz einfach wenn du die Kamera mal an einen Port klemmst der vorher garantiert ohne CRC Fehler gearbeitet hat.
Wandern die CRC Fehler mit dann ist es die Kamera selber oder das Kabel. Den Switch kann man dann (fast) ausschliessen.
Hast du die aktuellste Firmware auf die Switches geflasht ??
Wenn nein solltest du das auch unbedingt tun und die Switches danach kaltstarten.
Bitte warten ..
Mitglied: Coreknabe
14.12.2015 um 15:14 Uhr
Die Fehler sind ausschließlich an den Axis-Ports. Die CRC-Fehler sind nach den Änderungen definitiv weniger geworden, aber halt immer noch da.
Die Switche fahren die aktuellste Firmware, wie auch die Kameras.
Bitte warten ..
Mitglied: michi1983
14.12.2015 um 15:30 Uhr
Zitat von @Coreknabe:

Die Fehler sind ausschließlich an den Axis-Ports. Die CRC-Fehler sind nach den Änderungen definitiv weniger geworden, aber halt immer noch da.
Die Switche fahren die aktuellste Firmware, wie auch die Kameras.
Und wie @aqui schon gefragt hat... Was passiert wenn du die Cam an einen anderen Port am Switch steckst? Gehen die Fehler mit?
Bitte warten ..
Mitglied: Coreknabe
14.12.2015 um 15:51 Uhr
Was passiert wenn du die Cam an einen anderen Port am Switch steckst? Gehen die Fehler mit?
Das sind 10, 12 Cams, das liegt nicht an den Ports...
Bitte warten ..
Mitglied: michi1983
14.12.2015 um 16:18 Uhr
Zitat von @Coreknabe:

Was passiert wenn du die Cam an einen anderen Port am Switch steckst? Gehen die Fehler mit?
Das sind 10, 12 Cams, das liegt nicht an den Ports...
Na dann weißt du jetzt ja wer Schuld hat :-) face-smile
Viel Spaß beim Auswechseln.

Gruß
Bitte warten ..
Heiß diskutierte Inhalte
Off Topic
Wie sieht eine korrekte IT-Organisation aus?
imebroVor 1 TagFrageOff Topic20 Kommentare

Hallo, da unser IT-Verantwortlicher ja vor einem Jahr gehen musste, stelle ich mir die Frage, wie denn eine korrekte IT-Organisation überhaupt aussehen muss. Zur ...

Server-Hardware
Mini-PC oder Server für Dauerbetrieb
Surfer12Vor 1 TagFrageServer-Hardware20 Kommentare

Hallo zusammen, wir projektieren gerade eine neue Zutrittslösung für ein kleines Hotel mit ca. 20 Zimmern. Die Gäste sollen in Zukunft einen SelfCheckIn machen ...

LAN, WAN, Wireless
Cat 7 Patchkabel mit nur 11MBits im Download
gelöst RickHHVor 1 TagFrageLAN, WAN, Wireless7 Kommentare

Moin zusammen, ich habe mir soeben ein paar Patchkabel (aus einem Cat 7 Kabel) fertig gemacht. Die Belegung ist: 1 weiß/grün 2 grün 3 weiß/orange 4 blau 5 weiß/blau ...

Firewall
Windows Defender dauerhaft deaktivieren
Frankie222Vor 1 TagFrageFirewall9 Kommentare

Hallo, ich wollte mal fragen ob jemand weiss wie man bei Windows 10 Home den kompletten Schutz deaktiviert. Den Defender und alles! Ich habe ...

Notebook & Zubehör
Funktionieren keine USB-DVD-RW an Surfaces?
StefanKittelVor 1 TagFrageNotebook & Zubehör14 Kommentare

Hallo, ein Kunde von mir hat ein Surface Pro. Wenn er ein USB-DVD-RW-Laufwerk an die Dockingstation anschliesst funktioniert es nicht. - Es bekommt Strom ...

Batch & Shell
Umwandeln einer Dezimalzahl in eine Binärzahl
BadBatchCoderVor 1 TagAnleitungBatch & Shell4 Kommentare

Hey, ich habe ein fertiges Skript für die Umwandlung einer Dezimalzahl in einer binäre Zahl. Zurzeit kann man damit Zahlen von bis 65535 ...

Windows 10
Windows 10 20HS SCCM
stoepsu77Vor 1 TagFrageWindows 1014 Kommentare

Hallo zusammen Ich hoffe, dass jemand von euch mir eine weitere Idee geben kann. Ich habe keine Ideen mehr. Folgendes: Wir haben eine Tasksequenz ...

SAN, NAS, DAS
NAS mit Backup Funktion gesucht
YellowcakeVor 1 TagFrageSAN, NAS, DAS8 Kommentare

Hallo zusammen ich bin total unerfahren was diese NAS Systeme angeht die man sich zuhause hinstellen kann. Aktuell habe ich einen kleinen Server hier ...