Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Bat Prozedur bricht immer nach ca. 4 min. ab

Mitglied: snowhill

snowhill (Level 1) - Jetzt verbinden

12.12.2007, aktualisiert 13.12.2007, 3220 Aufrufe, 1 Kommentar

bild.bat

Hallo

Folgendes:
Ich habe eine Datei:

Bild.bat

mit folgenden Code:
rcp elektra:/usr/elektra/archiv99/TD_01000_8588_0_01.CIP katalog:/ekat/eltis_cd/eltis_cd/cip/01-8588.CIP
rcp elektra:/usr/elektra/archiv99/TD_01000_8590_0_01.CIP katalog:/ekat/eltis_cd/eltis_cd/cip/01-8590.CIP
rcp elektra:/usr/elektra/archiv99/TD_01000_8606_0_01.CIP katalog:/ekat/eltis_cd/eltis_cd/cip/01-8606.CIP
rcp elektra:/usr/elektra/archiv99/TD_01000_8607_B_01.CIP katalog:/ekat/eltis_cd/eltis_cd/cip/01-8607.CIP
rcp elektra:/usr/elektra/archiv99/TD_01000_8608_0_01.CIP katalog:/ekat/eltis_cd/eltis_cd/cip/01-8608.CIP
rcp elektra:/usr/elektra/archiv99/TD_01000_8613_0_01.CIP katalog:/ekat/eltis_cd/eltis_cd/cip/01-8613.CIP
rcp elektra:/usr/elektra/archiv99/TD_01000_8628_0_01.CIP katalog:/ekat/eltis_cd/eltis_cd/cip/01-8628.CIP
rcp elektra:/usr/elektra/archiv99/TD_01000_8630_0_01.CIP katalog:/ekat/eltis_cd/eltis_cd/cip/01-8630.CIP
rcp elektra:/usr/elektra/archiv99/TD_01000_9132_B_01.CIP katalog:/ekat/eltis_cd/eltis_cd/cip/01-9132.CIP
rcp elektra:/usr/elektra/archiv99/TD_01000_9133_B_01.CIP katalog:/ekat/eltis_cd/eltis_cd/cip/01-9133.CIP
rcp elektra:/usr/elektra/archiv99/TD_01000_9136_B_01.CIP katalog:/ekat/eltis_cd/eltis_cd/cip/01-9136.CIP
rcp elektra:/usr/elektra/archiv99/TD_01000_9138_B_01.CIP katalog:/ekat/eltis_cd/eltis_cd/cip/01-9138.CIP
rcp elektra:/usr/elektra/archiv99/TD_01000_9139_A_01.CIP katalog:/ekat/eltis_cd/eltis_cd/cip/01-9139.CIP
..........

ca. 1000 Zeilen

ABER:
Nach 4 Minuten bricht er den Vorgang ab

Fehlermeldung:
Keine.
Der Kopiervorgang bleibt einfach stehen, die Befehlszeile zeigt er noch an aber das Bild wird nicht kopiert.

Betriebssystem Windows 2000 SP4 (bei Windows 2000 SP2 hat es funktioniert - ich weiß aber nicht ob weitere Einstellungen getätigt wurden)

Lösungsversuche:
Öffne ich ein neues CMD-Fenster und tippe den Befehl ab, bei dem er stehen geblieben ist funktioniert es ohne Probleme
Lösche ich die ersten 100 Zeilen und starte erneut, dann kommt er ungefähr 100 Zeilen weiter... d.h. er bricht immer nach einer bestimmten Zeit (ca. 4 Min. ab)

Hat jemand eine Ahnung woran das liegen könnte???

Vielen Dank - Snowhill
Mitglied: Biber
13.12.2007 um 06:52 Uhr
Moin Snowhill,

dieses Verhalten deuten ja darauf hin, dass die Befehle nicht nacheinander gestartet werden (wie es die Batchdatei suggeriert) sondern parallel.
Und dann ist natürlich irgendwann dicht - z.B. die Anzahl paralleler Download-Connections ausgereizt.

Abhilfe:
  • entweder die rcp-Aufrufen ändern in "Start /w rcp...[bla]..."-Aufrufe
  • oder, falls die rcp-Aufrufe irgendeine Bildschirmausgabe haben (z.B "...file copied.."), diese umleiten in eine Datei und erst weitermachen, wenn diese Datei da ist.

Grüße
Biber
Bitte warten ..
Ähnliche Inhalte
Weiterbildung
Bat Dateien
Frage von fajo23Weiterbildung20 Kommentare

Ich habe folgendes Problem. Ich habe auf meiner Festplatte viele Dateinamen die wie folgt aussehen: 20180126 2355 - Dlf ...

Windows Netzwerk

Korrekte Prozedur Domänencomputer Windows 10 Neuinstallation

Frage von lcer00Windows Netzwerk7 Kommentare

Hallo zusammen, bezugnehmend auf dieses Thread wollte ich nur noch mal nachfragen, wie man korrekterweise den PC innerhalb der ...

Batch & Shell

Bat Datei Auführen

gelöst Frage von talaihanBatch & Shell1 Kommentar

Hallo, wie kann man es erreichen das eine Bat Datei auf einem Lokalen Rechner ohne Internetzugriff und ohne zugehörigkeit ...

Router & Routing

Routing bricht zusammen

gelöst Frage von 127944Router & Routing57 Kommentare

Ich beschäftige mich nun seit diversen Tagen mit einem Problem, bei dem ich einfach nicht weiter komme. Aus mir ...

Neue Wissensbeiträge
iOS
IOS hat nen Cursor !!!
Tipp von Criemo vor 6 StundeniOS

Nette Funktion im iOS. iPhone-Mauszeiger aktivieren „Nichts ist nerviger, als bei einem Tippfehler zu versuchen, den iOS-Cursor an die ...

Off Topic
Avengers 4: Endgame - Erster Trailer
Information von Frank vor 2 TagenOff Topic1 Kommentar

Ich weiß es ist Off Topic, aber ich freue mich auf diesen Film und vielleicht geht es anderen hier ...

Webbrowser
Microsoft bestätigt Edge mit Chromium-Kern
Information von Frank vor 2 TagenWebbrowser5 Kommentare

Microsoft hat nun in seinem Blog bestätigt, dass die nächste Edge Version kein EdgeHTML mehr für die Darstellung benutzen ...

Sicherheit

MikroTik: Sicherheitslücke wird ausgenutzt obwohl ein Update seit langem verfügbar ist

Information von sabines vor 2 TagenSicherheit

Obwohl ein Update, dass die nun massenhaft ausgenutzte Lücke schließt, seit langem (März 2018) verfügbar ist, wird es offensichtlich ...

Heiß diskutierte Inhalte
Exchange Server
Exchange Server 2010: Keine Eingehenden E-MAils
Frage von gabeBUExchange Server15 Kommentare

Hallo Zusammen Ich habe das kurzen auf dem Exchange 2010 Server das Problem, dass ich keine externen E-Mails mehr ...

Rechtliche Fragen
Systemhaus auf Abwegen
Frage von rocco61Rechtliche Fragen13 Kommentare

Hallo zusammen, bin derzeit ratlos bei dem folgenden Scenario: In einen Seniorenheim wurde beschlossen, die IT an eine andere ...

Router & Routing
MikroTik - Routing, Bridging, Switching
gelöst Frage von Alex29Router & Routing9 Kommentare

Hallo in die Runde, als Hobby-Admin würde ich bitte mal wieder Eure Hilfe benötigen. Seit der Umstellung auf RouterOS ...

Outlook & Mail
Kalendersync mit Android und Outlook
Frage von Stefan007Outlook & Mail8 Kommentare

Hi Leute, kennt jemand eine Möglichkeit um Termine zwischen installiertem Outlook auf dem PC und dem Kalender auf einem ...