Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Batch per GPO verteilen - funktioniert bei 2 Usern nicht

Mitglied: schlumpfinchen

schlumpfinchen (Level 1) - Jetzt verbinden

02.04.2010, aktualisiert 10:27 Uhr, 7508 Aufrufe, 2 Kommentare

Hallöchen - ich schon wieder

ich bin derzeit noch in der Testphase, um 3 Desktopicons per Gruppenrichtline zu verteilen.

Es gibt also ein cmd-File mit Inhalt

01.
mkdir %systemroot%\system32\abc
02.
copy /Y \\domain.name\SysVol\domain.local\Policies\{D20050A5-3546-471A-AF5D-768309ED440D}\User\Scripts\Logon\xxx.ico %systemroot%\system32\abc
03.
copy /Y \\domain.name\SysVol\domain.local\Policies\{D20050A5-3546-471A-AF5D-768309ED440D}\User\Scripts\Logon\Icon.lnk "%homedrive%%homepath%\desktop"
Dieses cmd-File sowie die Files xxx.ico und Icon.lnk liegen unter der jeweiligen Policy im sysvol Verzeichnis.

Meine Tests waren erfolgreich - es wurde der Ordner in system32 sowie das Desktop-Icon richtig angelegt.
Nachdem ich nun 2 Echt-User in die jeweilge Berechtigungsgruppe hinterlegt habe, haben diese mir gesagt, dass das Icon nicht da sei (und nach meiner Kontrolle ist
auch der Ordner nicht erstellt worden).
Nun, dann habe ich mich auf einem weiteren Test-PC mit diesen beiden Usern angemeldet - dort hat die Ausführung sofort funktioniert.

Habt ihr eine Idee, woran ich hier scheitere?

Clients laufen unter XP, SP3
Server: AD auf 2003, SP2

Achja, das Script vom Sysvol-Ordner geöffnet funktioniert bei den beiden Usern tadellos ...

lg
schlumpfinchen
Mitglied: bastla
02.04.2010 um 17:48 Uhr
Hallo schlumpfinchen!

Da die Icons unterhalb von "System32" gespeichert werden sollen, dürfte es eine Frage der Berechtigungen sein ...

Die einfachste Lösung wäre es (abgesehen davon, einen anderen Speicherort zu wählen ), das Kopieren der Icons per "Start"- (Computerkonfiguration) und nicht per "Logon"-Script durchzuführen ...

BTW: Ein "copy" in einem Batch überschreibt vorhandene Dateien auch ohne "/y" ...

Grüße
bastla
Bitte warten ..
Mitglied: schlumpfinchen
15.04.2010 um 14:54 Uhr
Hallöchen

Danke für eure Inputs.
Hab den Speicherort umgestellt, funktioniert soweit ganz gut.

Ein Problem hab ich noch:
ich hab noch eine Abfrage gemacht in vbs, danach wird die cmd Datei aufgerufen.
Eigentlich sollte die vbs Datei beim Computer Startup starten (und ein Programm installieren) - leider tut's das nicht.
Händisch angeworfen funktioniert die Installation.

Ich hab die GPO erstellt, und das vbs File bei Startup angegeben. Im sysvol-Ordner der GPO liegen vbs und cmd Datei.


Dankeschön im Voraus für eure Hilfe
schlumpfinchen

edit: scheinbar läuft da doch irgendwas beim Startup - im eventlog bekomm ich Warnung 108 - Application Management: "Die Änderungen an den Softwareeinstellungen wurden nicht angewendet. Fehler: Die Gruppenrichtlinienumgebung sollte die Erweiterung in der synchronen Vordergrundrichtlinienaktualisierung aufrufen". ????
Bitte warten ..
Ähnliche Inhalte
Windows Server

GPO soll zwangsabmeldung von Usern ermöglichen

gelöst Frage von LordNicon79Windows Server7 Kommentare

Hallo zusammen, ich suche grad die Möglichkeit über GPOs ein Zeitfenster zur Anmeldung von Usern zu definieren. Den Punkt ...

Windows Server

Windows 2012 Autologon von 2 Usern

Frage von femi71Windows Server10 Kommentare

Hallo, Ich habe einen Windows 2012 Server auf dem ich einige Sachen per Autostart starte, für einen lokalen Benutzer ...

Windows Server

GPO Dateiverteilung funktioniert nicht

gelöst Frage von killtecWindows Server6 Kommentare

Hallo, ich habe eine GPO, die soll mir den Teamviewer QS auf den Desktop kopieren, jedoch passiert das aus ...

Windows Server

GPO um Usern zu verbieten Updates zu installieren

Frage von TomTestWindows Server1 Kommentar

Hallo liebe Freunde gepflegter Probleme wir haben hier einige Terminalserver und in einer verknüpften GPO zu der OU in ...

Neue Wissensbeiträge
Internet
EU-Urheberrechtsreform: Zusammenfassung
Information von Frank vor 1 TagInternet

Auf golem.de gibt es eine Analyse von Friedhelm Greis, der das Thema EU-Urheberrechtsreform gut und strukturiert zusammenfasst. Zwar haben ...

Microsoft Office

Office365 Schwachstellen bei Sicherheit und Datenschutz

Information von Penny.Cilin vor 2 TagenMicrosoft Office7 Kommentare

Auf Heise+ gibt es einen Artikel bzgl. Office365 Schwachstellen. Das ist noch ein Grund mehr seine Daten nicht in ...

Sicherheit
Schwachstellen in VPN Clients
Tipp von transocean vor 4 TagenSicherheit2 Kommentare

Moin, es gibt Sicherheitslücken bei VPN Clients namhafter Hersteller, wie man hier lesen kann. Gruß Uwe

Sicherheit

Wikileaks-Gründer Julian Assange wurde festgenommen

Information von Frank vor 7 TagenSicherheit3 Kommentare

Wikileaks-Gründer Julian Assange wurde heute in London festgenommen. Die Botschaft Ecuadors, in der er seit sieben Jahren lebte, hat ...

Heiß diskutierte Inhalte
Tipps & Tricks
Verdammt voll erwischt
Frage von AlchimedesTipps & Tricks23 Kommentare

Folgende Mail habe ich auf meinem Freenet Account erhalten: Nun folgendes Problem: 1) Ich besuche Porno Seiten yep hat ...

Drucker und Scanner
Xerox 7328 muss jeden Tag neu installert werden
Frage von PN-SchrauberDrucker und Scanner20 Kommentare

hallo, ich habe in Problem mit einem unserer Drucker. Vorweg, die meisten unserer Netzwerkdrucker laufen über einen Druckserver, dieser ...

HTML
Google maps
Frage von jensgebkenHTML20 Kommentare

Hallo Gemeinschaft, hab mal ne Frage zu Maps - habe es hinbekommen, dass ich einen iframe link erstellen kann ...

Switche und Hubs
PC Verursach Probleme im Netzwerk
gelöst Frage von spoboeSwitche und Hubs16 Kommentare

Hallo zusammen, folgene Situation macht mich inzwischen ratlos: In unserem Betrieb ist ein Rechner über die Hausverkabelung an einem ...