BIOS-RAID mit 4 TB platten werden im System als nur 1802GB RAID-Verbund angezeigt - Debian

Mitglied: Gansterjo2

Gansterjo2 (Level 1) - Jetzt verbinden

31.01.2016, aktualisiert 13:05 Uhr, 1250 Aufrufe, 4 Kommentare

Liebe Forumsmitglieder

Mein Ziel: Aus einem herrkömlichen Computer soll ein NAS werden. Dabei werden die Platten über das BIOS-RAID zu einem Festplattenverbund konfiguriert (25GB als Systemdisk und 4001GB als Datendisk)

Mein System:
- Mainboard: ASUS Z170M-Plus
- CPU: i5-6500
- RAM: 16GB RAM
- Festplatten: 2x 251GB Platten [RAID 1], 2x 4001GB Platten [RAID 1] (Über BIOS-Raid konfiguriert)

Betriebssystem: Linux linux-nas 3.16.0-4-amd64 #1 SMP Debian 3.16.7-ckt20-1+deb8u3 (2016-01-17) x86_64 GNU/Linux

Also ein Debian 3.16.7


Mein Problem:
Die 4 TB Platten werden als RAID-Verbund im Betriebssystem nur als 1,8 TB angezeigt

6f78ce1530757078855c9715e1fc9938 - Klicke auf das Bild, um es zu vergrößern


Das habe ich schon Probiert:
- Den RAID-Verbund abgebrochen und im BIOS neu konfiguriert
- Den RAID-Verbund als GPT formatieren
- Den RAID-Verbund zu formatieren und anzugeben, dass es 4 TB sind
- mit GParted versucht den RAID-Verbund zu formatieren (bricht das Raid selbständig ab, da nur im Lesemodus darauf zugegriffen werden kann ?!?)

Wie kann ich den Fehler beheben?

Ich bedanke mich schon jetzt für die Antworten.
Mitglied: Lochkartenstanzer
31.01.2016, aktualisiert um 14:53 Uhr
Zitat von @Gansterjo2:

Mein Ziel: Aus einem herrkömlichen Computer soll ein NAS werden. Dabei werden die Platten über das BIOS-RAID zu einem Festplattenverbund konfiguriert (25GB als Systemdisk und 4001GB als Datendisk)

Wieso machst du das überhaupt über das BIOS? Für mich sieht das wie ein Fakeraid aus, bei dem der BIOS-Progframmierer geschlampt hat. Wenn dda nur 2 TB angezeigt stimmt irgendetwas mit der "Blockanzahl" ncht. Das Ding rechnet anscheinend Modulo 32bit.

ich würde einfach die RAIDs manuell mit mdadm zusammenbauen.

lks

Nachtrag


Boote mal mit veschiedenen live-linuxen wie z.B. knoppix, kali, ubuntu, cenOS, etc. udn ggf noch einem Windpws-PE (Installationsmedien reichen) und schau, ob die Größenangabe immer noch so falsch ist. Sollte das dre fall sein, ist es vermutlich ein BIOS-Problem. Ansonsten ein treiberproblem.

lks
Bitte warten ..
Mitglied: Gansterjo2
31.01.2016 um 15:48 Uhr
Vielen Dank für diese Tipps.

Ich wollte ein RAID über das BIOS erstellen, weil ich dachte, dass dies eine saubere Lösung wäre. Das booten über mehrere Systeme (und anschauen des RAID-Laufwerks) werde ich morgen machen, da ich im Geschäft einen Multiboot USB-Stick erstellen muss und diesen gleich ausprobieren könnte. Testen sollte ich das eigentlich sowieso.

Falls es ein Treiberproblem wäre könnte ich sowieso nicht viel dagegen unternehmen, da ASUS keine Treiber für Linux bereitstellt. Ich müsste dann einfach, wie du es bereits geschrieben hast, ein RAID mit mdadm erstellen.

Morogenabend werde ich Rückmeldung geben.

Liebe Grüsse aus der Schweiz :-) face-smile
Bitte warten ..
Mitglied: Gansterjo2
03.02.2016 um 19:42 Uhr
Hallo Zusammen

So ich konnte nun testen, ob ein Fehler im RAID liegt.

Ich habe von einer Windows 8.1 CD gebootet. Windows zeigt als möglichkeit eine normale 4 TB platte (also das RAID). Es ist also davon auszugehen, dass entweder der Treiber nicht stimmt oder Linux nicht mit so grossen Festplatten ohne zusätzliche Konfiguration umgehen kann...

Was soll ich als nächstes tun?

Freundliche Grüsse

Gansterjo2
Bitte warten ..
Mitglied: Gansterjo2
08.02.2016 um 09:29 Uhr
Hallo Zusammen

Das Problem ist nun abgeschlossen, bin auf Widnows Server 2012 umgestiegen.

Freundliche Grüsse

Gansterjo2
Bitte warten ..
Heiß diskutierte Inhalte
Off Topic
Realistische Gehaltsvorstellung für eine "IT-Allroundkraft"
gelöst JiggyLeeVor 23 StundenFrageOff Topic19 Kommentare

Hallo an alle, ich hege momentan den Wunsch mich von der alten verstaubten Behörden Bürokratie und langweiliger Aufgaben los zu lösen und in einem ...

Windows 10
Windows 10 Geschwindigkeitprobleme trotz viel mehr Gb Ram
Matthes88Vor 1 TagFrageWindows 1045 Kommentare

Hallo ihr lieben aaaalso : Da mein neuer Arbeitsspeicher (32gb) von meiner alten Windows 7 version (max mit 8gb kompatibel) nicht angenommen wurde, habe ...

Humor (lol)
Tipp: Dinge, die man besser nicht klaut
altmetallerVor 1 TagTippHumor (lol)12 Kommentare

Hallo, so wurde meiner Hündin z.B. heute der (eingeschaltete) GPS-Tracker mit Mobilfunkanbindung quasi "direkt vom Halsband weggefunden". Akku hatte noch 60% :-P Und ich ...

Windows Server
GPU Passthrough HYPER-V 2019
bintesVor 1 TagFrageWindows Server8 Kommentare

Hallo, ich habe ein ein Problem mit der Bereitstellung einer Grafikkarte an eine virtuelle Maschine. Hardware: - HPE ProLiant DL380 Gen9 V4 Rack Server ...

Video & Streaming
Videoaufnahme funktioniert nur bis zum ersten Reboot (0x80040217)
IllusionFACTORYVor 1 TagFrageVideo & Streaming11 Kommentare

Ich nehme über eine Video-Software von einem USB-Hardware-Encoder Video auf. Das funktioniert exakt bis zum ersten Reboot - danach bekomme ich beim Starten der ...

Windows Server
Windows Admin Center DC
maximidVor 1 TagFrageWindows Server3 Kommentare

Hallo, ich hätte mal eine Frage zu Windows Admin Center und zwar schaue ich es mir aktuell etwas an da mir die zentrale Verwaltung ...

Grafikkarten & Monitore
Monitorhalterung mit 80cm Armlänge
ben1300Vor 22 StundenFrageGrafikkarten & Monitore7 Kommentare

Guten Abend ! ich bin auf der Suche nach einer Monitorhalterung, im besten Fall ohne Bohrung für einen 28" Monitor (Vesa Halterung). Nun kommt ...

SAN, NAS, DAS
Synology DS213j - Volume nach HDD Austausch vergrößern
gelöst JasperBeardleyVor 1 TagFrageSAN, NAS, DAS4 Kommentare

Moin, ich hab meinem NAS zwei neue 8TB spendiert, da die 3TB Platten jetzt 6 Jahre alt sind. Da die beiden Platten im JBOD ...