Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

CAPSMAN: Probleme mit getaggten VLANs

Mitglied: snoert

snoert (Level 1) - Jetzt verbinden

05.08.2019, aktualisiert 21:57 Uhr, 427 Aufrufe, 1 Kommentar

Hallo zusammen,

ich habe Probleme mit der VLAN-Konfiguration bei folgendem Setup:
Ich habe einen RB750gr3 als CAPSMAN Controller konfiguriert. Dieser ist mit einem PoE-Switch verbunden. Vom Switch geht ein längeres Patchkabel zum Wohnzimmer im EG wo ein cap AC angeschlossen ist. Vom Wohnzimmer geht ein 2. Kabel ein Stockwerk höher zum zweiten cap AC. Der 2. cap AC hängt direkt am ersten und wird von dort mit Strom versorgt. Das hat bislang ohne Probleme funktioniert bis ich ein Gast-WLAN nebst zugehöriger VLANs konfiguriert habe. Ich hatte erst CAPSMAN forwarding ausprobiert und bin nun beim CAPSMAN mit lokalen Ausgang stecken geblieben. Das Problem ist in beiden Fällen das gleiche: Ich habe einen Temperatursensor. Dieser ist dauerhaft mit dem WLAN verbunden. Mehrmals in der Woche kann dieser keine IP-Adresse über DHCP beziehen. Ab und zu geht es wieder einmal, dann wieder nicht. Ich kann hier kein Muster erkennen. In diesem Fall bringt ein Neustart vom Sensor gar nichts. Wenn ich aber dann über CAPSMAN einmal die cap AC neu provisoniere oder die cap AC neu starte funktioniert es sofort wieder.
Zur Konfiguration:
  • Ich habe eine Management-IP am Accesspoint im VLAN 1. Die IP-Adresse bekommt er über DHCP. Aktivieren konnte ich das nur auf der Bridge1. Wenn ich den DHCP-Client auf dem VLAN1-Interface aktiviere, bekommt er keine IP-Adresse.
  • VLAN 10: Internes WLAN
  • VLAN 20: Gäste WLAN
  • Ich habe die MTU überall erhöht, weil mir nicht so klar ist wie hier der Ablauf ist. Vom Router kommt ein getaggter Ethernet Frame mit bis zu 1522 Byte am 1. cap AC an. Deswegen muss doch dort die MTU erhöht werden (Hauptsache höhrer als 1522). Ich habe das auf dem ether1, ether2 und zusätzlich auf der Bridge gemacht
  • Auf den cap AC benötige ich doch keine VLAN Interfaces, da ich dort keine IP-Adresse zu vergeben habe. Ich tagge hier nur durch, korrekt?
  • Spanning Tree habe ich deaktiviert, VLAN Filter ist eingeschaltet.

  • Anbei der Auszug vom cap AC. Letztendlich ist diese auf beiben cap AC die gleiche:
01.
/interface bridge
02.
add fast-forward=no igmp-snooping=yes mtu=1580 name=bridge1 protocol-mode=none vlan-filtering=yes
01.
/interface ethernet
02.
set [ find default-name=ether1 ] mtu=1580 speed=100Mbps
03.
set [ find default-name=ether2 ] mtu=1580 speed=100Mbps
01.
/interface vlan
02.
add interface=bridge1 name=vlan1 vlan-id=1
01.
/interface bridge port
02.
add bridge=bridge1 interface=ether1
03.
add bridge=bridge1 interface=ether2
01.
/interface bridge vlan
02.
add bridge=bridge1 tagged=bridge1,ether1,ether2,wlan1,wlan2 vlan-ids=10,20
01.
/interface wireless cap
02.
set bridge=bridge1 caps-man-addresses=192.168.100.1 enabled=yes interfaces=wlan1, wlan2
01.
/ip dhcp-client
02.
add dhcp-options=hostname,clientid disabled=no interface=bridge1
01.
Auf dem CAPSMAN Controller sind die VLANs fest gesetzt:
02.
add client-to-client-forwarding=yes  local-forwarding=yes name=datapath-meins vlan-id=10 vlan-mode=use-tag
03.
add client-to-client-forwarding=yes  local-forwarding=yes name=datapath-gast vlan-id=20 vlan-mode=use-tag
Könntet Ihr bitte einmal kurz darüber schauen, ob hier alles stimmt?
Mitglied: aqui
06.08.2019, aktualisiert um 10:38 Uhr
An der MTU zu drehen ist tödlich, das solltest du in keinem Falle machen und dringenst wieder rückgängig auf den Default 1500 setzen !!
Du betreibst ja keinerlei Encapsulation sondern arbeitest rein in einer LAN Umgebung in so fern ist es also sinnfrei an der MTU zu drehen, da du ja niemals andere MTUs hast.
Auf den cap AC benötige ich doch keine VLAN Interfaces
Ja, das ist richtig. Die Management IP reicht.
Spanning Tree habe ich deaktiviert
Besser nicht, denn das birgt dann die Gefahr von Loops. Belasse das auch auf dem RSTP Default und aktiviere das auch auf deinem Switch. Am Switch solltest du die RSTP Priority auf 8192 setzen und so den Switch zum Root Switch machen.

Zum Rest ist schwer was zu sagen, denn es bleibt wegen fehlender Infos unklar wie deine VLAN Konfig aussieht. Z.B. wer der zentrale Router ist der die IP Adressen der VLANs vorhält und das Layer 3 terminiert.
Du solltest in jedem Falle Router OS 6.41 oder höher installiert haben um die neue VLAN Syntax zu nutzen.
Das Mikrotik VLAN Tutorial hier beschreibt dir in allen Einzelheiten wie das dann umzusetzen ist:
https://administrator.de/wissen/mikrotik-vlan-konfiguration-routeros-ver ...
Hast du das so umgesetzt ??
Dynamische P Adressen beim Management sind generell keine gute Idee. Wenn du DHCP dafür nutzen willst solltest du zumindest im DHCP Server eine feste IP Reservierung auf Basis der Mac Adresse konfigurieren, damit die Management IP immer fix ist. Oder eben ganz statisch.
Sinnvopll ist erstmal das Basis Gerüst des netzes so wie im Tutortial umzusetzen das es stabil rennt und dann erst CapsMan zu aktivieren.
Bitte warten ..
Ähnliche Inhalte
LAN, WAN, Wireless

WLAN: VLAN-Zuordnung anhand Radius-Eigenschaften? MikroTik CAPsMAN

gelöst Frage von hummusLAN, WAN, Wireless65 Kommentare

Liebe Experten, ich habe eine pfSense als Router und mehrere Zyxel GS1900-Switche im Einsatz. Dort hängen aktuell zwei MikroTik ...

Router & Routing

Wie CAPs am CAPsMAN updaten?

gelöst Frage von McLionRouter & Routing13 Kommentare

Hallo, ich betreibe schon seit einem 0.5 Jahr erfolgreich den CAPsManager. Nun habe ich den Manager upgedatet, weiß aber ...

Netzwerkmanagement

Internes wlan1 in CAPsMAN einbinden

gelöst Frage von McLionNetzwerkmanagement9 Kommentare

Hallo, ich habe erfolgreich CAPsMAN mit zwei anderen MKs eingerichtet. Nun möchte ich die interne wlan1-Schnetstelle mit in den ...

Netzwerkmanagement

Problem DHCP und VLAN

Frage von idontknowNetzwerkmanagement6 Kommentare

Hi, Ich würde mich sehr freuen, wenn mir jemand bei meinem kleinen aber feinen Problem helfen könnte ;-) Problem: ...

Neue Wissensbeiträge
Linux Userverwaltung

Samba-ActiveDirectory mit FreeRADIUS, CheckMK, Nextcloud, OpenVPN, ProxmoxVE und mehr

Anleitung von BinaryBear vor 3 StundenLinux Userverwaltung

Ich habe die letzten Wochen (Monate) damit verbracht mit in das Thema ActiveDirectory und Samba einzuarbeiten. Dabei habe ich ...

Verschlüsselung & Zertifikate

Extended Validation Certificates are (Really, Really) Dead

Information von Dani vor 2 TagenVerschlüsselung & Zertifikate

Moin all, sehr interessanter Artikel zu EV SSL/TLS- Zertifikate von Troy Hunt: Gruß, Dani

Humor (lol)
Das IoT wird schlimmer
Erfahrungsbericht von Henere vor 5 TagenHumor (lol)8 Kommentare

Nun auch schon über den WSUS:

Sicherheit

Win10 1809 und höher erlauben nun das Sperren und Whitelisten von bestimmten Geräten

Tipp von DerWoWusste vor 5 TagenSicherheit1 Kommentar

Vor 1809 konnten nur Geräteklassen gesperrt werden, nun können endlich einzelne Device instance IDs gewhitelistet werden (oder andersherum: gesperrt ...

Heiß diskutierte Inhalte
Netzwerke
Suche schnelleren VPN-Router für IPSec-Verbindung und zusätzlichem S0-Port für TK-Anlage, um Fritzbox zu ersetzen
Frage von TomSEE01Netzwerke46 Kommentare

Hallo, ich bin neu hier im Forum. Und zwar hätte ich folgende Frage, ich benötige eine VPN-Server Fähige Firewall/Router, ...

Schulung & Training
Was sollte man im Helpdesk bzw Service Desk 1st Level wissen
Frage von loubertSchulung & Training28 Kommentare

Hallo zusammen, ich fange demnächst in einem IT-Systemhaus meinen neuen Job im IT-Helpdesk (UHD), 1st Level (für externe Kunden,) ...

Netzwerkmanagement
Netzwerksegmentierung eines 16bit Kundennetzes
Frage von Locke2016Netzwerkmanagement21 Kommentare

Hallo lieber IT Mitstreiter, ich habe folgendes Problem bei einem Kunden, der ein grosses /16 Netz hat und bei ...

Hosting & Housing
IPv4 Dienst im IPv6 Netzwerk
gelöst Frage von Jumper205Hosting & Housing19 Kommentare

Hallo Zusammen, ich benötige mal euer schwarm Wissen. Ich wurde vor einiger Zeit auf einen Deutsche Glasfaser Anschluss umgestellt. ...