Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

clientanmeldung mit startskript (gpo) läuft zu lange

Mitglied: riemus

riemus (Level 1) - Jetzt verbinden

05.03.2008, aktualisiert 10.03.2008, 6864 Aufrufe, 3 Kommentare

hallo!
wir haben ein problem mit der clientanmeldung an unserer windows 2003-domäne.

in einer gruppenrichtlinie haben wir im start-skript folgende batch-dateien hinterlegt:
1.) c:\
cd\
rd c:\temp
md c:\temp
rd c:\dat

2.) net use o: /delete
net use o:\\ipadresse\freigabe

seit die gruppenrichtlinie verknüpft ist, dauert die anmeldung an den clients bis zu 10 minuten.
kann man die abarbeitung des skripts irgendwie beschleunigen?

auch dachte ich dass die skripts in der gpo bereits vor der anmeldung durchgeführt werden? kann man hier noch etwas einstellen?
Mitglied: 60730
05.03.2008 um 16:40 Uhr
rd c:\temp /q
md c:\temp
rd c:\dat /q


net use o: /delete
net use o: \\ipadresse\freigabe

Hi,

zuerst mal, warum ist die batch so konstruiert?
c:\
cd\
kannst du dir - wenn das wirklich die Batch ist - sparen - genauso, wie die Fehlermeldungen die das Skript liefert....

"Sowas" brauchst du nur, wenn du innerhalb von c: in einen Ordner - en du nicht genau kennst wechseln mußt. z.B cd c:\ temp? - das sehe ich aber in deinem Beispiel nicht - daher raus damit.


Die Zeile rd c:\temp "reicht" doch
Allerdings würde ich dann auch c:\temp /q dranstellen, um die Nachfrage - ob wirklich gelöscht werden soll zu unterbinden.

"läuft" die Batch überhaupt durch?
"Sowas" immer in einer Dosbox Testen und Fehler suchen, bevor das in die GPO reinkommt.

PS: Wo steht das in der GPO? Beim Start des Rechners?

Probier mal die Änderungen, die du oben siehst...
Auch das Leerzeichen zwischen Net Use o: und \\ !!!
Bitte warten ..
Mitglied: riemus
10.03.2008 um 09:29 Uhr
hallo, als erstes mal danke für die antwort!

die fehlenden parameter im "rd"-befehl und das fehlende leerzeichen im "net use" war mein fehler beim erstellen des thread.
hab die ersten beiden zeilen rausgenommen und die batch-datei lautet jetzt genau so:

rd c:\temp /s/q
md c:\temp
rd c:\orbis32 /s/q

net use o: /delete
net use o: \\192.168.145.21\public

leider ist keine änderung eingetreten.

die batchdatei wird über folgende gpo aufgerufen:

Computerkonfiguration - Windows-Einstellungen - Skripts - Starten (die batch liegt im sysvol-ordner in der entsprechenden policy).

wie gesagt, wenn die policy aktiv ist, dauert die anmeldung bis zu 15min, bei inaktiver policy gehts ratz-fatz...
Bitte warten ..
Mitglied: 60730
10.03.2008 um 10:01 Uhr
Moin,

Mach mal folgendes:

Starte das Script, manuell, nachdem du dich angemeldet hast stoppe die Zeit.
Wahrscheinlich wird er sich beim temp Ordner beschweren, also kopiert du den vorher und löscht die Kopie.

Und dann zerdrösel das doch mal in einzelne Schritte.

Wie lange das Temp löschen dauert - das mußt du mal stoppen
Genauso wie den orbis Ordner und das Net use.

Das Net Use würde ich in das Userloginscript verschieben.
Bitte warten ..
Ähnliche Inhalte
Batch & Shell
Öffentlicher Desktop - Startskript
gelöst Frage von xbast1xBatch & Shell2 Kommentare

Hallo zusammen, ich habe ein Batchfile welcher Dateien und Verknüpfungen auf dem öffentlichen Desktop entfernen soll. Lokal ausgeführt funktioniert ...

Batch & Shell
Homelaufwerke im Startskript zuweisen
Frage von SirTomBatch & Shell3 Kommentare

Hallo, ich möchte gerne die Homelaufwerke in einem Startskript (vbs, Windowsumgebung) zuweisen. Momentran sieht das so aus (nur Teile ...

Windows Server
Ps1 Script lauft nicht
gelöst Frage von 131455Windows Server8 Kommentare

Hallo, führe ich Zeilen wie würde die eben als Aufgabenplanung gerne hinterlegen. Gruss Rainer

Windows Server
Dateiname zu lang
gelöst Frage von nooneelsebutmeWindows Server3 Kommentare

Hallo, habe Daten von einem Server 2008 R2 auf einen Server 2016 ES per robocopy migriert. Hat alles Problemlos ...

Neue Wissensbeiträge
iOS
WatchChat für Whatsapp
Tipp von Criemo vor 1 TagiOS

Ziemlich coole App für WhatsApp User in Verbindung mit der Apple Watch. Gibts für iOS sowohl als auch für ...

iOS
IOS hat nen Cursor !!!
Tipp von Criemo vor 1 TagiOS5 Kommentare

Nette Funktion im iOS. iPhone-Mauszeiger aktivieren „Nichts ist nerviger, als bei einem Tippfehler zu versuchen, den iOS-Cursor an die ...

Off Topic
Avengers 4: Endgame - Erster Trailer
Information von Frank vor 3 TagenOff Topic2 Kommentare

Ich weiß es ist Off Topic, aber ich freue mich auf diesen Film und vielleicht geht es anderen hier ...

Webbrowser
Microsoft bestätigt Edge mit Chromium-Kern
Information von Frank vor 4 TagenWebbrowser5 Kommentare

Microsoft hat nun in seinem Blog bestätigt, dass die nächste Edge Version kein EdgeHTML mehr für die Darstellung benutzen ...

Heiß diskutierte Inhalte
Exchange Server
Exchange Server 2010: Keine Eingehenden E-MAils
gelöst Frage von gabeBUExchange Server17 Kommentare

Hallo Zusammen Ich habe das kurzen auf dem Exchange 2010 Server das Problem, dass ich keine externen E-Mails mehr ...

Windows Netzwerk
Kerio. Kann keine Mails empfangen aber senden. Wer ist schuld. Kerio oder Windows domäne?
gelöst Frage von frosch2Windows Netzwerk17 Kommentare

Hallo, es existiert ein Problem bei uns mit dem mailen. Alle bestehenden Nutzer können mailen. Raus wie rein. Neuen ...

Hosting & Housing
VMware VM mit über 1TB RAM für S4HANA
Frage von Leo-leHosting & Housing15 Kommentare

Hallo zusammen, wer hat Erfahrng und kann mir einen Tipp zum sizing von S4HANA Systemen geben? Wir möchten, zunächst ...

Ubuntu
Eingehängte Partition ändern
Frage von Florian961988Ubuntu14 Kommentare

Hallo wir nutzen hier GITLAB(liegt in einer VMWARE ESXI mit UBUNTU 18.04), dort hat man eine Partition für Root ...