Cups-Server mit SMB lehnt Verbindungen ab (smb.conf)?

Mitglied: ErikHeinemann

ErikHeinemann (Level 1) - Jetzt verbinden

16.04.2021, aktualisiert 08:29 Uhr, 892 Aufrufe, 17 Kommentare, 1 Danke

Guten Morgen,
ich habe einen Ubuntu 20.04 Server mit Cups als Printspooler. Nun Soll noch Samba hinzugefügt werden für eine einfache Verwendung unter Windows. Ich habe mich an den im Internet verfügbaren Anleitungen orientiert und die smb.conf so angepasst, dass Samba Cups als Spooler erkennt.
Wenn ich nun aber den Drucker unter Windows hinzufügen will (\\Printspooler\drucker) bekommte ich die Meldung das keine Weiteren Verbindungen zum Client hergestellt werden können, da bereits die maximale zahl an Verbindungen zu dem Remote-Computer erreicht ist. (siehe Screenshot)

Ich denke das es ein Fehler in der smb.conf ist, habe aber keine Ahnung was es sein könnte.
Vielen Dank für die Hilfe!!
screenshot 2021-04-16 082302 - Klicke auf das Bild, um es zu vergrößern
Mitglied: Lochkartenstanzer
16.04.2021, aktualisiert um 08:56 Uhr
Moin,

Hast Du Samba-Benutzer angelegt oder zumindest die Verbindung als Gast zugelassen?

Wie sieht der Rest der Config aus?

Und warum verbindest Du den Drucker nicht einfach als "Internet-Printer" statt als SMB-Printer?

lks
Bitte warten ..
Mitglied: ErikHeinemann
16.04.2021 um 09:14 Uhr
Hi, Danke für deine Antwort,

den Gastzugrif habe (glaube) ich aktiviert.

Hier die smb.conf:

Mein Ausbilder gab mir die Aufgabe neue Systeme zu probieren. Leider ist es am ende nicht möglich, dass wenn wir dieses System auswählen, würden die Mitarbeiter es nicht hinbekommen einen Internettrucker hinzuzufügen.

Danke & Gruß
Erik
Bitte warten ..
Mitglied: Lochkartenstanzer
16.04.2021, aktualisiert um 10:01 Uhr
Da das Forensystem größere Änderungen nicht erlaubt, habe ich die bereinigte Version frisch reingestellt.


Ich habe mal Deine Config um die Kommentare (#) bereinigt, damit es einfacher zu lesen ist udn die Kollegen dann besser "mitraten" können:


lks

Was mir auffällt, ist das Du netlogon auskommentiert hast. War das in der default-Config so oder hast Du das selbst gemacht.
Bitte warten ..
Mitglied: commodity
16.04.2021 um 09:48 Uhr
Zitat von @Lochkartenstanzer:
Ich habe mal Deine Config um die Kommentare (#) bereinigt, damit es einfacher zu lesen ist udn die Kollegen dann besser "mitraten" können:
Das war auf jeden Fall eine gute Idee! +1

Ich bin in Samba nicht erfahren, aber gehört das nicht auch zur Config des TO?


Dort steht dann auch ein
was doch bedeutet, dass er nicht authorisierte Zugriffe auf einen guest-account mappt. Dieser guest-account ist aber gar nicht angelegt bzw. definiert. Dafür gab/gibt(?) es doch
siehe hier(älteres Baujahr) oder
hier (auch nicht ganz frisch).

Vielleicht hilft es bei der Richtung. Good Luck!
Bitte warten ..
Mitglied: ErikHeinemann
16.04.2021 um 09:50 Uhr
Vielen Dank,
das kommt aus der Standard konfig.
Bitte warten ..
Mitglied: Lochkartenstanzer
16.04.2021 um 09:50 Uhr
Ich bin in Samba nicht erfahren, aber gehört das nicht auch zur Config des TO?

Ups War ein Copy&Paste-fehler.

Wird gleich berichtigt.


lks
Bitte warten ..
Mitglied: Lochkartenstanzer
16.04.2021, aktualisiert um 09:58 Uhr
Hier nochmal die berichtigte bereinigtte Version ohne die #-Kommentare zum mitraten


lks
Bitte warten ..
Mitglied: ErikHeinemann
16.04.2021 um 10:05 Uhr
Muss ich vielleicht das zugreifende Gerät noch irgendwie erlauben?
Bitte warten ..
Mitglied: Lochkartenstanzer
16.04.2021 um 10:08 Uhr
Zitat von @commodity:

Zitat von @Lochkartenstanzer:
Ich habe mal Deine Config um die Kommentare (#) bereinigt, damit es einfacher zu lesen ist udn die Kollegen dann besser "mitraten" können:
Das war auf jeden Fall eine gute Idee! +1

Ich bin in Samba nicht erfahren, aber gehört das nicht auch zur Config des TO?

Nachdem ich das komplette Config ohne den Copy&Past-Fehler gesehen habe, vermute ich auch, daß da der Hase im Pfeffer liegt:

Dort steht dann auch ein
was doch bedeutet, dass er nicht authorisierte Zugriffe auf einen guest-account mappt. Dieser guest-account ist aber gar nicht angelegt bzw. definiert. Dafür gab/gibt(?) es doch
siehe hier(älteres Baujahr) oder
hier (auch nicht ganz frisch).


lks
Bitte warten ..
Mitglied: ErikHeinemann
16.04.2021 um 10:49 Uhr
Ich habe jetzt noch
hinzugefügt.

Mein Administrator Account hat root Rechte.
Müsste ich noch was ändern? oder sollte das das Problem dann lösen?


Vielen Dank für eure Mühe!!!
Bitte warten ..
Mitglied: Lochkartenstanzer
16.04.2021, aktualisiert um 11:15 Uhr
Zitat von @ErikHeinemann:

Ich habe jetzt noch
hinzugefügt.

Mein Administrator Account hat root Rechte.
Müsste ich noch was ändern? oder sollte das das Problem dann lösen?


Nein! Guest mapped man nie auf admin-Rechte, abgesehen davon, daß es den "administrator" unter Linux i.d.R. nicht gibt.

Schreib da lieber "nobody" hin.

Das ist der User, der dafür gedacht ist.

lks
Bitte warten ..
Mitglied: ErikHeinemann
16.04.2021 um 11:16 Uhr
Ja, ist mir bekannt. Befinde mich aber in einem geschlossenen Textsystem Daher. Aber dann probiere ich mal Nobody.
Bitte warten ..
Mitglied: NordicMike
16.04.2021 um 12:10 Uhr
Ist der Name der Freigabe richtig?

\\spoolserver\druckername

Ich frage, weil wir unter Windows die CUPS Drucker so hinzufügen müssen:

http://spoolserver:631/printers/druckername
Bitte warten ..
Mitglied: Lochkartenstanzer
16.04.2021 um 12:18 Uhr
Zitat von @NordicMike:

Ist der Name der Freigabe richtig?

\\spoolserver\druckername

Ich frage, weil wir unter Windows die CUPS Drucker so hinzufügen müssen:

http://spoolserver:631/printers/druckername

Deswegen habe ich ja nachgefragt, warum er smb und nicht Internet-Printing benutzt.

lks
Bitte warten ..
Mitglied: ErikHeinemann
16.04.2021 um 14:21 Uhr
Die Freigabe die du beschreibst ist die über HTTP, die funktioniert auch einwandfrei. Aber das Zeil meiner Recherche im Auftrag meines Ausbilders ist, herauszufinden wie es über Samba funktioniert.
Bitte warten ..
Mitglied: Lochkartenstanzer
16.04.2021, aktualisiert um 14:28 Uhr
Zitat von @ErikHeinemann:

Die Freigabe die du beschreibst ist die über HTTP, die funktioniert auch einwandfrei. Aber das Zeil meiner Recherche im Auftrag meines Ausbilders ist, herauszufinden wie es über Samba funktioniert.

Dann schreib das doch dazu.

Dann richte mal einen zusätzlichen Benutzer "windowsuser" unter Ubuntu ein, richte dem einen Sambaaccount ein und vergib dem ein Paßwort.

Dann schaust Du, ob Du mit Windows auf das Home-Verzeichnis des Users kommst und auch ob Du dann den Drucker nutzen kannst.

Wenn das alles erledigt wurde udn damit die Funktionalität von Samba sichergestellt ist, machst Du Dich daran, das ganze als anonymer User (=Gast) zu tun.

lks
Bitte warten ..
Mitglied: ErikHeinemann
16.04.2021 um 14:44 Uhr
Okay, setze ich mich nächste Woche dran. Vielen dank für deine Hilfe!!!
Bitte warten ..
Heiß diskutierte Inhalte
Router & Routing
FB und Archer 2 getrennte Netze mit einer WAN-Verbindung
neuhier14Vor 1 TagFrageRouter & Routing25 Kommentare

Hallo, ich habe eine Fritzbox 7490 und einen Archer C5 mit OpenWRT. Die Fritzbox ist mein Hauptrouter. Ich würde daneben gerne ein komplett getrenntes ...

Netzwerke
PFSense und Transferprobleme
Xaero1982Vor 1 TagFrageNetzwerke25 Kommentare

Moin Zusammen, leidiges Thema PFSense - ich hab mich mal wieder ran gewagt. Ich hab hier so ein paar VLANs laufen und nen ESX. ...

Exchange Server
Postfach für öffentliche Ordner ist voll
gelöst Tommy525600Vor 1 TagFrageExchange Server6 Kommentare

Hallo an alle, ich habe folgendes Problem: Mein primäres Postfach für öffentliche Ordner ist voll (99,58 GB) (und ja, ich kann auch nix dafür). ...

Linux
Bootable Win7 stick from Raspberry commandline
winlinVor 22 StundenFrageLinux12 Kommentare

Hallo zusammen Ich benötige einen bootfähigen Win7 USB Stick. Muss diesen über meine Raspberry erstellen. Was ist die beste Variante habe schon ein paar ...

Windows Server
Kein Netzwerkzugriff auf Windows Server 2019?
Henk86Vor 1 TagFrageWindows Server8 Kommentare

Ich habe mir einen neuen "Heimserver" mit Windows Server 2019 (evaluation vorerst) aufgesetzt. Gestern habe ich von meinem Hauptrechner einige Daten auf den Server ...

Windows Server
Problem bei Windows 10 Deployment mit MDT
gelöst neophyte2021Vor 1 TagFrageWindows Server7 Kommentare

Hallo, ich habe folgendes Problem, ich habe in einem Artikel auf englisch gelesen, das wenn man mit dem MDT Windows 10 ausrollen will und ...

Netzwerke
Verständnisfrage pfSense mit Fritzbox, VLAN und Switch
newbie1Vor 1 TagFrageNetzwerke8 Kommentare

Hallo, ich bin kurz davor mir eine pfSense einzurichten via ISO-Image auf einem alten PC. Vorhaben: Fritzbox -> pfSense -> Switch -> Endgeräte Was ...

Exchange Server
Mails fehlen im Exchange-Server 2016
it-basixsVor 23 StundenFrageExchange Server4 Kommentare

Moin, moin zusammen. Ich habe leider ein Problem mit einem Exchange Server 2016 CU20 inkl. aller Patches. Laut Ereignisanzeige von POPcon, werden die Mails ...