Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Dateiattribut lässt sich nicht zurücksetzen

Mitglied: pulp

pulp (Level 1) - Jetzt verbinden

06.02.2006, aktualisiert 08.03.2006, 10144 Aufrufe, 7 Kommentare

Hallo!

Vielleicht kennt jemand das Problem. Ich habe hier einige ältere Dateien (aus dem Jahr 1994). Bei allen ist das Attribut "versteckt" aktiv.
Soweit so gut. Geht man unter Windows in die Eigenschaften der Datei rein sieht man das angehakte Kästen "versteckt" ausgegraut. Zugriff
nicht möglich. Der attrib-Befehl über den command-prompt ist ebenfalls nicht möglich. Ein attrib <dateiname> -h wird mit der Fehlermeldung "Versteckte Datei wird nicht zurückgesetzt" beantwortet. Bei allen Dateien ist zudem noch das Attribut "System" aktiv (welches sich auch nicht zurück setzen lässt.

Die Dateien selbst sind *.sys oder *.bat Dateien. Nichts ungewöhnliches eigentlich. Vielleicht sollte ich noch erwähnen, daß diese Dateien von einem alten Novell-File-Server stammen und das das beschriebene Verhalten kein Rechteproblem ist, da auch eine lokale Kopie (mit ALLEN Rechten) keine Veränderung zu lässt.

Hat jemand eine Idee? Wäre gut, da ich diese Dateien brauche...sichtbar!

Viele Grüße
Markus
Mitglied: Metzger-MCP
06.02.2006 um 17:59 Uhr
Gehe mal her und übernehme von jeder Datei den Besitz. Aktiviere danach noch mal die NTFS Berechtigungen und versuche das danach noch mal ( attrib -r -a -s -h *.* /s )

-Readonly
-System
-Hide
-Archive

/s -> in allen darunterliegenden Pfaden



Falls das nicht geht, versuche die Datein auf ein FAT32 formatierten Datenträger zu kopieren und dort die überschüssigen Attribute zu entsorgen.

Mfg Metzger
Bitte warten ..
Mitglied: gogoflash
06.02.2006 um 19:48 Uhr
Hi,

wenn alle Stricke reißen. Kopier den Kram doch auf eine FAT32 Partition, das interessiert sich nicht für Dateirechte.
Recht simpel, und nicht gerade schick, aber was solls.


Gruß Miguel
Bitte warten ..
Mitglied: pulp
06.02.2006 um 21:06 Uhr
...ja, was soll ich sagen. Daran hatte ich auch schon gedacht. Aber selbst auf einer popligen Diskette mit FAT ist das Attribut nicht wegzukriegen. Und "hidden" unterstüzt ja FAT auch.

Wie schon erwähnt, es ist definitiv kein Rechteproblem.

Was macht der /s Parameter? Den kenne ich in Verbindung mit attrib nicht. Kann das jetzt nicht ausprobieren, da ich zu Hause und die Dateien auf der Arbeit sind...)
Aber trotzdem schon mal Danke für den Tipp.

Viele Grüße
Markus
Bitte warten ..
Mitglied: gogoflash
07.02.2006 um 21:37 Uhr
Hi,

der Parameter /s kennzeichnet eine Datei als Systemdatei.

Schick mir mal eine -wenn es geht- von diesen Dateien. Das sieht ja schon komisch aus.

E-Mail per PN
Falls das Problem gelöst ist, wäre eine Antwort von Dir nicht schlecht.

Gruß Miguel
Bitte warten ..
Mitglied: Metzger-MCP
08.02.2006 um 09:05 Uhr
Fehlaussage !!!!!

/s

Dieser Schalter bedeutet so wie ich das in meinem 1sten Post geschrieben habe.
auch die Datein in den Unterordnern.

+s als Schalter bedeutet Systembit setzen
-s als Schalter bedeutet Systembit entfernen

notfalls nachzulesen under attrib /? in der Komandoconsole

Mfg Metzger

P.S. Wäre da auch mal dran interessiert -> unverändeliche Datei
Bitte warten ..
Mitglied: gogoflash
08.02.2006 um 14:58 Uhr
Hi,

ok nehm ich zurück und behaupte das Gegenteil. /s Unterordner +s Systembit hab ich übersehen.

Gruß Miguel
Bitte warten ..
Mitglied: pulp
08.03.2006 um 17:18 Uhr
Hallo!

Habe das Problem nun so gelöst, daß ich die Dateien auf einen FTP-Server übertrage habe. Nach dem Runterladen war das Attribut zurückgesetzt. Warum das so ist verstehe ich zwar nicht, aber hauptsache es funktioniert.

Viele Grüße und Danke an alle die geholfen haben.
Markus
Bitte warten ..
Neue Wissensbeiträge
iOS
WatchChat für Whatsapp
Tipp von Criemo vor 19 StundeniOS

Ziemlich coole App für WhatsApp User in Verbindung mit der Apple Watch. Gibts für iOS sowohl als auch für ...

iOS
IOS hat nen Cursor !!!
Tipp von Criemo vor 1 TagiOS5 Kommentare

Nette Funktion im iOS. iPhone-Mauszeiger aktivieren „Nichts ist nerviger, als bei einem Tippfehler zu versuchen, den iOS-Cursor an die ...

Off Topic
Avengers 4: Endgame - Erster Trailer
Information von Frank vor 3 TagenOff Topic2 Kommentare

Ich weiß es ist Off Topic, aber ich freue mich auf diesen Film und vielleicht geht es anderen hier ...

Webbrowser
Microsoft bestätigt Edge mit Chromium-Kern
Information von Frank vor 3 TagenWebbrowser5 Kommentare

Microsoft hat nun in seinem Blog bestätigt, dass die nächste Edge Version kein EdgeHTML mehr für die Darstellung benutzen ...

Heiß diskutierte Inhalte
Exchange Server
Exchange Server 2010: Keine Eingehenden E-MAils
gelöst Frage von gabeBUExchange Server17 Kommentare

Hallo Zusammen Ich habe das kurzen auf dem Exchange 2010 Server das Problem, dass ich keine externen E-Mails mehr ...

Server
Server in zwei verschiedene Netzwerke einbinden
gelöst Frage von BennyFServer13 Kommentare

Hallo zusammen, bei uns im Haus sind im Erdgeschoss die Geschäftsräume und ab dem 1. Stock sind unsere privaten ...

Windows Netzwerk
Kerio. Kann keine Mails empfangen aber senden. Wer ist schuld. Kerio oder Windows domäne?
Frage von frosch2Windows Netzwerk13 Kommentare

Hallo, es existiert ein Problem bei uns mit dem mailen. Alle bestehenden Nutzer können mailen. Raus wie rein. Neuen ...

Netzwerkmanagement
Ticketsystem für eine Kommune gesucht
gelöst Frage von akovisNetzwerkmanagement11 Kommentare

Ich suche aktuell ein Ticketsystem für eine Kleinstadt von 13000 Einwaohnern. Das System soll alle Anfragen aus verschiedenen Kanälen ...