Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Dateiname zu lang

Mitglied: nooneelsebutme

nooneelsebutme (Level 1) - Jetzt verbinden

23.07.2018 um 09:59 Uhr, 1248 Aufrufe, 3 Kommentare, 1 Danke

Hallo,

habe Daten von einem Server 2008 R2 auf einen Server 2016 ES per robocopy migriert. Hat alles Problemlos funktioniert. Einige Ordner-Strukturen sind allerdings sehr tief, wenn die Clients jetzt darauf zugreifen wollen, kommt die Meldung "Dateiname zu lang". Versuchte ich das in der gleichen Struktur auf dem alten Server funktioniert es. Woran kann das liegen? Was auffällt, beim öffnen der Datei auf dem alten Server bricht er den Pfad herunter und es tauchen ~Zeichen darin auf. (Also Applikation in dem Fall ein PDF Reader )(Öffne: W:Pfad\Unterpfad\~weiterer UnterPfad\~noch ein Pfad ..) Beim neuen Server kommt gleich die Fehlermeldung von der explorer.exe.

Woher kommt der Unterschied, die 255 Zeichen Grenze müsste doch auch bei beiden Servern zuschlagen, warum ging/geht es beim alten Server?

Vielen Dank schon mal.
Mitglied: certifiedit.net
23.07.2018 um 10:03 Uhr
Hallo,

ggf. weil der alte Server entweder anders verlinkt hat (Verzeichnisumstellung, er war english ovgl.) Vielleicht war der Zugriff auch anders gelöst. In Gänze kann man aber sagen, dass man sich normalerweise hütet so lange Pfade zu konstruieren.*

VG

*Genaueres kann man ohne genaue Einsicht in deine Systeme zu haben nicht sagen.
Bitte warten ..
Mitglied: dark.cube
LÖSUNG 23.07.2018, aktualisiert um 10:09 Uhr
Prüf doch mal ob auf deinem alten Server die 8.3 file name creation enabled war, soweit ich das gesehen habe, sollte dies bei 2008er Server der Fall sein und bei neuen(2012 aufwärts) nicht. Also könntest du diese auf dem neuen Server einschalten und nach einem Neustart nochmals prüfen oder aber du solltest die Verzeichnistiefe kürzen.

https://support.microsoft.com/de-de/help/121007/how-to-disable-8-3-file- ...

//Nachtrag
das funktioniert wohl leider nur, wenn die Dateien kopiert worden sind, nachdem die 8.3 name creation enabled war.
Bitte warten ..
Mitglied: nooneelsebutme
23.07.2018 um 10:33 Uhr
Hallo,

ja das scheint die Ursache zu sein, komischerweise war das auf dem neuen Server auf C aktiviert, auf der Datenpartition D allerdings nicht. Hab das jetzt mal aktiviert, scheint aber wirklich für die vorhandenen Daten nicht zu funktionieren.
Bitte warten ..
Ähnliche Inhalte
CMS
Menütitel in Typo3 zu lang
gelöst Frage von honeybeeCMS3 Kommentare

Hallo, da ich mich leider wenig mit Typo3 auskenne, habe ich eine Frage: Ein Menütitel in Typo3 ist zu ...

Datenbanken
MySql Set oConn sind 4 Sekunden zu lang?
Frage von zeroblue2005Datenbanken

Hallo Zusammen, wir haben einen alten Server 2k8 R2 am laufen mit: Apache/2.2.14 (Win32) DAV/2 mod_autoindex_color PHP/5.3.1 mod_apreq2-20090110/2.7.1 mod_perl/2.0.4 ...

Batch & Shell
(PS) Pfad zu lang bei move-item?
Frage von functionstrutBatch & Shell14 Kommentare

Hallo, ich habe irgendwie ein ganz simples problem :-s einfach folgender versuchsaufbau: sagt er mir: Die Datei ist aber ...

Exchange Server

Anmeldung an Dömäne dauert sehr Lang ca. 5 min

Frage von TgimminiExchange Server5 Kommentare

Hallo Zusammen, Ich bin hier in diesem Forum Neu und hoffe von euch eine Lösung für mein Problem zu ...

Neue Wissensbeiträge
Sicherheit

Chrome 79 übermittelt eingegebene Kennwörter nach Hause

Information von DerWoWusste vor 2 TagenSicherheit15 Kommentare

Ab sofort warnt Chrome standardmäßig Nutzer davor, wenn aus Leaks bekannte Passwörter zum Einsatz kommen. Beim Besuch einer Website, ...

Viren und Trojaner
Trend Micro WFBS 10 SP1 Patch 2185
Tipp von Abramelin vor 2 TagenViren und Trojaner3 Kommentare

Hi, Hab gerade gesehen das Patch 2185 für TM WFBS 10 SP1 erschienen ist! Werde mal Morgen den Patch ...

Viren und Trojaner

Neuer Virus lässt Windows im abgesicherten Modus starten

Tipp von transocean vor 3 TagenViren und Trojaner7 Kommentare

Moin, lest selbst. Grüße Uwe

Sicherheit
Böser Bug in Domänenkennwortrichtlinie!
Information von DerWoWusste vor 3 TagenSicherheit2 Kommentare

Ich spiegele mal Borncity: In Kürze: Nutzt Ihr eine Domänen-Kennwortrichtlinie der herkömmlichen Art (keine PSO-Richtlinie)? Ja? Und plant Ihr, ...

Heiß diskutierte Inhalte
Netzwerke
Netzwerkstruktur für Zuhause 1Anschluss 2 Netze
Frage von chrishaefNetzwerke27 Kommentare

Hallo liebes Forum, Ich hätte da mal eine Frage an die Profis. Bei uns liegt ein DSL Anschluss im ...

Windows 7
Windows 7 - Ein DSL Speedtest - Mehrere Browser - Unterschiedliche Ergebnisse
Frage von AusAltwirdNeuWindows 725 Kommentare

Hallo zusammen, mein PC hat zwei Rj45 Anschlüsse. Beide sind auf Gigabit Vollduplex eingestellt. An beiden Anschlüssen erreiche ich ...

Batch & Shell
Eingabeaufforderung macht Pause bei Datensicherung mit Robocopy auf DVD
Frage von anmelderBatch & Shell23 Kommentare

Hallo, ich sichere einige Daten per Robocopy auf DVD-RAM. Wenn ich nicht am Rechner sitze macht der Befehl nach ...

Windows Server
Neuinstallation Windows Server 2016 - wie würdet Ihr vorgehen
Frage von mollyneoWindows Server21 Kommentare

Moin, ich habe gerade ein kleines Problem mit einer bestehenden Installation eines "Fachmanns" und möchte gern wissen, wie ihr ...