Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

E-Mails mit PHP versenden, wie einrichten?!

Mitglied: toxick

toxick (Level 1) - Jetzt verbinden

04.07.2005, aktualisiert 05.07.2005, 12082 Aufrufe, 3 Kommentare

Hallo allerseits,

ich hab ein kleines Problem. Wir haben ein Win 2003er Webserver am laufen und stellen dazu PHP bereit. Leider können wir über die Standart PHP Funktionen keine Mails versenden. Entweder kommen immer Fehlermeldungen a'la: "Warning: mail(): Failed to connect to mailserver at "locahost" port 25, verify your "SMTP" and "smtp_port" setting in php.ini or use ini_set() in ..." oder es passiert gar nichts.

Wir haben auf dem Server zwar einen SMTP bzw. POP3 Server am laufen über den auch der Mailverkehr abgewickelt wird, hierbei handelt es sich aber um die Standart Win 2003 Boardmittel, sprich ein Mailserver like Exchange oder so etwas ist nicht installiert.

In der PHP.ini wurden bereits einträge vorgenommen, welchen Port (25), welchen Server (localhost) und welche Mailadresse (xxx@xxx.de) benutzt werden soll. Einen Neustart haben wir auch schon vorgenommen. Leider alles ohne Ergebnis. Oder wie geht man dabei generell vor? Wahrscheinlich ist der Grundstock, sprich der Mailserver, wenn man das so nennen kann, fehlerhaft! Was muss eingerichtet bzw. i.O. sein damit die Mails versendet werden können?

Brauch ich da jetzt einen Exchange um die Mails versenden zu können oder was hab ich falsch gemacht?!

Ich hoffe mir kann wer helfen. Wäre echt klasse.


mfg


P.S.: Wäre es ratsam einen Exchange zu installieren? Wenn ja, wo? Soll man diesen auf einer Extra Machine installieren um auch den internen Verkehr darüber laufen zu lassen? was meint ihr? Womit habt Ihr die Besten Erfahrungen gemacht? Oder gibt es gute "cost-(fast)-nix" Mailserver die man empfehlen kann?
Mitglied: 10545
04.07.2005 um 12:10 Uhr
Moin,

siehe dazu https://www.administrator.de/Windows_2003_SMTP.html

MS erlaubt keinen "externen" Versand über den SMTP-Dienst.

Du musst also einen "kleinen" Mailserver aufsetzen. "Mercury-Mail" oder eben auch "ArgoSoft Mailserver" wären die Freeware-Kandidaten.

Gruß, Rene
Bitte warten ..
Mitglied: toxick
04.07.2005 um 12:18 Uhr
Ok, herzlichen Dank.

Kann ich hierzu einen Exchange 2003 auf einem anderen PC installieren und die beiden PC's dann sozusagen connecten?
Bitte warten ..
Mitglied: 10545
05.07.2005 um 06:38 Uhr
Moin,

.... PC's dann sozusagen connecten?

Ja.

Gruß, Rene
Bitte warten ..
Ähnliche Inhalte
PHP
PHP Mail Funktion
Frage von gamerffPHP5 Kommentare

Hallo Forum, ich versuche grade mit der PHP mail() Funktion ein Kontaktformular zu erstellen. Leider kommt beim absenden immer ...

E-Mail
E-Mail Newsletter
Frage von ProtectedE-Mail7 Kommentare

Hallo, wir versenden im Monat rund 1.000 E-Mails mit unserem E-Mail Server. Leider gelangen wir oft in Spam-Ordner bei ...

Entwicklung
E-mail Textanalyse
gelöst Frage von BitconEntwicklung5 Kommentare

Hallo zusammen Ich möchte im Rahmen meiner Ausbildung zum Fachinformatiker ein Projekt für die meine Firma realisieren. Das Projekt ...

Rechtliche Fragen
E-Mail-Disclaimer
gelöst Frage von MarcysRechtliche Fragen17 Kommentare

Hallo zusammen, ich würde gerne etwas mehr über die E-Mail-Disclaimer von euch wissen wollen. Ich meine gehört zu haben ...

Neue Wissensbeiträge
iOS
WatchChat für Whatsapp
Tipp von Criemo vor 1 TagiOS

Ziemlich coole App für WhatsApp User in Verbindung mit der Apple Watch. Gibts für iOS sowohl als auch für ...

iOS
IOS hat nen Cursor !!!
Tipp von Criemo vor 1 TagiOS5 Kommentare

Nette Funktion im iOS. iPhone-Mauszeiger aktivieren „Nichts ist nerviger, als bei einem Tippfehler zu versuchen, den iOS-Cursor an die ...

Off Topic
Avengers 4: Endgame - Erster Trailer
Information von Frank vor 3 TagenOff Topic2 Kommentare

Ich weiß es ist Off Topic, aber ich freue mich auf diesen Film und vielleicht geht es anderen hier ...

Webbrowser
Microsoft bestätigt Edge mit Chromium-Kern
Information von Frank vor 3 TagenWebbrowser5 Kommentare

Microsoft hat nun in seinem Blog bestätigt, dass die nächste Edge Version kein EdgeHTML mehr für die Darstellung benutzen ...

Heiß diskutierte Inhalte
Exchange Server
Exchange Server 2010: Keine Eingehenden E-MAils
gelöst Frage von gabeBUExchange Server17 Kommentare

Hallo Zusammen Ich habe das kurzen auf dem Exchange 2010 Server das Problem, dass ich keine externen E-Mails mehr ...

Windows Netzwerk
Kerio. Kann keine Mails empfangen aber senden. Wer ist schuld. Kerio oder Windows domäne?
gelöst Frage von frosch2Windows Netzwerk17 Kommentare

Hallo, es existiert ein Problem bei uns mit dem mailen. Alle bestehenden Nutzer können mailen. Raus wie rein. Neuen ...

LAN, WAN, Wireless
LAN Kabel plötzlich nur noch 100-10 mbps statt 1000
Frage von ScravysLAN, WAN, Wireless13 Kommentare

Guten Tag, ich habe ein Problem mit meinem Netzwerk und zwar habe ich mir ein 20m starres verlegekabel cat.7 ...

Server
Server in zwei verschiedene Netzwerke einbinden
gelöst Frage von BennyFServer13 Kommentare

Hallo zusammen, bei uns im Haus sind im Erdgeschoss die Geschäftsräume und ab dem 1. Stock sind unsere privaten ...