Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Mein erster Windows-Server

Mitglied: gormhorger

gormhorger (Level 1) - Jetzt verbinden

05.10.2005, aktualisiert 06.10.2005, 9964 Aufrufe, 2 Kommentare

Erfahrungsbericht & Probleme bei der Konfiguration des IIS6 unter Windows Server 2003 Enterprise x64 Edition

Zuerst ein paar Worte zur Hardware - mein Testserver verfügt über folgende Komponenten:
Prozessor: 2x <link="http://de.wikipedia.org/wiki/Opteron;>Opteron</link>" Modell 244 mit je 1.8 GHz
Mainboard: <link="http://www.tyan.com/products/html/thunderk8we.html;>Tyan" Thunder K8WE(S2895)</link>
Festplatten: 4x <link="http://www.samsung.com/Products/HardDiskDrive/SpinPointPSeries/HardDisk ..." SP2004C</link> zu einem <link="http://de.wikipedia.org/wiki/RAID#RAID_01;>RAID" 0+1</link> verbunden
Arbeitsspeicher: 2GB DDR ECC Reg DIMM (KINGSTON)

Als Betriebssystem habe ich mich für die noch recht frische <link="http://www.microsoft.com/windowsserver2003/64bit/x64/enterprise.mspx&qu ..." von Windows Server 2003</link> entschieden. Bei der Installation des Betriebssystems bekam ich erste Probleme mit dem Raid-Treiber von NVIDIA. Bei Verwendung der aktuellen Treiber stürzt die Installation mit einem 0x0000007b Stop-Error ab, die Treiber auf der BoardCD sind hingegen unvollständig (es fehlen zwei cat-Dateien). Unter Verwendung der unvollständigen älteren Treiber verlief die weitere Installation glücklicherweise anstandslos. Nach dem Abschluss der Installation konnten dann auch die aktuellen 64bit-Treiber installiert werden.

Als nächstes habe ich den IIS6 gestartet und PHP laut Anleitung (<link="http://de.php.net/windows;>1</link>/<link=;http:/ ...") eingerichtet. Dies hat natürlich nicht funktioniert, da beim Aufrufen einer ersten PHP-Seite der folgende Text zu lesen war:
<font class="code">%1 is not a valid Win32 application</font>
Nach Stundenlanger Suche im Netz bin ich schließlich bei php.net im <link="http://bugs.php.net/bug.php?id=33606;>BUG-Bereich</link>" auf eine Lösung gestoßen:
<font class="code">Some friendly person contacted me after seeing this article and told me
how to correct it. The issue is indeed caused by IIS attempting to run
php5isapi.dll with 64-bit extensions which would of course lead to
failure. I corrected this by entering the following into the Windows
Run dialog:

cscript %SYSTEMDRIVE%\inetpub\adminscripts\adsutil.vbs SET
W3SVC/AppPools/Enable32bitAppOnWin64 1

If you people could kindly add a comment about installing PHP on the
Windows 64-bi environment, it could potentially help many people.</font>Seit dem läuft PHP ohne Probleme.

MySQL ließ sich wiedererwartend völlig problemlos installieren und administrieren, so dass ich nun eigentlich alles beisammen habe um ein paar Webseiten zu hosten und zu den Problemen übergehen kann (weiter unten in den Kommentaren)...
Mitglied: gormhorger
05.10.2005 um 17:54 Uhr
Zuerst einmal habe ich mir zum Thema "mehrere Domains hosten" bei techchannel.de ein PDF über die Konfiguration und Wartung von IIS6 gekauft um den gleichen Artikel wenig später bei Microsoft noch einmal kostenlos zu erhalten... (http://www.tecchannel.de/server/windows/402156/ und http://download.microsoft.com/download/b/b/0/bb086391-8b27-4017-971c-6d ...) Naja, 60 Cent für das Gefühl von Microsoft etwas billiger als woanders zu bekommen.
In diesem Artikel wird folgendes zum Hosten mehrerer Domains mit Host-Headern gesagt:
<font class="code">Im Zuge der Einrichtung der Site haben Sie unter anderem ein Verzeichnis angegeben, in dem sich die Dateien der Site befinden. Auch alle Unterverzeichnisse dieses Verzeichnisses können dabei Dateien der Webseite beinhalten.
Wenn Sie also Ihre Seiten in das Verzeichnis kopiert und als Test die IP-Adresse 127.0.0.1 und den gewünschten Namen angegeben haben, dann können Sie Ihre Testseite im Prinzip direkt mit dem Browser abrufen: Die Eingabe des gewählten Host-Namens ? also zum Beispiel http://www.IhreSite.de ? reicht aus. Damit das mit der Loopback-Adresse auch funktioniert, ist lediglich noch ein Eintrag in der Datei Hosts im Verzeichnis \WINDOWS\SYSTEM32\DRIVERS\ETC notwendig.
</font>
Was ich eigentlich erreichen wollte war das Folgende:
Gebe ich im Browser www.seite1.de ein, werde ich zu Ordner A weitergeleitet. Gebe ich www.seite2.de ein, werde ich zu Ordner B geleitet. Gebe ich die IP-Adresse ein, bekomme ich eine Fehlermeldung.

Ich habe im IIS zwei neue Webseiten erstellt und die Standardseite gestoppt. Seit dem erhalte ich bei der Eingabe meiner IP-Adresse oder eines Domainnamens ins Browserfenster folgende Meldung:
<font class="code">Bad Request (Invalid Hostname)</font>

Wie muss ich vorgehen, damit die Eingabe meiner Domainnamen richtig interpretiert wird?

Vielen Dank schon mal fürs lesen, Rene.
Bitte warten ..
Mitglied: gormhorger
06.10.2005 um 12:48 Uhr
Das Problem mit dem "Bad Request" entstand durch eine falsch konfigurierte Firewall. Aber es gibt gleich ein neues Problem:

Bei Eingabe der IP-Adresse des Servers erscheint die Default-Seite (das ist gewollt).
Bei Eingabe des Domainnamens mit www erscheint die Domain-Seite (das ist auch gewollt).
Bei Eingabe des Domainnamens ohne www erscheint "Directory Listing Denied
This Virtual Directory does not allow contents to be listed." (und das ist nicht gewollt).

Was hab ich falsch gemacht bzw. vergessen zu konfigurieren?

Danke.
Bitte warten ..
Ähnliche Inhalte
Windows 10
Windows 10 startet erst beim 2. Mal
gelöst Frage von HardwareFreakWindows 1021 Kommentare

Hallo zusammen, Ich bin neu im Forum und habe direkt mal eine Frage an euch. Mein PC hat seit ...

Windows Server

AD-Änderungen erst nach Replikation !?

gelöst Frage von RicoPausBWindows Server9 Kommentare

kurze angefragt Wenn ich am DC unserer Niederlassung Änderungen vornehme, wie z.B. Gruppenzugehörigkeiten oder Anpassungen an der GPO oder ...

LAN, WAN, Wireless

Internetverbindung funktioniert erst nach ipconfig renew

Frage von Joshh1LAN, WAN, Wireless6 Kommentare

Hallo zusammen, wir nehmen mal folgendes an: Ich bin in einem Hotel und habe mir dort ein Appartment gekauft. ...

Windows Netzwerk

Netzwerkverbindung klappt erst beim zweiten Anlauf

gelöst Frage von D1Ck3nWindows Netzwerk12 Kommentare

Hallo zusammen, ich habe ein Problem mit meiner Netzwerkverbindung: Wenn ich versuche mich per SSH (Putty und WinSCP) auf ...

Neue Wissensbeiträge
Sicherheit

Heise Beitrag Passwort-Sammlung mit 773 Millionen Online-Konten im Netz aufgetaucht

Information von Penny.Cilin vor 2 StundenSicherheit1 Kommentar

Auf Heise Online ist folgender Beitrag veröffentlicht worden: Heise Beitrag passwörter geleakt Ich bin mir jetzt nicht ganz sicher, ...

Microsoft Office
TEAMS - Skype for business
Tipp von Nebellicht vor 2 StundenMicrosoft Office

Hallo, ms ersetzt Skype for business durch TEAMS. Also, nicht wundern wenn mit der OFFICE365 Umgebung kein Skype for ...

Windows 10

Windows 10: Cortana und die Suche gehen bald wieder eigene Wege

Information von Frank vor 6 StundenWindows 101 Kommentar

Microsoft hat einen neuen Insider Build von Windows 10 veröffentlicht (Fast Ring, Version 18317), wo die digitale Assistentin "Cortana" ...

Humor (lol)
Und wie seid Ihr gegen Cyberattacken gewappnet?
Information von DerWoWusste vor 2 TagenHumor (lol)6 Kommentare

aber wo ist der Hammer? :-)

Heiß diskutierte Inhalte
Microsoft
SFirm 4.0 auf Terminalserver startet für jeden angemeldeten Benutzer diverse Dienste
Frage von Frank84Microsoft25 Kommentare

Hallo zusammen, wir verwenden Sfirm 4.0 auf einem Terminalserver (der SQL Server ist auf einem separaten Server), das Problem ...

Windows Server
Uhren gehen immer wieder falsch
Frage von killtecWindows Server22 Kommentare

Hallo, ich habe folgende Konstellation: 1. Physischer DC Div. Virtuelle DC's auf Hyper-V Servern Die Hyper-V-Server, der Physische DC ...

Windows 10
VM wächst schnell von 14 auf 35 GB an - warum?
Frage von degudejungWindows 1018 Kommentare

Hallo, ich bin ein Freund schlanker VMs und setze daher gerne mit dem Erscheinen einer neuen Win10 Version - ...

Internet
Google-Suchergebnisse, Schnelleinblendung, woher kommt der Inhalt?
gelöst Frage von departure69Internet17 Kommentare

Hallo. Ich bin der Systembetreuer einer kleinen Gemeinde in Süddeutschland. Wir betreiben auch eine Leihbücherei. Eine Kundin hat letzten ...