Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

ESXi 4.1 Probleme mit die Datastorse bzw. der Raidcontroller

Mitglied: bombass

bombass (Level 1) - Jetzt verbinden

08.01.2011, aktualisiert 10.01.2011, 6251 Aufrufe, 11 Kommentare

Liebe Froum Mitglieder,

ich betreibe einen ESXi 4.1 auf einen IBM TD200 mit folgeden Hardware:

Server: IBM TD200
Raidcontroller: IBM ServerRaid-MR10i SAS/SATA controller (mit Batterie)
CPU: Intel Xeon DP E5506 4x 2.13GHz
Raid 5: (3 IBM Platten a 1000 GB, 7200)
RAM: 20 Gb (1333Mhz)
Netzwerkkarte: NetXtreme II 1000 Express G Ethernet Adapter- PCIe

Software: Esxi 4.1
2 Datastore a 1,3 TB jeweils

Ich nutze "Veem Monitore for Vmware" um die Latenz Zeiten zu messen und der Host zu beobachten. Das Veem Monitore lauft selber auf einen Vmware

Was ich bemerkt habe dass die VM's ab und zu komplett frieren. D.H die CPU warten auf die I/O um die Daten zu lesen oder zu schreiben (meistens ein paar 1000 Millisekunden = 2 - 3 Sekunden).


c1ee564023770413b54b29cb7b7014b9 - Klicke auf das Bild, um es zu vergrößern


4549270714aad25beca06fb9501fb61a - Klicke auf das Bild, um es zu vergrößern


8fcb272d25a0613375de4b56b0cbaf71 - Klicke auf das Bild, um es zu vergrößern


3ab30cb2fd30c40efb444f004758d917 - Klicke auf das Bild, um es zu vergrößern

8cac9de6131ce8841a5ec26c61ecec8e - Klicke auf das Bild, um es zu vergrößern

Bei der Raidcontroler Status scheint alle ok zu sein!

Mir kommt es vor, als würde der ESXi order der Server irgend ein Job ausführen (alle 10-15 Min). Un das führt dazu, dass der Raidcontroller langsammer wird, bzw. die Read/ Write Latency

Ich bitte um Hilfe.

Besten Grüße
Rafael

Hier sind ein paar Screenshot von einen anderen Server mit die gleicht Konfiguration:

9ea54c818d5ef74551b0a66017469515 - Klicke auf das Bild, um es zu vergrößern


8cac9de6131ce8841a5ec26c61ecec8e - Klicke auf das Bild, um es zu vergrößern
Mitglied: Dani
08.01.2011 um 17:57 Uhr
Hi Rafael,
meine Gegenfrage an dich lautet: Wie viele virtuelle Maschinen laufen auf dem phy. Server und wa läuft auf den einzelnen Maschinen?


Grüße,
Dani
Bitte warten ..
Mitglied: Oldmcreher
08.01.2011 um 18:26 Uhr
Hi Rafael,

Hast Du in einer der VM`s evtl. Jobs laufen (Datenbanken?)

Kannst Du da noch eine HDD einbauen und ein RAID 10 einsetzen (Mehr R/W Performance)?

Kannst Du uns evlt. die VMWare Support FIles exportieren und zur Verfügung stellen?

Wie hast Du das Caching auf dem Controller eingestellt?

Ist die Firmware Aktuell auf den Controllern und Disks?
Bitte warten ..
Mitglied: bombass
08.01.2011 um 18:28 Uhr
Hi Dani,

es laufen nur 3 Virtuelle Machinen:
- WinXP Pro 32 Bit. wird als Backupmachine und für die Telephon-Analge. Das ganze wird meistens von mir manuel angestoßen.
- Win 7. Mit eine MSSQL DB
- MindTouch 2010 (Ubuntu )

Das Problem den ich oben beschrieben habe, trifft auch wenn alle VM's ausgeschaltet sind. D.h die Read / Write Lateny sind zu hoch auch wenn alle VM's ausgeschlatet sind.

Grüße
Rafael
Bitte warten ..
Mitglied: bombass
08.01.2011 um 18:34 Uhr
Hallo Oldmcreher,


Hast Du in einer der VM`s evtl. Jobs laufen (Datenbanken?)
--> Das Problem den ich oben beschrieben habe, trifft auch wenn alle VM's ausgeschaltet sind. D.h die Read / Write Lateny sind zu hoch auch wenn alle VM's
ausgeschlatet sind.
Kannst Du da noch eine HDD einbauen und ein RAID 10 einsetzen (Mehr R/W Performance)?
--> Ja, das kann ich machen, ich werde es am Montag testen.


Kannst Du uns evlt. die VMWare Support FIles exportieren und zur Verfügung stellen?
--> Wie mache ich das ? Kann ich das File über das VClient exportieren?

Wie hast Du das Caching auf dem Controller eingestellt?
--> Ich werde es am Montag prüfen,

Ist die Firmware Aktuell auf den Controllern und Disks?
--> Ich habe keine Update gemacht. Der ESXi unterstützt die IBM TD200 Server. Das Server haben wir vor ein paar Wochen gekauft. Die Firmware sollten aktuell sein.

Grüße
Rafael
Bitte warten ..
Mitglied: Oldmcreher
08.01.2011 um 18:38 Uhr
Oh schnelle Antwort

Ja,.die VMWare Supportfiles kannst Du über den VM-Client bekommen.

Neue Hardware bedeutet nicht gleich, dass die aktuelle Firmware installiert ist, dass solltest Du unbedingt überprüfen, grade im Storagebereich kann es da zu großen Performance-Problemen kommen.
Bitte warten ..
Mitglied: bombass
08.01.2011 um 19:18 Uhr
Hi,

ja, ich setzte vor meinen PC seit 6 Stunden. Ich muss diese Problem lösen, ab nächste Woche brauchen wir die VM's für die Produktibe Einsatz. Ich werde die Logs file exporteiren und hochladen. Welche Abschnitt brauchst du davon?

Was ich auch bemerkt habe, dass dass diese Fehler ofter kommt:

a55d8d277432325a753f045dedef0be1 - Klicke auf das Bild, um es zu vergrößern

Ich habe was gefunden bei VMWare:

http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&am ...

Könnte dies das Problem sein?

Anbei die Datastores Einstellkungen:

ea01ee3d4e79bfd8861389567933cf7f - Klicke auf das Bild, um es zu vergrößern

Schöen Grüße
Rafael
Bitte warten ..
Mitglied: Oldmcreher
08.01.2011 um 20:59 Uhr
Hi Rafael,

ich glaube ich brauche das ganze Supportfile.

Der Artikel bezieht sich auf ein HBA also SAN, wo es Probleme mit Que gibt...

Also nicht für Deinen Fall.

Hast Du Dein Raid 5 in zwei Luns aufgeteilt oder wie kommen die 2 x 1,36 TB zusammen?

Wo hast Du die Cache Dateien der Server abgelegt?

Die erste Fehlermeldung sagt Dir dass das Vcenter nicht mit der VM Kommunizieren kann.

Kannst Du mir etwas über Dein Netzwerk sagen?

Hast Du mehrere Netzwerkkarten?
Sind die Ports alle 100% richtig koniguriert?

Das würde die Heartbeat Probleme erklären.
Bitte warten ..
Mitglied: bombass
08.01.2011 um 22:38 Uhr
Hallo Herr Reher,

, dein Name habe ich in deinen Profile gefunden

ich habe einen Raid 5 volume von 3 Platten erstellet. Danach habe das Volume in zwei VV (viruelle Volumen) aufgeteilt (je 1,35 TB).
von die zwei Volumen habe ich dann die zwei Datastores erstellet.

Die VM's liegen direkt auf die zwei Datasores, d.h die liegen nicht in eine SAN oder externe Platte.

Wo hast Du die Cache Dateien der Server abgelegt? --> Was meinst damit? Welche cache dateien?

anbei noch mehr Information über meine Konfiguration:

9cb38a3692c52b5adc631a82209057f8 - Klicke auf das Bild, um es zu vergrößern


d0cf495494827b59bfa3e80a3c59f9a0 - Klicke auf das Bild, um es zu vergrößern

Die Logs files sind zu Große, welche davon soll ich hochladen oder dir per Mail schicken

a119f0b963b672e6ab00cbd1956c341c - Klicke auf das Bild, um es zu vergrößern

Soll ich vieleicht das Raid 5 auflösen und einen Raid 10 erstellen? Was mich wundert ist, dass der Esxi für mehrere Studen sehr gut lauft und dann fangt wieder an zu "wacklen", komisch?



Schöne Grüße
Rafael
Bitte warten ..
Mitglied: Oldmcreher
09.01.2011 um 10:32 Uhr
Moin Rafael,

kannst Du mir die Files auf einen FTP server ablegen oder Rapidshare oder sowas?

Ich würde DIr aus Performancegründen auf jeden Fall zu einem Raid 10 raten.

Die Cachefiles der VMs solltest Du immer "bei der VM" speichern.

Ja komisch ist das verhalten schon, desderwegen brauch ich ja die VMSupport Files,
Bitte warten ..
Mitglied: bombass
12.01.2011 um 09:52 Uhr
Hallo Zusammen,

das Problem würde inzwischen gelöst. Und zwar durch das aktivieren der Cache an das RaidController von Write Policy= "Writethrough" zu Writethrough="Writeback". Was ich auch bemerkt habe ist, dass der Raidcontroller keine Batterie hat. Dafür hat der Server 2 Netzteile un eine (USV) (APC Smart UPS 1000VA).

Nun das Peinliche: ich bin ja ein Software entwickler und kein Administartor, daher ist mein Wissen in dieses Bereich begrenzt. Ich bedanke mich für eure Feedback

Frage1: wie ich oben beschrieben habe, handelt es sich um eine Raid 5 mit 3 Platten (3 x 1,5 TB). Nun habe ich im Office eine 1 TB Platte übrig. Macht es sinn das Raid 5 zu erweiteren mit eine 4 Platte. Wird das noch mehr Performence bringen?

Frage2: lohnt es sich einen Raid Batterie zu kaufen (150€) oder reicht es dass der Server 2 Netzteile und eine USV hat?

Übrigens: Das WriteLatency is gesungen von 1000 Millisekunden zu gerade mal 0.05 Millsekunde (durschnitlich). Hammer Unterschied!!! Oder?

Schöne Grüße
Rafael
Bitte warten ..
Mitglied: Oldmcreher
12.01.2011 um 15:43 Uhr
Hi Rafael,

zur Frage 2 solltest Du diesen Beirag lesen und selbst entscheiden:

http://de.wikipedia.org/wiki/Battery_Backup_Unit

(Wir nutzen in unserem Betrieb die BBU`s)

zu Frage 1:

http://de.wikipedia.org/wiki/RAID#RAID_5:_Leistung_.2B_Parit.C3.A4t.2C_ ...

Ich würde ein Raid 10 einstzen, dann hättest Du effektiv noch 2 TB Plattenplatz zur Verfügung.
Beim Raid 5 bleiben Dir 3 TB nutzbarer Plattenplatz, hast bei einem rebuild aber Performance-verluste.
Bitte warten ..
Ähnliche Inhalte
Linux
Problem ESXi Embedded Host Client
gelöst Frage von ProtectedLinux1 Kommentar

Hallo, ich habe nun den Embedded Host Client installiert. Leider kam der "503 error" Fehler. Daraufhin habe ich folgendes ...

Vmware

Problem nach VM-Verschiebung von ESX 4.1 auf 6.0

gelöst Frage von Leo-leVmware3 Kommentare

Hallo Forum, ich habe mal wieder ein Problem mit VMware. Insgesamt habe ich schon etliche Vms verschoben , convertiert ...

Linux Userverwaltung

Univention Corporate Server 4.1

Erfahrungsbericht von ollikaaLinux Userverwaltung7 Kommentare

Einleitung Die aktuelle Version des Univention Corporate Server (kurz: UCS) ist 4.1 und stellt die Grundlage dieses Berichtes. Ich ...

Exchange Server

Exchange Problem nach Verschiebung auf anderen ESXi Host

Frage von Leo-leExchange Server8 Kommentare

Hallo Leute, Vielleicht kann mir jemand helfen. Gestern wurde bei uns ein virtualisierter Exchange auf einen anderen esxi konvertiern. ...

Neue Wissensbeiträge
Viren und Trojaner

Staatstrojaner soll auch per Einbruch installiert werden können

Information von transocean vor 1 TagViren und Trojaner2 Kommentare

Moin, Bundesinnenminister Horst Seehofer will dem Verfassungsschutz Wohnungseinbrüche erlauben, um den geplanten Staatstrojaner zu installieren. Gruß Uwe

Windows 7
Win7 Update scheitert KB4512506
Information von infowars vor 1 TagWindows 7

Falls jemand auch das Problem hat mit dem: Monatliches Sicherheitsqualitätsrollup für Windows 7 für x64-basierte-Systeme (KB4512506) Das scheint mit ...

Humor (lol)
Wenn hacken nach hinten los geht
Information von em-pie vor 2 TagenHumor (lol)5 Kommentare

Moin, weil heute Freitag ist, nachfolgender kurzer Artikel zum schmunzeln:) l+f: NULL ist ein notorischer Falschparker

Windows Update
Windows: August 2019 Patchday-Probleme
Information von kgborn vor 3 TagenWindows Update3 Kommentare

Ich kippe mal einige kurze Informationen hier rein - vielleicht hilft es Betroffenen. Die August 2019-Updates für Windows haben ...

Heiß diskutierte Inhalte
Switche und Hubs
Glasfaser-Anschluss Telekom muss verteilt werden
Frage von cansoniSwitche und Hubs28 Kommentare

Vorweg: Bin nur Anwender und kein Experte Die Situation: Der Vermieter stellt einen Glasfaseranschluss in der Wohnung bereit. Wir ...

Ubuntu
Download manchmal langsam oder komplette Abbrüche bzw. Videos spielen nicht bis zum Schluss
Frage von stefanstpUbuntu17 Kommentare

Immer wieder berichten unsere Kunden, dass Downloads abbrechen oder super langsam sind oder Videos nicht abgespielt werden können bzw. ...

Hyper-V
VMs von Hyper-V auf externer Festplatte
Frage von SnowbirdHyper-V17 Kommentare

Hallo, ich möchte gerne von VirtualBox auf Hyper-V umsteigen und würde auch gerne weiterhin meine VMs auf der externen ...

Festplatten, SSD, Raid
SSDs durch Lagerung ohne Strom nach 6 Monaten defekt?!?
gelöst Frage von GlobetrotterFestplatten, SSD, Raid15 Kommentare

Moin Gemeinde Ich hatte gerade nen Trauerspiel Habe hier etliche NAS-Geräte herumfahren welche ich mal auf die Seite gelegt ...