Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Exchange 2010 SMTP funktioniert nicht mehr

Mitglied: Shardas

Shardas (Level 1) - Jetzt verbinden

12.07.2018, aktualisiert 10:47 Uhr, 1785 Aufrufe, 14 Kommentare

Hallo zusammen,

sehr kurioses verhalten unseres Exchange 2010 SP3 auf 2008 R2. Seit dem "Windows Update-Reboot" Mittwoch Nachts funktioniert ca alle 5-6 Stunden das SMTP nicht mehr. Der Exchange empfängt und sendet keine E-Mails mehr (ca 300 Mailboxen)


Folgende Fakten:
  • Ein "telnet exchange-server.domain.local 25" wird mit einer Zeitüberschreitung beendet
  • Ein "telnet exchange-server.domain.local 587" funktioniert
  • Datenbanken ohne Fehler eingebunden
  • Outlook und OWA zeigt keine Auffälligkeiten. Clients sind "online".
  • Ein Neustart des Servers hilft, bis der Fehler sich wiederholt
  • In den Event Logs sind keine neuen Fehlermeldungen hinzugekommen
  • Exchange Dienste lassen sich nicht neustarten, der ganze Server muss neugestartet werden

Wie kann ich die Ursache herausfinden wenn alle Systeme und Dienste vorgeben optimal zu laufen?
Mitglied: certifiedit.net
12.07.2018 um 10:28 Uhr
Hallo Shardas,

dann solltest du prüfen oder prüfen lassen, weshalb der SMTP Dienst anscheinend aufhört zu Arbeiten. Eventlog etc dürften hierfür helfen.

Viele Grüße,

certifiedit
Bitte warten ..
Mitglied: Shardas
12.07.2018 um 11:16 Uhr
Wie ich oben geschrieben habe ist in den Eventlogs im Vergleich zu den Tagen an denen es noch funktionierte keine Fehler hinzugekommen.
Wie würdest du den SMTP Dienst prüfen?
Bitte warten ..
Mitglied: mollet
12.07.2018, aktualisiert um 11:26 Uhr
Hallo, wir haben das selbe Problem, selbe Konstellation.
Seit dem die Updates KB4338423, KB4339093, KB4338818 und KB4087364 installiert wurden nimmt der SMTP Dienst einfach keine Anfragen mehr an. Den Transport Dienst zu beenden über Dienste hat leider auch nicht funktioniert.

Es muss ein Fehler im Update sein oder unser und euer Exchange ist nicht Up2date, ich finde bisher sonst niemandem mit einem ähnlichen Problem.

Und die erste Anwort wurde wieder geschrieben ohne überhaupt gelesen zu haben was alles schon gemacht wurde.
Das zieht hier nicht. Kein Eventlog Eintrag, der SMTP log hört auch einfach ab einer gewissen Uhrzeit einfach auf, nämlich dann, wenn der Transport Dienst (Smtp) nicht mehr arbeitet.
Bitte warten ..
Mitglied: certifiedit.net
12.07.2018, aktualisiert um 11:33 Uhr
Das zieht hier nicht. Kein Eventlog Eintrag, der SMTP log hört auch einfach ab einer gewissen Uhrzeit einfach auf, nämlich dann, wenn der Transport Dienst (Smtp) nicht mehr arbeitet.

Dann muss das Logging hochgestellt werden und wie viele hier schon angaben die Eventlogs geprüft zu haben (Alle!), am Ende darin aber klar der Fehleransatz zu finden war...

@mollet: schau genau hin, die weiteren Informationen wurden erst im Nachhinein ergänzt...

ich hab zumindest bei den von mir betreuten Handvoll Ex2010 keine Probleme. Direktempfang, logisch.

Aber weiterer Ansatz: Dienste lassen sich nicht neustarten - warum nicht? Hier muss es einen Fehler geben, der irgendwo auch auftaucht.

Aber ich zieh mich hier zurück, wenn man für die Tipps angegangen wird. Wer was wissen will, PN, kostenpflichtige Dienstleistung und gut
Bitte warten ..
Mitglied: Pjordorf
12.07.2018, aktualisiert um 15:05 Uhr
Hallo,

Zitat von Shardas:
  • Ein "telnet exchange-server.domain.local 25" wird mit einer Zeitüberschreitung beendet
Die aufgelöste IP passt und dein Exchange soll auch auf Port 25 antworten?

* Ein Neustart des Servers hilft, bis der Fehler sich wiederholt
Geht aus deiner Fehlerbeschreibung schon hervor

* In den Event Logs sind keine neuen Fehlermeldungen hinzugekommen
Nicht nur nach neuen Fehlern suchen. Alle Einträge seit dem letzten Neustarten in allen Logs durchgehen.

* Exchange Dienste lassen sich nicht neustarten, der ganze Server muss neugestartet werden
Was genau passiert wen du die einzelen Exchange Dienste stoppen (Beenden) willst bzw. tust. Das nichts passiert ist hier eine falsche Antwort, und ein laufender Exchange besteht aus einigen Diensten und auch abhängigkeiten.

Wie kann ich die Ursache herausfinden wenn alle Systeme und Dienste vorgeben optimal zu laufen?
Naja, der Status eines Dienstes sagt nichts über das verhalten des Dienstes aus. Z.B. Dein SMTP Dienst scheint ja zu laufen, aber tut halt nix mehr.

http://exchange.sembee.info/2010/shutdown-script.asp
https://www.petri.com/forums/forum/messaging-software/exchange-2000-2003 ...
Was passiert bei dir wenn du mal alle Dienste nach obigen Beipiel im 2ten Link Manuel in einer CMD beendest? OK oder Fehler und dann was für Fehler? Dein Exchange läuft auf ein Server 2008R2, auf ein Blech oder als VM? Wieviel RAM und welche Platten usw.? Und was läuft noch auf den Server 2008R2?

Gruß,
Peter
Bitte warten ..
Mitglied: OrangerAgent
LÖSUNG 12.07.2018 um 16:23 Uhr
auch Hallo!

hier der gleiche Fehler.
Windows 2008r2 und Exchange 2010 sp3
Nach einigen Stunden verweigert Exchange die Mailannahme.
Reboot hilft nur temporär.

Leidensgenossen gibt's auf Heise und auch auf reddit:

https://www.heise.de/forum/heise-Security/News-Kommentare/Patchday-Micro ...

https://www.reddit.com/r/exchangeserver/comments/8y5qh4/exchange_server_ ...

Mein erster Versuch zur Abhilfe: KB4338420 (Update für .Net) deinstalliert.
Neustart und jetzt 4-6h warten ...
Bitte warten ..
Mitglied: Shardas
13.07.2018 um 09:07 Uhr
Vielen Dank für die Rückmeldung, ich bin gespannt
Bitte warten ..
Mitglied: OrangerAgent
13.07.2018 um 11:38 Uhr
Nochmal Hallo,

der Fehler tritt noch immer auf.

jetzt habe ich (KB4338818) deinstalliert und weiß heute Abend mehr.

im Heise-Threat schreibt der TO das dies bei ihm geholfen hat.

so long ...
Bitte warten ..
Mitglied: Pjordorf
13.07.2018, aktualisiert um 12:11 Uhr
Hallo,

Zitat von OrangerAgent:
im Heise-Threat
Das ist dort keine Bedrohung. Thread oder Threat ist nicht das gleiche.

Gruß,
Peter
Bitte warten ..
Mitglied: Shardas
13.07.2018 um 11:56 Uhr
Laut Reddit liegt das Problem auch nicht am .NET Update. Anscheinend liegt es an KB4338818 und oder KB4339093. Ich habe die beiden Updates soeben deinstalliert und den Exchange neugestartet.

Heute Abend gebe ich dann Feedback
Bitte warten ..
Mitglied: Bartsch
13.07.2018 um 12:23 Uhr
Hallo!

bei uns trat der selbe Fehler auf. Server 2008R2 Exchange 2010SP3.
Nach den Windows Updates vom 11.07.2018 versagte der SMTP alle 4 bis 6 Stunden den Dienst.

Nach deinstallation der Windows Updates KB4340556 bzw. KB4338420 und KB4338818 läuft
der Exchange Server nun wieder seit 18 Stunden durch ohne SMTP versagen.
Bitte warten ..
Mitglied: mollet
14.07.2018, aktualisiert 15.07.2018
Für alle Eventlog "Sucher" und "Dienstleister" ...

https://www.borncity.com/blog/2018/07/13/kb4018385-zurckgezogen-weitere- ...

wir haben das Update vor ca. 24h deinstalliert, seither keine Probleme mehr mit dem Exchange 2010.
Bitte warten ..
Mitglied: Shardas
15.07.2018 um 13:07 Uhr
Kann ich so bestätigen, unserer läuft nun auch wieder
Bitte warten ..
Mitglied: schicksal
19.07.2018 um 15:25 Uhr
Danke euch für diese Kommentare, die haben mir verm. heute den A.... gerettet, das Update wurde gestern bei mir eingespielt.
Nach den ersten Problemen stieß ich auf euch.

Vielen Dank für eure genauen Infos.

LG

Mike
Bitte warten ..
Ähnliche Inhalte
Windows Server

SMTP Relay über Gmail funktioniert nicht

gelöst Frage von JohnWorksWindows Server10 Kommentare

Hallo Zusammen, ich habe Anleitung ( ) den SMTP-Server hinzugefügt und soweit konfiguriert. Nach der Installation und Konfiguration werden ...

Exchange Server

Exchange 2010 ERP und SMTP Benutzer

gelöst Frage von SepposExchange Server5 Kommentare

Hallo Forum, ich versuche zur Zeit eine kleine ERP Lösung an einen Exchange 2010 anzubinden. Ich habe einen Exchange ...

Exchange Server

Exchange 2010 SMTP - externer Nutzer (Domäne)

gelöst Frage von 97561Exchange Server2 Kommentare

Moin zusammen, folgendes Prozedere: Exchange 2010 auf SBS installiert. Domäne und Nutzer etc. funktionieren einwandfrei. Problem ist ein Benutzer, ...

Exchange Server

Exchange 2010 SMTP-Connector - zusätzliches Relay

Frage von FA-jkaExchange Server6 Kommentare

Hallo, in meinem Testnetz (basierend auf einem SBS2011) möchte ich von diversen Geräten (IMM-Konsole, RAID-Controller, NAS, Backup-Software, USV-Software, VPN-Gateways ...

Neue Wissensbeiträge
Humor (lol)
Administrator.de Perlen
Tipp von DerWindowsFreak2 vor 1 TagHumor (lol)2 Kommentare

Hallo, Heute beim stöbern auf dieser Seite bin auf folgenden Thread aus dem Jahre 2006 gestossen: Was meint ihr? ...

Erkennung und -Abwehr
OpenSSH-Backdoor Malware erkennen
Tipp von Frank vor 2 TagenErkennung und -Abwehr

Sicherheitsforscher von Eset haben 21 Malware-Familien untersucht. Die Malware soll Hintertüren via OpenSSH bereitstellen, so dass Angreifer Fernzugriff auf ...

iOS
WatchChat für Whatsapp
Tipp von Criemo vor 5 TageniOS5 Kommentare

Ziemlich coole App für WhatsApp User in Verbindung mit der Apple Watch. Gibts für iOS sowohl als auch für ...

iOS
IOS hat nen Cursor!
Tipp von Criemo vor 5 TageniOS5 Kommentare

Nette Funktion im iOS. iPhone-Mauszeiger aktivieren „Nichts ist nerviger, als bei einem Tippfehler zu versuchen, den iOS-Cursor an die ...

Heiß diskutierte Inhalte
Festplatten, SSD, Raid
SSD zeigt falsche Werte
Frage von karl2014Festplatten, SSD, Raid25 Kommentare

Ich habe ein Problem mit der SSD in meinem Laptop mit Windows 10. Es ist eine 1Tb Platte die ...

Windows 10
Windows Enterprise 1809 Eval nicht bootbar
Frage von Sunny89Windows 1022 Kommentare

Hallo zusammen, bevor ich mich jetzt noch stundenlang rumärger wollte ich euch fragen, ob Ihr die gleichen Probleme habt ...

Ubuntu
Installation freerdp 2.0.0-rc4
Frage von kristovUbuntu20 Kommentare

Hallo, möchte freerdp 2.0.0-rc4 auf linux mint 18.3 installieren, habe aber keine Ahnung, wie das funktioniert. freerdp 1.1 ist ...

Router & Routing
VPN u. WLAN Router für Reisen
Frage von stephan902Router & Routing17 Kommentare

Hallo, ich bin auf der Suche nach einem VPN/WLAN-Router für unterwegs. Und zwar möchte ich auf Reisen einfach den ...