Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Exchange 2013 - Update schlägt fehlt

Mitglied: chb1982

chb1982 (Level 2) - Jetzt verbinden

15.07.2018 um 17:01 Uhr, 954 Aufrufe, 20 Kommentare

Hallo zusammen,

kann sich jemand einen Reim auf die unten stehenden Fehlermeldung machen?
Sie tritt auf beim Update von Exchange 2013 auf CU20 im Schritt "Postfachrolle Postfachdienst"

Ich bin etwas ratlos, was sie mir sagen möchte


01.
Fehler:
02.
Der folgende Fehler wurde generiert, als "$error.Clear(); 
03.
          if ($RoleIsDatacenter -ne $true -and $RoleIsDatacenterDedicated -ne $true)
04.
          {
05.
          if (Test-ExchangeServersWriteAccess -DomainController $RoleDomainController -ErrorAction SilentlyContinue)
06.
          {
07.
          $sysMbx = $null;
08.
          $name = "SystemMailbox{bb558c35-97f1-4cb9-8ff7-d53741dc928c}";
09.
          $dispName = "Microsoft Exchange";
10.
          Write-ExchangeSetupLog -Info ("Retrieving mailboxes with Name=$name.");
11.
          $mbxs = @(Get-Mailbox -Arbitration -Filter {name -eq $name} -IgnoreDefaultScope -ResultSize 1 );
12.
          if ($mbxs.Length -eq 0)
13.
          {
14.
          Write-ExchangeSetupLog -Info ("Retrieving mailbox databases on Server=$RoleFqdnOrName.");
15.
          $dbs = @(Get-MailboxDatabase -Server:$RoleFqdnOrName -DomainController $RoleDomainController);
16.
          if ($dbs.Length -ne 0)
17.
          {
18.
          Write-ExchangeSetupLog -Info ("Retrieving users with Name=$name.");
19.
          $arbUsers = @(Get-User -Filter {name -eq $name} -IgnoreDefaultScope -ResultSize 1);
20.
          if ($arbUsers.Length -ne 0)
21.
          {
22.
          Write-ExchangeSetupLog -Info ("Enabling mailbox $name.");
23.
          $sysMbx = Enable-Mailbox -Arbitration -Identity $arbUsers[0] -DisplayName $dispName -database $dbs[0].Identity;
24.
          }
25.
          }
26.
          }
27.
          else
28.
          {
29.
          if ($mbxs[0].DisplayName -ne $dispName )
30.
          {
31.
          Write-ExchangeSetupLog -Info ("Setting DisplayName=$dispName.");
32.
          Set-Mailbox -Arbitration -Identity $mbxs[0] -DisplayName $dispName -Force;
33.
          }
34.
          $sysMbx = $mbxs[0];
35.
          }
36.

37.
          # Set the Organization Capabilities needed for this mailbox
38.
          if ($sysMbx -ne $null)
39.
          {
40.
          # We need 1 GB for uploading large OAB files to the organization mailbox
41.
          Write-ExchangeSetupLog -Info ("Setting mailbox properties.");
42.
          set-mailbox -Arbitration -identity $sysMbx -UMGrammar:$true -OABGen:$true -GMGen:$true -ClientExtensions:$true -MailRouting:$true -MessageTracking:$true -PstProvider:$true -MaxSendSize 1GB -Force;
43.

44.
          Write-ExchangeSetupLog -Info ("Configuring offline address book(s) for this mailbox");
45.
          Get-OfflineAddressBook | where {$_.ExchangeVersion.CompareTo([Microsoft.Exchange.Data.ExchangeObjectVersion]::Exchange2012) -ge 0 -and $_.GeneratingMailbox -eq $null} | Set-OfflineAddressBook -GeneratingMailbox $sysMbx.Identity;
46.
          }
47.
          else
48.
          {
49.
          Write-ExchangeSetupLog -Info ("Cannot find arbitration mailbox with name=$name.");
50.
          }
51.
          }
52.
          else
53.
          {
54.
          Write-ExchangeSetupLog -Info "Skipping creating E15 System Mailbox because of insufficient permission."
55.
          }
56.
          }
57.
        " ausgeführt wurde: "Microsoft.Exchange.Data.DataValidationException: 'Database' ist für 'UserMailbox' verbindlich.".
58.

59.
Fehler:
60.
Der folgende Fehler wurde generiert, als "$error.Clear(); 
61.
          if ($RoleIsDatacenter -ne $true -and $RoleIsDatacenterDedicated -ne $true)
62.
          {
63.
          if (Test-ExchangeServersWriteAccess -DomainController $RoleDomainController -ErrorAction SilentlyContinue)
64.
          {
65.
          $sysMbx = $null;
66.
          $name = "SystemMailbox{bb558c35-97f1-4cb9-8ff7-d53741dc928c}";
67.
          $dispName = "Microsoft Exchange";
68.
          Write-ExchangeSetupLog -Info ("Retrieving mailboxes with Name=$name.");
69.
          $mbxs = @(Get-Mailbox -Arbitration -Filter {name -eq $name} -IgnoreDefaultScope -ResultSize 1 );
70.
          if ($mbxs.Length -eq 0)
71.
          {
72.
          Write-ExchangeSetupLog -Info ("Retrieving mailbox databases on Server=$RoleFqdnOrName.");
73.
          $dbs = @(Get-MailboxDatabase -Server:$RoleFqdnOrName -DomainController $RoleDomainController);
74.
          if ($dbs.Length -ne 0)
75.
          {
76.
          Write-ExchangeSetupLog -Info ("Retrieving users with Name=$name.");
77.
          $arbUsers = @(Get-User -Filter {name -eq $name} -IgnoreDefaultScope -ResultSize 1);
78.
          if ($arbUsers.Length -ne 0)
79.
          {
80.
          Write-ExchangeSetupLog -Info ("Enabling mailbox $name.");
81.
          $sysMbx = Enable-Mailbox -Arbitration -Identity $arbUsers[0] -DisplayName $dispName -database $dbs[0].Identity;
82.
          }
83.
          }
84.
          }
85.
          else
86.
          {
87.
          if ($mbxs[0].DisplayName -ne $dispName )
88.
          {
89.
          Write-ExchangeSetupLog -Info ("Setting DisplayName=$dispName.");
90.
          Set-Mailbox -Arbitration -Identity $mbxs[0] -DisplayName $dispName -Force;
91.
          }
92.
          $sysMbx = $mbxs[0];
93.
          }
94.

95.
          # Set the Organization Capabilities needed for this mailbox
96.
          if ($sysMbx -ne $null)
97.
          {
98.
          # We need 1 GB for uploading large OAB files to the organization mailbox
99.
          Write-ExchangeSetupLog -Info ("Setting mailbox properties.");
100.
          set-mailbox -Arbitration -identity $sysMbx -UMGrammar:$true -OABGen:$true -GMGen:$true -ClientExtensions:$true -MailRouting:$true -MessageTracking:$true -PstProvider:$true -MaxSendSize 1GB -Force;
101.

102.
          Write-ExchangeSetupLog -Info ("Configuring offline address book(s) for this mailbox");
103.
          Get-OfflineAddressBook | where {$_.ExchangeVersion.CompareTo([Microsoft.Exchange.Data.ExchangeObjectVersion]::Exchange2012) -ge 0 -and $_.GeneratingMailbox -eq $null} | Set-OfflineAddressBook -GeneratingMailbox $sysMbx.Identity;
104.
          }
105.
          else
106.
          {
107.
          Write-ExchangeSetupLog -Info ("Cannot find arbitration mailbox with name=$name.");
108.
          }
109.
          }
110.
          else
111.
          {
112.
          Write-ExchangeSetupLog -Info "Skipping creating E15 System Mailbox because of insufficient permission."
113.
          }
114.
          }
115.
        " ausgeführt wurde: "Microsoft.Exchange.Data.DataValidationException: 'Database' ist für 'UserMailbox' verbindlich.
116.
   bei Microsoft.Exchange.Configuration.Tasks.Task.ThrowError(Exception exception, ErrorCategory errorCategory, Object target, String helpUrl)
117.
   bei Microsoft.Exchange.Configuration.Tasks.Task.WriteError(Exception exception, ErrorCategory category, Object target, Boolean reThrow)
118.
   bei Microsoft.Exchange.Configuration.Tasks.DataAccessTask`1.Validate(TDataObject dataObject)
119.
   bei Microsoft.Exchange.Configuration.Tasks.SetTaskBase`1.InternalValidate()
120.
   bei Microsoft.Exchange.Configuration.Tasks.SetRecipientObjectTask`3.InternalValidate()
121.
   bei Microsoft.Exchange.Management.Common.SetMailEnabledRecipientObjectTask`3.InternalValidate()
122.
   bei Microsoft.Exchange.Management.RecipientTasks.SetUserBase`2.InternalValidate()
123.
   bei Microsoft.Exchange.Management.RecipientTasks.SetMailboxBase`2.InternalValidate()
124.
   bei Microsoft.Exchange.Management.RecipientTasks.SetMailbox.InternalValidate()
125.
   bei Microsoft.Exchange.Configuration.Tasks.Task.<ProcessRecord>b__b()
126.
   bei Microsoft.Exchange.Configuration.Tasks.Task.InvokeRetryableFunc(String funcName, Action func, Boolean terminatePipelineIfFailed)".
127.
Mitglied: Pjordorf
15.07.2018 um 17:27 Uhr
Hallo,

Zitat von chb1982:
kann sich jemand einen Reim auf die unten stehenden Fehlermeldung machen?
Auf was tippst du denn was dieses auslöst? Was wurde in den Ereignissprotokollen geschrieben?
Genug RAM auf dein Datacenter?

Gruß,
Peter
Bitte warten ..
Mitglied: chb1982
15.07.2018, aktualisiert um 18:35 Uhr
Moin,

ja, RAM passt.

Ich bin ein wenig weiter und habe es auf die Systempostfächer eingrenzen können.

Das ergbibt aber das nächster Problem.

Ich bin der Anleitung von Franky gefolgt:

Systempostfächer neu erstellen

Nun kann ich aber kein Setup.exe \PrepareAD ausführen, weil noch meine vorherige, halb fertige Installation hängt.

Die Benutzer habe ich gelöscht, nur bekomme ich sie über \PrepareAD nicht neu angelegt.
Bitte warten ..
Mitglied: chb1982
15.07.2018 um 18:58 Uhr
So, neue Lage:

Ich habe die Systempostfächer per Hand angelegt. Also den per Hand Benutzer
SystemMailbox{e0dc1c29-89c3-4034-b678-e6c29d823ed9}
angelegt und mit
01.
Enable-Mailbox –Arbitration –Identity
Damit scheint aber etwas noch nicht zu stimmen, wie die Meldung unten vermuten lässt. Diese Meldung bekomme ich nun im Setup.




01.
Fehler:
02.
Der folgende Fehler wurde generiert, als "$error.Clear(); 
03.
          $name = [Microsoft.Exchange.Management.RecipientTasks.EnableMailbox]::DiscoveryMailboxUniqueName;
04.
          $dispname = [Microsoft.Exchange.Management.RecipientTasks.EnableMailbox]::DiscoveryMailboxDisplayName;
05.
          $dismbx = get-mailbox -Filter {name -eq $name} -IgnoreDefaultScope -resultSize 1;
06.
          if( $dismbx -ne $null)
07.
          {
08.
          $srvname = $dismbx.ServerName;
09.
          if( $dismbx.Database -ne $null -and $RoleFqdnOrName -like "$srvname.*" )
10.
          {
11.
          Write-ExchangeSetupLog -info "Setup DiscoverySearchMailbox Permission.";
12.
          $mountedMdb = get-mailboxdatabase $dismbx.Database -status | where { $_.Mounted -eq $true };
13.
          if( $mountedMdb -eq $null )
14.
          {
15.
          Write-ExchangeSetupLog -info "Mounting database before stamp DiscoverySearchMailbox Permission...";
16.
          mount-database $dismbx.Database;
17.
          }
18.

19.
          $mountedMdb = get-mailboxdatabase $dismbx.Database -status | where { $_.Mounted -eq $true };
20.
          if( $mountedMdb -ne $null )
21.
          {
22.
          $dmRoleGroupGuid = [Microsoft.Exchange.Data.Directory.Management.RoleGroup]::DiscoveryManagement_InitInfo.WellKnownGuid;
23.
          $dmRoleGroup = Get-RoleGroup -Identity $dmRoleGroupGuid -DomainController $RoleDomainController -ErrorAction:SilentlyContinue;
24.
          if( $dmRoleGroup -ne $null )
25.
          {
26.
            trap [Exception]
27.
            {
28.
              Add-MailboxPermission $dismbx -User $dmRoleGroup.Name -AccessRights FullAccess -DomainController $RoleDomainController -ErrorAction SilentlyContinue;
29.
              continue;
30.
            }
31.
            
32.
            Add-MailboxPermission $dismbx -User $dmRoleGroup.Identity -AccessRights FullAccess -DomainController $RoleDomainController -WarningAction SilentlyContinue;
33.
          }
34.
          }
35.
          }
36.
          }
37.
        " ausgeführt wurde: "System.InvalidOperationException: Fehler beim Einbinden der Datenbank "MBDB2013". Fehler: Fehler bei Active Manager-Vorgang: Fehler bei der Datenbankaktion: Fehler bei Vorgang mit folgender Meldung: MapiExceptionDatabaseError: Unable to mount database. (hr=0x80004005, ec=1108)
38.
Diagnostic context:
39.
    Lid: 65256  
40.
    Lid: 10722   StoreEc: 0x454     
41.
    Lid: 1494    ---- Remote Context Beg ----
42.
    Lid: 45120   dwParam: 0x377C48
43.
    Lid: 57728   dwParam: 0x377CA6
44.
    Lid: 46144   dwParam: 0x377D33
45.
    Lid: 34880   dwParam: 0x377D33
46.
    Lid: 34760   StoreEc: 0xFFFFFDE3
47.
    Lid: 41344   Guid: b20c0d7e-0764-455f-a61f-ca969bae4a03
48.
    Lid: 35200   dwParam: 0x174C
49.
    Lid: 46144   dwParam: 0x378050
50.
    Lid: 34880   dwParam: 0x378050
51.
    Lid: 54472   StoreEc: 0x1388    
52.
    Lid: 42184   StoreEc: 0x454     
53.
    Lid: 1750    ---- Remote Context End ----
54.
    Lid: 1047    StoreEc: 0x454     .. [Datenbank: MBDB2013, Server: vwl-exch13.sk.local] ---> Microsoft.Exchange.Cluster.Replay.AmDbActionWrapperException: Fehler bei Active Manager-Vorgang: Fehler bei der Datenbankaktion: Fehler bei Vorgang mit folgender Meldung: MapiExceptionDatabaseError: Unable to mount database. (hr=0x80004005, ec=1108)
55.
Diagnostic context:
56.
    Lid: 65256  
57.
    Lid: 10722   StoreEc: 0x454     
58.
    Lid: 1494    ---- Remote Context Beg ----
59.
    Lid: 45120   dwParam: 0x377C48
60.
    Lid: 57728   dwParam: 0x377CA6
61.
    Lid: 46144   dwParam: 0x377D33
62.
    Lid: 34880   dwParam: 0x377D33
63.
    Lid: 34760   StoreEc: 0xFFFFFDE3
64.
    Lid: 41344   Guid: b20c0d7e-0764-455f-a61f-ca969bae4a03
65.
    Lid: 35200   dwParam: 0x174C
66.
    Lid: 46144   dwParam: 0x378050
67.
    Lid: 34880   dwParam: 0x378050
68.
    Lid: 54472   StoreEc: 0x1388    
69.
    Lid: 42184   StoreEc: 0x454     
70.
    Lid: 1750    ---- Remote Context End ----
71.
    Lid: 1047    StoreEc: 0x454     .. [Datenbank: MBDB2013, Server: vwl-exch13.sk.local] ---> Microsoft.Exchange.Data.Storage.AmOperationFailedException: Fehler bei Active Manager-Vorgang: Fehler bei Vorgang mit folgender Meldung: MapiExceptionDatabaseError: Unable to mount database. (hr=0x80004005, ec=1108)
72.
Diagnostic context:
73.
    Lid: 65256  
74.
    Lid: 10722   StoreEc: 0x454     
75.
    Lid: 1494    ---- Remote Context Beg ----
76.
    Lid: 45120   dwParam: 0x377C48
77.
    Lid: 57728   dwParam: 0x377CA6
78.
    Lid: 46144   dwParam: 0x377D33
79.
    Lid: 34880   dwParam: 0x377D33
80.
    Lid: 34760   StoreEc: 0xFFFFFDE3
81.
    Lid: 41344   Guid: b20c0d7e-0764-455f-a61f-ca969bae4a03
82.
    Lid: 35200   dwParam: 0x174C
83.
    Lid: 46144   dwParam: 0x378050
84.
    Lid: 34880   dwParam: 0x378050
85.
    Lid: 54472   StoreEc: 0x1388    
86.
    Lid: 42184   StoreEc: 0x454     
87.
    Lid: 1750    ---- Remote Context End ----
88.
    Lid: 1047    StoreEc: 0x454     . [Server: vwl-exch13.sk.local] ---> Microsoft.Mapi.MapiExceptionDatabaseError: MapiExceptionDatabaseError: Unable to mount database. (hr=0x80004005, ec=1108)
89.
Diagnostic context:
90.
    Lid: 65256  
91.
    Lid: 10722   StoreEc: 0x454     
92.
    Lid: 1494    ---- Remote Context Beg ----
93.
    Lid: 45120   dwParam: 0x377C48
94.
    Lid: 57728   dwParam: 0x377CA6
95.
    Lid: 46144   dwParam: 0x377D33
96.
    Lid: 34880   dwParam: 0x377D33
97.
    Lid: 34760   StoreEc: 0xFFFFFDE3
98.
    Lid: 41344   Guid: b20c0d7e-0764-455f-a61f-ca969bae4a03
99.
    Lid: 35200   dwParam: 0x174C
100.
    Lid: 46144   dwParam: 0x378050
101.
    Lid: 34880   dwParam: 0x378050
102.
    Lid: 54472   StoreEc: 0x1388    
103.
    Lid: 42184   StoreEc: 0x454     
104.
    Lid: 1750    ---- Remote Context End ----
105.
    Lid: 1047    StoreEc: 0x454     
106.
   bei Microsoft.Mapi.MapiExceptionHelper.InternalThrowIfErrorOrWarning(String message, Int32 hresult, Boolean allowWarnings, Int32 ec, DiagnosticContext diagCtx, Exception innerException)
107.
   bei Microsoft.Mapi.MapiExceptionHelper.ThrowIfError(String message, Int32 hresult, IExInterface iUnknown, Exception innerException)
108.
   bei Microsoft.Mapi.ExRpcAdmin.MountDatabase(Guid guidStorageGroup, Guid guidMdb, Int32 ulFlags)
109.
   bei Microsoft.Exchange.Cluster.Replay.StoreRpcController.<>c__DisplayClass9.<MountDatabase>b__8()
110.
   bei Microsoft.Exchange.Cluster.Replay.SafeRefCountedTimeoutWrapper.<>c__DisplayClass2.<ProtectedCallWithTimeout>b__0()
111.
   bei Microsoft.Exchange.Data.HA.InvokeWithTimeout.Invoke(Action invokableAction, Action foregroundAction, TimeSpan invokeTimeout, Boolean sendWatsonReportNoThrow, Object cancelEvent)
112.
   bei Microsoft.Exchange.Cluster.Replay.SafeRefCountedTimeoutWrapper.ProtectedCallWithTimeout(String operationName, TimeSpan timeout, Action operation)
113.
   bei Microsoft.Exchange.Cluster.ActiveManagerServer.AmStoreHelper.Mount(Guid mdbGuid, MountFlags flags)
114.
   bei Microsoft.Exchange.Cluster.ActiveManagerServer.ActiveManagerCore.<>c__DisplayClasse.<MountDatabaseDirect>b__4()
115.
   bei Microsoft.Exchange.Cluster.Replay.FailoverPerformanceTrackerBase`1.RunTimedOperation(TOpCode opCode, Action operation)
116.
   bei Microsoft.Exchange.Cluster.ActiveManagerServer.ActiveManagerCore.MountDatabaseDirect(Guid mdbGuid, MountFlags storeFlags, AmMountFlags amMountFlags, AmDbActionCode actionCode)
117.
   bei Microsoft.Exchange.Cluster.ActiveManagerServer.AmRpcServer.<>c__DisplayClass1b.<MountDatabaseDirect>b__1a()
118.
   bei Microsoft.Exchange.Data.Storage.Cluster.HaRpcExceptionWrapperBase`2.RunRpcServerOperation(String databaseName, RpcServerOperation rpcOperation)
119.
   --- Ende der internen Ausnahmestapelüberwachung ---
120.
   bei Microsoft.Exchange.Data.Storage.Cluster.HaRpcExceptionWrapperBase`2.ClientRethrowIfFailed(String databaseName, String serverName, RpcErrorExceptionInfo errorInfo)
121.
   bei Microsoft.Exchange.Data.Storage.ActiveManager.AmRpcClientHelper.RunRpcOperationWithAuth(AmRpcOperationHint rpcOperationHint, String serverName, String databaseName, NetworkCredential networkCredential, Nullable`1 timeoutMs, InternalRpcOperation rpcOperation)
122.
   bei Microsoft.Exchange.Data.Storage.ActiveManager.AmRpcClientHelper.MountDatabaseDirectEx(String serverToRpc, Guid dbGuid, AmMountArg mountArg)
123.
   bei Microsoft.Exchange.Cluster.ActiveManagerServer.AmRpcClientWrapper.MountDatabaseDirectEx(String serverToRpc, Guid dbGuid, AmMountArg mountArg)
124.
   bei Microsoft.Exchange.Cluster.ActiveManagerServer.AmDbAction.MountDatabaseDirect(AmServerName serverName, AmServerName lastMountedServerName, Guid dbGuid, MountFlags storeFlags, AmMountFlags amFlags, AmDbActionCode actionCode)
125.
   bei Microsoft.Exchange.Cluster.ActiveManagerServer.AmDbStandaloneAction.<>c__DisplayClass2.<MountInternal>b__0(Object param0, EventArgs param1)
126.
   bei Microsoft.Exchange.Cluster.ActiveManagerServer.AmHelper.HandleKnownExceptions(EventHandler ev)
127.
   --- Ende der internen Ausnahmestapelüberwachung ---
128.
   bei Microsoft.Exchange.Data.Storage.Cluster.HaRpcExceptionWrapperBase`2.ClientRethrowIfFailed(String databaseName, String serverName, RpcErrorExceptionInfo errorInfo)
129.
   bei Microsoft.Exchange.Data.Storage.ActiveManager.AmRpcClientHelper.RunDatabaseRpcWithReferral(AmRpcOperationHint rpcOperationHint, IADDatabase database, String targetServer, InternalRpcOperation rpcOperation)
130.
   bei Microsoft.Exchange.Management.SystemConfigurationTasks.MountDatabase.RequestMount(MountFlags storeMountFlags)
131.
   bei Microsoft.Exchange.Management.SystemConfigurationTasks.MountDatabase.InternalProcessRecord()
132.
   --- Ende der internen Ausnahmestapelüberwachung ---
133.
   bei Microsoft.Exchange.Configuration.Tasks.Task.ThrowError(Exception exception, ErrorCategory errorCategory, Object target, String helpUrl)
134.
   bei Microsoft.Exchange.Configuration.Tasks.Task.WriteError(Exception exception, ErrorCategory category, Object target)
135.
   bei Microsoft.Exchange.Management.SystemConfigurationTasks.MountDatabase.InternalProcessRecord()
136.
   bei Microsoft.Exchange.Configuration.Tasks.Task.<ProcessRecord>b__b()
137.
   bei Microsoft.Exchange.Configuration.Tasks.Task.InvokeRetryableFunc(String funcName, Action func, Boolean terminatePipelineIfFailed)".
138.

139.
Bitte warten ..
Mitglied: Vision2015
15.07.2018, aktualisiert um 19:05 Uhr
Moin...
Zitat von chb1982:

Moin,

ja, RAM passt.
sagt wer?

Ich bin ein wenig weiter und habe es auf die Systempostfächer eingrenzen können.
ja...
01.
#We need 1 GB for uploading large OAB files to the organization mailbox 
sagt mr das deine settings nicht passen, oder die platte voll ist!

Das ergbibt aber das nächster Problem.
wie?

Ich bin der Anleitung von Franky gefolgt:

Systempostfächer neu erstellen
ahhhh....

Nun kann ich aber kein Setup.exe \PrepareAD ausführen, weil noch meine vorherige, halb fertige Installation hängt.
klar...

Die Benutzer habe ich gelöscht, nur bekomme ich sie über \PrepareAD nicht neu angelegt.
neee. sach nicht das du das wirklich gemacht hast!?

ok... alles auf null... mach ein restore von deinem Image / Datensicherung!... sicher über vorher alle DB´s...
am besten alle exchange dienste / und AV anhalten, wech kopieren!

du hast doch eine Datensicherung... oder?

von was hast du den auf CU20 ein Update gemacht?

Frank
Bitte warten ..
Mitglied: Vision2015
15.07.2018 um 19:12 Uhr
Moin...

MapiExceptionDatabaseError: Unable to mount database.

prüfe mal die DB auf Dirty Shutdown

eseutil /r & eseutil /p

Frank
Bitte warten ..
Mitglied: chb1982
15.07.2018 um 19:22 Uhr
Moin!

Ja, doch, die Benutzer habe ich gelöscht. Kurz danach kam es mir dann auch, dass es evtl. ne blöde Idee ist in dem Zustand. Ist nunmal passiert.

01.
toreEc: 0x454     .. [Datenbank: MBDB2013, Server: vwl-exch13.sk.local] ---> Microsoft.Exchange.Data.Storage.AmOperationFailedException: Fehler bei Active Manager-Vorgang: Fehler bei Vorgang mit folgender Meldung: MapiExceptionDatabaseError: Unable to mount database. (hr=0x80004005, ec=1108) 
Offensichtlich klemmt es eher an der Datenbank, oder?


Es gibt einen Snapshot von dem Exchange-Server. Komplette Backups vom AD von gestern. Also den Exchange bekomme ich ohne Probleme in den Zustand von vorher. Beim AD wird es etwas blöd.

Ich komme von nem CU6.

Für mich fühlt es sich noch nicht so an, als müsste man tatsächlich das Backup zurück holen. Mir fehlt etwas der Ansatz, aber wenn es wirklich an der Datenbank hängt, die er nicht einbinden kann, habe ich das Gefühl das Ruder nochmal rum zu reißen ist - mit der passenden Idee.
Bitte warten ..
Mitglied: certifiedit.net
15.07.2018 um 19:25 Uhr
Bringt dir alles nix, die User hast du schon gelöscht oder ist das nur ein Testsystem?
Bitte warten ..
Mitglied: chb1982
15.07.2018, aktualisiert um 19:38 Uhr
Moin!

Eine Datenbank ist sauber,

die zweite:

01.
Error: Access to source database failed with Jet error -1032
Was aber daran liegt, dass der Informationsspeicher-Dienst läuft. Wenn der beendet ist, sind beide im Clean Shutdown.

Sorry für die blöde Frage, bisher war das nie ein Thema:
Sollten die Dienste während des Setup nicht gestopt sein???
Bitte warten ..
Mitglied: chb1982
15.07.2018 um 19:32 Uhr
Zitat von certifiedit.net:

Bringt dir alles nix, die User hast du schon gelöscht oder ist das nur ein Testsystem?

Nein, kein Testsystem.

Ist es denn wirklich nicht möglich, die User händisch anzulegen? Für mich sah das so aus, als seien es normale AD-Benutzer (Die Namen sind relevant).

Systempostfächer
Bitte warten ..
Mitglied: Vision2015
15.07.2018 um 19:55 Uhr
Moin..
Zitat von chb1982:

Moin!

Ja, doch, die Benutzer habe ich gelöscht. Kurz danach kam es mir dann auch, dass es evtl. ne blöde Idee ist in dem Zustand. Ist nunmal passiert.

01.
toreEc: 0x454     .. [Datenbank: MBDB2013, Server: vwl-exch13.sk.local] ---> Microsoft.Exchange.Data.Storage.AmOperationFailedException: Fehler bei Active Manager-Vorgang: Fehler bei Vorgang mit folgender Meldung: MapiExceptionDatabaseError: Unable to mount database. (hr=0x80004005, ec=1108) 
Offensichtlich klemmt es eher an der Datenbank, oder?
ja...


Es gibt einen Snapshot von dem Exchange-Server. Komplette Backups vom AD von gestern. Also den Exchange bekomme ich ohne Probleme in den Zustand von vorher. Beim AD wird es etwas blöd.
Moment.... ein snapshot ist kein Backup- oder was meinst du genau?
AD ? ok der EX2013 ist mit dem AD verheiratet... Aber..
sag mal, kann es sein, das du den DC und den Exchange auf einer Maschiene am laufen hast?

Ich komme von nem CU6.
hm...

Für mich fühlt es sich noch nicht so an, als müsste man tatsächlich das Backup zurück holen. Mir fehlt etwas der Ansatz, aber wenn es wirklich an der Datenbank hängt, die er nicht einbinden kann, habe ich das Gefühl das Ruder nochmal rum zu reißen ist - mit der passenden Idee.
da dein Setup nicht durchgelaufen ist, ist die Installation hinüber!
deswegen, am schnellsten alles auf anfang!

Frank
Bitte warten ..
Mitglied: certifiedit.net
15.07.2018 um 20:01 Uhr
Zitat von chb1982:

Zitat von certifiedit.net:

Bringt dir alles nix, die User hast du schon gelöscht oder ist das nur ein Testsystem?

Nein, kein Testsystem.

Ist es denn wirklich nicht möglich, die User händisch anzulegen? Für mich sah das so aus, als seien es normale AD-Benutzer (Die Namen sind relevant).


Dann hol dir am besten einen Profi an Board. Wollen die Leute morgen damit arbeiten?
Bitte warten ..
Mitglied: Vision2015
15.07.2018 um 20:02 Uhr
Moin...

also wenn du die DB geprüft hast, und ok sind......

hm...

halte mal alle exchange dienste an!
kopiere die DB einmal weg...
lösche oder verschiebe alle *.chk files & alle E0*.log
server neustarten...

Frank
Bitte warten ..
Mitglied: chb1982
15.07.2018 um 20:04 Uhr
Hallo Frank,

es gibt beides. Ein Backup von allen Maschinen, allerdings von gestern Abend. Passt soweit, weil ich heute morgen mit dem Update angefangen habe und sonst auf den Servern heute nichts passiert.

Von dem Exchange gibt es zusätzlich einen VmWare-Snapshot von kurz vor der Installation.

Keine Sorge, der Exchange 2013 läuft nicht auf dem gleichen Server wie das AD.


da dein Setup nicht durchgelaufen ist, ist die Installation hinüber!
deswegen, am schnellsten alles auf anfang!

ich verstehe was du sagst
Um das Backup der virtuellen Maschinen zurück zu holen, muss ich die aktuell laufenden entfernen (zu wenig Platz für beide gleichzeitig auf dem Storage).
Auch wenn das Recovery regelmäßig getestet wird, habe ich da etwas Angst vor. Vor allem weil es ja "nur" die Datenbank ist, die gerade noch zu hängen scheint. Ein paar andere Probleme vorher habe ich in den Griff bekommen.

Mir fehlen aber die Ideen und Argumente gegen deinen Rat
Bitte warten ..
Mitglied: Vision2015
15.07.2018 um 20:12 Uhr
Moin...

hast du schon die logfiles gelöscht?

Frank
Bitte warten ..
Mitglied: certifiedit.net
15.07.2018 um 20:15 Uhr
Auch wenn das Recovery regelmäßig getestet wird, habe ich da etwas Angst vor. Vor allem weil es ja "nur" die Datenbank ist, die gerade noch zu hängen scheint. Ein paar andere Probleme vorher habe ich in den Griff bekommen.

wenn ich das richtig lese hast du bereits auch schon die Benutzer (wohl aus Ex und AD) gelöscht, also nein, das betrifft mittlerweile das System global.
Bitte warten ..
Mitglied: Vision2015
15.07.2018 um 20:24 Uhr
Moin...

ich hoffe doch nur die SystemMailbox User....
ich denke wenn die *.chk files & E0*.log files gelöscht sind, startet die DB auch...

selbst wenn der Exchange danach rennt, wäre mir das zu **
alles auf 0 wäre die beste option!

und eine Datensicherung, wo du mal eben die DB restoren kannst!

Frank
Bitte warten ..
Mitglied: chb1982
15.07.2018, aktualisiert um 20:36 Uhr
Zitat von Vision2015:

Moin...

ich hoffe doch nur die SystemMailbox User....

Ja, ich habe "nur" die SystemMailBox User gelöscht und händisch neu angelegt.

ich denke wenn die *.chk files & E0*.log files gelöscht sind, startet die DB auch...

nein, leider nicht.

selbst wenn der Exchange danach rennt, wäre mir das zu **
alles auf 0 wäre die beste option!

Es steht bereits ein Exchange2016 in den Startlöchern (noch nicht installiert). Die Kiste muss also nur noch einmal für ein paar Tage hoch kommen um die Postfächer raus zu holen und morgen früh den Betrieb zu sichern. Trauen tue ich dem jetzt auch nicht mehr.

und eine Datensicherung, wo du mal eben die DB restoren kannst!

Frank

Die Dantenbank, die hier angemeckert wird hat kein einziges Postfach mehr. Die muss also gar nicht mehr eingehängt werden.
Gibt es eine Möglichkeit die aktuell los zu werden?
Bitte warten ..
Mitglied: Vision2015
LÖSUNG 15.07.2018 um 20:37 Uhr
Moin..

01.
eseutil /mh *.edb
02.

03.
eseutil /p *.edb
04.

05.
eseutil /mh *.edb
wenn das nix bringt, mach ein restore!

Frank
Bitte warten ..
Mitglied: chb1982
16.07.2018 um 05:36 Uhr
Moin!

So, Server wurden gestern noch aus dem Backup geholt, läuft jetzt wieder im alten Stand.

Danke für eure Unterstützung. Zwar hat sie mich nicht vor dem Schritt des Recover bewahrt, aber so bin ich wenigstens sicher, dass es nicht vorschnell war.
Vielen Dank und einen schönen Wochenstart.
Bitte warten ..
Mitglied: Vision2015
16.07.2018 um 07:26 Uhr
Moin...

noch was zum Lesen

Frank
Bitte warten ..
Ähnliche Inhalte
Exchange Server
Exchange 2013 ECP fehlt komplett
gelöst Frage von MazenauerExchange Server9 Kommentare

Guten Morgen zusammen, Ich habe das Problem, dass mir während der Installation von Exchange 2013 inkl. SP1 das ECP ...

Microsoft Office

Onenote Botton "Besprechungsnotitzen" fehlt in den Outlook 2013 Besprechungen

Frage von ScrollerMicrosoft Office2 Kommentare

Hallo, wie muss ich denn den aktivieren? Danke für Eure Infos! SC!

Microsoft Office

Outlook 2013 - Kalender Frei-Gebucht Info fehlt bei Termin Erstellung

Frage von K-ist-KMicrosoft Office

Hallo Werte Leute ich habe wieder mal ein Problem, was ich nicht ganz verstehe, und bin ein wenig auf ...

Windows Server

Netzwerkname Fehlt

Frage von ammdopplebWindows Server18 Kommentare

Hallo ADMINISTRATORen, ich bitte euch um Hilfe, und bedanke mich hierfür vorab schon mal sehr. Gleich vorab, mein Wissensstand ...

Neue Wissensbeiträge
Humor (lol)
Das IoT wird schlimmer
Erfahrungsbericht von Henere vor 1 TagHumor (lol)7 Kommentare

Nun auch schon über den WSUS:

Sicherheit

Win10 1809 und höher erlauben nun das Sperren und Whitelisten von bestimmten Geräten

Tipp von DerWoWusste vor 2 TagenSicherheit1 Kommentar

Vor 1809 konnten nur Geräteklassen gesperrt werden, nun können endlich einzelne Device instance IDs gewhitelistet werden (oder andersherum: gesperrt ...

Windows 10

Hands-On: What is new in the Windows 10 November 2019 Update?

Information von DerWoWusste vor 2 TagenWindows 10

Die wenigen (aber zum Teil interessanten) Neuheiten werden in diesem Video sehr schnell erklärt und vorgeführt.

Grafik

Gute Spiele aus der Ubuntu Repository: SuperTuxKart

Information von NetzwerkDude vor 3 TagenGrafik2 Kommentare

Fall jemand die Firmenpolicy hat das man Linux Software nur aus dem default Repository installieren kann: Ich habe festgestellt ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
10G Netzwerk konfigurieren für maximalen Datendurchsatz
gelöst Frage von hukimanLAN, WAN, Wireless37 Kommentare

Guten Morgen, in unserem Betrieb wurde das Netzwerk auf 10G (Kupfer) umgerüstet. Grund dafür sind große Laserscandaten die sehr ...

Netzwerke
Subnetzmaske mit Hilfe der IP-Adresse berechnen
gelöst Frage von Jennifer21Netzwerke21 Kommentare

Hi zusammen, kann mir bitte jemand helfen bei dieser Aufgabe. Ich muss die die Subnetzsmaske berechnen von den IP-Adressen: ...

Exchange Server
Exchange 2016 550 5.7.60 SMTP Client does not have permissions to send
Frage von kermit-elmoExchange Server17 Kommentare

Hallo, ich möchte für bestimmte Mitarbeiter einen IMAP Zugang zum Firmen internen Exchange 2016 bereitstellen. Ein paar verwenden Linux ...

Batch & Shell
Batch "dir B" nebeneinander statt untereinander mit , getrennt
gelöst Frage von plentmBatch & Shell16 Kommentare

Hallo zusammen, Mein erst Post und dann doch wahrscheinlich was einfaches. Leider reichen meine Kenntnisse dafür nicht aus, daher ...