Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Exchange SMTP Mail FROM in Telnet

Mitglied: Goofie

Goofie (Level 1) - Jetzt verbinden

23.03.2008, aktualisiert 25.03.2008, 7629 Aufrufe, 4 Kommentare

Das versenden von Mails via Telnet und Exchange funktioniert nur, wenn bei MAIL FROM: <myname@domain.com> verwendet wird. MAIL FROM: myname <myname@domain.com> funktioniert nicht!

Hi,

ich versuche verzweifelt rauszubekommen, warum mein Exchange per Telnet einfach nur E-Mails mit Absender-Mail-Adresse verschickt und ich keinen Absendername anfügen kann.

Wenn ich per Telnet auf den Server verbinde und
MAIL FROM: <myname@domain.com>
ausführe, dann funktioniert alles.
Will ich jedoch einen Absendername hinzufügen (MAIL FROM: myname <myname@domain.com>)
und nicht nur eine Absender-Mail-Adresse, dann meckert Exchange: 501 5.5.4 Invalid arguments.

Per Outlook Express kann ich jedoch auch einen beliebitgen Absendernamen eingeben und die Mails kommen korrekt an.

Wahrscheinlich ist die Eingabe-form falsch... kann mir jemand helfen???

Gruß

Ben
Mitglied: filippg
23.03.2008 um 17:13 Uhr
Hallo,

beim Mailversand per SMTP taucht der Absender zweimal auf: einmal im "MAIL FROM:"-SMTP-Befehl, und einmal im Message-Header. Der Message-Header wird im "DATA"-Teil übertragen. Der Mailserver wertet diese Header gar nicht aus (gut, zum Spamschutz wird das mittlerweile schon gemacht, ist eigentlich aber nicht vorgesehen). Und die Angabe des Absendernamens kann nur in den Message-Headern im DATA-Teil gemacht werden, nicht im MAIL FROM-Befehl.

Gruß

Filipp
Bitte warten ..
Mitglied: Goofie
24.03.2008 um 14:54 Uhr
@filippg: Danke für den Hinweis...
Ich versuche allerdings per PHP mit dem mail()-Befehl eine E-Mail zu versenden.
wie ich bereits erläutert habe, funktioniert dies nur, wenn ich als absender eine e-mail-adresse festlege...

mit:
$headers.="From: \"$fromname\" <$from>\r\n";
wird keine E-Mail versandt... ich bin hier etwas fündig geworden, aber der bugfix zeigt keine wirkung:

The fix is in Microsoft Article ID 291828 ( http://support.microsoft.com/?id=291828 ). Even though the "bug" workaround is for IIS 6.0 on Exchange 2003 communicating with a UNIX server, THIS SOLVES THE PROBLEM. Just skip down to the last section for Exchange 2003 and follow the instructions to modify the IIS 6 MetaBase with the MetaBase Explorer found in the IIS 6 Resource Kit.
Bitte warten ..
Mitglied: filippg
24.03.2008 um 15:33 Uhr
Hallo,

von PHP hattest du leider kein Wort geschrieben.
Und der Patch den du verlinkt hast bezieht sich auf einen komplett anderen Fehler.

Gruß

Filipp
Bitte warten ..
Mitglied: Goofie
25.03.2008 um 13:07 Uhr
Habs hinbekommen...

das Problem lag an folgendem: die in der PHP.ini kein Absender angegeben war, hat die Mail-funktion als Absender die im Header angegebene Adresse verwendet und zwar mit Absendername <E-Mail-adresse>, was Exchange aber so nicht annimmt.

Meine neue Mail-Funktion in PHP ändert also erst die Absenderadresse in der PHP.ini, im Header kann dann trotzdem Absendername <E-Mail-Adresse> verwendet werden.
Bitte warten ..
Ähnliche Inhalte
E-Mail

Frage SMTP Dialog via Telnet:25 mit Hoster

Frage von Various5E-Mail5 Kommentare

Schönen guten Tag Community Ein Kunde hat mich Heute angerufen und sich über SPAM Mails beklagt mit Viren Inhalt. ...

Exchange Server

Bei Maileingang am Exchang einen externen DL per Mail informieren

Frage von Oneil-1989Exchange Server13 Kommentare

Hallo zusammen, ich habe mal wieder so ne komische Aufgabe am Hals ;-). Vielleicht hat ja eine ne gute ...

Outlook & Mail

Office 365 - SMTP - automatisierte Mail versenden - "Gerät freigeben?!"

gelöst Frage von KMUlifeOutlook & Mail4 Kommentare

Hallo zusammen, Unser Serviceprogramm sollte konfiguriert werden können, dass auch User mit Office 365 Accounts automatisierte Mails schicken können. ...

E-Mail

Nachteile eines SMTP-Relays in E-Mail-Clients

Frage von rebuhleivE-Mail5 Kommentare

Eine allgemeine Frage: Ich habe einen Server auf einem Shared Host, dessen IP ständig auf Blacklists von einigen Mailservern ...

Neue Wissensbeiträge
Internet

Kommentar: Bundesregierung erwägt Ausschluss von Huawei im 5G-Netz - Unsere Presse wird immer sensationsgieriger

Information von Frank vor 8 StundenInternet2 Kommentare

Hier mal wieder ein schönes Beispiel für fehlgeleiteten Journalismus und Politik zugleich. Da werden aus Gerüchten plötzlich Fakten, da ...

Windows 10

Netzwerk-Bug in allen Windows 10-Versionen durch Januar 2019-Updates

Information von kgborn vor 12 StundenWindows 101 Kommentar

Nur ein kurzer Hinweis für Admins, die Windows 10-Clients im Portfolio haben. Mit den Updates vom 8. Januar 2019 ...

Windows 10

Windows 10 V1809: Rollout ist gestartet - kommt per Windows Update

Information von kgborn vor 1 TagWindows 102 Kommentare

Eine kurze Information für die Admins, die Windows 10 im Programm haben. Microsoft hat die letzte Baustelle (die Inkompatibilität ...

Sicherheit

Heise Beitrag Passwort-Sammlung mit 773 Millionen Online-Konten im Netz aufgetaucht

Information von Penny.Cilin vor 1 TagSicherheit6 Kommentare

Auf Heise Online ist folgender Beitrag veröffentlicht worden: Heise Beitrag passwörter geleakt Ich bin mir jetzt nicht ganz sicher, ...

Heiß diskutierte Inhalte
Switche und Hubs
Medienkonverter mit 12 oder 24 Ports gesucht
Frage von wmuellerSwitche und Hubs24 Kommentare

Guten Morgen, ich bin auf der Suche nach einem größeren Medienkonverter, der "stumpf" 1:1 die Ports auf über ein ...

Windows Server
Uhren gehen immer wieder falsch
Frage von killtecWindows Server23 Kommentare

Hallo, ich habe folgende Konstellation: 1. Physischer DC Div. Virtuelle DC's auf Hyper-V Servern Die Hyper-V-Server, der Physische DC ...

Batch & Shell
Mit findstr batch doppelte zeilen einer txt löschen
Frage von Burningx2Batch & Shell21 Kommentare

Hi Vor einer weile habe ich im netzt einen windows shell befehl gefunden mit welchem man über die konsole ...

Verschlüsselung & Zertifikate
Netzwerkfreigabe Verschlüsselung
Frage von grill-itVerschlüsselung & Zertifikate20 Kommentare

Moin zusammen, sicher nutzen hier die ein oder anderen ein Produkt zur Verschlüsselung von Netzwerkfreigaben/-laufwerken auf denen hochsensible Daten ...