Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Falsches Tastaturlayout bei Remote-Verbindung

Mitglied: marc-1303

marc-1303 (Level 2) - Jetzt verbinden

23.11.2011, aktualisiert 18:54 Uhr, 17114 Aufrufe, 3 Kommentare

Guten Tag

Seit einigen Tagen habe ich ein delikates Problem. Wenn ich von Zuhause aus über den IPSec-Tunnel auf meinen Server im Geschäft remote wird ein falsches Tastaturlayout zu Grunde gelegt.

Client zuhause: Win7 Pro SP1
Server: SBS 2011 Standard SP1

Ich bin mir im Mindesten nicht bewusst, dass ich diesbezüglich etwas geändert hätte. Ich finde in den Einstellungen zur Remoteverbindung keine Option, mit welcher ich dieses Verhalten beeinflussen könnte.

EDIT
Kleine Ergänzung, ich hab das eben noch mal kontrolliert: Sowohl auf dem Client wie auch auf dem Server (während der Remote-Verbindung) sind die richtigen Tastatur-Layouts eingestellt. In meinem Fall Deutsch (Schweiz). Trotzdem kann ich z.B. kein Slash schreiben. Oder wenn ich ein _ schreiben möchte erhalte ich stattdessen ein ?
EDIT ENDE

Jemand eine Ahnung?

Grüsse
Marc
Mitglied: nEmEsIs
23.11.2011 um 21:20 Uhr
Hi

Klingt für mich als würde deine Tastatur auf Englisch umgestellt werden. Hatte das Problem mit Win 7 auch mal.
Lösung:
Trag mal auf deinem Server mit regedit
[HKEY_LOCAL_MACHINE][SYSTEM][CurrentControlSet][Control][Keyboard Layout]

REG_DWORD "IgnoreRemoteKeyboardLayout=1"

ein.
Dann abmelden und neu anmelden. Sollte das Problem lösen.

MFG Nemesis

PS: Schau mal als erstes ob du vll. das englische Tastaturlayout auf deinem Windows 7 Client aktiviert hast bzw. in der Liste auftaucht. Lösch es einfach mal raus.
Bei mir hat aber das oben erst eine Lösung gebracht. Unter XP keine Probleme mit Win 7 schon.
Bitte warten ..
Mitglied: marc-1303
24.11.2011 um 10:44 Uhr
Zitat von nEmEsIs:
Hi

Hallo NEmEsis
Sorry, bin erst jetzt, nach einer längeren Sitzung dazu gekommen zum Testen.

Klingt für mich als würde deine Tastatur auf Englisch umgestellt werden. Hatte das Problem mit Win 7 auch mal.
Lösung:
Trag mal auf deinem Server mit regedit
[HKEY_LOCAL_MACHINE][SYSTEM][CurrentControlSet][Control][Keyboard Layout]

Ich habe den neuen Key eingetragen. explorer.exe abgeschossen und neu gestartet. Ab- und wieder angemeldet.
Jetzt habe ich immer noch dasselbe Verhalten. Keine Besserung.

REG_DWORD "IgnoreRemoteKeyboardLayout=1"

ein.
Dann abmelden und neu anmelden. Sollte das Problem lösen.

MFG Nemesis

PS: Schau mal als erstes ob du vll. das englische Tastaturlayout auf deinem Windows 7 Client aktiviert hast bzw. in der Liste
auftaucht. Lösch es einfach mal raus.
Bei mir hat aber das oben erst eine Lösung gebracht. Unter XP keine Probleme mit Win 7 schon.

Auf meinem Client habe ich nur ein Tastaturlayout installiert (Deutsch Schweiz). Also kein englisches Layout.
Könnte es auch an irgend einer Gruppenrichtlinien-Einstellung liegen?

Gruss
Marc
Bitte warten ..
Mitglied: marc-1303
24.11.2011 um 10:52 Uhr
Ich glaube, ich habe das Problem eben behoben.
Wie folgt:

Ich habe auf dem Server wieder das englische Tastaturlayout installiert und mir die Sprachenleiste in der Taskleiste angezeigen lassen.
Trotzdem das Deutsche (Schweiz) Tastaturlayout als Standard definiert ist zeigt die Sprachenleiste "EN".
Jetzt kann ich wenigestens bei Bedarf um "DE" umschalten.

Danke trotzdem für Deine Hilfe, NEmEsis
Bitte warten ..
Ähnliche Inhalte
Windows Server
RemoteApp - Tastaturlayout
Frage von manuwjWindows Server2 Kommentare

Hallo zusammen, wir haben ein nicht nachvollziehbares Phänomen und ich bin mit meinem Latein am Ende. Wir konnten nach ...

Windows 8

Tastaturlayout auf Anmeldebildschirm auswählen

Frage von DT1234Windows 82 Kommentare

Ist es möglich, die Sprache (für die Tastatur) auch auf der Anmeldeseite von Windows 8.1 zu wechseln bzw. auszuwählen? ...

LAN, WAN, Wireless

Anderes Tastaturlayout im WLAN-Passwort-Eingabefeld

gelöst Frage von eraiserLAN, WAN, Wireless2 Kommentare

Hallo miteinander, ich habe inzwischen auf mehreren neu installierten Rechnern mit Windows 10 1607 festgestellt, dass das Tastaturlayout im ...

Administrator.de Feedback

Messagetimestamp falsch?

gelöst Frage von nepixlAdministrator.de Feedback4 Kommentare

Guten Morgen, irgendetwas stimmt mit den Uhrzeiten nicht. Eben eine Message von einem Admin.de-Kollegen erhalten mit dem Timestamp um ...

Neue Wissensbeiträge
Internet

CDU Propaganda: Urheberschutz im Internet - Ende des digitalen Wild-West

Information von Frank vor 8 StundenInternet3 Kommentare

Hallo Administratoren, aus einem Kommentar heraus habe ich folgenden Beiträge von Herr Sven Schulze und Axel Voss (beide CDU ...

Router & Routing

Zyxel VMG 1312 B30A - Firmwareupdate nur im "privaten" Firefox Modus möglich

Tipp von the-buccaneer vor 22 StundenRouter & Routing2 Kommentare

Hatte hier ein Zyxel 1312 das ums verrecken kein Firmwareupdate durchführen wollte. Datei ist auswählbar, dann kommt der Fortschrittskreisel ...

Windows 7

Windows 7 u. Server 2008 (R2) SHA-2-Update kommt am 12. März 2019

Information von kgborn vor 2 TagenWindows 75 Kommentare

Kleine Info für die Admins der oben genannten Maschinen. Ab Juli 2019 werden Updates von Microsoft nur noch mit ...

Firewall
PfSense 2.5.0 benötigt doch kein AES-NI
Information von ChriBo vor 4 TagenFirewall2 Kommentare

Hallo, Wie sich einige hier erinnern werden hat Jim Thompson in diesem Aritkel beschrieben, daß ab Version 2.5.0 ein ...

Heiß diskutierte Inhalte
Hardware
IT-Werkzeugkoffer bis 50,- EUR
gelöst Frage von departure69Hardware53 Kommentare

Hallo. Ich bin als IT-Systembetreuer einer Gemeinde zusätzlich auch der IT-Systembetreuer einer Grund- und Hauptschule. Dort muß ich jedoch ...

Netzwerke
Verteilung von Programmdaten außerhalb des internen Netzwerkes
Frage von mertaufmbergNetzwerke27 Kommentare

Guten Morgen liebe Administratoren, ich versuche zurzeit eine möglichst sichere und einfache Lösung zu suchen, um ein Programmverzeichnis über ...

Datenbanken
PHP Fatal error: Uncaught Error: Call to undefined function oci connect
Frage von PlanitecXDatenbanken19 Kommentare

Hallo Zusammen, ich sitze seit Tagen am Problem das ich keine PHP Anwendung mit Anbindung zu Oracle zum laufen ...

Hardware
PC im Selbstbau, Workstation, mittelklasse Gaming
gelöst Frage von MrRobot1997Hardware19 Kommentare

Hallöchen Leute, ich bin seit einigen Jahren leider nicht mehr wirklich im Bild, wenn es um die Hardware und ...