Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Fehler: %%a ist syntaktisch an dieser Stelle nicht verarbeitbar

Mitglied: fugu

fugu (Level 2) - Jetzt verbinden

15.09.2006, aktualisiert 16.09.2006, 26684 Aufrufe, 7 Kommentare

Moinz @Batchler

Ich habe hier 2 Server, die per M$-Backup je auf eine lokal angeschlossene USB-HDD sichern.
In der Buchhaltung haben wir einen Verantwortlichen "gefunden", der nun täglich die Bänder vom neu angeschafften REV Drive wechseln soll. Hierfür steht auch eingens eine XPProf-Dose bereit, woran das REV angeschlossen ist.

Ich möchte nun:
  • Die jeweils aktuellste *.bkf von den beiden USB-HDD auf die lokale HDD der XP-Dose holen.
  • Die *.bkf auf das REV schreiben

Soweit so gut...

01.
@ECHO OFF
02.

03.
CD /D D:\Backup
04.
DEL /S /Q *.*
05.

06.
NET USE X: \\srv01\DASI_SRV01
07.
NET USE Y: \\srv02\DASI_SRV02
08.

09.
CD X:\
10.
FOR /F "skip=1 tokens=*" %%a IN ('DIR /O /B X:') DO (
11.
  XCOPY "%%a" D:\Backup /I /C /E /Q /Y
12.
)
13.

14.
CD Y:\
15.
FOR /F "skip=1 tokens=*" %%a IN ('DIR /O /B Y:') DO (
16.
  XCOPY "%%a" D:\Backup /I /C /E /Q /Y
17.
)
18.

19.
"C:\Programme\Iomega\REV System Software\ImDrvCli.exe" /Drive=R: /Format
20.
XCOPY D:\Backup\*.* R:\ /I /C /E /Q /Y
21.
"C:\Programme\Iomega\REV System Software\ImDrvCli.exe" /Drive=R: /Eject
22.

23.
NET USE X: /D /Y
24.
NET USE Y: /D /Y
Leider bricht die FOR-Schleife mit der Meldung "%%a" ist syntaktisch an dieser Stelle nicht verarbeitbar. ab - und ich hab keine Idee, wo mein Fehler ist.

Thx for help, Fugu
Mitglied: hoschen
15.09.2006 um 13:37 Uhr
mach das mal so:

01.
@ECHO OFF
02.

03.
CD /D D:\Backup
04.
DEL /S /Q *.*
05.

06.
NET USE X: \\srv01\DASI_SRV01
07.
NET USE Y: \\srv02\DASI_SRV02
08.

09.
CD X:
10.
FOR /F "skip=1 tokens=*" %%a IN ('DIR /O /B X:') DO (
11.
  XCOPY "%%a" D:\Backup /I /C /E /Q /Y
12.
)
13.

14.
CD Y:
15.
FOR /F "skip=1 tokens=*" %%a IN ('DIR /O /B Y:') DO (
16.
  XCOPY "%%a" D:\Backup /I /C /E /Q /Y
17.
)
18.

19.
"C:\Programme\Iomega\REV System Software\ImDrvCli.exe" /Drive=R: /Format
20.
XCOPY D:\Backup\*.* R:\ /I /C /E /Q /Y
21.
"C:\Programme\Iomega\REV System Software\ImDrvCli.exe" /Drive=R: /Eject
22.

23.
NET USE X: /D /Y
24.
NET USE Y: /D /Y
Bitte warten ..
Mitglied: fugu
15.09.2006 um 13:43 Uhr
sorry, hatte ich vergessen zu erwähnen...
die Variante hatte ich schon
Bitte warten ..
Mitglied: hoschen
15.09.2006 um 14:17 Uhr
machst du mal diesen Versuch?

01.
@ECHO OFF
02.

03.
NET USE X: \\srv01\DASI_SRV01
04.
NET USE Y: \\srv02\DASI_SRV02
05.

06.
CD X:
07.
FOR /F "skip=1 tokens=*" %%a IN ('DIR /O /B X:') DO (
08.
  echo %%a
09.
)
Es sollte dann der Inhalt von X: aufgelistet werden!
Bitte warten ..
Mitglied: fugu
15.09.2006 um 14:22 Uhr
auch das hab ich schon versucht...
gleiche Fehlermeldung!

Den Laufwerkswechsel habe ich natürlich nicht mit
01.
CD X:
gemacht, sondern mit
01.
X:
02.

03.
bzw.
04.

05.
CD /D X:
Fugu
Bitte warten ..
Mitglied: geTuemII
15.09.2006 um 18:12 Uhr
Hallo Fugu,

vor die Commands gehört ein @ (@xcopy) und den Laufwerkswechsel mach mal besser mit pushd @pushd x:

[EDIT]
%%a gehört übrigens nicht in Anführungszeichen, aber das war dir sicher schon aufgefallen.
[/EDIT]

HTH geTuemII
Bitte warten ..
Mitglied: fugu
16.09.2006 um 08:39 Uhr
Danke geTuemII,

leider fruchtet das ebenfalls nix... auch dann nicht, wenn ich mich vorher manuell zu LW Y:\ wechsle. Und die Sicherungsdateien sind auch da, wo sie sein sollten.

01.
Y:\>dir /b
02.
srv02---2006-09-15.bkf
03.
srv02---2006-09-14.bkf
04.
srv02---2006-09-13.bkf
05.
srv02---2006-09-12.bkf
06.
srv02---2006-09-11.bkf
07.

08.
----
09.

10.
Y:\>FOR /F "skip=1 tokens=*" %%a IN ('DIR /O /B Y:') DO ( @XCOPY %%a D:\Backup /I /C /E /Q /Y )
11.
"%%a" ist syntaktisch an dieser Stelle nicht verarbeitbar.
Bitte warten ..
Mitglied: hoschen
16.09.2006 um 13:41 Uhr
dieser Befehl funktioniert nur in einer Batch-Datei!

01.
FOR /F "skip=1 tokens=*" %%a IN ('DIR /O /B Y:') DO ( @XCOPY %%a D:\Backup /I /C /E /Q /Y )
an der Kommandozeile (in einem Dos-Fenster) nur einmal % nicht %%

also:

Diesen Code in eine b-up.cmd und dann diesen Befehl "b-up.cmd" aufrufen.

01.
@echo off
02.

03.
FOR /F "skip=1 tokens=*" %%a IN ('DIR /O /B Y:') DO XCOPY %%a D:\Backup /I /C /E /Q /Y
Bitte warten ..
Ähnliche Inhalte
Batch & Shell

Enfernen führender Null(en) mit set a schlägt fehl

gelöst Frage von SchottenrockBatch & Shell4 Kommentare

Hallo liebe Community, nach langem Suchen komme ich nicht drauf und benötige Hilfe bei einem BATCH (ja, es MUSS ...

Batch & Shell

"goto" kann syntaktisch an dieser Stelle nicht verarbeitet werden

gelöst Frage von Y4nn1ckBatch & Shell14 Kommentare

Morgen, ich schreibe gerade an einem Zufallsgenerator für die Klasse, also an einem, der auswählt, wer dran kommt. Ich ...

Batch & Shell

"C.E.O." kann syntaktisch an dieser Stelle nicht verarbeitet werden

gelöst Frage von HeacienBatch & Shell2 Kommentare

Ich bin gerade dabi die Smartphone App 'Don't get fired!' in Batch als abgewandte Version nachzuschreiben. Da die Formatierung ...

Humor (lol)

Javascript Evaluation (a gleich 1 und a gleich 2 und a gleich 3)

gelöst Frage von LochkartenstanzerHumor (lol)6 Kommentare

Viel Spaß beim Knobeln: Can (a 1 && a 2 && a3) ever evaluate to true? lks Du hast ...

Neue Wissensbeiträge
Humor (lol)
Und wie seid Ihr gegen Cyberattacken gewappnet?
Information von DerWoWusste vor 1 TagHumor (lol)5 Kommentare

aber wo ist der Hammer? :-)

Sicherheit
Ein weiterer Microsoft-Stirnklatscher
Information von DerWoWusste vor 1 TagSicherheit7 Kommentare

Habe gerade einen Artikel zu einem Sicherheitsproblem gefunden, welches mir zu seiner Zeit (gepatcht 2015) wohl durchgerutscht ist. Es ...

Windows 10
Upgradepfade Windows 10 LTSC
Erfahrungsbericht von Datenreise vor 2 TagenWindows 10

Nur eine kurze Info, für diejenigen, die es interessiert, da es hierzu im Netz aus nachvollziehbaren Gründen nicht allzu ...

Administrator.de Feedback
Wartungsarbeiten heute Nacht (Update)
Information von Frank vor 2 TagenAdministrator.de Feedback10 Kommentare

Hallo User, durch Umbauarbeiten in unserem Rechenzentrum (am Backbone) kann es heute Nacht (14-15.01.2019) zu kurzen Ausfällen unserer Seite ...

Heiß diskutierte Inhalte
Windows 10
Windows 10 - kein Boot mehr nach Domänenaustritt
gelöst Frage von Ghost108Windows 1025 Kommentare

Hallo zusammen, habe hier eine Windows 10 Maschine, die ich gerne aus der Domäne austreten lassen möchte. Nach Austritt ...

Microsoft
SFirm 4.0 auf Terminalserver startet für jeden angemeldeten Benutzer diverse Dienste
Frage von Frank84Microsoft21 Kommentare

Hallo zusammen, wir verwenden Sfirm 4.0 auf einem Terminalserver (der SQL Server ist auf einem separaten Server), das Problem ...

Internet
Google-Suchergebnisse, Schnelleinblendung, woher kommt der Inhalt?
gelöst Frage von departure69Internet17 Kommentare

Hallo. Ich bin der Systembetreuer einer kleinen Gemeinde in Süddeutschland. Wir betreiben auch eine Leihbücherei. Eine Kundin hat letzten ...

Windows Server
Frage bzgl. Windows Server Lizenzierung Hyper-V
gelöst Frage von g0drealmWindows Server15 Kommentare

Guten Morgen, da wir demnächst wegen unserem neuen ERP-System einen Hyper-V Server bekommen, wollte ich vorab noch eine Sache ...