Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Fehler Installation von Ubuntu 9.10 mit RR2680

Mitglied: kos4live

kos4live (Level 1) - Jetzt verbinden

07.04.2010 um 22:59 Uhr, 7049 Aufrufe, 15 Kommentare

Die Installation bricht entweder beim schreiben der Partitionsdaten oder der Grundsyteminst. ab. Im syslog wird ein mir nicht verständlicher Fehler vom Raid-Controller gemeldet und eine Festplatte als Missing angezeigt.

Hallo,

ich habe mir einen HighPoint RocketRaid 2680 Raid-Controller besorgt und diesen mit einem RaidSonic IcyBox Backplane (5 Festplatten, Samsung 1TB) mit zwei Kabeln zu je 4 Mini-SATA anschlüssen verbunden. (Der zweite Port bzw. Kabel ist an nur 1 Anschluss angeschlossen, die anderen 3 sind frei)

Zuvor habe ich den Treiber für die rr2680 auf einem installieren Ubuntu x64 (gleiches System) als Modul compiliert.
Ich starte die Installation mit der Ubuntu 9.10 Alternate CD (nur Befehlszeile) und mache weiter bis mir der Installer anmeckert das er kein Datenträger findet.
An dieser stelle lade ich das Treiber-Modul wie es im der HighPoint RockerRaid "Ubuntu Linux Installation Guide" beschrieben ist. Danach findet er den Treiber und erkennt den Controller mit dem korrekten Raid. (Raid5, 4 TB, 5 Platten, auf 2 Ports am Controller)
Nun möchte ich das System Partitionieren mittels LVM. Begonnen mit der Geführten Partitionierung mit LVM, lösche ich die vom Installer angelegte root LV und lege diese in einer neuen gewünschten Größe an und gebe als Dateisystem ext4 und Mount-Point: / an.
Dazu lege ich noch eine weitere LV video an und definiere als Dateisystem XFS und als Mount-Punkt: /data/video (manuell).

Wenn ich nun die Partitionierung abschließe und die änderungen auf die Platte geschrieben werden sollen, macht er einen teil und bricht dann mit dem folgenden Fehler im syslog ab. (raid controller beep und zeigt ein missing einer platte bei `cat /proc/scsi/rr2680/6`)
Bei vorhergehenden Versuchen ist der Installer auch schon bis zur Grundsystem installation vorgedrungen, aber hat sich dann ebenfalls an irgendeiner stelle abgeschossen. (selbes problem)

Meine Frage nun, liegt das am Raid-Controller, den Treibern, eventuell dem Backplane oder womöglich an den Festplatten?
Zu der Antwort meiner Frage wäre natürlich eine passende Lösung nicht schlecht.

Vorab VIELEN DANK!

01.
Apr  7 20:14:03 apt-install: Queueing package lvm2 for later installation
02.
Apr  7 20:16:01 partman: mke2fs 1.41.9 (22-Aug-2009)
03.
Apr  7 20:16:05 kernel: [ 1192.680019] EXT4-fs (dm-0): barriers enabled
04.
Apr  7 20:16:05 kernel: [ 1192.704771] kjournald2 starting: pid 28871, dev dm-0:8, commit interval 5 seconds
05.
Apr  7 20:16:05 kernel: [ 1192.704846] EXT4-fs (dm-0): internal journal on dm-0:8
06.
Apr  7 20:16:05 kernel: [ 1192.704851] EXT4-fs (dm-0): delayed allocation enabled
07.
Apr  7 20:16:05 kernel: [ 1192.704857] EXT4-fs: file extents enabled
08.
Apr  7 20:16:05 kernel: [ 1192.705678] EXT4-fs: mballoc enabled
09.
Apr  7 20:16:05 kernel: [ 1192.705689] EXT4-fs (dm-0): mounted filesystem with ordered data mode
10.
Apr  7 20:16:05 kernel: [ 1193.013048] XFS mounting filesystem dm-2
11.
Apr  7 20:16:05 kernel: [ 1193.068035] Ending clean XFS mount for filesystem: dm-2
12.
Apr  7 20:16:15 kernel: [ 1203.089758] rr2680:Request(ffff88006d449ed0) 2a-0-0-bc 2b-80-0-0 || 80-0-0-0 0-0-0-0 to device S2/0 failed as status 2
13.
Apr  7 20:16:25 kernel: [ 1213.105795] rr2680:Request(ffff88006d443528) 28-0-4-57 fb-0-0-0 || 80-0-0-0 0-0-0-0 to device S2/0 failed as status 2
14.
Apr  7 20:16:30 kernel: [ 1218.113814] rr2680:Request(ffff88006d442df0) 2a-0-0-bc 2a-80-0-0 || 80-0-0-0 0-0-0-0 to device S2/0 failed as status 2
15.
Apr  7 20:16:30 kernel: [ 1218.113824] rr2680:Request(ffff88006d448d18) 2a-0-0-bc 2b-80-0-0 || 80-0-0-0 0-0-0-0 to device S2/0 failed as status 2
16.
Apr  7 20:16:36 kernel: [ 1223.661633] rr2680:hpt_reset(6/0/0)
17.
Apr  7 20:17:05 kernel: [ 1253.173746] rr2680:Device 2/0 removed.
18.
Apr  7 20:17:06 kernel: [ 1253.649742] rr2680:Request(ffff88006d443870) b0-0-1-0 0-0-40-40 || 0-0-0-0 0-0-0-0 to device S3/0 failed as status 6
19.
Apr  7 20:17:09 kernel: [ 1256.648535] end_request: I/O error, dev sda, sector 0
20.
Apr  7 20:17:09 kernel: [ 1256.648585] end_request: I/O error, dev sda, sector 0
21.
Apr  7 20:17:09 kernel: [ 1256.648590] ------------[ cut here ]------------
22.
Apr  7 20:17:09 kernel: [ 1256.648602] WARNING: at /build/buildd/linux-2.6.31/fs/buffer.c:1152 mark_buffer_dirty+0x86/0xb0()
23.
Apr  7 20:17:09 kernel: [ 1256.648608] Hardware name: TH55XE
24.
Apr  7 20:17:09 kernel: [ 1256.648611] Modules linked in: xfs exportfs reiserfs jfs ntfs vfat fat rr2680(P) r8169 mii parport_pc parport intel_agp nls_cp437 isofs usb_storage fbcon tileblit font bitblit softcursor vga16fb vgastate vesafb ohci1394 ieee
25.
Apr  7 20:17:09 kernel: [ 1256.648638] Pid: 17, comm: events/2 Tainted: P           2.6.31-14-generic #48-Ubuntu
26.
Apr  7 20:17:09 kernel: [ 1256.648640] Call Trace:
27.
Apr  7 20:17:09 kernel: [ 1256.648646]  [<ffffffff8105e788>] warn_slowpath_common+0x78/0xb0
28.
Apr  7 20:17:09 kernel: [ 1256.648649]  [<ffffffff8105e7cf>] warn_slowpath_null+0xf/0x20
29.
Apr  7 20:17:09 kernel: [ 1256.648651]  [<ffffffff811459e6>] mark_buffer_dirty+0x86/0xb0
30.
Apr  7 20:17:09 kernel: [ 1256.648655]  [<ffffffff81529662>] ? lock_kernel+0x22/0x40
31.
Apr  7 20:17:09 kernel: [ 1256.648659]  [<ffffffff811a78ee>] ext2_sync_fs+0x3e/0xa0
32.
Apr  7 20:17:09 kernel: [ 1256.648662]  [<ffffffff81143565>] __sync_filesystem+0x45/0x70
33.
Apr  7 20:17:09 kernel: [ 1256.648664]  [<ffffffff81143773>] sync_filesystem+0x43/0x60
34.
Apr  7 20:17:09 kernel: [ 1256.648666]  [<ffffffff8114c409>] fsync_bdev+0x29/0x60
35.
Apr  7 20:17:09 kernel: [ 1256.648670]  [<ffffffff812690c9>] invalidate_partition+0x29/0x50
36.
Apr  7 20:17:09 kernel: [ 1256.648673]  [<ffffffff8117e99f>] del_gendisk+0x3f/0x150
37.
Apr  7 20:17:09 kernel: [ 1256.648677]  [<ffffffff8131d0c2>] ? put_device+0x12/0x20
38.
Apr  7 20:17:09 kernel: [ 1256.648681]  [<ffffffff81345c52>] sd_remove+0x52/0xa0
39.
Apr  7 20:17:09 kernel: [ 1256.648683]  [<ffffffff81320a73>] __device_release_driver+0x53/0xb0
40.
Apr  7 20:17:09 kernel: [ 1256.648686]  [<ffffffff81320bc8>] device_release_driver+0x28/0x40
41.
Apr  7 20:17:09 kernel: [ 1256.648688]  [<ffffffff8131fcaa>] bus_remove_device+0x9a/0xc0
42.
Apr  7 20:17:09 kernel: [ 1256.648698]  [<ffffffffa00ae4e0>] ? os_sd_changed+0x0/0x90 [rr2680]
43.
Apr  7 20:17:09 kernel: [ 1256.648700]  [<ffffffff8131e137>] device_del+0x127/0x1a0
44.
Apr  7 20:17:09 kernel: [ 1256.648705]  [<ffffffffa00ae4e0>] ? os_sd_changed+0x0/0x90 [rr2680]
45.
Apr  7 20:17:09 kernel: [ 1256.648711]  [<ffffffffa00ae4e0>] ? os_sd_changed+0x0/0x90 [rr2680]
46.
Apr  7 20:17:09 kernel: [ 1256.648713]  [<ffffffff81341473>] __scsi_remove_device+0x53/0x90
47.
Apr  7 20:17:09 kernel: [ 1256.648715]  [<ffffffff813414db>] scsi_remove_device+0x2b/0x40
48.
Apr  7 20:17:09 kernel: [ 1256.648721]  [<ffffffffa00ae550>] os_sd_changed+0x70/0x90 [rr2680]
49.
Apr  7 20:17:09 kernel: [ 1256.648725]  [<ffffffff810737a5>] run_workqueue+0x95/0x170
50.
Apr  7 20:17:09 kernel: [ 1256.648727]  [<ffffffff81073924>] worker_thread+0xa4/0x120
51.
Apr  7 20:17:09 kernel: [ 1256.648729]  [<ffffffff81078b30>] ? autoremove_wake_function+0x0/0x40
52.
Apr  7 20:17:09 kernel: [ 1256.648732]  [<ffffffff81073880>] ? worker_thread+0x0/0x120
53.
Apr  7 20:17:09 kernel: [ 1256.648733]  [<ffffffff81078746>] kthread+0xa6/0xb0
54.
Apr  7 20:17:09 kernel: [ 1256.648736]  [<ffffffff810130ea>] child_rip+0xa/0x20
55.
Apr  7 20:17:09 kernel: [ 1256.648738]  [<ffffffff810786a0>] ? kthread+0x0/0xb0
56.
Apr  7 20:17:09 kernel: [ 1256.648740]  [<ffffffff810130e0>] ? child_rip+0x0/0x20
57.
Apr  7 20:17:09 kernel: [ 1256.648742] ---[ end trace 25a7de32ca66f6de ]---
58.
Apr  7 20:17:09 kernel: [ 1256.648746] Filesystem "dm-3": Disabling barriers, trial barrier write failed
59.
Apr  7 20:17:09 kernel: [ 1256.648776] I/O error in filesystem ("dm-3") meta-data dev dm-3 block 0x5d1ffff       ("xfs_read_buf") error 5 buf count 512
60.
Apr  7 20:17:09 kernel: [ 1256.670706] XFS: size check 2 failed
61.
Apr  7 20:17:09 kernel: [ 1256.670867] sd 6:0:0:0: [sda] Synchronizing SCSI cache
62.
Apr  7 20:17:09 kernel: [ 1256.670887] sd 6:0:0:0: [sda] Result: hostbyte=DID_OK driverbyte=DRIVER_OK
Das hier wurde wohl beim laden der Treiber ausgegeben:
01.
Apr  7 19:59:39 kernel: [  207.427178] rr2680: module license 'Proprietary' taints kernel.
02.
Apr  7 19:59:39 kernel: [  207.427181] Disabling lock debugging due to kernel taint
03.
Apr  7 19:59:39 kernel: [  207.427990] rr2680:RocketRAID 268x controller driver v1.4 (Mar 28 2010 15:45:10)
04.
Apr  7 19:59:39 kernel: [  207.428008] pci 0000:01:00.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
05.
Apr  7 19:59:39 kernel: [  207.428013] pci 0000:01:00.0: setting latency timer to 64
06.
Apr  7 19:59:39 kernel: [  207.428026] rr2680:adapter at PCI 1:0:0, IRQ 16
07.
Apr  7 19:59:44 kernel: [  211.906782] rr2680:Attached device index 00 (Path 00 | Target 00 | E0/Sff)  00000000
08.
Apr  7 19:59:44 kernel: [  211.936615] rr2680:Attached device index 01 (Path 01 | Target 00 | E0/Sff)  00000000
09.
Apr  7 19:59:44 kernel: [  211.968448] rr2680:Attached device index 02 (Path 02 | Target 00 | E0/Sff)  00000000
10.
Apr  7 19:59:44 kernel: [  212.000287] rr2680:Attached device index 03 (Path 03 | Target 00 | E0/Sff)  00000000
11.
Apr  7 19:59:44 kernel: [  212.030106] rr2680:Attached device index 04 (Path 04 | Target 00 | E0/Sff)  00000000
12.
Apr  7 19:59:44 kernel: [  212.066355] scsi6 : rr2680
13.
Apr  7 19:59:44 kernel: [  212.066567] scsi 6:0:0:0: Direct-Access     HPT      DISK_6_0         4.00 PQ: 0 ANSI: 5
14.
Apr  7 19:59:44 kernel: [  212.067130] sd 6:0:0:0: Attached scsi generic sg1 type 0
15.
Apr  7 19:59:44 kernel: [  212.068234] sd 6:0:0:0: [sda] 7813464064 512-byte logical blocks: (4.00 TB/3.63 TiB)
16.
Apr  7 19:59:44 kernel: [  212.068262] sd 6:0:0:0: [sda] Write Protect is off
17.
Apr  7 19:59:44 kernel: [  212.068264] sd 6:0:0:0: [sda] Mode Sense: 2f 00 00 00
18.
Apr  7 19:59:44 kernel: [  212.068280] sd 6:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
19.
Apr  7 19:59:44 kernel: [  212.068480]  sda: sda1 sda2 sda3
20.
Apr  7 19:59:44 kernel: [  212.090221] sd 6:0:0:0: [sda] Attached SCSI disk
21.
Apr  7 20:00:01 anna-install: Installing dmraid-udeb
22.
Apr  7 20:00:01 anna[6362]: DEBUG: retrieving dmraid-udeb 1.0.0.rc15-11ubuntu3
23.
Apr  7 20:00:06 anna[6362]: DEBUG: retrieving libdmraid1.0.0.rc15-udeb 1.0.0.rc15-11ubuntu3
24.
Apr  7 20:00:06 disk-detect: No Serial ATA RAID disks detected
25.
Apr  7 20:00:07 check-missing-firmware: no missing firmware in /tmp/missing-firmware
Irgendwo im Log taucht aber auch noch diese Zeile auf, ich denke aber das hat nur was mit dem Linux internen (Software-)Raid zu tun?
01.
Apr  7 20:00:07 md-devices: mdadm: No arrays found in config file
Mitglied: chefkochxp
08.04.2010 um 10:56 Uhr
Häng die Platten mal einzeln direkt aufs Board und boote von irgendeiner Live-CD
Mit dem Befehl

badblocks -s -o /var/log/badblocks /dev/hda4

kannst du die Platten dann mal einzeln durchtesten, achte aber bitte darauf, dass ein Lüfter draufpustet.
Wenn die Platten damit in Ordnung sind (Die Datei /var/log/badblocks bleibt leer), dann hast du warscheinlich thermische Probleme (Passiert häufiger bei Platten mit 3 oder mehr Plattern, was im Bereich ab 1 TB eigentlich üblich ist)
Da hilft dann nur eine 2. Backplane und die Platten auf 2 Backplanes aufteilen, oder einen (viel) stärkeren Lüfter einbauen
Bitte warten ..
Mitglied: kos4live
08.04.2010 um 11:03 Uhr
Zitat von chefkochxp:
Häng die Platten mal einzeln direkt aufs Board und boote von irgendeiner Live-CD
Mit dem Befehl

badblocks -s -o /var/log/badblocks /dev/hda4

Danke, das werde ich mal testen.


kannst du die Platten dann mal einzeln durchtesten, achte aber bitte darauf, dass ein Lüfter draufpustet.
Wenn die Platten damit in Ordnung sind (Die Datei /var/log/badblocks bleibt leer), dann hast du warscheinlich thermische Probleme
(Passiert häufiger bei Platten mit 3 oder mehr Plattern, was im Bereich ab 1 TB eigentlich üblich ist)
Da hilft dann nur eine 2. Backplane und die Platten auf 2 Backplanes aufteilen, oder einen (viel) stärkeren Lüfter
einbauen

An der Belüftung sollte es eigentlich nicht liegen. Die Front der Wechselrahmen (alles Aluminium) ist bei laufendem Lüfter ganz Kühl, anders wenn ich den Kühler abstecke (auch schon getestet)
Dann kann ich eigentlich nur hoffen das es wirklich ein Plattendefekt ist und den Garantieanspruch nehmen. Immerhin sind alle Komponenten komplett neu gekauft.
Bitte warten ..
Mitglied: kos4live
09.04.2010 um 08:02 Uhr
Auf den ersten 3 / 5 Platten war mittels dem badblocks read-only nichts zu finden.
Kann es sein das sich defekte Blöcke auch nur dann zeigen können wenn man mit schreibener Aktion darauf zugreifft?

Ich habe heute nach mal wie folgt gestartet:
01.
badblocks -s -n -c 131072 -o /var/log/badblocks_sda /dev/sda
Allerdings dauert das pro Platte ca. errechnete 12-14 Stunden. Daher habe ich 2 parralel zur prüfen gelassen.

Welche Rolle spielt eigentlich "-b" von badblocks, Ist das egal welche block size man angibt oder wirkt sich das in irgendeiner Weise aus?


Vielen Dank, sobald ich alle Platten durch habe melde ich mich erneut dazu!
Bitte warten ..
Mitglied: chefkochxp
09.04.2010 um 08:15 Uhr
Das -b solltest du angeben, wenn du in deinem Filesystem eine größere Blocksize als 1024 eingestellt hast, dann bringt es dir etwas mehr Geschwindigkeit, nur wenn die BS vom FS (ich liebe Abkürzungen xD) kleiner ist, solltest du nicht dran rumspielen.
Bitte warten ..
Mitglied: kos4live
09.04.2010 um 11:22 Uhr
Da es sich ja um HDD aus einem Raid-Verbund handelt, ist dort ja kein direktes FS drauf, zumindest wurde auch vom System keines erkannt. Demnach sollte die BS egal sein?
Bitte warten ..
Mitglied: chefkochxp
09.04.2010 um 11:31 Uhr
Stimmt, sorry, nicht mehr dran gedacht...
In dem Fall ist die BS egal, ich habe mir auch angewöhnt, den Befehl grundsätzlich ohne BS anzuwerfen, ohne Angabe tut er immer
Bitte warten ..
Mitglied: kos4live
09.04.2010 um 22:08 Uhr
Gibt es eigentlich eine wirkliche möglichkeit das prüfen mit Badblocks zu beschleunigen?
Ich kann keinen spürbaren unterschied zwischen badblocks ohne angabe und badblocks -c 131072 feststellen, außer dass das system etwas langsamer auf eingaben anspricht.
Würde es etwas bringen wenn ich das ganze drastisch erhöhe? (momentan braucht er bei der aktuellen angabe 20% ram, (von 2GB)
Verbaut ist ein Intel i3 die nach top nicht wirklich ausgelastet wird.

Der Paralelle durchlauf von zwei Platten hat statt errechneten 12-14h sogar 15h gedauert. Und ich habe noch 2 Platten zu prüfen. Derzeit Prüft noch eine einzelne Platte die aber auch auf ca. 15h kommen wird. Erst danach kann ich den Server neu starten bzw. ausschalten und die Platten wechseln.
Bitte warten ..
Mitglied: kos4live
10.04.2010 um 13:00 Uhr
Edit:
Genau genommen ist mir eben nach ein paar Installations-Versuchen aufgefallen, das der Controller (HightPoint Rocket RAID 2680) erst - ein weilchen nachdem - ich den Treiber initiiert habe, schreit. Also auch wenn ich garnicht mit der Installation fortfahre.
Kann das nun bedeuten das es an fehlerhaften Treiber (z.B. falsch compiliert) liegt, oder doch eher ein Hardware defekt am Controller oder der Festplatten?
Im Grunde stellt sich das ganze für mich so dar, das der Controller an sich ohne Treiber garnicht arbeitet (außer beim Boot das erkennen der Platten). Auch das initiieren bzw. bauen des Raids funktioniert erst nach Treiberinstallation.

Edit2:
Nachdem ich nun nochmal den RAID-Verbund gelöscht und neu angelegt hatte, sowie in einer VBox den Treiber neu compiliert habe, kam die Installation nun soweit wie beim ersten versuch auch, bis irgendwo innerhalb der Installation des Grundsystems. Dann ERROR.
Diesmal aber nicht Channel 4, sondern 3.
Ich blick hier irgendwie nicht durch. Vielleicht doch mal die Karte tauschen lassen?


ALT:

Sooo... UPDATE:

Ich habe die letzten beiden Platten nun erstmal nur mit dem normalen read-only badblocks Test geprüft.
Ergab bei alle Platten keinen fehler bzw. es wurden keine defekten Blöcke gefunden.

Daraufhin habe ich die Installation nochmal gestartet und prompt nach/während der Partitionierung ERROR.
Raid-Controller-Channel 4, ok also hab ich mir gedacht schließ ich mal das Kabel (Channel 5) von der anderen Platte an.
Gebootet, ... Partitionierung ... und ERROR. Diesmal laut Treiber Channel 5 (also selbe Platte).

Nun hab ich mal die betroffene Festplatte komplett abgesteckt. Raid-Controller hat es festgestellt aber soweit nicht gemeckert (is ja normal, wenn die z.B. erst ausgetascht werden soll; zur erinnerung RAID5).
Ok Installation gestartet, Partitionierung ... soweit ok, Grundsystem wird installiert ... ERROR ... während der Grundsysteminstallation. Raid-Controller Treiber meldet "Missing" auf ALLEN Channels (also fehlen ihm auf einmal alle Festplatten!?).

Das Problem liegt definitiv nicht am Backplane, ich habe nämlich zum Testen die Platten direkt am Raid-Controller (selbe Kabel wie zum Backplane) getestet. Thermische Probleme kann ich auch ausschließen, da es ja kurz nach dem Start passiert und die Platten sind Handgefühlt nicht wärmer als 35°C.

Nun stellt sich die Frage, liegt das Problem direkt am Raid-Controller (HightPoint Rocket RAID 2680), sprich Hardware-Defekt, oder kann es ein Treiber-Problem sein (z.B. falsch compiliert, oder womöglich liegt es an den Kabeln. Es sind zwei Kabel angeschlossen die auf je 4 SATA Anschlüsse aufsplitten. Davon sind bei dem ersten Kabel alle angeschlossen, bei dem zweiten nur eines. Der Controller hat nur 2 Ports. (Kabel-Typ: Mini SAS 36pin > 4x SATA 7pin, von DeLock)

Langsam verzweifle ich.
Bitte warten ..
Mitglied: chefkochxp
12.04.2010 um 07:45 Uhr
Hi und sorry, dass ich mich erst jetzt melde...
Für mich hört sich das weiterhin nach einem Plattenproblem, wobei der Treiber trotzdem ein bischen mitspielen könnte.
Ich war einmal an was ähnlichem dran, allerdings mit einem 3Ware-Controller (Modell weiss ich nimmer).
Da hat der Hersteller am Treiber was verbasselt und wenn eine Platte dann einen Lesefehler gemeldet hat, hat sich das komplette System weggehangen (Da half nicht mal mehr Alt + Print + K).

Meines Wissens gibt es keine Möglichkeit, den Badblocks zu beschleunigen, der wird durch die Platten an sich und durch die Interfaces ausgebremst, und die CPU kann nicht mehr Daten prüfen als sie bekommt...
Bitte warten ..
Mitglied: kos4live
12.04.2010 um 08:38 Uhr
Hallo, nicht so schlimm das du dich erst jetzt meldest. Immerhin hilfst du mir ja freiwillig.

Soll das dann deiner Meinung nach ein Fehler an allen Platten sein oder wie soll ich mir das vorstellen? Wie gesagt Badblocks hat nicht auf einer einen Fehler gefunden. Und das fünf Festplatten "schrott" sind, is doch eher Unwahrscheinlich? Wobei ich sagen muss, sie sind alle von der selben Serie, d.h. is auf eine sind alle Platten mit fortlaufender Seriennummer (und zu der einen sind auch nur 2 Nummern unterschied).

Für mich stellt sich jetzt letztendlich die Frage, was mach ich? Reklamier ich den Controller auf Garantie (bereits versucht zu initiieren), versuch ich ihn komplett gegen ein anderes Modell z.B. 3ware zu tauschen oder soll ich alle Platten tauschen? Was die Platten betrifft zweifle ich aber das mein Verkäufer die alle auf Verdacht tauschen möchte.

Was wäre denn für eine alternative zu dem Highpoint RocketRAID 2680 zu empfehlen. Preislich war die eben recht attraktiv für 150 Euro. Soweit ich weiß kosten die vergleichbaren 3ware oder Adaptec ab 300 Euro?
Bitte warten ..
Mitglied: chefkochxp
12.04.2010 um 13:14 Uhr
Dass alle 5 Platten ein Problem haben, ist so gut wie ausgeschlossen, der einzige Fall, den ich dazu kenne, waren die Probleme von Seagate mit dem Standbymodus bei einer bestimmten Firmware-Version.

In deinem Fall solltest du wirklich mal versuchen, den Controller getauscht zu bekommen, vllt. hast du nen netten Verkäufer, der dir dazu auch noch nen anderen als Teststellung mitgibt...

Highpoint habe ich leider keine Erfahrungen damit, deswegen kann ich nix dazu sagen. Was preislich aber auch noch in dem Bereich liegt, ist Promise (FastTrack Serie), die kenne ich zwar nur unter Windows, aber die sind auch sehr zuverlässig und auch recht fix
Bitte warten ..
Mitglied: kos4live
12.04.2010 um 13:40 Uhr
Zitat von chefkochxp:
Highpoint habe ich leider keine Erfahrungen damit, deswegen kann ich nix dazu sagen. Was preislich aber auch noch in dem Bereich
liegt, ist Promise (FastTrack Serie), die kenne ich zwar nur unter Windows, aber die sind auch sehr zuverlässig und auch
recht fix

Soweit ich das mal gehört habe sollen die Promise Controller mit Linux nicht so toll laufen. Zum einen recht umständlich zu installieren sein und zum anderen wohl gelegentlich Probleme.
Aber diese Info is auch schon ein paar Jahre her und werde mich dazu wohl auch mal wieder schlau machen müssen.

Was könnte man denn genrell für Raid-Controller mit 8-10 SATA Anschlussmöglichkeiten, bzw. 2 SAS (für bis zu 4 SATA pro Port, wie ich es bei der RR2680 habe)?
Bitte warten ..
Mitglied: chefkochxp
12.04.2010 um 14:55 Uhr
Wenn ich mal fragen darf, für was willst du den Rechner verwenden ? Wenn es nur ein Fileserver sein soll, kannst ne normale SATA-Karte reinbauen, dann machst einfach auf den Platten jeweils ne Boot-Partition (kannst ja mit dd auf alle Platten kopieren) und ne große Datenpartition, und machst dann mit mdadm ein Softwareraid aus den Datenpartitionen.

Hat dazu noch den Vorteil, dass du im K_Fall von jeder Platte noch booten kannst..

Controllertechnisch würde ich für deine Anforderungen den Adaptec Raid 3805 nehmen, allerdings kenne ich deine genauen Anforderungen an Performance usw. nicht, deswegen würde ich meine Hand dafür nicht ins Feuer legen. Den Controller wählt man normal immer anhand der Anforderungen aus..,.
Bitte warten ..
Mitglied: kos4live
12.04.2010 um 20:02 Uhr
In erster Linie soll der Rechner nur als Fileserver dienen. Aber ich werde ihn wohl in Zukunft auch als Datenbank-/ und Entwicklungssystem (PHP, MySQL etc.; braucht ja nicht viel) verwenden.
Es kann auch gut sein das ich damit auch mal Video-Kodierung oder so machen werde. Je nach dem auf was für ideen ich so komme. Ahso, Xen oder andere Virtualisierung wird dort wohl auch drauf kommen.

Mir geht es eben darum das ich mir was das Raid betrifft keine Kopf um Software-Konfiguration machen muss und die Karte selbst erkennt wenns ein Fehler gibt. So das ich nicht unbedingt selbst per Software kontrollieren muss.
Soweit ich weiß ist mein Mainboard auch nicht direkt HotSwap fähig (auch wenn das ein eher sekundäres aber wünschenswertes Feature ist), zumindest hat das bei meinen Platten-Test nicht geklappt.

Auf alle Fälle vielen Dank für deine Empfehlung!
Bitte warten ..
Mitglied: kos4live
04.05.2010 um 20:08 Uhr
Ich habe nun den Adaptec 3805 Controller eingebaut und ein RAID6 initialisiert sowie Ubuntu installiert. Funktioniert soweit alles ganz gut.
Somit gilt dieses Problem als gelöst. Lag also mehr oder weniger an dem HighPoint Controller.

Nochmals vielen Dank!
Bitte warten ..
Ähnliche Inhalte
Ubuntu
Update auf Ubuntu schlägt fehl
Frage von Philipp711Ubuntu3 Kommentare

Hallo Leute, ich betreibe einen kleinen Nextcloud-Server auf einem Ubuntu 16.04.3 LTS (Linux 4.4.0-104-generic). Der Standardprozedere zum Update des ...

Windows Tools
DotNet Installation schlägt fehl
gelöst Frage von emeriksWindows Tools1 Kommentar

Hi, Windows Server 2008 R2 SP1 Ich will/muss .Net auf min. 4.5 aktualisieren, weil eine Anwendung das erfordert. Egal, ...

Windows Server
RDS Installation schlägt fehl
gelöst Frage von mhard666Windows Server10 Kommentare

Hallo allerseits, ich schlage mich seit geraumer Zeit mit folgendem Problem herum: Ich versuche unter Server 2012R2 eine RDS-Umgebung ...

Ubuntu
Ubuntu: Installation von pnp4nagios
gelöst Frage von honeybeeUbuntu1 Kommentar

Hallo, habe Ubuntu 16.04.3 LTS. Beim Versuch, das Paket pnp4nagios zu installieren, kam der Fehler: Unable to locate package ...

Neue Wissensbeiträge
Windows 7
Updategängelung auf Windows 10, die zweite
Information von Penny.Cilin vor 2 TagenWindows 7

Hallo, da Windows 7 im kommenden Jahr nicht mehr supportet wird, werden Nutzer von Window 7 home premium wieder ...

Internet
EU-Urheberrechtsreform: Zusammenfassung
Information von Frank vor 5 TagenInternet1 Kommentar

Auf golem.de gibt es eine Analyse von Friedhelm Greis, der das Thema EU-Urheberrechtsreform gut und strukturiert zusammenfasst. Zwar haben ...

Microsoft Office

Office365 Schwachstellen bei Sicherheit und Datenschutz

Information von Penny.Cilin vor 6 TagenMicrosoft Office8 Kommentare

Auf Heise+ gibt es einen Artikel bzgl. Office365 Schwachstellen. Das ist noch ein Grund mehr seine Daten nicht in ...

Sicherheit
Schwachstellen in VPN Clients
Tipp von transocean vor 8 TagenSicherheit2 Kommentare

Moin, es gibt Sicherheitslücken bei VPN Clients namhafter Hersteller, wie man hier lesen kann. Gruß Uwe

Heiß diskutierte Inhalte
Windows Installation
Windows10 Home Neuinstallation - Raketentechnik
Frage von spacyfreakWindows Installation13 Kommentare

"Kannst du den Rechner von der Tante von WindowsXP auf Windows10 Home upgraden" haben sie gefragt? "Sicher, was kann ...

Utilities
Teamviewer 9.x "out of date" ??
gelöst Frage von keine-ahnungUtilities13 Kommentare

Moin at all, mein topaktueller teamviewer (alles 9.x - releases) verweigert seit heute die Arbeit und bemeckert: "the remote ...

Windows 10
Windows 10 verwendet FritzBox per IPv6 als DNS-Server an Stelle des per DHCP vergebenen DNS-Servers
Frage von Datax87Windows 1010 Kommentare

Hallo, ich habe ein kleines Problem mit der Namensauflösung (DNS) unter Windows 10. Mir ist heute aufgefallen, dass ich ...

Voice over IP
Anbindung Telekom Cloud PBX mit Sophos SG330
gelöst Frage von macomarVoice over IP7 Kommentare

Hallo an alle, wir beabsichtigen mit unserer alten Siemens Telefonanlage auf Telekom Cloud PBX umzusteigen. Da wir eine Verwaltung ...