Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Fehlermeldung bei Ausführung einer Batchdatei

Mitglied: imebro

imebro (Level 2) - Jetzt verbinden

07.02.2008, aktualisiert 29.05.2008, 3740 Aufrufe, 7 Kommentare

Hallo an Alle,

bei folgender Batchdatei erhalte ich eine Fehlermeldung, obwohl eine ähnliche Batch mit fast gleichem Befehl (nur eben andere Verzeichnisangaben) einwandfrei funktioniert.

Hier die Batchdatei:
01.
@ECHO OFF
02.
 
03.
ECHO Sicherung FOTOARCHIV 1>>D:\Daten\LOG\Sicherung_Fotoarchiv-LOG.txt 2>>&1
04.
 
05.
ECHO SICHERUNG GESTARTET!
06.
ECHO.
07.
 
08.
xcopy "S:\ARCHIV\™A\Materialien für ™A\Fotoarchiv"\*.* G:\Fotoarchiv_Backup /S /D /E /Y /I /R 1>>D:\Daten\LOG\Sicherung_Fotoarchiv-LOG.txt 2>>&1
09.
 
10.
ECHO.
11.
ECHO Kopiervorgang beendet! 1>>D:\Daten\LOG\Sicherung_Fotoarchiv-LOG.txt 2>>&1
12.
ECHO SICHERUNG FOTOARCHIV BEENDET! - Bitte Log-Datei einsehen (Sicherung_Fotoarchiv-LOG.txt)
13.
start D:\Daten\LOG\Sicherung_Fotoarchiv-LOG.txt
Anschließend erscheint folgende Fehlermeldung in der Log-Datei:
01.
Sicherung FOTOARCHIV 
02.
Datei *.* nicht gefunden.
03.
0 Datei(en) kopiert
04.
Kopiervorgang beendet! 
Bereits versucht habe ich folgendes:
  1. Ich habe die Zeichen "*.*" auch schon vom letzten Backslash durch ein Leerzeichen getrennt... auch ohne Erfolg.
  2. Auch mit "robocopy" funktioniert es nicht.
  3. Auch habe ich schon das Verzeichnis "Materielien für ÖA" einfach in "Materialien" geändert, um zu vermeiden, dass Leerzeichen dazwischen sind... auch ohne Erfolg. Deshalb steht jetzt der komplette Pfad in Anführungsstrichen.

Übrigens steht hinter "S:\ARCHIV\" ein ASCII-Zeichen, da dort normalerweise ein "Ö" steht (und in der gleichen Zeile nochmal).

Wie oben bereits geschrieben, funktioniert es mit folgender Zeile in einer anderen Batchdatei einwandfrei:
01.
xcopy D:\Daten\DAS\*.* G:\Backup_Laufwerk_S /S /D /E /Y /I /R 1>>D:\Daten\LOG\Sicherung_S-LOG.txt 2>>&1
Hat jemand eine Idee, wieso die Batch so nicht funktioniert?

Danke & Gruss
Ingo
Mitglied: stbewo
07.02.2008 um 09:10 Uhr
Hallo Ingo,

mach mal dein " hinter *.*

Beispiel:
Fotoarchiv\*.*"

Gruß
Stefan
Bitte warten ..
Mitglied: 60730
07.02.2008 um 11:29 Uhr
Hi Ingo,

das liegt an den Sonderzeichen im Pfad...

Probier mal folgendes:

cd "S:\ARCHIV\?A\Materialien für ?A\Fotoarchiv"
s:
copy *.* G:\Fotoarchiv_Backup /S /D /E /Y /I /R 1>>D:\Daten\LOG\Sicherung_Fotoarchiv-LOG.txt 2>>&1

Ist nicht hübsch, aber bestimmt selten - Umlaute machen Umstände *gg*
Bitte warten ..
Mitglied: imebro
07.02.2008 um 13:51 Uhr
Hallo,

habe beide Möglichkeiten und etliche Varianten davon ausprobiert (also mit und ohne "" oder mit Ö, mit ? mit ASCII-Zeichen) - leider hat nichts funktioniert.

Jetzt erhalte ich folgende Fehlermeldung:

Sicherung FOTOARCHIV
Syntaxfehler.
Kopiervorgang beendet!

Hat noch jemand Ideen?

Gruss
Ingo
Bitte warten ..
Mitglied: 60730
07.02.2008 um 13:53 Uhr
Hallo,

habe beide Möglichkeiten und etliche
Varianten davon ausprobiert (also mit und
ohne "" oder mit Ö, mit ? mit
ASCII-Zeichen) - leider hat nichts
funktioniert.

Jetzt erhalte ich folgende Fehlermeldung:

> Sicherung FOTOARCHIV
> Syntaxfehler.
> Kopiervorgang beendet!

Hat noch jemand Ideen?

Gruss
Ingo

Upps...

da hab ich beim copy & paste ein x verschlampert...

Xcopy
Bitte warten ..
Mitglied: imebro
07.02.2008 um 16:21 Uhr
Jetzt erscheint:

Die Syntax für den Dateinamen, Verzeichnisnamen oder die Datenträgerbezeichnung ist falsch.

Hmmm....???
Bitte warten ..
Mitglied: 60730
07.02.2008 um 16:55 Uhr
Bei dir steht /R 1 drin????
Ob /S und /E beide drin sein müssen, sei dahingestellt.

Was deine "2>>&1" sollen, verstehe ich nicht, ohne die gehts (wie soll die Batch aufgerufen werden)

Gruß

Probier doch bitte mal das ganze da unten...


@ECHO OFF
@ECHO Sicherung FOTOARCHIV 1>>D:\Daten\LOG\Sicherung_Fotoarchiv-LOG.txt
@ECHO SICHERUNG GESTARTET!
ECHO.
cd "S:\ARCHIV\?A\Materialien für ?A\Fotoarchiv"
s:
xcopy *.* G:\Fotoarchiv_Backup /S /D /E /Y /I /R >>D:\Daten\LOG\Sicherung_Fotoarchiv-LOG.txt
ECHO.
@ECHO Kopiervorgang beendet! >>D:\Daten\LOG\Sicherung_Fotoarchiv-LOG.txt
@ECHO SICHERUNG FOTOARCHIV BEENDET! - Bitte Log-Datei einsehen (Sicherung_Fotoarchiv-LOG.txt)
start D:\Daten\LOG\Sicherung_Fotoarchiv-LOG.txt
Bitte warten ..
Mitglied: 56223
29.05.2008 um 08:08 Uhr
Hallo zusammen,

ich will nicht extra was neues Verfassen deshalb schreib ich mal mein Problem hier rein.

Ich hab folgendes vor:

Ich will ein Ordner unter C:\Dokumente~und~Einstellungen\All Users\Startmenue\Programme

ein Program Löschen.
Befehl:

rmdir /s /q C:\Dokumente~und~Einstellungen\All Users\Startmenue\Programme\gotomaxx

Fehlermeldung:

C:\Dokumente und Einstellungen\meinusername\Desktop>echo
ECHO ist eingeschaltet (ON).

C:\Dokumente und Einstellungen\meinusername\Desktop>rmdir /s /q C:\Dokumente~und~
instellungen\All Users\Startmenue\Programme\gotomaxx
Das System kann den angegebenen Pfad nicht finden.
Das System kann den angegebenen Pfad nicht finden.

C:\Dokumente und Einstellungen\meinusername\Desktop>PAUSE
Drücken Sie eine beliebige Taste . . .
Bitte warten ..
Ähnliche Inhalte
Batch & Shell

Batchdatei Fehlermeldung unterdrücken

gelöst Frage von Koala86Batch & Shell5 Kommentare

Hallo, ich habe ein Problem mit einer Batchdatei. Ich habe ein Script geschrieben, welches automatisch einen Screenshots im Ordner ...

Batch & Shell

Batchdatei: Variablen-Wertezuweisung

gelöst Frage von donnyS73lbBatch & Shell2 Kommentare

Hallole, eine Anfängerfrage: Was mache ich hier falsch? echo %variable1% liefert das richtige Ergebnis, denn variable1 hat einen gültigen ...

Windows 10

Aufgabenplanung und Batchdatei

gelöst Frage von supertuxWindows 105 Kommentare

Hallo zusammen, ich habe mir eine Batch erstellt, diese setzt bestimmt User-Einstellung am PC zurück. Diese Batch habe ich ...

Batch & Shell

Problem mit Batchdatei

Frage von achkleinBatch & Shell3 Kommentare

Hallo, ich habe für eine Bekannte eine kleine Batchdatei geschrieben, die automatisch alte Nachsendeaufträge im Download-Ordner löschen soll. Allerdings ...

Neue Wissensbeiträge
Windows Mobile

Support für Windows Mobile endet im Dezember 2019

Information von transocean vor 5 StundenWindows Mobile

Moin, MS empfiehlt als Alternative den Umstieg auf IOS oder Android, wie man hier lesen kann. Gruß Uwe

Internet

Kommentar: Bundesregierung erwägt Ausschluss von Huawei im 5G-Netz - Unsere Presse wird immer sensationsgieriger

Information von Frank vor 2 TagenInternet5 Kommentare

Hier mal wieder ein schönes Beispiel für fehlgeleiteten Journalismus und Politik zugleich. Da werden aus Gerüchten plötzlich Fakten, da ...

Windows 10

Netzwerk-Bug in allen Windows 10-Versionen durch Januar 2019-Updates

Information von kgborn vor 2 TagenWindows 101 Kommentar

Nur ein kurzer Hinweis für Admins, die Windows 10-Clients im Portfolio haben. Mit den Updates vom 8. Januar 2019 ...

Windows 10

Windows 10 V1809: Rollout ist gestartet - kommt per Windows Update

Information von kgborn vor 3 TagenWindows 102 Kommentare

Eine kurze Information für die Admins, die Windows 10 im Programm haben. Microsoft hat die letzte Baustelle (die Inkompatibilität ...

Heiß diskutierte Inhalte
TK-Netze & Geräte
TAPI auf einem Win2016Server installieren und einrichten
Frage von wstabelTK-Netze & Geräte32 Kommentare

Hallo liebe Admins, ich habe folgende Situation: 1 Windows Server 2016 Standard als DC 1 SNOM 710 IP-Telefon 1 ...

Off Topic
Darf ich ein Forum erstellen das Produkte eines Herstellers betrifft?
Frage von cyberwallOff Topic8 Kommentare

Hallo Community, ich habe da eine "rechtliche" bzw. allgemeine Frage zum erstellen von Foren. Darf ich als "normale Person" ...

Switche und Hubs
HP PS1810-8G Switch stürzt bei iperf3 ab
Frage von BierkistenschlepperSwitche und Hubs6 Kommentare

Hallo, ich habe folgendes Setup: VDSL -> FritzBox (DHCP) -> HP PS1810-8G Switch => Bonding mit 2 Leitungen => ...

Java
Kann die public class und public static void main String in Java nicht ausführen?
gelöst Frage von DomiITJava5 Kommentare

Kann die public class und public static void main String in Java nicht ausführen? Hi Leute, ich bin programmier ...