Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Freeradius mit mariadb verweigert Authentifizierung

Mitglied: 0sindbad0

0sindbad0 (Level 1) - Jetzt verbinden

22.07.2019 um 16:15 Uhr, 310 Aufrufe, 7 Kommentare

Moin,

ich habe unter einem Hyper-V eine Debian 9 Installation mit freeradius, daloradius und mariadb. Soweit läuft das Ganze wie gewünscht. Dann steht im NAS plötzlich
"Die wiederholten Authentifizierungsversuche von User[MAC] beim Beitreten...schlugen fehl" und eine Anmeldung ist nicht mehr möglich. Im Radiuslog versucht im 30 Sekundenrythmus ein anderer Client sich zu verbinden, was laut Log auch klappt. Diese Client hatte sich auch schon morgens angemeldet, ohne Probleme. Auch andere Clients haben solche Authentifizierungsversuche alle 30 Sekunden fabriziert, aber eben auch nicht immer.


Mon Jul 22 09:52:37 2019 : Auth: (5130) Login OK: [Bernd/<via Auth-Type = eap>] (from client NAS port 0 via TLS tunnel)
Mon Jul 22 09:52:37 2019 : Auth: (5131) Login OK: [Bernd/<via Auth-Type = eap>] (from client NAS port 45 cli aa-bb-cc-dd-ee-ff)
...

...
Mon Jul 22 11:02:53 2019 : Auth: (6345) Login OK: [Bernd/<via Auth-Type = eap>] (from client NAS port 0 via TLS tunnel)
Mon Jul 22 11:02:53 2019 : Auth: (6346) Login OK: [Bernd/<via Auth-Type = eap>] (from client NAS port 96 cli aa-bb-cc-dd-ee-ff)


Zwischendrin reihen sich noch andere Nutzer in diesen 30 sekündigen Takt ein, nutzen dann scheinbar aber die alte WPA2 SSID.

Ich finde nichts aussagekräftiges im radius.log oder NAS. Ich hatte die Speicherverwaltung des Hyper-V in Verdacht, da hier dynamischer Speicher steht und dieser immer mehr fordert, als ich ihm zuweise. Im Debian TOP dann allerdings die kleinste Menge von 1G steht.

Ich vermute durch diese ständige Anmelderei wird der Radius oder etwas anderes belegt und es kommt zu einem Fehlschlag, nicht zu einem reject. Dieser steht aber nicht im radiuslog, nur im NAS. Das NAS gibt aber auch nicht an, dass es den RADIUS nicht erreicht.

Kann mir jemand einen Tip geben, was oder wo ich noch schauen soll?

Als Plan B werde ich den Radius aus der pfsense nutzen und nur die user.conf ohne sql nutzen. Mehr brauchen wir aktuell nicht, wollte mit dem sql nur aussagekräftiger sein bezüglich Bandbreitennutzung.

Danke!
Mitglied: lcer00
22.07.2019 um 17:05 Uhr
Hallo,

die Sache mit dem Dynamischen RAM bei Debian in hyperv funktioniert bei mir auch nicht immer. Für meine Elastic Stack VMs habe ich deshalb den Speicher fest zugewiesen.

Das Paket hyperv-daemons hast Du installiert? Außerdem ist ein ntp-Client hilfreich, der zur Not die Zeit nachkorrigiert. Jedenfalls würde ich die Systemzeit checken.

Grüße

lcer
Bitte warten ..
Mitglied: aqui
23.07.2019 um 10:22 Uhr
Am besten den FreeRadius mal mit -X im Debug mMode starten um präzisere Ursachenforschung zu betreiben.
https://administrator.de/wissen/netzwerk-zugangskontrolle-802-1x-freerad ...
Bitte warten ..
Mitglied: 0sindbad0
23.07.2019 um 10:44 Uhr
Danke für deine Hilfe. ntp läuft, Zeit scheint zu stimmen. Zeitsync zwischen Hyper-v und VM habe ich abgeschalten, weil das das Log gefüllt hat. Nach dem Fehler habe ich heute die hyperv-deamons installiert und den Arbeitsspeicher fest auf 2G festgelegt sowie die MAC auf statisch gestellt.
Bitte warten ..
Mitglied: 0sindbad0
23.07.2019 um 11:03 Uhr
Hallo aqui,
da habe ich auch nichts gefunden, wobei ich mit der Sichtung der Ausgabe etwas zu kämpfen hatte.

Ich habe aber bemerkt, dass ich

!! WICHTIG: Die folgenden Anpassungen in der Datei /etc/raddb/eap.conf sind zwingend für die dynamische VLAN Zuweisung: Im Abschnitt TTLS ist der Parameter use_tunneled_reply = yes auf yes zu setzen. Ebenso im Abschnitt PEAP auch diesen Parameter auf yes !!

aus deiner Anleitung nicht umgesetzt habe. Ich könnte mir vorstellen, dass das eine Art Schleife erzeugen könnte. Wobei es ja eine Weile auch ohne diese Parameter ging.

Ich werde den Debugmodus noch einmal anwerfen und versuchen, einen Vorgang zu erwischen.

Danke
Bitte warten ..
Mitglied: 0sindbad0
23.07.2019 um 16:02 Uhr
Ich habe die Ausgabe mal als Textdatei gespeichert und hier abgelegt.

freeradius debugausgabe

Der Text ging hier nicht ins Forum rein. User Niels versucht sich, es gibt keine Fehlermeldung im NAS.
Ich erkenne da gar nichts. Es sieht etwas wurschtelig aus in Bezug auf EAP. Evtl habe ich da Fehlkonfigurationen.
Bitte warten ..
Mitglied: lcer00
23.07.2019 um 18:51 Uhr
Also ich sehe in der Ausgabe keinen Fehler, keine Ablehnung der Verbindung etc. Dafür 252x success

Das würde bedeuten, dass der Radius alles richtig macht und den Benutzer korrekt authentifiziert. Unter diesen Umständen würde ich mich anderweitig nach Fehlern umsehen.

Welches NAS? Was ist dort eingestellt.

Grüße

lcer
Bitte warten ..
Mitglied: 0sindbad0
23.07.2019 um 21:12 Uhr
Ja, alle 30 Sekunden der gleiche User. Und das halte ich für nicht normal. Ein nicht erfolgter Versuch war leider nicht dabei
NAS ist ein Zonedirector 1200
nas - Klicke auf das Bild, um es zu vergrößern
Bitte warten ..
Ähnliche Inhalte
Datenbanken
MySQL-MariaDB oder Postgres?
gelöst Frage von TheCritterDatenbanken11 Kommentare

Hallo, in unserer Firma sind die meisten Entwickler der Meinung Postgres wäre im produktiven Umfeld die bessere Wahl als ...

Datenbanken
MariaDB hohe CPU load
Frage von mixmastertobsiDatenbanken6 Kommentare

Hallo, ich habe ein großes Problem mit unserem MariaDB Server. Wir haben den Server auf Verison 10.3. geupdatet und ...

Linux Netzwerk
FreeRadius Lokal
Frage von D1-aB-loLinux Netzwerk7 Kommentare

Ich habe hier schon ein Thema erstellt das sich mit dem FreeRadius beschäftigt in Verbindung mit LDAP. Nun erstelle ...

Firewall
PFSense 2.3.2 Freeradius
Frage von horstvogelFirewall7 Kommentare

Hallo, ich suche nach einer Anleitung wie ich über die Weboberfläche der PFSense einer Radius Server aufsetzen kann. PFSense ...

Neue Wissensbeiträge
Sicherheits-Tools

TrendMicro Worry-Free Business Security 10.0 SP1 - Jetzt in Deutsch verfügbar! (Windows 10 1903 Support)

Tipp von TrinXx vor 1 TagSicherheits-Tools1 Kommentar

Moin! Nach wochenlangem Warten wird Trend Micro das SP1 für WFBS 10 voraussichtlich am 26.08.19 veröffentlichen. Ich habe das ...

Hyper-V
Setup VM W2016 startet nicht in Hyper-V 2016
Erfahrungsbericht von keine-ahnung vor 2 TagenHyper-V4 Kommentare

Moin, sitze gerade über meinem neuen Server und versuche, die VM auf den Host zu prügeln. Jetzt wollte ich ...

Server-Hardware

HPE Proliant ML350P Gen8 Probleme mit Zugriff auf Raid-Volumes

Erfahrungsbericht von goscho vor 2 TagenServer-Hardware1 Kommentar

Hallo Leute, das Problemgerät: HPE ML350P G8 Windows Server 2012R2 HyperV-Host 8 x 300 GB 10K SAS HDD (1 ...

Humor (lol)

"Linux und 5 Gründe Warum man kein Windows verwenden sollte sondern Ubuntu Linux"

Information von Snowbird vor 4 TagenHumor (lol)9 Kommentare

Gerade gefunden. Ja, ist etwas älter, aber irgendwie lustig?

Heiß diskutierte Inhalte
Backup
Veeam Backup Endpoint Free sichert nicht alle Dateien in AppData
gelöst Frage von speedy26gonzalesBackup12 Kommentare

Hallo, ich sollte ein paar Dateien in C:\Users\xyc\AppData\Local\Microsoft\Outlook wieder herstellen. Auf dem Benutzerkonto ist in Outlook ein IMAP Konto ...

Server
Ein Server ins Haus stellen. Was brauche ich dafür?
Frage von JoschiTomServer10 Kommentare

Hallo Community, ich spiele mit dem Gedanken eine Server mir zu holen. Was brauche ich dafür? Und wie sind ...

Windows 10
Windows 10 Backup auf Netzwerk Storage
Frage von Futschel2608Windows 1010 Kommentare

Hallo geehrte Mitstreiter Innen, Wir wollen in unserer Windows 10 Domäne den Einzelnen Usern ermöglichen ihre Desktop PC's zusichern. ...

Batch & Shell
Mittels SED Text ersetzen in Anführungszeichen
gelöst Frage von nekronBatch & Shell9 Kommentare

Moin … bin nicht wirklich der SED/regex Mensch, vielleicht kann mir jemand auf die Schnelle Helfen :) ich habe ...