Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Funktionen werden nicht ausgeführt, aber warum?

Mitglied: moK

moK (Level 1) - Jetzt verbinden

01.04.2010, aktualisiert 11.04.2010, 3784 Aufrufe, 4 Kommentare

Hi Leute,
ich habe mal eine Frage... ich finde einfach keine lösung

und zwar habe ich eine php datei (img.php) die mir ein bild erzeugt, diese datei lade ich mit:

01.
<img alt="" src="img.php" />
ich habe auch eine funktions datei wo meine funktionen drin stehen die lade ich mit include auf der start seite, dort sind auch funktionen für das generieren von dem bild drinne...

also includiere ich die datei auch in meine 'img.php'... für mich klingt das eigentlch logisch, jedoch sind die funktionen nicht aufrufbar..

habt ihr ein schimmer warum das so ist? ich hoffe ich habe das verständlich erklärt wenn nicht poste ich ein direktes bsp.

Gruß moK
Mitglied: matze2010
01.04.2010 um 22:01 Uhr
Hallo und guten Abend,

woher weißt du, dass die Funktionen nicht aufrufbar sind?

Bekommst du eine Fehlermeldung oder einfach kein Bild?

Hast du den Mime-Type des Bildes im header() vor der Ausgabe von Daten gesetzt?

Zum testen kannst du evtl. mal in eine Datei loggen, da ja vermutlich keine Ausgabe abgefangen wird.

Was gibt img.php aus, wenn du es direkt aufrufst?

Ein paar Informationen mehr sind glaube ich schon nötig.

Lg
Matze
Bitte warten ..
Mitglied: moK
01.04.2010 um 22:32 Uhr
also, das ist mir jetzt aber irgendwie peinlich...

ich habe jetzt versucht ein beispiel aufzubauen und es geht auf anhieb!

dann habe ich es an meinem großen Projekt nochmals getestet (weil ich es vor einigen wochen aufgegeben habe, da ich den fehler nicht gefunden habe)

und nun geht alles wie ich es wollte...

dein Stichwort header brachte mich auf mein fehler... ich habe anscheinen nachträglich in den header geschrieben gehabt....

danke für deine hilfe!
Bitte warten ..
Mitglied: Arano
01.04.2010 um 22:41 Uhr
Hallöchen zusammen.

Du hast da einen kleinen aber (wie immer) bedeutsamen Fehler in deinem Gedankengang.

In der Kurzform: "functions.inc.php" ist nicht in "img.php", somit stehen die Funktionen auch nicht zur Verfügung.

Und das ist so weil:
Durch das Einbinden weiterer Ressourcen (Bilder, CSS, Javasctip, ect.) _per HTML_ wird jede dieser Ressourcen über eine neue Anfrage vom Server abgerufen.
z.B.: Das Öffnen der Seite domain/index.html bewirkt das der Browser noch die weiteren Dateien anfordert: "domain/styles.css", "domain/javascript.js", "domain/favicon.ico", "domain/images/teamfoto.jpg". Alles sind Ressourcen die innerhalb des HTMLs eingebunden wurden.
So auch bei dir: "domain/img.php"
Aber die PHP-Datei wird erst auf dem Server ausgeführt ! Und weil diese kein include auf die "functions.inc.php" enthält - existieren deine Funktionen _für diese Anfrage_ nicht !
Das ist quasi so als würdest du "domain/img.php" direkt in die Adresszeile deines Browsers tippen, dann ist natürlich nicht vorhanden - wie du an nahmst.


~Arano

*Edit:*
also includiere ich die datei auch in meine 'img.php'...
Jetzt so im nach hinein:
Meintest du damit das du die Datei wirklich per include in die Datei img.php eingebunden hast !?

Habe das eben so gelesen als gingst du davon aus, das das Einbinden von "funktions.inc.php" in die Startseite ausreichen würde... ups, habe mich da wohl getäuscht...
Bitte warten ..
Mitglied: moK
01.04.2010 um 22:53 Uhr
die erklärung war gut, jedoch war das nicht mein problem... ich hatte die datei ja included in meiner img.php...

der ablauf den du geschildert hast war mir bekannt... das problem war wirklich die geschichte mit dem header...

in einer meinen funktionen wurde in den header geschrieben.. dann wurde in meiner bild datei eine daten ausgabe gemacht und dann wieder in den header der MIME Type für das Bild geschrieben... aber wie wir ja wissen meckert da PHP immer...

ps: ich hatte auch erwähnt das ich in der img.php die functions.inc.php includiere... aber der text ist gut für leute die das problem mal haben (und die suchfunktion nutzen) werden, denn es ist gut erklärt...
Bitte warten ..
Ähnliche Inhalte
Windows 7
Tablett Funktion aktivieren
Frage von Adnan88Windows 71 Kommentar

Hallo, habe ein Win 7 - Pro 32 bit Edition, nun wollte ich einen TouchScreen Monitor nutzen allerdings ist ...

Microsoft Office
Excel Wenn-Funktion
gelöst Frage von freshman2017Microsoft Office2 Kommentare

Moin Moin und guten Abend, ich bräuchte da nochmal Eure Hilfe. Ich habe eine Exelliste mit verschiedenen Werten: Hier ...

PHP
PHP Mail Funktion
Frage von gamerffPHP5 Kommentare

Hallo Forum, ich versuche grade mit der PHP mail() Funktion ein Kontaktformular zu erstellen. Leider kommt beim absenden immer ...

Batch & Shell

Powershell Funktion X innerhalb von Funktion X aufrufen

gelöst Frage von MarabuntaBatch & Shell1 Kommentar

Hi, Ich konnte es jetzt nicht nachstellen. So funktioniert alles gut. Wenn ich aber einige Male falsche Werte eintrage ...

Neue Wissensbeiträge
Router & Routing
Der "768k-Day" kommt
Information von LordGurke vor 1 StundeRouter & Routing1 Kommentar

Für Leute, die Router mit BGP-Fulltable betreiben vielleicht ein interessanter Hinweis: Die IPv4-Fulltable erreicht voraussichtlich innerhalb der nächsten 2-3 ...

Debian

Partition angeblich voll, dabei aber noch nicht mal zur Hälfte belegt

Anleitung von diemilz vor 4 StundenDebian7 Kommentare

Hallo zusammen, ich habe ein kleines Problem: Ich habe auf einem physischen Debian Linux Server als ZoneMinder-Server (HP ProLiant ...

Windows 7
Updategängelung auf Windows 10, die zweite
Information von Penny.Cilin vor 4 TagenWindows 72 Kommentare

Hallo, da Windows 7 im kommenden Jahr nicht mehr supportet wird, werden Nutzer von Window 7 home premium wieder ...

Internet
EU-Urheberrechtsreform: Zusammenfassung
Information von Frank vor 7 TagenInternet1 Kommentar

Auf golem.de gibt es eine Analyse von Friedhelm Greis, der das Thema EU-Urheberrechtsreform gut und strukturiert zusammenfasst. Zwar haben ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
Notebooks in Firmenwlan authentifizieren
gelöst Frage von EarthShakerLAN, WAN, Wireless17 Kommentare

Guten Tag, unsere Firma möchte gerne flächendeckend WLAN einführen und hat zu diesem Zweck einen Dienstleister beauftragt. Wir benötigen ...

Backup
Veeam Community Edition
Frage von dgrebnerBackup15 Kommentare

Hallo Zusammen, kann jemand seine praktischen Erfahrungswerte mit der Veeam-Community Edition mit mir teilen? Es gab dazu ja schon ...

Peripheriegeräte
PS2 Y-Kabel für Maus+Tastatur an PS2 Combo-Anschluss ASUS Prime X370-A
gelöst Frage von Windows10GegnerPeripheriegeräte13 Kommentare

Hallo, ich bin am Überlegen das o.g. Motherboard anzuschaffen. Da ich aber noch PS/2 für Maus+Tastatur benötige (bei optischen ...

Netzwerkmanagement
Netzwerk vorübergehend weg
Frage von ahstaxNetzwerkmanagement11 Kommentare

Hallo, folgendes Szenario stellt sich dar: Im Netzwerk mit Win7-PCs wurden Switche ausgetauscht. Grundsätzlich funktioniert alles mindestens so gut ...