Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Gemapptes Laufwerk wird erst nach Aufruf über den Explorer von Anwendung gefunden

Mitglied: Hubtus

Hubtus (Level 1) - Jetzt verbinden

18.09.2007, aktualisiert 15:27 Uhr, 8289 Aufrufe, 5 Kommentare

Eine Anwendung unter Win XP Pro möchte auf ein gemapptes Laufwerk zugreifen. Dieses Laufwerk (N: ) wird aber von der Anwendung nicht gefunden, obwohl es ordnungsgemäß gemappt wurde und auch beim erneuten Anmelden wieder verbunden wird. Erst wenn der Laufwerksinhalt einmal im Explorer angezeigt wurde findet die Anwendung auch das Laufwerk.

Auf ein anderes Netzlaufwerk (Z: ) kann ordnungsgemäß und ohne Probleme zugegriffen werden.

Wo liegt das Problem? Wer kennt eine Lösung?


Danke im Voraus.

Hubertus
Mitglied: TuXHunt3R
18.09.2007 um 13:48 Uhr
Wie werden die Laufwerke bei euch gemappt? Von Hand, per Loginbatch, per Login-VBScript?

Wenn du mit einem Loginscript arbeitest (Batch oder VBScript), poste doch mal den Code dieses Files
Bitte warten ..
Mitglied: Hubtus
18.09.2007 um 14:06 Uhr
Die Laufwerke sind ganz normal im Explorer per "Netzlaufwerk verbinden..." gemappt.
Bitte warten ..
Mitglied: TuXHunt3R
18.09.2007 um 15:27 Uhr
Arbeitest du in einer Domäne?

Wenn NEIN, pack den folgenden Code in ein Batchfile (Textdatei mit Endung "bat"), ersetze <servername> und <freigabe> durch deine Angaben und pack das Ding in den Autostart.

01.
net use N: /delete
02.
net use N: \\<servername>\<freigabe>
Ein Beispiel:

01.
net use N: /delete
02.
net use N: \\srv01\verwaltung$

Probier das Mal und gib uns Bescheid, ob es etwas gebracht hat.
Bitte warten ..
Mitglied: MaryLong
11.05.2010 um 11:26 Uhr
Guten Morgen

ich weiss, der Beitrag ist schon uralt, trotzdem nochmals eine Anfrage in die selbe Richtung. Habe momentan das genannte Problem. Für eine Applikation werden auf drei Win2k3-Server nmittels KIX-Script 4 Laufwerke auf WinXP SP3 Clients gemappt. In 99% der Fälle funktioniert dies auch einwandfrei, aber ab und an liegt genau das genannte Problem auf einem Client an.

"Das Laufwerk wird von der Anwendung nicht gefunden, obwohl es ordnungsgemäß gemappt wurde und auch beim erneuten Anmelden wieder verbunden wird. Erst wenn der Laufwerksinhalt einmal im Explorer angezeigt wurde findet die Anwendung auch das Laufwerk."

Es betrifft nicht immer den selben Client, aber immer dasselbe Laufwerk -> X:. Das Mapping erfolgt beim Logon mittels KIX-Script über die DC's. Der Codeauszug:

USE J: /DEL
USE S: /DEL
USE V: /DEL
USE X: /DEL
USE J: "\\servera\Applikationsordner"
USE S: "\\serverb\Gruppenshare"
USE V: "\\serverb\Applikationsvorlagen"
USE X: "\\serverc\Applikationsshare"

Tests Batchdatei (NET USE X: /DELETE und NET USE X: "\\serverc\Applikationsshare") führen zum selben Ergebnis.

Any ideas? Bin für jeden Tipp dankbar.

Schönen Tag auch
MaryLong
Bitte warten ..
Mitglied: TuXHunt3R
01.06.2010 um 11:43 Uhr
Hallo MaryLong (ich rauche American Spirit )

Ausser das Laufwerke mit /persistent:yes zu mappen und das Automatische Trennen zu entfernen: Keine.

Gruss TuXHunT3R
Bitte warten ..
Ähnliche Inhalte
Windows Userverwaltung
GPO Laufwerk wird nicht gemappt
Frage von banane31Windows Userverwaltung1 Kommentar

Hallo und einen schönen Freitag allen zusammen, vor weg: Ich hoffe das Thema wird nicht zu einem "Freitags Fred" ...

Windows 7

Aufruf einer Anwendung im Internet Explorer 11 mit ausgeblendeter URL

gelöst Frage von karlosWindows 718 Kommentare

Unter Win7 SP1 64bit wird eine, im lokalem Netz befindliche Anwendung, im Webbrowser aufgerufen. Der Internet Explorer 11 ist ...

Windows Server

Laufwerke werden nicht immer gemappt (Windows)

Frage von YotYotWindows Server7 Kommentare

Mahlzeit! Nehmen wir mal an, ich hätte ein Netzwerk mit einem DC, einem Fileserver und zwei Terminalservern, allesamt unter ...

Java

Aufruf der web.xml

gelöst Frage von qwertz1Java3 Kommentare

Hallo, ich habe einen Server, der diverse Java-Servlets hat. Habe nur http-Zugriff auf diesen Server. Die Servlets kann man ...

Neue Wissensbeiträge
iOS
IOS hat nen Cursor !!!
Tipp von Criemo vor 11 StundeniOS2 Kommentare

Nette Funktion im iOS. iPhone-Mauszeiger aktivieren „Nichts ist nerviger, als bei einem Tippfehler zu versuchen, den iOS-Cursor an die ...

Off Topic
Avengers 4: Endgame - Erster Trailer
Information von Frank vor 2 TagenOff Topic2 Kommentare

Ich weiß es ist Off Topic, aber ich freue mich auf diesen Film und vielleicht geht es anderen hier ...

Webbrowser
Microsoft bestätigt Edge mit Chromium-Kern
Information von Frank vor 2 TagenWebbrowser5 Kommentare

Microsoft hat nun in seinem Blog bestätigt, dass die nächste Edge Version kein EdgeHTML mehr für die Darstellung benutzen ...

Sicherheit

MikroTik: Sicherheitslücke wird ausgenutzt obwohl ein Update seit langem verfügbar ist

Information von sabines vor 3 TagenSicherheit

Obwohl ein Update, dass die nun massenhaft ausgenutzte Lücke schließt, seit langem (März 2018) verfügbar ist, wird es offensichtlich ...

Heiß diskutierte Inhalte
Exchange Server
Exchange Server 2010: Keine Eingehenden E-MAils
Frage von gabeBUExchange Server16 Kommentare

Hallo Zusammen Ich habe das kurzen auf dem Exchange 2010 Server das Problem, dass ich keine externen E-Mails mehr ...

Rechtliche Fragen
Systemhaus auf Abwegen
Frage von rocco61Rechtliche Fragen15 Kommentare

Hallo zusammen, bin derzeit ratlos bei dem folgenden Scenario: In einen Seniorenheim wurde beschlossen, die IT an eine andere ...

Server
Server in zwei verschiedene Netzwerke einbinden
Frage von BennyFServer10 Kommentare

Hallo zusammen, bei uns im Haus sind im Erdgeschoss die Geschäftsräume und ab dem 1. Stock sind unsere privaten ...

Outlook & Mail
Kalendersync mit Android und Outlook
Frage von Stefan007Outlook & Mail9 Kommentare

Hi Leute, kennt jemand eine Möglichkeit um Termine zwischen installiertem Outlook auf dem PC und dem Kalender auf einem ...