Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Gigaset 108 WLAN USB-Adapter mit ndiswrapper - klappt nicht!

Mitglied: cascio

cascio (Level 1) - Jetzt verbinden

18.06.2006, aktualisiert 19.07.2006, 13033 Aufrufe, 5 Kommentare

Hallo,

ich habe seit kurzem SuSE Linux 10.1 auf der zweiten HDD meines Privat-Rechners laufen und bin momentan dabei mich in dieses Betriebssystem einzuarbeiten (also noch ein totaler Anfänger auf dem Gebiet). Als Windows-Nutzer bin ich es gewohnt, dass die meisten USB-Geräte dank Plug&Play einfach anzuschließen und einzurichten sind, was unter Linux aufgrund fehlender Treiber meist nicht der Fall ist.

Nun stehe ich vor dem Problem meinen Gigaset 108 WLAN USB-Adapter, mit dem ich über einen Router ins Internet komme, unter Linux einzurichten. Nach einigem googlen im Netz verwies man mich auf das Program ndiswrapper, mit dem Windows XP Treiber auch unter Linux installierbar sind. Aktuellen Release 1.17 des Programms runtergeladen, entpackt und anhand der Anleitung installiert. In der Liste der unterstützten Chipsets auf der Site fand ich schließlich auch den SIEMENS GIGASET USB 108 ADAPTER (Atheros 5523, usbid: 129b:160c) mit dem Verweis auf die XP-Treiber der mitgelieferten CD (athfmwdl + net5523), welche ich mir ebenfalls in ein Verzeichnis auf der Linux-Platte kopierte und mit ndiswrapper erfolgreich installierte - scheint alles soweit in Ordnung zu sein: mit ndiswrapper -mwurde das Modul ins Konfigurationsfile geschrieben und ndiswrapper -l gibt mir die Antwort 'driver installed, hardware present' aus.

Nur das Modul wie in dem Tutorial unter Opensuse.org oder Opensuse_Atheros bzw. Sourceforge.net mit modprobe ndiswrapper zu laden funktioniert bei mir irgendwie nicht. Ich weiß nicht warum! Er brachte im Terminal irgendwie immer nur die Fehlermeldung: "invalid argument". Inzwischen hab ich's zwar irgendwie geschafft, dass er den Befehl so ausführt ohne zu meckern, aber im syslog bestätigt mir kein Eintrag das erfolgreich geladene Modul.

Der Stick wird offensichtlich erkannt, was mir auch die Hardwareliste und ndiswrapper bestätigen. Nur in iwconfig existiert kein Eintrag 'wlan0', was der Anleitung zufolge jedoch so sein müsste. Die Einrichtung im Netzwerkkonfigurationsprogramm konnte ich deshalb also schon von vornherein knicken, das brachte nix auch.

Ich hab schon alles Mögliche probiert und weiß nun keinen Rat mehr (hab ich irgendetwas übersehen oder falsch gemacht?)! Wenn mir jemand von euch diesbezüglich helfen kann, wäre ich sehr dankbar. Hab nämlich keinen Bock nur fürs surfen jedesmal den Rechner unter Windows zu booten; hab mir Linux ja eigentlich deshalb installiert, da es als allgemein sicher und stabil gilt und will's deshalb nicht gleich wieder ad acta legen.

Danke schon mal im Voraus

thomas
Mitglied: BartSimpson
19.06.2006 um 12:20 Uhr
ndiswrapper ist eh eine heisse Kiste, die man meiden sollte wie die Pest.
Was sagt denn dmesg nach dem du alles geladen hast?
Bitte warten ..
Mitglied: cascio
20.06.2006 um 17:49 Uhr
dmesg? Tut mirLeid, ich hab nur in der System-Logdatei unter /var/log/messages nachgeschaut und konnte keine Anhaltspunkte auf einen erfolgreichen Ladevorgang des Programms finden - nur Fehlermeldungen. Wie gesagt, ich bin auf dem Territorium von Linux neu und daher noch ziemlich unerfahren.

Von ndiswrapper habe ich bisher nix Schlechtes gehört, was macht die Sache denn so unsicher?
Bitte warten ..
Mitglied: BartSimpson
20.06.2006 um 18:06 Uhr
Das ganze Konzept ein Treiber der eigentlich für ein ganz anderes System ist.
dmesg verrät dir mehr infos wenn ein modul geladen wird.
Bitte warten ..
Mitglied: cascio
24.06.2006 um 21:57 Uhr
Das ist ja das Problem, das Modul wird ja nicht geladen. Deshalb ist im syslog nix verzeichnet. Und mit dem Stichwort dmesg kann ich auch nichts weiter anfangen - konnte dazu nichts im System nicht finden.

Ndiswrapper ist aber bisher die einzige Methode, von der ich gehört habe, mit der man fremde WLAN-Hardware unter Linux installieren kann und was woanders offensichtlich auch erfolgreich funktioniert. Wenn es dazu Alternativen gäbe, würde ich die sicherlich auch ausprobieren.
Bitte warten ..
Mitglied: cascio
19.07.2006 um 17:41 Uhr
Ich glaub, ich werd mir wohl doch 'ne andere Distribution raufschmeißen... eine mit besserer Hardwareunterstützung.
Bitte warten ..
Ähnliche Inhalte
Windows Tools

UEFI: USB unter WinPE nicht verfügbar (BIOS klappt) ImageX

gelöst Frage von RobinSABCWindows Tools6 Kommentare

Evtl kann mir hier jemand helfen. Ich habe hier 3 verschiedene Hardwareplattformen (jeweils ca 20-30 Stück+1 weitere Plattform im ...

LAN, WAN, Wireless

Gibt es USB zu WLAN Adapter?

Frage von grkaLAN, WAN, Wireless3 Kommentare

Hallo, ich habe ein Gerät das ein USB Kabel hat und im PC als Serieller COM Port in der ...

LAN, WAN, Wireless

Opnsense wlan mittels USB-Stick erweitern

gelöst Frage von BalivorinskyLAN, WAN, Wireless4 Kommentare

Hallo, kann ich eine neue Schnittstelle für ein WLAN mittels USB Stcik erstellen. Habe den WLAN-USB Stick in die ...

Voice over IP

Gigaset N720 DM Einrichtung Starface

Frage von Huibuh2010Voice over IP3 Kommentare

Hey Leute, bei uns war der N720 Dect Manager defekt. Nun habe ich ein neuen installiert und die selbe ...

Neue Wissensbeiträge
DSL, VDSL

Einwahlparameter verschiedener deutscher DSL-Provider mit VLAN ID

Tipp von the-buccaneer vor 19 StundenDSL, VDSL

Ohne Gewähr für Aktualität. Im Netz gefunden. Buc

Batch & Shell
Powershell-Scripts ohne Anzeige aufrufen
Tipp von fritzo vor 19 StundenBatch & Shell

Ich habe ein Powershell-Script geschrieben, welches personalisierte Vorlagenpfade für MS Office für den angemeldeten User aus dem Active Directory ...

Sicherheits-Tools

CDBurnerXP Updates werden als unerwünschted Programm angezeigt Win32 FusionCore.T

Information von StefanKittel vor 20 StundenSicherheits-Tools

Hallo, dies ist nur eine Information. ich verteile bei einigen sehr kleinen Kunden 3rd parity Updates mit NinitePro. Heute ...

Windows 10

Aus der Reihe "Windows 10 und der Datenschutz"

Information von Trontur vor 1 TagWindows 105 Kommentare

"Unter dem Druck der Datenschutz-Grundverordnung (DSGVO) kommt Microsoft den europäischen Kunden peu à peu entgegen. Wenn sich Windows 10 ...

Heiß diskutierte Inhalte
Outlook & Mail
Outlook Profile 2019
Frage von AkcentOutlook & Mail16 Kommentare

Hallo, vor Outlook 2019 konnte man unter der Systemsteuerung noch die Outlook Profile und Mailkonten ohne Outlook zu starten ...

Windows 10
Daten auf SSD verschwunden
Frage von m.riefWindows 1015 Kommentare

Guten Abend, Ich habe heute ein Notebook neu installiert da die Festplatte Probleme machte. Nun ist Windows 10 1909 ...

Windows Server
Win2016 - Shadowcopies werden nicht aufgelistet
gelöst Frage von emeriksWindows Server15 Kommentare

Hi, habe hier ein seltsames Problem: Win 2016 Server mit 4 Daten-Volumes Für jedes Volume werden mehrmals am Tag ...

E-Mail
Spam von russischen Servern
Frage von mausebaerE-Mail14 Kommentare

Ich bekam bis vor kurzem noch jede Menge Spam von Absendern mit russischen Adressen. Hab mir sogar einen Ordner ...