Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst IFMEMBER Domänen-Benutzer

Mitglied: tekila

tekila (Level 1) - Jetzt verbinden

04.09.2007, aktualisiert 13:53 Uhr, 10838 Aufrufe, 5 Kommentare

Login Skript funktioniert nicht mit internen Benutzergruppen (Domänen-Admins, -Benutzer etc.)

Hallo!

Ich bekomme es einfach nicht hin: In meinem Login Skript funktioniert die IFMEMBER - Funktion nicht mit integrierten Benutzergruppen wie Domänen-Admins, -Benutzer etc. Mit selbst angelegten Gruppen funktioniert es einwandfrei!
01.
@Echo off
02.

03.
NET TIME \\Server /SET /YES
04.

05.

06.
:Mapping
07.

08.
Echo Laufwerke werden verbunden...
09.
Echo.
10.

11.
:EDV
12.

13.
\\server\NETLOGON\ifmember.exe Domänen-Admins
14.
if %errorlevel%==1 (
15.

16.
Echo ### Domänen-Admins ###
17.
Echo.
18.
 
19.
NET USE G: /DELETE /YES
20.

21.
NET USE G: \\Server\Allgemein /PERSISTENT:NO
22.

23.
)
24.
pause
Ich bekomme immer den Wert "0" zurück.

Habe schon alle möglichen Schreibweisen probiert: COMPANY\Domänen-Admins oder "COMPANY\Domänen-Admins". Auch exakt auf Groß und Kleinschreibung geachtet. Nichts zu machen.

Mit "IFMEMBER /list" wird mir jede Gruppe angezeigt, auch die Domänen-Benutzer etc.

Die IFMEMBER.EXE befindet sich wie zu sehen auf dem Server im Netlogon.

Bin über jede Hilfe dankbar!
Mitglied: einwegglas
04.09.2007 um 12:01 Uhr
domänen-admins findet er auch nicht. sonder nur domõnen-admins. probier doch mal danach zu fragen.

An­mer­kung: Der Au­tor hat Pro­ble­me mit den Um­lau­ten äöüß in den Grup­pen­na­men, so z.B. mit Domä­nen-Ad­mins, die sich nicht ve­ri­fi­zie­ren las­sen. (WindowsNT Administrattion)
Bitte warten ..
Mitglied: tekila
04.09.2007 um 13:19 Uhr
Hatte ich noch nicht ausprobiert. Es hilft allerdings auch nicht.

Wenn ich im logon.cmd "Domänen-Admins" schreibe erscheint es in der DOS-Box bei Ausführung als "Dom­õnen-Admins".

Wenn ich im Skript sofort "Domõnen-Admins" schreibe erscheint in der DOS "Dom§nen-Admins" (??).
Bitte warten ..
Mitglied: Dani
04.09.2007 um 13:43 Uhr
Hallo ihr beiden,

@bigbossAUT
Geh hin, mache eine Eingabeaufforderung auf und tippe "edit" ein. Darüber dann das Script öffenen und die ö,ä,ü & ß korrigieren. Das speichern am Ende nicht vergessen. Nun sollte das Script laufen.


Grüße
Dani
Bitte warten ..
Mitglied: tekila
04.09.2007 um 13:51 Uhr
Heureka ;)

Script mit DOS Editor laden und die "ä" noch einmal neu geschrieben (nicht õ!).

Vielen Danke!

Kennt jemand einen guten Windows Editor wo dieser "Fehler" nicht auftritt?
Bitte warten ..
Mitglied: Dani
04.09.2007 um 13:53 Uhr
Kein Problem...schau dir mal Notepad++ an. Dort gibt es ein kl. Plugin für diesen "BUG". *g*
Haben wir hier auch im Einsatz. Sind recht zufrieden damit.


Grüße
Dani
Bitte warten ..
Neue Wissensbeiträge
Datenschutz

SiSyPHuS Win10: Analyse der Telemetriekomponenten in Windows 10

Tipp von freesolo vor 13 StundenDatenschutz1 Kommentar

Alle die sich detailliert für die Datensammlung interessieren die unter Windows 10 stattfindet, sollten sich folgende Analyse des BSI ...

Sicherheit
Adminrechte dank Intel-Grafikkarte
Information von DerWoWusste vor 15 StundenSicherheit1 Kommentar

ist das Advisory, welches beschreibt, welche Intel HD Graphics Modelle Sicherheitslücken haben, mit denen sich schwache Nutzer zu Admins ...

Internet

EU Urheberrechtsreform: Eingriff in die Internetkultur

Information von Frank vor 1 TagInternet1 Kommentar

Liebe Besucherin, lieber Besucher, warum erscheint das obere Banner in allen Beiträgen? Aus Protest gegen Teile der geplanten EU-Urheberrechtsreform ...

Windows Server
Windows Backup - FilterManager Event 3
Tipp von NixVerstehen vor 2 TagenWindows Server

Hallo zusammen, ich bin kein gelernter ITler und auch beruflich nicht in dem Feld tätig. Wir setzen in unserem ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
Glasfaserkabel verlegen und Anschlüsse setzen
Frage von LLL0rdLAN, WAN, Wireless21 Kommentare

Hallo Leute, ich muss demnächst ein Netzwerkkabel auf einer Länge von ca. 70 Metern verlegen. Das Netzwerkkabel soll dabei ...

Windows Server
Mac Rechner im Windows Netzwerk - was jetzt?
gelöst Frage von Kopfg3ldWindows Server18 Kommentare

Hallo zusammen, ich habe folgende Herausforderungen. Aber erst mal was kurz zum Netzwerk - Windows Server (ältester ist ein ...

Microsoft Office
Sharepoint 2016 mag keine Umlaute in .docx-Titeln
gelöst Frage von DerWoWussteMicrosoft Office14 Kommentare

Moin Kollegen. Nutzt hier jemand Sharepoint? Könnt Ihr, unabhängig von der Sharepointversion, bitte einen Test machen? Ladet ein .docx ...

Basic
VBS soll alle Ordner auswählen, die im Startmenu angezeigt werden
Frage von Senseless-CreatureBasic12 Kommentare

Guten Morgen - gibt es eine Möglichkeit, per VBS das Startmenu in Win10 zu modifizieren? Ich beherrsche VBS mittlerweile ...