Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst IIS 6.0 liefert ASP-Seiten nur manchmal aus

Mitglied: theton

theton (Level 2) - Jetzt verbinden

15.12.2007, aktualisiert 25.10.2008, 3600 Aufrufe, 1 Kommentar

Ich hab hier gerade ein ziemlich seltsames Problem auf einem IIS 6.0 und die Log-Meldungen dazu sagen eigentlich schon alles.

123.123.123.124, -, 12/15/2007, 9:54:53, W3SVC987878937, P15200622, 123.123.123.123, 0, 1132, 2120, 200, 0, GET, /zeiterfassung/Default.asp, -,

123.123.123.124, -, 12/15/2007, 9:54:57, W3SVC987878937, P15200622, 123.123.123.123, 265, 1323, 266, 404, 2, GET, /zeiterfassung/default.asp, -,

Wie man sieht, wird einmal die default.asp erfolgreich aufgerufen. Auf dieser befindet sich ein Login-Formular. Logge ich mich dort ein, bekomme ich einen 404 und im Browser erscheint nur "Das System kann die angegebene Datei nicht finden." Ich hab den ASP-Kram nicht programmiert und kenne mich auch nicht wirklich mit IIS aus (arbeite normalerweise eher mit Linux-Servern und nicht mit IIS), aber bis vor einiger Zeit lief das Ganze wohl noch. (Bin neu in der Firma und kann daher nur davon ausgehen, was die Kollegen mir sagen, die behaupten, dass dieses Zeiterfassungstool vor einiger Zeit noch lief.) ASP ist als Webdiensterweiterung installiert und auch zugelassen. Für die betreffende Website habe ich auch noch den ASP.NET-ISAPI-Filter eingetragen, aber auch das verschaffte keine Abhilfe. Langsam kann ich mir nicht mehr erklären wo die Probleme liegen. Zugriffsrechte können es eigentlich nicht sein, da die Datei aufrufbar ist (siehe erste Logmeldung). Wenn ich sie in default.aspx umbenenne, wird sie auch ausgeführt und ich bekomme (erwartungsgemäß) diverse Fehlermeldungen. Hat evtl. jemand eine Idee was ich noch machen kann damit es wieder läuft oder wo ich nach Fehlerquellen suchen kann? Kann man im IIS evtl. angeben, dass POST-Daten zu einer solchen Meldung führen o.ä.?
Mitglied: theton
25.10.2008 um 07:08 Uhr
Das Problem ist erledigt. Windows-typisch verschaffte eine Neuinstallation Abhilfe. Selbst der MS-Support hatte keine andere Lösung. Also mir wäre das als Software-Hersteller echt peinlich.
Bitte warten ..
Ähnliche Inhalte
Webentwicklung
ASP MVC auf IIS 8.5
Frage von hpbrunsWebentwicklung3 Kommentare

Hallo liebe Gemeinde Ich bin schier am Verzweifeln. Seit zwei Wochen doktor ich an einem Problem rum und krieg's ...

Windows Server
IIS 6.0 und Domänenanmeldung
Frage von slanskyWindows Server

Hallo Leute, ich habe eine Frage, aber erst die Umgebung: Domäne mit 3 DCs Windows Server 2008 R2 und ...

Webentwicklung
IIS 10 ASP Parserfehler auf Windows 10
gelöst Frage von NexderWebentwicklung10 Kommentare

Hallo, ich entwickle aktuell Privat einen WebService und will ihn testweise auf einem Notebook hosten (Keine Kommentare hierfür bitte ...

Batch & Shell

Bash - ssh liefert in bash-Script manchmal keinen Output

Frage von NostralyrBatch & Shell11 Kommentare

Moin moin, kurz und knackig: folgendes Problem. Ich habe mir ein Bash-Script, was vereinfacht folgendes tut: nun liefert er ...

Neue Wissensbeiträge
iOS
WatchChat für Whatsapp
Tipp von Criemo vor 1 TagiOS3 Kommentare

Ziemlich coole App für WhatsApp User in Verbindung mit der Apple Watch. Gibts für iOS sowohl als auch für ...

iOS
IOS hat nen Cursor !!!
Tipp von Criemo vor 1 TagiOS5 Kommentare

Nette Funktion im iOS. iPhone-Mauszeiger aktivieren „Nichts ist nerviger, als bei einem Tippfehler zu versuchen, den iOS-Cursor an die ...

Off Topic
Avengers 4: Endgame - Erster Trailer
Information von Frank vor 3 TagenOff Topic2 Kommentare

Ich weiß es ist Off Topic, aber ich freue mich auf diesen Film und vielleicht geht es anderen hier ...

Webbrowser
Microsoft bestätigt Edge mit Chromium-Kern
Information von Frank vor 4 TagenWebbrowser5 Kommentare

Microsoft hat nun in seinem Blog bestätigt, dass die nächste Edge Version kein EdgeHTML mehr für die Darstellung benutzen ...

Heiß diskutierte Inhalte
Windows Netzwerk
Kerio. Kann keine Mails empfangen aber senden. Wer ist schuld. Kerio oder Windows domäne?
gelöst Frage von frosch2Windows Netzwerk25 Kommentare

Hallo, es existiert ein Problem bei uns mit dem mailen. Alle bestehenden Nutzer können mailen. Raus wie rein. Neuen ...

Hosting & Housing
VMware VM mit über 1TB RAM für S4HANA
Frage von Leo-leHosting & Housing21 Kommentare

Hallo zusammen, wer hat Erfahrng und kann mir einen Tipp zum sizing von S4HANA Systemen geben? Wir möchten, zunächst ...

LAN, WAN, Wireless
WLAN und Ausmessung - Eine Glaubensfrage?
Frage von ptr2brainLAN, WAN, Wireless18 Kommentare

Liebe Experten, als Sys-Admin habe ich mir schon öfter die Frage gestellt, ob es sich beim Thema WLAN und ...

Exchange Server
Exchange Server 2010: Keine Eingehenden E-MAils
gelöst Frage von gabeBUExchange Server17 Kommentare

Hallo Zusammen Ich habe das kurzen auf dem Exchange 2010 Server das Problem, dass ich keine externen E-Mails mehr ...