Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Kein Bild nach Boot ohne Monitor

Mitglied: netadm

netadm (Level 1) - Jetzt verbinden

28.09.2011 um 07:52 Uhr, 3918 Aufrufe, 7 Kommentare

Hallo,

ich habe folgendes Problem,bei dem ich auch über die Suchfunktion noch nichts passendes finden konnte. Ich habe einen PC mit folgender Konfiguration:

- Asus-Desktopboard (Intel P55 Chipsatz)
- VGA Asus EN210 SILENT DI PCI-E

Installiert ist hierauf Opensuse 11.3 64bit mit Kernel 2.6.34.12. Gestartet wird das System ohne grafische Oberfläche im Runlevel 3.

Es funktioniert alles einwandfrei, solange während des Bootvorgangs ein Monitor angeschlossen ist. Wird dieser jedoch erst nach dem Bootvorgang angeschlossen, so bleibt dieser schwarz und lässt sich nicht zum Leben erwecken. Ich habe dies schon mit dem VGA- und dem DVI-Port getestet. Aber leider der gleiche Effekt.

Gibt es eine Lösung, dass der Monitor auch an geht, wenn er erst im Nachhinein angeschlossen wird?

Viele Grüße
Mitglied: 64748
28.09.2011 um 08:17 Uhr
Guten Morgen,

wichtig wäre zu wissen, woran es scheitert. Eine Idee ist, das Linux irgendein (oder mehrere) Module nur lädt, wenn ein Monitor angeschlossen ist.
Schreib das Kommando
lsmod | sort > lsmod_ohne_Monitor.txt
in eine Textdatei, und speichere das ganze so, dass Du es bei schwarzem Bildschirm ausführen kannst, oder lass es beim shutdown automatisch ausführen (chmod 755 nicht vergessen! falls Du das Kommando als Datei abspeicherst).
Dann vergleiche die geladenen Module bei schwarzem Monitor mit den Modulen mit funktionierendem Monitor.
Falls es sich jedoch um ein Feature der Grafikkarte handelt, dann wird das nichts nutzen.

Außerdem kannst Du die Xorg.log Dateien für beide Fälle vergleichen.


Markus
Bitte warten ..
Mitglied: netadm
01.10.2011 um 17:35 Uhr
Schönen guten Abend,

vielen Dank für den schnellen Tip. Ich vermute da liegt auch schon das Problem. Beim Boot ohne Monitor wird das Modul namens "nouveau" nicht geladen. Dies scheint ein nVidia- Treibermodul zu sein.

Könnte ich dies testweise während des Betriebs z.B. per ssh nachladen? Dann müsste der Monitor ja theoretisch angehen oder funktioniert das nicht? Mit welchem Kommando würde dies denn funktionieren? Mit modprobe ? Und wenn dies das Problem wäre, kann ich OpenSuSE dazu bringen, das Modul immer zu laden, unabhängig davon, ob ein Monitor angeschlossen ist?

Xorg- Logs kann ich keine finden. Aber kann es bei mir überhaupt welche geben, wenn ich im Runlevel 3 ohne grafische Oberfläche arbeite?

Viele Grüße
Bitte warten ..
Mitglied: 64748
01.10.2011 um 18:37 Uhr
Hallo,

mit
modprobe nouveau
in der rc.local sollte das Module bei jedem Systemstart geladen werden.

Die lofiles sind normalerweise in /var/log aber ich kenn mich mit Suse nicht aus.

Markus
Bitte warten ..
Mitglied: netadm
05.10.2011 um 21:43 Uhr
Hallo nochmal,

also mein Problem ist nun zur Hälfte gelöst.

Ich bekomme den Monitor mit


modprobe nouveau
den Monitor wieder an. Jedoch erst nachdem ich das Modul einmal entladen und neu geladen habe.
Gibt es evtl. eine Möglichkeit, dies automatisch beim Bootvorgang zu machen?
Bitte warten ..
Mitglied: 64748
05.10.2011 um 21:44 Uhr
Du meinst, Du musst es laden, dann wieder entladen und dann nochmal laden?

Markus
Bitte warten ..
Mitglied: netadm
05.10.2011 um 22:00 Uhr
Nicht ganz.

Wenn ich ohne Monitor boote, dann wird das Modul erstmal nicht mit geladen. Somit bleibt der Monitor auch dunkel.

Mache ich nun jedoch

 modprobe -v nouveau 


so tut sich überhaupt nichts. Erst nach

 modprobe -r nouveau 

 modprobe -v nouveau 


werden das nouveau-Modul und die zugehörigen Module neu geladen und der Monitor geht an.
Bitte warten ..
Mitglied: 64748
05.10.2011 um 22:08 Uhr
Du solltest mal die Dokumentation zu Suse zu Rate ziehen. Dort steht auch, wie man bestimmte Module beim Systemstart laden kann. Ich würde es in der rc.local machen. Allerdings gibt's auch ein Verzeichnis /etc/modprobe.d in dem solche Dinge gesteuert werden. So ähnlich wird's bei Suse auch sein.

Zur Not schreibst Du ein Skript:
#!bin/sh
modprobe nouveau
sleep 2
rmmod nouveau
sleep 2
modprobe nouveau
und lässt es in der rc.local ausführen.

Markus
Bitte warten ..
Ähnliche Inhalte
Peripheriegeräte
Bild über Netzwerk an Monitor
Frage von Ghost108Peripheriegeräte13 Kommentare

Hallo zusammen, ich möchte gerne folgendes realisieren: Ich habe 4 virtuelle Maschinen (Windows 7). Gerne möchte ich jetzt in ...

Grafik

Bild auf 4k Monitor vollständig anzeigen

gelöst Frage von flotautGrafik8 Kommentare

Hallo, wir haben einen 4k Monitor bei uns. Dazu haben wir ein Bild das jedoch nicht in 4k Auflösung ...

Grafikkarten & Monitore

Surface kann Bild nur auf einem externen Monitor ausgeben

Frage von 0815typGrafikkarten & Monitore28 Kommentare

Hallo zusammen Folgendes Problem: Ein Surface (Book 2, 13'') ist an einem Surface Dock angeschlossen, am Dock hinten zwei ...

Grafikkarten & Monitore

älterer Compaq Laptop mit Windows 10 bei Anschluss HDMI Monitor Bild weg

Frage von Andy1805Grafikkarten & Monitore4 Kommentare

Hallo, ein Kollege von mir hat einen älteren Laptop, der VGA und HDMI Anschluss hat. Schliesse ich einen HDMI ...

Neue Wissensbeiträge
Internet

CDU Propaganda: Urheberschutz im Internet - Ende des digitalen Wild-West

Information von Frank vor 10 StundenInternet3 Kommentare

Hallo Administratoren, aus einem Kommentar heraus habe ich folgenden Beiträge von Herr Sven Schulze und Axel Voss (beide CDU ...

Router & Routing

Zyxel VMG 1312 B30A - Firmwareupdate nur im "privaten" Firefox Modus möglich

Tipp von the-buccaneer vor 1 TagRouter & Routing2 Kommentare

Hatte hier ein Zyxel 1312 das ums verrecken kein Firmwareupdate durchführen wollte. Datei ist auswählbar, dann kommt der Fortschrittskreisel ...

Windows 7

Windows 7 u. Server 2008 (R2) SHA-2-Update kommt am 12. März 2019

Information von kgborn vor 2 TagenWindows 75 Kommentare

Kleine Info für die Admins der oben genannten Maschinen. Ab Juli 2019 werden Updates von Microsoft nur noch mit ...

Firewall
PfSense 2.5.0 benötigt doch kein AES-NI
Information von ChriBo vor 4 TagenFirewall2 Kommentare

Hallo, Wie sich einige hier erinnern werden hat Jim Thompson in diesem Aritkel beschrieben, daß ab Version 2.5.0 ein ...

Heiß diskutierte Inhalte
Hardware
IT-Werkzeugkoffer bis 50,- EUR
gelöst Frage von departure69Hardware53 Kommentare

Hallo. Ich bin als IT-Systembetreuer einer Gemeinde zusätzlich auch der IT-Systembetreuer einer Grund- und Hauptschule. Dort muß ich jedoch ...

Netzwerke
Verteilung von Programmdaten außerhalb des internen Netzwerkes
Frage von mertaufmbergNetzwerke27 Kommentare

Guten Morgen liebe Administratoren, ich versuche zurzeit eine möglichst sichere und einfache Lösung zu suchen, um ein Programmverzeichnis über ...

Datenbanken
PHP Fatal error: Uncaught Error: Call to undefined function oci connect
Frage von PlanitecXDatenbanken19 Kommentare

Hallo Zusammen, ich sitze seit Tagen am Problem das ich keine PHP Anwendung mit Anbindung zu Oracle zum laufen ...

Hardware
PC im Selbstbau, Workstation, mittelklasse Gaming
gelöst Frage von MrRobot1997Hardware19 Kommentare

Hallöchen Leute, ich bin seit einigen Jahren leider nicht mehr wirklich im Bild, wenn es um die Hardware und ...