Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Kommunikation zwischen VLAN auf einem Cisco 2950 Switch

Mitglied: Nightpanther

Nightpanther (Level 1) - Jetzt verbinden

16.03.2010 um 15:00 Uhr, 9502 Aufrufe, 6 Kommentare

Hi Comunity,

bin neu hier und habe leider in den großen weiten des Internets keine Antwort auf mein Problem gestoßen, weshalb ich jetzt hier nachfrage.
Zu meinem Problem.

Ich habe einen Cisco 2950 Switch bekommen und wollte auf diesem mehrere Subnetze einrichten. Soweit ist es mir auch gelungen, nur habe ich das Problem, dass ich zwischen den Subnetzen keine Kommunikation hin bekomme. Sprich es ist kein Ping in ein anderes Subnetz möglich. 2 Ports sollen in einem Netz sein und die anderen 22 in ein anderen. in dem 2er Netz soll ein Rechner und die Internetverbindung sein. Das andere Netz soll dann für die anderen Rechner sein und wahlweiße vom Internet getrennt werden.

In der Running-config habe ich gesehen das immer nur ein Subnetz hochgefahren ist. Fahre ich ein zweites VLAN hoch, fährt das andere runter.
Kann ich überhaupt 2 VLAN gleichzeitig laufen lassen auf dem Switch und wenn ja, wie mache ich das?

Wäre toll wenn mir Jemand helfen kann.

Mit freundlichen Grüßen

Nightpanther
Mitglied: Dani
16.03.2010 um 15:29 Uhr
Hi Nightpanther,
damit VLAN's miteinander "sprechen" können benötigst du einen Layer-3-Switch oder eben einen Router der mit VLANs umgehen kann.
Bitte poste doch deine laufenden Konfiguration.


Grüße,
Dani
Bitte warten ..
Mitglied: aqui
16.03.2010 um 20:47 Uhr
Der 2950 kann das aber auch im seiner Basis SW.
Du richtest ganz normal deine VLANs ein und generierst ein sog. vlan interface zu diesem VLAN.
Deine Konfig sollte dann so aussehen: (Annahme du hast ausser dem default VLAN 1 noch die VLANs 10, 20 und 30 )

Cisco_Switch#

clock timezone MET 1
clock summer-time MEST recurring last Sun Mar 2:00 last Sun Oct 3:00
!
spanning-tree mode rapid-pvst
spanning-tree extend system-id
!
interface FastEthernet0/1
description Enduser Ports in VLAN 1
spanning-tree portfast
!
interface FastEthernet0/10
description Enduser Ports in VLAN 10
switchport access vlan 10
spanning-tree portfast
!
interface FastEthernet0/11
description Enduser Ports in VLAN 10
switchport access vlan 10
spanning-tree portfast
!
interface FastEthernet0/12
description Enduser Ports in VLAN 20
switchport access vlan 20
spanning-tree portfast
!
interface FastEthernet0/13
description Enduser Ports in VLAN 20
switchport access vlan 20
spanning-tree portfast
!
interface FastEthernet0/14
description Enduser Ports in VLAN 30
switchport access vlan 30
spanning-tree portfast
!
interface FastEthernet0/15
description Enduser Ports in VLAN 30
switchport access vlan 30
spanning-tree portfast
!
interface GigabitEthernet0/1
shutdown
!
interface GigabitEthernet0/2
shutdown
!
interface Vlan1
ip address 172.16.1.254 255.255.255.0
no ip route-cache
!
interface Vlan10
ip address 172.16.10.254 255.255.255.0
no ip route-cache
!
interface Vlan20
ip address 172.16.20.254 255.255.255.0
no ip route-cache
!
interface Vlan30
ip address 172.16.30.254 255.255.255.0
no ip route-cache
!
ip http server
ip http secure-server
!
end

Wenn deine PCs mit ihrem Gateway in den jeweiligen VLANs nun auf die Cisco VLAN Interface IP zeigen, dann kannst du problemlos zw. den VLANs routen !!!
Bitte warten ..
Mitglied: Nightpanther
17.03.2010 um 07:26 Uhr
Hi und danke für eure schnellen Antworten.

So wie Aqui die config gepostet hat sieht meine auch aus, abgesehen von der Menge an VLAN.
Posten meiner eigenen Config ist bissl schwieriger, da der Zugriff über einen anderen Rechner der nicht am Internet hängt aus folgt. Jedoch bekomm ich nicht hin das er beide VLAN hochgefahren hat. Bei mir ist immer eines der beiden shutdown und wenn ich es hochfahre sagt der Switch mir das er aus administrativen Gründen den anderen runter fährt.
Bitte warten ..
Mitglied: aqui
19.03.2010 um 10:14 Uhr
Dann hast du keinen aktiven Port in dem VLAN konfiguriert und alle deine Ports sind immer noch im Default VLAN 1!!! Dann nimmt der Switch das IP Interface (vlan interface) in den Shutdown state ! Das ist normal.

Du hast also entweder einen Fehler in der Portzuweisung der VLANs gemacht (switchport access vlan x) oder in den Endgeräten falsche Gateway Einträge gemacht oder was auch immer ?!
Mit "switchport access vlan x" weist du einem VLAN einen Port zu. Das musst du machen und mindestens einer dieser Ports muss aktiv sein, also mit einem aufgesteckten Endgerät, damit das VLAN Interface aktiviert ist.
Ist ja auch logisch, wenn kein aktiver Port in einem VLAN, dann muss der Switch ja auch das VLAN Interface nicht aktivieren, denn wo nix iss kann man auch nix routen. Da ist der Switch also schon von sich aus schlau !!

Ohne das du deine Konfig hier mal postest kommen wir nicht recht weiter ! Mit Konfig hier hättest du das im Handumdrehen am Laufen !
Eigentlich ist das doch kein Thema. Auch wenn der PC nicht am Internet hängt kannst du doch per Telnet oder Terminal drauf auf den Switch von diesem PC.
Alle Telnet Terminal Programme wie z.B. Putty oder TeraTerm bieten die Option einer Log Datei.
Die öffnest du, gibts dann ein show run ein und schliesst sie wieder.
Mit RDP oder was auch immer kann man dann doch diese simple Text Datei problemlos auf seinen Rechner kopieren und hier posten....oder ?? Wo ist da denn dein Problem ?
Bitte warten ..
Mitglied: Nightpanther
27.04.2010 um 09:26 Uhr
Entschuldigt für die lange Wartezeit, aber hatte zwischenzeitlich mal Urlaub

Habe mal die Config abgetippt.

Projekt#show running-conf

Building configuration…

Current configuration : 3031 bytes
!
Version 12.1
No service single-slot-reload-enable
No service pad
Service timestamps debug uptime
Service timestamps log uptime
No service password-encryption
!
Hostname Projekt
!
Enable secret 5 $1$46os$ThaZgLXSK20mhZPKFPb1v1
!
ip subnet-zero
!
Spanning-tree extend system-id
!
!
interface FastEthernet0/1
switchport mode access
no ip address
!
interface FastEthernet0/2
switchport mode access
no ip address
!
interface FastEthernet0/3
switchport access vlan 2
switchport mode access
no ip address
!
interface FastEthernet0/4
switchport access vlan 2
switchport mode access
no ip address
!
interface FastEthernet0/5
switchport access vlan 2
switchport mode access
no ip address
!
interface FastEthernet0/6
switchport access vlan 2
switchport mode access
no ip address
!
interface FastEthernet0/7
switchport access vlan 2
switchport mode access
no ip address
!
interface FastEthernet0/8
switchport access vlan 2
switchport mode access
no ip address
!
interface FastEthernet0/9
switchport access vlan 2
switchport mode access
no ip address
!
interface FastEthernet0/10
switchport access vlan 2
switchport mode access
no ip address
!
interface FastEthernet0/11
switchport access vlan 2
switchport mode access
no ip address
!
interface FastEthernet0/12
switchport access vlan 2
switchport mode access
no ip address
!
interface FastEthernet0/13
switchport access vlan 2
switchport mode access
no ip address
!
interface FastEthernet0/14
switchport access vlan 2
switchport mode access
no ip address
!
interface FastEthernet0/15
switchport access vlan 2
switchport mode access
no ip address
!
interface FastEthernet0/16
switchport access vlan 2
switchport mode access
no ip address
!
interface FastEthernet0/17
switchport access vlan 2
switchport mode access
no ip address
!
interface FastEthernet0/18
switchport access vlan 2
switchport mode access
no ip address
!
interface FastEthernet0/19
switchport access vlan 2
switchport mode access
no ip address
!
interface FastEthernet0/20
switchport access vlan 2
switchport mode access
no ip address
!
interface FastEthernet0/21
switchport access vlan 2
switchport mode access
no ip address
!
interface FastEthernet0/22
switchport access vlan 2
switchport mode access
no ip address
!
interface FastEthernet0/23
switchport access vlan 2
switchport mode access
no ip address
!
interface FastEthernet0/24
switchport access vlan 2
switchport mode access
no ip address
!
interface FastEthernet0/25
switchport access vlan 3
switchport mode access
no ip address
shutdown
!
interface FastEthernet0/26
switchport access vlan 3
switchport mode access
no ip address
shutdown
!
interface vlan1
ip address 192.168.178.199 255.255.255.0
no ip route-cache
shutdown
!
interface vlan2
ip address 192.168.128.254 255.255.255.0
no ip route-cache
shutdown
!
interface vlan3
ip address 110.111.113.2 255.255.255.252
no ip route-cache
!
ip default-gateway 192.168.178.1
ip http server
!
!
line con 0
line vty 4
login
line vty 5 15
login
!
end

Projekt#




Bei mir fehlt zwar jetzt noch das spanning-tree portfast aber ich meine das es nur stark was ausmacht wenn man per dhcp die ip bezieht.

Er fährt die Vlan 1 und 2 nicht hoch trotz das ich die Rechner anschließe und die richtigen IP-Daten eingebe.

Hoffentlich kann mir jetzt geholfen werden.

P.S.: Schonmal versucht an einem PC der weder über eine Internetverbindung, CD-Laufwerk, Floppy noch über USB verfügt Daten an einen anderen PC zu schicken. War ja froh das das Teil was mir zur Verfügung steht nen Com-Anschluss hat.

Edit: Habe die Spanning-tree hinzugefügt, aber er kann die infos mit show spanning-tree nicht abrufen. Was mache ich da noch falsch
Kann man das ganze auch mit einer Brisge lösen und wenn ja wie muss ich das configurieren?
Bitte warten ..
Mitglied: alex-w
28.05.2010 um 14:17 Uhr
Das Vlan 1 ist das Default Vlan das darfst du garnicht bearbeiten. Ändern die Interface Ports z.B nach Vlan 10 dann sollte es funktioneren.
Bitte warten ..
Ähnliche Inhalte
LAN, WAN, Wireless
Cisco Catalyst Switch kein VLAN
Frage von quarterabiturLAN, WAN, Wireless1 Kommentar

Hallo zusammen, ich heine ein kleines Problem mit einem Catalsyst Switch. Dieser zeigt mir auf gewissen Ports (13-16) die ...

Router & Routing
Cisco 2950 als DCHP Client
Frage von Windows10GegnerRouter & Routing23 Kommentare

Hallo, ich würde gerne meinen Switch als DHCP-Client betreiben, sodass der sich beim Boten die passende festgelegte IP vom ...

Netzwerke
Fragen Inter-VLAN Kommunikation
gelöst Frage von 118080Netzwerke10 Kommentare

Guten Abend Allerseits Ich habe mal angefangen mich mit VLANs zu beschäftigen. Ich habe vor demnächst mein Netzwerk in ...

LAN, WAN, Wireless

Keine Verbindung über Monowall VLAN mit Cisco Switch

Frage von ph0rl2LAN, WAN, Wireless5 Kommentare

Hallo zusammen, also erst einmal vorweg: Dies sind meine ersten Gehversuche mit einem managerbaren Switch und VLANs. Für ein ...

Neue Wissensbeiträge
Vmware

Which four application services are delivered by VMware Horizon 7

Erfahrungsbericht von erichamm vor 2 StundenVmware2 Kommentare

Which four application services are delivered by VMware Horizon 7? A. Packaged apps with VMware ThinApp B. Virtualized apps ...

Windows 7
Updategängelung auf Windows 10, die zweite
Information von Penny.Cilin vor 3 TagenWindows 71 Kommentar

Hallo, da Windows 7 im kommenden Jahr nicht mehr supportet wird, werden Nutzer von Window 7 home premium wieder ...

Internet
EU-Urheberrechtsreform: Zusammenfassung
Information von Frank vor 5 TagenInternet1 Kommentar

Auf golem.de gibt es eine Analyse von Friedhelm Greis, der das Thema EU-Urheberrechtsreform gut und strukturiert zusammenfasst. Zwar haben ...

Microsoft Office

Office365 Schwachstellen bei Sicherheit und Datenschutz

Information von Penny.Cilin vor 6 TagenMicrosoft Office9 Kommentare

Auf Heise+ gibt es einen Artikel bzgl. Office365 Schwachstellen. Das ist noch ein Grund mehr seine Daten nicht in ...

Heiß diskutierte Inhalte
Utilities
Teamviewer 9.x "out of date" ??
gelöst Frage von keine-ahnungUtilities15 Kommentare

Moin at all, mein topaktueller teamviewer (alles 9.x - releases) verweigert seit heute die Arbeit und bemeckert: "the remote ...

Peripheriegeräte
PS2 Y-Kabel für Maus+Tastatur an PS2 Combo-Anschluss ASUS Prime X370-A
gelöst Frage von Windows10GegnerPeripheriegeräte12 Kommentare

Hallo, ich bin am Überlegen das o.g. Motherboard anzuschaffen. Da ich aber noch PS/2 für Maus+Tastatur benötige (bei optischen ...

Windows 10
Netzlaufwerk verschwindet (aber nur bestimmter Laufwerksbuchstabe)
gelöst Frage von survial555Windows 1010 Kommentare

Hallo, ich habe ein ganz seltsames Problem. Systemumgebung: Server 2012 R2 als DC und Windows 10 Pro als Clients ...

Windows Server
RDP Meldung vor erzwungener Abmeldung
Frage von DOCTRLWindows Server9 Kommentare

Hallo, Situation: Remotedesktop Farm mit mehreren Servern und einer Domäne. Nutzer werden Montags und Donnerstags automatisch abgemeldet. 15 Minuten ...