Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWünsch Dir wasWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Konfiguration von drei Switches

Mitglied: Mr-Limon

Mr-Limon (Level 1) - Jetzt verbinden

08.04.2013 um 13:26 Uhr, 2559 Aufrufe, 10 Kommentare

Hallo,

ich habe ein Problem mit der Konfiguration von drei Switches. Das Setup mal verbildlicht:

5a981a4e2b20c824f9900dc9d3f0199c - Klicke auf das Bild, um es zu vergrößern

Alle Geräte sind im gleichen Netz und alle relevanten Ports im standard VLAN 1. Die Verbindung zwischen Switch1 und Switch2 besteht schon lange und funktioniert, Switch3 wurde nun durch einen neuen HP 1910 (umgelabeltes 3Com Gerät) ersetzt.

1. Szenario
Nur Switch 1 und 2 sind per tagged Uplink verbunden, Kommunikation funktioniert korrekt.

2. Szenario
Switch3 kommt hinzu und wir per untagged Uplink mit Switch1 verbunden. Danach ist keine Verbindung zu Switch2 mehr möglich, während die Kommunikation mit Switch3 funktioniert.

3. Szenario
Der Uplink zu Switch3 wird auf tagged umgestellt, anschließend ist auch wieder eine Verbindung zu Switch2 möglich.

Jetzt meine Frage: Wie kann es sein, dass durch das Hinzufügen des dritten Switches die Verbindung zum zweiten unterbrochen wird? Und warum funktioniert sie bei einem tagged Uplink dann doch korrekt? Was übersehe ich?

Randnotiz: Ja, ich weiß, es sind Billiggeräte, trotzdem muss ich daraus irgendwie das Beste machen.

Grüße
Mitglied: 108012
08.04.2013 um 13:33 Uhr
Hallo,

Wie kann es sein, dass durch das Hinzufügen des dritten Switches die Verbindung zum zweiten unterbrochen wird?
Das kann mehrere Gründe haben, aber ein ganz simpler ist das beide Switche die gleich IP Adresse haben.

Und warum funktioniert sie bei einem tagged Uplink dann doch korrekt?
Wenn man über Uplinks VLANs von einem Switch zum nächsten Switch einem Router führt oder weiterleiten müssen diese getaggt sein und heißen dann Trunk.

Was übersehe ich?
S.o.

Randnotiz: Ja, ich weiß, es sind Billiggeräte, trotzdem muss ich daraus irgendwie das Beste machen.
Viele Leute fahren VW Golf und würden gerne einen Mercedes 600 fahren oder kaufen nur da motzt nicht jeder gleich so wenn die Kohle nicht reicht.

Gruß
Dobby
Bitte warten ..
Mitglied: MrNetman
08.04.2013, aktualisiert um 13:35 Uhr
Hi Zitrone,

wenn auf dem Switch 3 keine VLANs konfiguriert sind, dann klappt es eben nicht.
Aber im Detail: Bei nur einem VLAN und dann noch VLAN 1 - warum sind die uplinks getaggt?
Was die Switchports übel nehmen sind cdp oder lldp Pakete* (Cisco Discovery Protocol, Link Layer Discovery Protocol). Daran erkennen sie einen weiteren Switch und hängen den Prot ab, bevor ein Loop passiert.
Bei (hier unnötigen) getaggten Ports ist es nicht das lldp Protokoll, sondern das
STP Protokoll** (Spanning Tree Protocol), auf das zu achten ist. Da das aber nicht konfiguriert ist, kann der Switch nichts machen.

Also bitte dei Switche sauber konfigurieren, dann passiert das auch nicht mehr.

GRuß
Netman

VLAN1 hat bei vielen Herstellern eine Sonderfunktion als nicht veränderbares default VLAN. Bei anderen kann man das default VLAN verändern. Aber wichtig bleibt es allemal.
Bitte warten ..
Mitglied: 108012
08.04.2013, aktualisiert um 17:31 Uhr
Kleine Anmerkung noch von mir zum Spanning Tree Protokoll, es muss auch auf jeder Seite das selbe STP
eingesetzt werden oder so dass es keine Probleme erzeugt.

Gruß
Dobby

EDIT#
Korrektur.
Bitte warten ..
Mitglied: Mr-Limon
08.04.2013, aktualisiert um 14:37 Uhr
Hallo Dobby und Netzmann,

Das kann mehrere Gründe haben, aber ein ganz simpler ist das beide Switche die gleich IP Adresse haben.
Das ist nicht der Fall.

Wenn man über Uplinks VLANs von einem Switch zum nächsten Switch einem Router führt oder weiterleiten müssen
diese getaggt sein und heißen dann Trunk.
Das ist klar, aber zwischen Switch1 und Switch3 werden gar keine VLANs benötigt, da auf Switch3 sowieso alle Ports im standard VLAN 1 sind. Somit wäre der eigentlich angestrebte untagged Uplink hier ausreichend - nur tritt dann das beschriebene Problem auf.

Was die Switchports übel nehmen sind cdp oder lldp Pakete
LLDP ist auf allen drei Switches aktiviert, die dürfen sich ja ruhig erkennen und machen das auch korrekt. Warum sollte das hier zum Problem führen?

Bei (hier unnötigen) getaggten Ports ist es nicht das lldp Protokoll, sondern das STP Protokoll
RSTP ist (standardmäßig) auf Switch2 und Switch3 aktiviert, Switch1 unterstützt es gar nicht. VLANs werden auf Switch1 und Switch2 benötigt, der tagged Uplink zu Switch3 ist hingegen unnötig, aber mit dem untagged Uplink tritt das beschriebene Problem auf.

Die Funktion von LLDP und STP sind mir prinzipiell bekannt, aber nicht im Detail. Wenn ich das also richtig verstehe, dann wird maximal ein per LLDP identifizierter Switch gleichzeitig akzeptiert, sofern die entsprechenden Uplink-Ports nicht explizit als solche kenntlich gemacht werden (z.B. in Form eines Trunks)?

edit
Ok, habe einen weiteren Beitrag von NetMan gefunden
https://www.administrator.de/forum/2-hp-v1910-miteinander-verbinden-kein ...
demnach liegts also am LLDP.

Vielen Dank für die Hilfe!

Grüße
Bitte warten ..
Mitglied: 108012
08.04.2013 um 14:23 Uhr
...da auf Switch3 sowieso alle Ports im standard VLAN 1 sind
Also doch VLANs die Switch übergreifend laufen, oder?

Gruß
Dobby
Bitte warten ..
Mitglied: Mr-Limon
08.04.2013 um 14:32 Uhr
Also doch VLANs die Switch übergreifend laufen, oder?

Jein. Auf allen Switches gibt es das standard VLAN 1, bei den managed Switches von HP sind da ja grundsätzlich erstmal alle Ports (untagged) drin. Da auf Switch3 ausschließlich dieses eine VLAN existiert, würde ein untagged Uplink reichen, genauso ist auch ein tagged Uplink möglich (aber überflüssig).

Wirklich Switch übergreifende VLANs gibt es nur zwischen Switch 1 und 2, aber die hatte ich bei der Fehlersuche deaktiviert.

Grüße
Bitte warten ..
Mitglied: MrNetman
08.04.2013 um 14:40 Uhr
Na, dann,

jetz mal alles ganz normal:
- STP richtig konfigurieren.
- Uplinks richtig konfigurieren. Edgeports sind keine uplink-Ports auf gemanagten Switches. Und LLDP veranlaßt vernünftige Switches den Port abzuschalten. - auch deine tun das. Schon mal zur Vorbeugung vor unbedachten Loops oder Erweiterungen.
- VLAN richtig konfigurieren und zwar auf allen Switchen.

Gruß
Netman
Bitte warten ..
Mitglied: aqui
08.04.2013, aktualisiert um 16:39 Uhr
.@Dobby
Technisch ist das nicht ganz korrekt was du oben sagst:
RSTP ist rückwärtskompatibel zu STP. Du kannst also RSTP und STP immer problemlos mischen. Die Ports am RSTP die auf einen nur STP Switch gehen schalten dann automatisch in den STP Modus zurück. Das gilt auch für RSTP Switches die noch mit dem alten Draft 3 arbeiten und auf RSTP Draft 4 Switches connecten.
Das ist also kein Problem.
Schlimmer ist es wenn PV(R)STP Switches auf Single Span oder PRVSTP+ switches verbinden, das gibt dann ein Chaos und funktioniert nicht, da nicht kompatibel.
Da der TO oben aber Billigswitches von HP einsetzt dir nur Single Span können und auch SMC eine Taiwangurke ist die auch nur Single Span kann ist das also ganz sicher nicht das Problem !
Da er keinerlei redundante Szenarien hat in dem Design oben ist STP wohl nicht der böse Buhmann.

Es ist eher so wie Kollege NetMan schon vermutet das der TO inkonsistente VLAN Tags auf dem Uplink hat und/oder das einer der Switches das Default VLAN auf den Tagged Uplink nicht untagged überträgt.
Da hilft dann nur das Handbuch weiter...
Bitte warten ..
Mitglied: Mr-Limon
08.04.2013 um 20:57 Uhr
Es war ein STP Problem. Zwar waren auf den Switchen 2 und 3 jeweils RSTP aktiviert, aber irgendetwas hat wohl doch nicht gepasst. Switch 1 unterstützt, wie bereits erwähnt, kein STP (ist ein 1810G v1). Nach dem Deaktivieren funktioniert das Setup jetzt problemlos.

Nochmals vielen Dank für die Hilfe!

Grüße
Bitte warten ..
Mitglied: 108012
08.04.2013 um 21:17 Uhr
Wenn es das dann war bitte noch schnell ein Beitrag ist erledigt. Danke.

Gruß
Dobby
Bitte warten ..
Ähnliche Inhalte
Router & Routing
MikroTik Switch Konfiguration
gelöst Frage von Pixi123Router & Routing5 Kommentare

Hallo! Dank einem Hinweis von aqui bin ich von einem d-link Switch zu Mikrotik gewechselt. Ich habe ein bisschen ...

Netzwerkmanagement
Switch ACL-Konfiguration
gelöst Frage von Philipp711Netzwerkmanagement9 Kommentare

Hallo Leute, ich habe eine kleine Frage zur Konfiguration von ACL's auf unserem Switch. Unsere Infrastruktur ist in verschiedene ...

LAN, WAN, Wireless
HP Switch VLAN Konfiguration
Frage von staybbLAN, WAN, Wireless12 Kommentare

Hallo, ich möchte eine bereits bestehende Netzwerkstruktur mit VLANs erweitern. Und zwar ist folgendes Szenario vorhanden: HP Layer 2 ...

LAN, WAN, Wireless

VLAN Konfiguration (Lancom AP und Netgear-Switch)

gelöst Frage von shindukeLAN, WAN, Wireless3 Kommentare

Hallo zusammen, ich stehe vor einem kleinen Verständnis-/Konfigurationsproblem was die VLAN Konfiguration angeht. Folgende Sachlage Wir benötigen für unsere ...

Neue Wissensbeiträge
Linux Tools
Rsync datenvolumen reduzieren mit -fuzzy
Anleitung von NetzwerkDude vor 1 TagLinux Tools

Moin, aus der Kategorie "Häufig übersehene Parameter": Meistens benutzt kaum jemand den fuzzy Parameter von rsync, und er taucht ...

Sicherheit

Citrix ADC, Gateway u. SD-Wan: Schwachstellen patchen

Information von kgborn vor 3 TagenSicherheit

Keine Ahnung, wie viele Admins von Citrix-Applicances hier unterwegs sind und ob die Versorgung mit Advisories klappt. Aber im ...

Off Topic

Im Tel Raum von Hamburg (040) sind mal wieder viele Indische Microsoft Anrufer unterwegs

Information von TomTomBon vor 4 TagenOff Topic9 Kommentare

Moin Moin, Die sind so schlecht das sogar meine Frau sofort die erkannt hat was die sind. Und Ihr ...

Router & Routing

FritzOS 7.20 kommt auch auf Deine Fritze (wahrscheinlich)

Information von Visucius vor 4 TagenRouter & Routing19 Kommentare

Nachdem ich hier die Hassliebe zu den kleinen Kistchen kenne, sollten wir das nicht zu breit ausdehnen. Ein paar ...

Heiß diskutierte Inhalte
SAN, NAS, DAS
NAS mit interner RDX-Aufnahme
Frage von keine-ahnungSAN, NAS, DAS16 Kommentare

Moin at all, offenbar habe ich nur das "for free google" freigeschalten ich bin auf der Suche nach einem ...

Microsoft
Freitagsfrage einfach aus Interesse: Gibt es Windows Systeme Server sowie Clients die ein komplett sauberes Eventlog haben?
Frage von bloodstixMicrosoft14 Kommentare

Hallo zusammen, mich würde mal interessieren wie da eure Erfahrungen sind. Selbst bei frisch installierten Clients/Servern gibt es immer ...

Outlook & Mail
Outlook 2016 - Termine als RTF senden
Frage von emeriksOutlook & Mail14 Kommentare

Hi, in Anlehnung an meine vorherige Frage: Outlook stellt Termin-Mail-Body mit HTML-Code für Leerzeichen dar Wie/wo kann man Outlook ...

Outlook & Mail
Outlook stellt Termin-Mail-Body mit HTML-Code für Leerzeichen dar
Frage von emeriksOutlook & Mail11 Kommentare

Hi, habt Ihr sowas s.u. schon mal gesehen? Meldung kommt von meinen Kollegen. Ich habe es selbst nicht gesehen. ...