Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Laufwerks-Mapping über Batch - Laufwerke werden zu spät im Explorer angezeigt

Mitglied: Philzip

Philzip (Level 1) - Jetzt verbinden

17.04.2019, aktualisiert 18:27 Uhr, 481 Aufrufe, 17 Kommentare, 1 Danke

Hallo zusammen,

ich habe beim Thema Laufwerksmapping via Batch ein Phänomen, welches ich so noch nicht kannte.

Per Batch werden drei Laufwerke mit folgendem Code (pro Laufwerk) eingebunden:

01.
if not exist G: net use G: \\Servername.domain\Verwaltung$/persistent:no
Die Batch wird quasi punktgenau ohne spürbare Ladezeit fehlerfrei ausgeführt:

unbenannt - Klicke auf das Bild, um es zu vergrößern

Nach erfolgreichem Ausführen der Batch dauert es jedoch gerne noch mal ein bis zwei Minuten, bis die Laufwerke im Explorer angezeigt werden.

Bei anderen IT-Infrastrukturen, die ähnlich aufgebaut sind, konnte ich solche Probleme noch nie feststellen. Es handelt sich um einen Server 2016 und Windows 10 Clients. Das Problem ist auch auf anderen Windows 10 Releases reproduzierbar (getestet wurden 1803 und 1809).

Was daran merkwürdig ist - dieses Problem tritt nur unmittelbar nach dem Rechnerneustart auf. Wenn der Rechner bereits eine Weile läuft, bevor man die VPN Verbindung zum Firmennetz herstellt und die Laufwerke-Batch ausführt, werden die Laufwerke unmittelbar nach Ausführen der Batch im Explorer angezeigt.

Hat jemand einen Tipp für mich, wo ich hier ansetzen kann?

Grüße

PS: Die Client-Performance dürfte hier keine Rolle spielen, alle Clients sind nagelneu und mit schnellen NVME-SSDs ausgestattet.

PPS: Dieses Problem tritt nur beim ersten Verbinden der Laufwerke nach einem Rechnerneustart auf. Wenn man sie trennt und die Batch erneut ausführt, sind sie im Explorer sofort verfügbar.
Mitglied: Spirit-of-Eli
17.04.2019 um 20:03 Uhr
Moin,

am besten löst sich dies über GPO.

Solche Scripte sind auch unnütz den früher hat man es per Logon Script gelöst.

Gruß
Spirit
Bitte warten ..
Mitglied: Philzip
17.04.2019 um 20:12 Uhr
GPO dauert zu lange über VPN. Das sind 10 bis 20 Sekunden, die man sich mit einer Batch sparen könnte. Dennoch danke für den Tipp
Bitte warten ..
Mitglied: Spirit-of-Eli
17.04.2019 um 21:03 Uhr
Deine Beobachtung ist entgegen des Normalfalls.
Ich bin froh wenn ich eine Umgebung ohne mapping beim Login habe.

Richtig konfiguriert ist es über GPOs zu lösen.
Bitte warten ..
Mitglied: Philzip
17.04.2019 um 21:08 Uhr
Sagt wer? GPO ist langsamer als Batch, das ist Fakt. Ob es nun 5 oder 20 Sekunden sind spielt doch keine Rolle. Bei meinem Anwendungsfall wird erwartet, dass die Laufwerke sofort verfügbar sind - so, wie ich und viele andere es von einer Batch gewohnt sind.
Bitte warten ..
Mitglied: Kraemer
17.04.2019 um 22:08 Uhr
Moin,

deine Erwartungen sind "komisch" entsprechen sie im Standard doch deiner Beschreibung und nicht deinen Erwartungen.
GPO ist das mittel der Wahl
Bitte warten ..
Mitglied: Meierjo
17.04.2019 um 22:13 Uhr
Hallo

Hast du die GPO "Beim Neustarten des Computers und bei der Anmeldung immer auf das Netzwerk warten", aktiviert?

Gruss
Bitte warten ..
Mitglied: em-pie
17.04.2019 um 22:16 Uhr
Moin,


Zitat von Kraemer:
[...]
GPO ist das mittel der Wahl

Sehe ich auch so.

Entscheidend ist doch, wann die GPO für die Laufwerke durchlaufen werden. Wenn vorher noch 7374929 Drucker gemapped, Shortcuts erstellt und Dateien kopiert werden sollen, ist es klar, dass die Laufwerke erst zig Sekunden später bereit stehen...

Gruß
em-pie
Bitte warten ..
Mitglied: Philzip
17.04.2019, aktualisiert um 22:24 Uhr
Ich hätte vielleicht deutlicher erwähnen sollen, dass es hier ausschließlich um das Verbinden der Laufwerke von extern geht. Intern werden die Shares über GPO gemappt.

@Kraemer Hattest du mein Anliegen auch so verstanden? Falls ja bitte ich dich, meine Anforderung zu respektieren. Ich möchte mein Problem lösen und nicht als Workaround auf GPO wechseln - da die GPO (von extern über VPN) wie erwähnt deutlich zu lange zum Verbinden braucht.

@Meierjo: Nein - dürfte aber auch keine Rolle spielen, da der Client sowieso außerhalb des LANs hochgefahren/angemeldet wird.

Gruß

@em-pie: Auch für dich zur Info - es geht um externe Clients, die über VPN arbeiten. Intern sind die Laufwerke über GPO sofort nach dem Anmelden verfügbar.
Bitte warten ..
Mitglied: Kauzig
18.04.2019 um 07:15 Uhr
Ich hätte vielleicht deutlicher erwähnen sollen, dass es hier ausschließlich um das Verbinden der Laufwerke von extern geht. Intern werden die Shares über GPO gemappt.

Vllt liegt es ja auch wie schon ein Vorredner angemerkt hat an der Netzwerkverbindung.
Kann schon sein dass Batch schneller ist, solang du aber das Laufwerk nicht erreichen kannst wird Windows das Laufwerk auch nicht Verbindung und noch weniger bereitstellen.

Wenn dem so ist und unbedingt direkt nach der Anmeldung die Laufwerke vorhanden sein sollten, dann wäre eben auch wieder die Frage ob man nicht doch auf GPO zurückgreift um eben erst eine Anmeldung durchführen zu können, wenn das Netzwerk verbunden ist. Somit würde eben bei der Anmeldung die Zeit länger dauern und ob du dann eine GPO oder Batch verwendest sollte zeit technisch keine Rolle spielen.

Grüße
Kauzig
Bitte warten ..
Mitglied: Spirit-of-Eli
18.04.2019, aktualisiert um 08:02 Uhr
Rein Zeitlich macht es ja sogar Sinn GPOs zu nutzen.
Ob jetzt 20s längere Anmeldezeit oder 2min auf die Laufwerke warten.

Gerade bei Terminal Servern wäre es mit Script genau umgekehrt.
Bitte warten ..
Mitglied: Philzip
18.04.2019 um 09:42 Uhr
@Kauzig - Verstehe ich nicht. Was soll das bringen? Der VPN Client wird nach dem Anmelden gestartet.

@Spirit-of-Eli - ehm... jo. Aber die 2 Minuten sind ja wie erwähnt genau das Problem, dass ich hier lösen will. Bei einer Batch bin ich nämlich wenige Sekunden gewohnt, nicht wenige Minuten :D
Bitte warten ..
Mitglied: Kauzig
18.04.2019 um 10:20 Uhr
@Kauzig - Verstehe ich nicht. Was soll das bringen? Der VPN Client wird nach dem Anmelden gestartet.


Vllt ist genau, dass das Problem wieso deine Laufwerke nicht davor gemapped sind?

Szenario: PC fährt hoch --> User meldet sich an --> VPN-Client fährt hoch (Delay) --> nun kann man die Laufwerke erst sehen und eine Verbindung aufbauen.

Somit ist es meiner Ansicht nicht wirklich ein Zeitproblem, der Batch-Datei, sondern der VPN-Client braucht einfach auch eine Zeit (zum starten, zum handshake mit dem VPN-Server etc).
Bitte warten ..
Mitglied: mayho33
18.04.2019 um 14:02 Uhr
Zitat von Philzip:

GPO dauert zu lange über VPN. Das sind 10 bis 20 Sekunden, die man sich mit einer Batch sparen könnte. Dennoch danke für den Tipp

Dann halt via lokaler GPO...
Bitte warten ..
Mitglied: em-pie
18.04.2019 um 15:18 Uhr
Moin,

Dann erkläre mal bitte, welcher VPN Client und zu welchem Zeitpunkt die Batch gestartet wird!

Je nach VPN-Client kann dieser auch eine batch nach Verbindungsaufbau starten lassen.

Gruß
em-pie
Bitte warten ..
Mitglied: Kraemer
18.04.2019 um 21:56 Uhr
Zitat von Philzip:

Ich hätte vielleicht deutlicher erwähnen sollen, dass es hier ausschließlich um das Verbinden der Laufwerke von extern geht.
hättest du

Intern werden die Shares über GPO gemappt.
so macht man das

@Kraemer Hattest du mein Anliegen auch so verstanden?
woher - hattest du nicht erwähnt. Spielt allerdings in diesem Fall nur eine untergeordnete Rolle

Falls ja bitte ich dich, meine Anforderung zu respektieren.
tu ich doch. Ich sage dir nur, dass das Verhalten soweit normal scheint

Ich möchte mein Problem lösen und nicht als Workaround auf GPO wechseln
nana - GPO ist die Lösung. Dein Fehleranfälliges Script ist der Workaround, auf den du ja aus unbekannten Gründen setzen willst

- da die GPO (von extern über VPN) wie erwähnt deutlich zu lange zum Verbinden braucht.
kann ich nicht bestätigen

@Meierjo: Nein - dürfte aber auch keine Rolle spielen, da der Client sowieso außerhalb des LANs hochgefahren/angemeldet wird.
doch, durchaus. Vorausgesetzt die Rechner sind in der Domäne. Aber auch darüber verlierst du kein Wort. Ich tippe mal auf nicht, da du auf dieses Batchgefrickel setzt.

Der VPN Client wird nach dem Anmelden gestartet.
das ist natürlich Suboptimal.

Der Status Quo ist also immer noch: Es läuft alles, wie man erwarten darf.

Wie kann man das nun u.U. verbessern?
Um das zu klären sind einige Fragen offen:
1. sind die Rechner Teil der Domäne
2. welcher VPN-Client wird verwendet
3. Unterstützt der Client eine Verbindung vor bzw. mit der Anmeldung?

Gruß
Bitte warten ..
Mitglied: Philzip
22.04.2019 um 10:26 Uhr
@Kraemer:

1. Ja, sind sie
2. Watchguard SSL VPN Client
3. Leider nicht dass ich wüsste

Diese Konstellation hatte ich allerdings wie erwähnt auch schon sehr oft in anderen Infrastrukturen - dort war das nie ein Problem. Daher bin ich über das Fehlerbild doch etwas verwundert.
Bitte warten ..
Mitglied: Spirit-of-Eli
22.04.2019, aktualisiert um 10:46 Uhr
Zitat von Philzip:

@Kraemer:

1. Ja, sind sie
2. Watchguard SSL VPN Client
3. Leider nicht dass ich wüsste

Diese Konstellation hatte ich allerdings wie erwähnt auch schon sehr oft in anderen Infrastrukturen - dort war das nie ein Problem. Daher bin ich über das Fehlerbild doch etwas verwundert.

Du könntest auch auf L2TP schwenken. Das ist bei der Watchguard in genau so wenigen Klicks realisiert und spart den Client.
Funktioniert meines Wissens nach schneller.

Schöner wäre natürlich eine Lösung wie DA:
https://administrator.de/forum/windows-anmeldung-vpn-domain-anmelden-227 ...

Ist allerdings angekündigt und daher würde ich auf die neue Technologie "Allways In" setzen.
Bitte warten ..
Ähnliche Inhalte
Windows Netzwerk
ISCSI Laufwerk wird doppelt angezeigt
gelöst Frage von ShardasWindows Netzwerk2 Kommentare

Liebe Community, einer unserer Server 2008 R2 zeigt ein ISCSI Laufwerk 2x an. Wegen den laufenden Sitzungen können wir ...

Batch & Shell
Laufwerk Name ändern
gelöst Frage von ShanksBatch & Shell6 Kommentare

Hallo Zusammen, ich hoffe ihr könnt mir helfen bei meinem Problem. Erstmal möchte ich sagen, dass ich ein Absoluter ...

Backup
Synology + RDX Laufwerk
gelöst Frage von Wild-WolfBackup3 Kommentare

Hallo liebe "Kellerkinder" :D Laut Tandberg soll es möglich sein, ein RDX an ein Synology NAS anzuschließen. Hat jemand ...

Windows Installation
Verschlüsseltes Laufwerk formatiert
gelöst Frage von tornegiusWindows Installation9 Kommentare

Ich habe folgendes Problem. Wollte heute ein Systemabbild von Windows C wiederherstellen. Dies wollte ich mit der Windows CD ...

Neue Wissensbeiträge
Internet
Big Brother is Watching You
Information von transocean vor 3 StundenInternet

Moin, die Datenkrake Google fischt Informationen über Einkäufe ab, die GMail Nutzer im Netz tätigen. Gruß Uwe

Datenschutz
TeamViewer gehackt !
Information von aqui vor 5 StundenDatenschutz1 Kommentar

Hat schon einen Grund warum verantwortungsvolle Admins diese Software nicht einsetzen und sie in den meisten größeren Firmen aus ...

Netzwerke

Cisco Security Warnung für SoHo Switches der SG Serie

Information von aqui vor 1 TagNetzwerke3 Kommentare

Update auf eine aktuelle Version wäre also eine gute Idee ! ;-)

Sicherheit

Der TeamViewer-Entwickler war 2016 Opfer eines Cyber-Angriffs

Information von kgborn vor 1 TagSicherheit1 Kommentar

Ich denke, nur wenige dürften die kleine Firma TeamViewer aus Göppingen kennen - und einsetzen wird die Produkte von ...

Heiß diskutierte Inhalte
Router & Routing
Reverse Proxy - Anfängerfragen
Frage von NixVerstehenRouter & Routing15 Kommentare

Servus zusammen, endlich Freitag und ich darf wieder meine Anfängerfragen stellen :-) Ich bereite gerade einen Testaufbau für ein ...

Verschlüsselung & Zertifikate
Verschlüsselungsmethoden für Netzwerkdateien im Firmennetzwerk
Frage von kafipauseVerschlüsselung & Zertifikate7 Kommentare

Hallo, ich suche für meine Firma eine Verschlüsselungssoftware, um einige Ordner auf einem Fileserver zu verschlüsseln und verschiedenen Gruppen ...

Windows Netzwerk
Clients finden Domäne nicht mehr (Server 2008 R2)
Frage von bitshopWindows Netzwerk6 Kommentare

Hallo, habe das Problem, dass sich kein PC mehr an der Domäne anmelden lässt. Vor kurzer Zeit ist das ...

Festplatten, SSD, Raid
Intel C612 AHCI SATA Raid ohne Warnungen?
gelöst Frage von NordicMikeFestplatten, SSD, Raid6 Kommentare

Moin zusammen, ich suche mir gerade einen Wolf. Ich habe einen Server 2016 core auf ein Supermicro X10DRi mit ...