Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Linux Mint startet nicht mehr mit grafischer Anmeldung

Mitglied: laster

laster (Level 2) - Jetzt verbinden

07.09.2017, aktualisiert 15:01 Uhr, 2095 Aufrufe, 6 Kommentare

Hallo,

habe ein NB mit Linux Mint 17.3 Cinnamon 64-bit (Cinnamon Version 2.8.8).
Nach Problemen mit einem Programm (basierend auf Eclipse) folgte ich einem angeblichen Lösungsvorschlag:
01.
sudo apt-get remove libwebkitgtk-1.0-0
Als ich das NB am Abend neu startete, zeigte sich der gewohnte Startbildschirm mit Anmeldefenster nicht mehr.
Ein Start des Desktops geht nur noch aus der Konsole ([Strg]+[Alt]+[F1]) mit startx, dann erscheint die normale Anmeldung...
Auf der Konsole kommt aber die Meldung "errors from xkbcomp are not fatal to the X server"

Eine Installation von libwebkitgtk-1.0-0 hilft auch nicht weiter.

Eine Idee, wie ich wieder zum normalen Zustand komme?

vG
LS
Mitglied: beidermachtvongreyscull
07.09.2017 um 15:42 Uhr
Was steht denn in der xorg.log?
Bitte warten ..
Mitglied: beidermachtvongreyscull
07.09.2017 um 15:45 Uhr
In der Zwischenzeit schau mal in

/etc/grub.d/10_linux

Was steht in der Zeile vt_handoff="1"?
Bitte warten ..
Mitglied: laster
07.09.2017, aktualisiert um 16:35 Uhr
Hallo Mitglied: beidermachtvongreyscull,

/var/log/Xorg.0.log
01.
[   677.355] (II) NVIDIA(0): Setting mode "DFP-0:nvidia-auto-select"
02.
[   678.763] (II) NVIDIA(GPU-0): Display (Seiko/Epson (DFP-0)) does not support NVIDIA 3D
03.
[   678.764] (II) NVIDIA(GPU-0):     Vision stereo.
04.
[   678.893] [dix] couldn't enable device 11
05.
[   705.646] (II) NVIDIA(0): Setting mode "DFP-0:nvidia-auto-select"
06.
[   707.233] (II) NVIDIA(GPU-0): Display (Seiko/Epson (DFP-0)) does not support NVIDIA 3D
07.
[   707.233] (II) NVIDIA(GPU-0):     Vision stereo.
08.
[   707.445] (--) synaptics: SynPS/2 Synaptics TouchPad: touchpad found
09.
[   719.516] (II) XKB: generating xkmfile /tmp/server-935791BB8D314AF76E0BAA786B66BB82FD866F95.xkm
/etc/grub.d/10_linux
01.
function gfxmode {
02.
	set gfxpayload="$1"
03.
	if [ "$1" = "keep" ]; then
04.
		set vt_handoff=vt.handoff=7
05.
	else
06.
		set vt_handoff=
07.
	fi
08.
}
In den Klang-Einstellungen habe ich auch das Problem, dass 3 Ausgänge angezeigt werden (Digital, Lautsprecher, Dummy-Ausgabe) und rechts in den Einstellungen nur die Dummy-Ausgabe angezeigt (und bearbeitet werden kann).
Scheint ein NVIDIA Treiber Problem zu sein (Sound wird nicht erkannt)
Bitte warten ..
Mitglied: beidermachtvongreyscull
07.09.2017 um 16:44 Uhr
Zitat von laster:

In den Klang-Einstellungen habe ich auch das Problem, dass 3 Ausgänge angezeigt werden (Digital, Lautsprecher, Dummy-Ausgabe) und rechts in den Einstellungen nur die Dummy-Ausgabe angezeigt (und bearbeitet werden kann).
Scheint ein NVIDIA Treiber Problem zu sein (Sound wird nicht erkannt)

Ich nehme derzeit auch an, dass es Dir den zerschossen hat.
Allerdings dürfte dann auf keiner Console der X-Server anlaufen. Das tut er aber.

Liste mal bitte Deine /etc/default/grub auf.
Mich würde interessieren, welches payload-setting drin ist.

Ferner bitte die Ausgabe von lsmod.
Der NVIDIA-Proprietäre Treiber verweigert den Dienst, wenn er den Nouveau findet.
Den würde ich normalerweise über die grub sperren.
Bitte warten ..
Mitglied: laster
07.09.2017 um 16:55 Uhr
/etc/default/grub (ohne Kommentarzeilen):
01.
GRUB_DEFAULT=0
02.
GRUB_HIDDEN_TIMEOUT=0
03.
GRUB_HIDDEN_TIMEOUT_QUIET=true
04.
GRUB_TIMEOUT=10
05.
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
06.
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=Linux acpi_backlight=vendor"
07.
GRUB_CMDLINE_LINUX=""
und lsmod
01.
Module                  Size  Used by
02.
ctr                    16384  2 
03.
ccm                    20480  2 
04.
nfnetlink_queue        24576  0 
05.
nfnetlink_log          20480  0 
06.
nfnetlink              16384  2 nfnetlink_log,nfnetlink_queue
07.
pata_pcmcia            20480  1 
08.
dm_crypt               24576  0 
09.
hp_wmi                 16384  0 
10.
sparse_keymap          16384  1 hp_wmi
11.
snd_hda_codec_analog    16384  1 
12.
snd_hda_codec_generic    69632  2 snd_hda_codec_analog
13.
snd_hda_intel          36864  2 
14.
snd_hda_controller     32768  1 snd_hda_intel
15.
coretemp               16384  0 
16.
snd_hda_codec         143360  4 snd_hda_codec_generic,snd_hda_intel,snd_hda_controller,snd_hda_codec_analog
17.
snd_hwdep              20480  1 snd_hda_codec
18.
kvm                   479232  0 
19.
snd_pcm               106496  3 snd_hda_codec,snd_hda_intel,snd_hda_controller
20.
snd_seq_midi           16384  0 
21.
arc4                   16384  2 
22.
snd_seq_midi_event     16384  1 snd_seq_midi
23.
dm_multipath           24576  0 
24.
scsi_dh                16384  1 dm_multipath
25.
nvidia              10571776  41 
26.
iwl4965               114688  0 
27.
snd_rawmidi            32768  1 snd_seq_midi
28.
joydev                 20480  0 
29.
serio_raw              16384  0 
30.
snd_seq                65536  2 snd_seq_midi_event,snd_seq_midi
31.
r852                   20480  0 
32.
iwlegacy              106496  1 iwl4965
33.
sm_common              20480  1 r852
34.
snd_seq_device         16384  3 snd_seq,snd_rawmidi,snd_seq_midi
35.
snd_timer              32768  2 snd_pcm,snd_seq
36.
nand                   69632  2 r852,sm_common
37.
nand_ecc               16384  1 nand
38.
nand_bch               16384  1 nand
39.
mac80211              708608  2 iwl4965,iwlegacy
40.
pcmcia                 65536  1 pata_pcmcia
41.
bch                    20480  1 nand_bch
42.
r592                   20480  0 
43.
nand_ids               16384  1 nand
44.
memstick               20480  1 r592
45.
mtd                    61440  2 nand,sm_common
46.
yenta_socket           45056  0 
47.
snd                    86016  14 snd_hwdep,snd_timer,snd_pcm,snd_seq,snd_rawmidi,snd_hda_codec_generic,snd_hda_codec,snd_hda_intel,snd_seq_device,snd_hda_codec_analog
48.
pcmcia_rsrc            20480  1 yenta_socket
49.
pcmcia_core            24576  3 pcmcia,pcmcia_rsrc,yenta_socket
50.
lpc_ich                24576  0 
51.
cfg80211              524288  3 iwl4965,iwlegacy,mac80211
52.
drm                   344064  3 nvidia
53.
soundcore              16384  2 snd,snd_hda_codec
54.
mei_me                 20480  0 
55.
mei                    90112  1 mei_me
56.
shpchp                 40960  0 
57.
rfcomm                 69632  0 
58.
wmi                    20480  1 hp_wmi
59.
bnep                   20480  2 
60.
bluetooth             491520  10 bnep,rfcomm
61.
irda                  200704  0 
62.
crc_ccitt              16384  1 irda
63.
8250_fintek            16384  0 
64.
tpm_infineon           20480  0 
65.
binfmt_misc            20480  1 
66.
hp_accel               28672  0 
67.
lis3lv02d              20480  1 hp_accel
68.
input_polldev          16384  1 lis3lv02d
69.
parport_pc             32768  1 
70.
mac_hid                16384  0 
71.
ppdev                  20480  0 
72.
lp                     20480  0 
73.
parport                45056  3 lp,ppdev,parport_pc
74.
dm_mirror              24576  0 
75.
dm_region_hash         24576  1 dm_mirror
76.
dm_log                 20480  2 dm_region_hash,dm_mirror
77.
hid_generic            16384  0 
78.
usbhid                 53248  0 
79.
hid                   110592  2 hid_generic,usbhid
80.
psmouse               114688  0 
81.
sdhci_pci              24576  0 
82.
firewire_ohci          40960  0 
83.
sdhci                  45056  1 sdhci_pci
84.
ahci                   36864  1 
85.
firewire_core          69632  1 firewire_ohci
86.
crc_itu_t              16384  1 firewire_core
87.
libahci                32768  1 ahci
88.
e1000e                237568  0 
89.
ptp                    20480  1 e1000e
90.
video                  20480  0 
91.
pata_acpi              16384  0 
92.
pps_core               20480  1 ptp
Bitte warten ..
Mitglied: beidermachtvongreyscull
07.09.2017, aktualisiert um 17:31 Uhr
Zitat von laster:

/etc/default/grub (ohne Kommentarzeilen):
01.
> .
02.
> .
03.
> .
04.
> .
05.
> .
06.
> GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=Linux acpi_backlight=vendor nomodeset"
07.
> 

Wenn Du diese Zeile um "nomodeset" ergänzt, sollte Dein Splash Screen wieder funktionieren, vielleicht sogar der XServer nachdem Du GRUB aktualisiert hast und gebootet hast.
lsmod sah zwar OK aus, aber ich bin beim NVIDIA-Treiber sehr vorsichtig.

Es ist auf jeden Fall gut, wenn Du ne Live-CD hast um ggf. die Büchse booten zu können.
Bitte warten ..
Ähnliche Inhalte
Linux Desktop

Linux Mint automatische Anmeldung deaktivieren

gelöst Frage von lasterLinux Desktop4 Kommentare

Hallo, habe Linux Mint 18 Sarah xfce 64 Bit installiert. Am Anfang hatte ich die automatische Anmeldung eingestellt, ist ...

Linux

Linux Mint 17

gelöst Frage von bebo57Linux3 Kommentare

Habe probehalber Linux Mint installiert . Laptop ThinkPad T400 Auf der Tastatur sind die Tasten z und y vertauscht ...

Linux

Linux Shell wechseln unter VirtualBox auf Linux Mint

gelöst Frage von TastenklopperLinux2 Kommentare

Hallo geehrte Mitstreiter, seit neuestem Arbeite ich primär mit Linux-Mint. Da ich für diverse Arbeiten VMs benötige und ich ...

Linux Desktop

Linux Mint öffentlicher Schlüssel nicht verfügbar

Frage von lasterLinux Desktop2 Kommentare

Guten Abend, hab mir mein Linux zerschossen (weis nicht wie ). Beim update kommen mehrere Meldungen in dieser Art: ...

Neue Wissensbeiträge
Off Topic
Europawahl 2019 - Ein Statement der Jugend
Information von Frank vor 4 StundenOff Topic

Dies ist ein offener Brief. Ein Statement. Von einem großen Teil der Youtuber-Szene. Am Wochenende sind die EU-Wahlen und ...

Off Topic
Europawahl 2019
Information von Frank vor 1 TagOff Topic31 Kommentare

Vom 23. bis 26. Mai 2019 findet die Europawahl in den Mitgliedstaaten der Europäischen Union statt (ja auch in ...

Humor (lol)

Minister wollen offenbar Ausweispflicht für .de-Domain

Information von Kraemer vor 1 TagHumor (lol)7 Kommentare

Zitat von Golem.de: Die zuständigen Verbraucherschutzminister fordern einem Medienbericht zufolge offenbar eine Ausweispflicht für .de-Domains. Das soll Betrugsfälle mit ...

Off Topic
Was als Noob hier mal gesagt werden musste
Information von th30ther vor 3 TagenOff Topic5 Kommentare

Moinsen wertes Forum, ich möchte mich an dieser Stelle mal beim Forum generell und bei aqui speziell bedanken! Ich ...

Heiß diskutierte Inhalte
Off Topic
Europawahl 2019
Information von FrankOff Topic31 Kommentare

Vom 23. bis 26. Mai 2019 findet die Europawahl in den Mitgliedstaaten der Europäischen Union statt (ja auch in ...

Ausbildung
Wie sind eure Erfahrungen als oder mit Ü30 Azubis für Fachinformatik Systemintegration?
Frage von CaptainProcessorAusbildung26 Kommentare

Tagchen allerseits :) Mir steht in wenigen Monaten eine Veränderung bevor, da mein AG seine IT auslagert und ich ...

Router & Routing
ZyXEL ZyWALL USG 20 Routing
Frage von Oggy01Router & Routing14 Kommentare

Hallo, und wieder habe ich ein Problem mit dem Routing. Bis vor ein paar Tagen habe ich das mit ...

Virtualisierung
VServer (Linux): Absichern, verschlüsseln usw
Frage von mrserious73Virtualisierung11 Kommentare

Hallo zusammen, ich möchte einen Linux-Vserver mieten und diesen absichern. Darunter verstehe ich in diesem Falle hauptsächlich: Dafür sorgen, ...