Dieser Beitrag ist schon älter. Bitte vergewissern Sie sich, dass die Rahmenbedingungen oder der enthaltene Lösungsvorschlag noch dem aktuellen Stand der Technik entspricht.

LPT-Port unter Drucker hinzufügen fehlt und kann auch nicht mehr hinzu gefügt werden

Mitglied: TomBose
Hallo,

ich bin am verzweifeln und weiß langsam nicht mehr weiter.
Ich hatte auf meinem Notebook HP Jetadmin installiert und wollte nun
zum testen einen Drucker noch per LPT1: anbinden. Nur unter Drucker
hinzufügen (genauso wie unter den Servereigenschaften/Anschlüße)) ging immer
dieser HP Jetadmin Asi auf und hat mir nur Netports (TCP/IP) angeboten.
Schlau wie ich war und weil die HP´s jetzt ja alle Webserver haben, habe
ich den Jetadmin deinstalliert und gehofft, daß mir wieder der normale Local
Port angeboten wird. Fehlanzeige! Nun habe ich gar keinen Local Port mehr
zur Auswahl. (in der devicemap steht der LPT1: noch) Einzige Chance ist
einen neuen Anschlußtyp hinzufügen, aber niemand kann mir sagen, welche
.inf ich für einen normalen LPT1: benötige. Habe schon vieles probiert, nichts
hat geholfen. Kann mir hier vielleicht jemand weiterhelfen!?

Wäre extrem dankbar für Hilfe!



Neuigkeiten:

Habe die Dateien gefunden: msports.inf, parport.sys und die lpt.vxd, kann diese aber weder
über Anschluß hinzufügen noch über händische Installation dazu bewegen mir wieder meinen
LPT1: Anschluß unter Drucker hinzufügen zu geben. Das scheien alles die Dateien für die
devicemap zu sein und nicht für die Druckeranschlüße unter Servereigenschaften. HILFE!

Content-Key: 4798

Url: https://administrator.de/contentid/4798

Ausgedruckt am: 21.06.2021 um 15:06 Uhr

4 Kommentare
Mitglied: TomBose
Also den Druckerport direkt kann ich jetzt ansprechen. Ich kann aber immer noch keinen Drucker auf dem LPT1: hinzufügen, weil immernoch der Local Port fehlt.

Weiß denn wirklich keiner weiter?!

*schnief*
Mitglied: HotFelix
Hallo!
Vielleicht hilft dir dieser Hinweis von mir.
Hatte fast das gleiche Problem bei einer Installation.
Meine LTP Anschlüsse waren auf ein mal weg.
Versuche mal folgendes:
1. schau unter systemverwaltung, ob dort ein ltp und / oder com anschluss angezeigt wird.
ich schätze mal, dass nur der com anschluß angezeigt wird und das 2xmal.
also com1 und com2

3. falls das so sein sollte, beende windows und starte den rechner neu
4. begebe dich ins bios deines rechners (einstellung für Parallel und seriell)
und deaktiviere einen der COM anschlüsse
5. boote deinen rechner wieder neu --> starte windows und jetzt sollte ein LPT und ein COM Anschluss wieder zur verfügung stehen.

bei mir war das der Fall!

Viel Glück
Felix alias Hot
Mitglied: TomBose
Hallo,

in der Devicemap (Gerätemanager) ist der LPT1: vorhanden und funktioniert auch.
Mit Programmen, die den LPT1: dirket ansprechen geht es ja auch. (RAW-Modus)
Aber wenn ich unter Drucker hinzufügen (auch in den Servereigenschaften -> Anschlüße)
einen LPT auswählen will fehlt dieser da komplett. Habe da nur noch Standard TCP/IP Ports.
Kann auch keinen neuen Anschlußtyp hinzufügen, bzw. findet er keine .inf für den
Druckeranschluß unter Drucker hinzufügen.

Habe das Thema aber aufgegeben, da mir nichtmal unsere MCSE´s und MCT´s weiter
helfen konnten. Ich selbst bin leider noch MSCA.....

Aber trotzdem danke....

Schalömle

TOM
Mitglied: JonCarpenter
Hallo,

ich hatte gestern auch das oben genannte Problem und habe das gesamte Netz durchsucht und keine Lösung gefunden. Unter anderem habe ich auch diesen Beitrag gelesen und er entsprach genau dem was ich suchte, aber leider ohne eine Lösung. Deshalb möchte ich die Lösung hier beschreiben, wenn auch etwas spät.

Die Ursache war entweder auch der HP Jet Admin, welchen ich auch probeweise installiert hatte oder ein Registry Tweaker mit welchen ich diverse Einstellungen gemacht hatte und dabei einen evtl. einen Treiber deaktivierte.
Dabei wurden in der Registry unter "HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Print\Monitors" der Schlüssel "Local Port" entfernt oder in den Schlüssel "AutorunsDisabled" verschoben.
Nach der Wiederherstellung des Schlüssels "Local Port" unter "...\Monitors\" mit der darin enthaltenen Zeichenfolge "Driver" (REG_SZ) "localspl.dll" und anschließenden Neustart des Rechners, waren alle Schnittstellen (LPTx, COMx, FILE, ISDNPORTx, ...) wieder vorhanden.
Sollte dies nicht der Fall sein, kann man noch überprüfen ob die localspl.dll unter %systemroot%\system32\ zu finden ist, wenn nicht, diese von der WindowsCD X:\i386\LOCALSPL.DL_ in das Verzeichnis extrahieren.
Heiß diskutierte Beiträge
Router & Routing
Deutsche Glasfaser. NT direkt an pfSense möglich oder besser Kaskade?
fnbaluVor 1 TagFrageRouter & Routing23 Kommentare

Hallo zusammen, am kommenden Mittwoch wird bei mir der Deutsche Glasfaser Anschluss aktiviert. Anfangs wird darüber kein Telefon laufen, aber vielleicht später. Mir stellt sich ...

Notebook & Zubehör
Alt-Laptop Vergleichsmeinungen
winlinVor 1 TagFrageNotebook & Zubehör12 Kommentare

Hallo zusammen Habe zwei Laptops und einen mini pc und würde gerne wissen was ihr zu den beiden Laptops sagt??? Was dürfte ich Max an ...

Batch & Shell
Problem mit einer Batchdatei
stevie72Vor 1 TagFrageBatch & Shell11 Kommentare

Guten Abend zusammen! Ich habe ein problem eine Batch ans laufen zu bekommen. Folgende Problem Stellung: Wir haben etwa 20 Rechner in der Bibliothek. Darauf ...

Firewall
OpenVPN-Problem
gelöst ingorosVor 22 StundenFrageFirewall20 Kommentare

Hallo, habe gestern mit ipfire einen OpenVPN-Server aufgesetzt. Der läuft auch wunderbar. Sowohl Win7, wie auch Win10pro können sich problemlos anmelden. Ein Laptop mit Win10 ...

Windows 10
Remotedesktopzugang mit Openvpn sicher?
LegofrauVor 1 TagFrageWindows 108 Kommentare

Guten Morgen, wie sicher ist es wenn man Remotedesktopzugang durch einen Openvpn Tunnel betreibt? Der Openvpn Tunnel ist mit aktuellen Zertifikaten abgesichert. Der Pc hat ...

Windows Server
AD Replikation zwischen Standorten schlägt fehl nach Level auf 2008R2
diematrix125Vor 1 TagFrageWindows Server14 Kommentare

Hallo zusammen, ich habe ein (mittelschweres?) Problem mit dem AD. Ausgangssituation: Standort A: 3 DCs unter Win 2008R2 Standort B: 1 DC unter Win 2008R2 ...

Windows 10
Win 10 Fehler 0xc000000e und bootmbr fehlt
dressaVor 1 TagFrageWindows 1010 Kommentare

Hallo miteinander. Ein guter Kollege von mir kam auf mich zu weil sein PC mit wichtigen Daten nicht mehr läuft. Er hatte laut seinen Aussagen ...

LAN, WAN, Wireless
Gastnetzwerk für Restaurant mit FritzBox 4040
gelöst Net-ZwerKVor 6 StundenFrageLAN, WAN, Wireless11 Kommentare

Moin! Ich soll in einem kleinen Restaurant ein WLAN als Gastnetz einrichten. Aktuell ist vorhanden: Telekom Digitalisierungsbox Premium im Keller (macht ein WLAN, welches der ...