Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWünsch Dir wasWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Merkwürdiges Kollisions-Problem (?)

Mitglied: LordGurke

LordGurke (Level 3) - Jetzt verbinden

14.01.2011 um 22:54 Uhr, 4598 Aufrufe, 2 Kommentare

Hallo zusammen,

ich habe hier ein merkwürdiges Problem mit meinem Switch oder meiner Netzwerkkarte - das kann ich nicht so genau einkreisen.
Mir fiel auf, dass ich beim Kopieren von Dateien übers Netzwerk zu meinem Notebook auf einmal massive Geschwindigkeitsprobleme hatte.
Kopiere ich vom NAS eine Datei, habe ich dauerhaft zwischen 90 und 95 MBit/s Datendurchsatz. Kopiere ich jedoch von einem weiteren Netzwerkgerät zeitgleich eine weitere Datei, bricht die Geschwindigkeit auf etwas zwischen 20 und 60 MBit/s ein - ich bin es gewohnt, dass dann einfach die Netzwerkkarte ausgelastet ist und beide Dateien mehr oder weniger die Hälfte der verfügbaren Geschwindigkeit bekommen.

Nun habe ich mit Wireshark reingehorcht und festgestellt, dass immer wieder "previous segment lost" und "dup ack" auftaucht. Während das passiert, ist auch an diesem Switchport für etwa eine Sekunde keine Aktivität mehr. Sowas kenne ich nur von Hubs, wenn Pakete kollidieren. Aber eben das sollte ja an einem Switch nicht passieren
Ich gebe zu, dass dieser Switch kein Enterprise-Juniper-Gerät ist, aber durchaus ein für den Privatgebrauch bei mir ausreichender 16-Port-Switch von D-Link in 19"-Ausführung.
Zudem habe ich einen anderen Rechner an diesen Switchport angeschlossen und ebenfalls zwei Dateien übertragen - Ergbnis war eine Netzwerkkarte mit dauerhaft 99% Netzwerkauslastung, von daher will ich mal den Switch als Fehlerquelle ausschließen.
Während der kaputtgehenden Pakete bleibt der Link bestehen und die Geschwindigkeit bleibt bei 100MBit/s FD laut Switch-LEDs...
Da es sich beim ersten Gerät um ein Notebook handelt, kann ich da auch eher schlecht mal eben zum Testen die Netzwerkkarte tauschen


Gibt es eventuell noch andere mögliche Fehlerquellen, vielleicht auch Software-Seitig?
Mich verwundert halt, dass ich eine Datei mit praktisch voller Geschwindigkeit problemlos ziehen kann, aber der Transfer einer zweiten Datei reproduzierbar diese Probleme verursacht...


Schonmal vielen Dank für die Hilfe und viele Grüße aus dem Tal
Max
Mitglied: aqui
15.01.2011 um 11:36 Uhr
Hast du mal versucht den Switchport UND den Notebook Port fix auf 100 Mbit Fulldup zu setzen ?? LEDs kann man oft nicht trauen und die Symptome hören sich nach einem klassischen Autonegotiation zw. Port und NIC Problem an ?!
Bitte warten ..
Mitglied: LordGurke
22.01.2011 um 23:34 Uhr
Zwar spät, aber immerhin habe ich jetzt Gewissheit:
Der Switch ist doch Schuld.

Offensichtlich ist der interne Pufferspeicher dieses Switches defekt und fabriziert diese Fehler, wenn halt viele Pakete gepuffert weden (wenn ich von mehreren Geräten ziehe).
Ich habe gerade zum Testen einen geliehenen Switch angeschlossen und kann dieses Verhalten dort nicht feststellen.
Nun habe ich mit meinem Switch noch ein paar Tests mit Wireshark gemacht und festgestellt, dass generell auf allen Ports viele Pakete defekt sind. Bei normaler Internetnutzung habe ich etwa 10% defekte Pakete, am geliehenen Switch genau 0 defekte Pakete (von etwas über 85.000).
Werde den jetzt erstmal eine Nacht von allen Kabeln getrennt stehen lassen und morgen gucken, ob es vielleicht nur ein temporäres Phänomen war. Wenn nicht, habe ich dann wenigstens zwei Argumente für den neuen Gigabit-Switch
Bitte warten ..
Neue Wissensbeiträge
Monitoring

Unabhängiger Ansatz - IoT (frei von Cloud- oder Appzwang) - Hier mit Schaltsteckdosen

Anleitung von beidermachtvongreyscull vor 22 StundenMonitoring1 Kommentar

Tach Kollegen, ich erzähle Euch mal von meiner Ausgangslage und den/m Problem(chen) Ich benutze ein NAS zur Lagerung meiner ...

Microsoft
Microsoft Advanced Threat Protection for Linux
Information von Dani vor 3 TagenMicrosoft

Microsoft Defender Advanced Threat Protection (MD ATP) support for Linux with kernel version 3.10.0-327 or later, including the following ...

Humor (lol)
! ! Today ist SysAdmin-Day ! !
Information von VGem-e vor 4 TagenHumor (lol)5 Kommentare

Moin, "Happy Birthday" an alle Systemadministratoren, Mausschubser, System-/EDV-Betreuer, SysOps etc!! Siehe auch. Edit (Video hinzugefügt): Gruß VGem-e

Exchange Server
Basic Authentication and Exchange Online
Information von Dani vor 6 TagenExchange Server

Today we are pleased to announce some new changes to Modern Authentication controls in the Microsoft 365 Admin Center, ...

Heiß diskutierte Inhalte
Google Android
Handy gehackt ? - Gegemassnahmen
Frage von hushpuppiesGoogle Android26 Kommentare

Hallo zusammen, folgendes Szenario: Kollegin kommt heute zu mir und erzählt, dass ihre Tochter gestern über WhatsApp von einem ...

Google Android
Smartphone - Internes Radio auf Bluetooth Lautsprecher abspielen
Frage von emeriksGoogle Android25 Kommentare

Hi, vielleicht kann ja einer von Euch auch sowas beantworten. Ich habe hier ein Samsung Smartphone - S10 Lite. ...

Cloud-Dienste
Cisco 8841 - Enter activation code
gelöst Frage von c0d3.r3dCloud-Dienste21 Kommentare

Guten Morgen, ich habe gerade von einem Mitarbeiter den Hinweis bekommen, dass sein Telefon (Cisco 8841) einen Welcome-Screen mit ...

Windows Server
DCPromo bleibt bei Migration Server 2008R2 auf 2016 hängen
gelöst Frage von Leo-leWindows Server20 Kommentare

Hallo Forum, wir sind gerade dabei, unsere beiden DCs auf Server 2016 zu migrieren. Aktuell hängt der zusätzlich ins ...

Weniger Werbung?
Administrator Magazin
07 | 2020 In der Juli-Ausgabe beleuchtet das IT-Administrator Magazin den Themenschwerpunkt "Monitoring & Support". Darin zeigt die Redaktion unter anderem, wie Sie die Leistung von Terminalservern im Blick behalten und welche Neuerungen das Ticketsystem OTRS 8 mitbringt. Auch die Überwachung von USV-Anlagen darf nicht fehlen. In ...