Mozilla Firefox 60.9.0esr (autoconfig.js, mozilla.cfg) Konfigurationsdatei konnte nicht gelesen werden

Mitglied: Skrypz

Skrypz (Level 1) - Jetzt verbinden

13.02.2020, aktualisiert 11:33 Uhr, 1355 Aufrufe, 7 Kommentare

Hallo,

ich habe bei mir den Firefox 60.9.0esr 64bit installiert und will nun über eine autoconfig.js mit folgendem Inhalt:

pref("general.config.filename", "mozilla.cfg");
pref("general.config.obscure_value", 0);


auf die mozilla.cfg verweisen in der die Standardkonfigurationen für den Firefox in unserem Unternehmen vorhanden sind. Mit folgendem Inhalt:

COMMENT (DO NOT REMOVE)
lockPref("app.update.enabled", false);
lockPref("app.update.auto", false);
lockPref("app.update.mode", 0);
lockPref("app.update.service.enabled", false);
pref("browser.rights.3.shown", true);
pref("browser.startup.homepage_override.mstone","ignore");
defaultPref("browser.startup.homepage", "data:text/plain,browser.startup.homepage=https:
www.zensiert.de");
etc.............................


Die autoconfig.js liegt unter C:\Program Files\Mozilla Firefox\defaults\pref
Die mozilla.cfg unter C:\Program Files\Mozilla Firefox

Die Dateien werden per Skript das auf einem Netzlaufwerk liegt (genauso wie die zwei Konfigdateien) in den Installationsordner kopiert.
Das ganze wird über das Skript als Administrator ausgeführt somit sind auch alle Rechte vorhanden.

Beim ausführen von Firefox kommt dann folgende Fehlermeldung: "Konfigurationsdatei konnte nicht gelesen werden."
Sobald ich die autoconfig.js lösche bekomme ich diese Fehlermeldung nicht mehr.

Kann mir hier jemand weiterhelfen? Hab ich bei der Vorgehensweise was falsch gemacht? Evtl. habt ihr ja Beispiele wie ihr das in eurem Unternehmen regelt.
Mitglied: Luci0815
13.02.2020, aktualisiert um 11:56 Uhr
Es lässt sich zwar nicht alles per GPO verwalten, aber vielleicht kommst du damit aus? https://github.com/mozilla/policy-templates/releases

Den Update-Dienst kannst du bereits bei der Installation ausschließen:

Setup.exe /INI=install.ini

Inhalt ini:
[Install]
MaintenanceService=false
Bitte warten ..
Mitglied: 142970
142970 (Level 1)
LÖSUNG 13.02.2020, aktualisiert um 12:01 Uhr
Die Meldung weist zu 99 Prozent auf einen Syntax- oder Encodingfehler in den Config-Dateien hin
Der hier ist ebenfalls über ein Zeichen gestolpert.
https://unix.stackexchange.com/questions/317642/firefox-not-reading-defa ...
Da du deine Config hier nicht in Codeblocks gepostet hast können wir das leider nicht feststellen.

COMMENT (DO NOT REMOVE)
Außerdem fehlen hier ja die Commentzeichen (/ /) in der ersten Zeile deiner Config

https://support.mozilla.org/de/kb/firefox-mit-autoconfig-anpassen
Bitte warten ..
Mitglied: Skrypz
13.02.2020 um 11:54 Uhr
Hallo, danke für deine Hilfe aber wir haben derzeit noch kein AD. Wird erst mitte des Jahres intigriert.
Bitte warten ..
Mitglied: Luci0815
LÖSUNG 13.02.2020, aktualisiert um 12:06 Uhr
Ich mache es wie du, außer dass bei mir die js "local-settings.js" heißt.

Gibt es einen Grund, warum du die 60.9.0 einsetzt und nicht die aktuelle 68.5.0?
Bitte warten ..
Mitglied: Skrypz
13.02.2020 um 12:54 Uhr
Dankeschön!
Ja, sollte eigentlich alles passen.

Bei uns wird derzeit nur die 60.9 unterstützt bzgl. einer externen Firma.
Bitte warten ..
Mitglied: 142970
142970 (Level 1)
13.02.2020, aktualisiert um 13:02 Uhr
Meinen Hinweis zur Syntax und Encoding von oben geprüft oder übersehen?
Bitte warten ..
Mitglied: Skrypz
13.02.2020 um 13:18 Uhr
Ich bin gerade dabei aber es scheint die Lösung zu sein!!! Vielen vielen Dank!!
Bitte warten ..
Heiß diskutierte Inhalte
Firewall
PfSense direkt an Glasfasermodem der Telekom über PPPoE
snah0815Vor 1 TagFrageFirewall24 Kommentare

Hallo Zusammen, nachdem ich die pfSense nun eine Zeit lang in einer Kaskade mit einer Fritzbox 7590 betrieben habe, möchte ich nun gerne die ...

Netzwerkmanagement
TIA568A oder B - Leistungsunterschiede oder egal?
gelöst alboshiroVor 1 TagFrageNetzwerkmanagement15 Kommentare

Hallo Zusammen, ich bin aktuell im Hausbau und habe in jedem Zimmer ein RJ45 CAT7 Ethernetkabel für jeden Raum verlegt. Jetzt müsste ich die ...

Internet
Kein Internet nach Windows 2019 Server Installation
gelöst ZygmundVor 21 StundenFrageInternet24 Kommentare

Computer : HP ProLiant DL580 Gen7 , 4x CPU , 16 GB ECC Ram, 1 TB SAS Installation von - Windows 8 Server - ...

LAN, WAN, Wireless
WLAN-ACCESSPOINT welche soll ich mir kaufen?
samet22Vor 1 TagFrageLAN, WAN, Wireless11 Kommentare

Hallo :) Ich halte mich kurz: Ich möchte mir neue WLAN-Accesspoints für die Firma kaufen da die jetzigen fast 7 Jahre alt sind und ...

Webentwicklung
Wo legt Joomla den Content im Verzeichnis ab ?
MachelloVor 1 TagFrageWebentwicklung17 Kommentare

Hallo Zusammen, ich habe folgendes Problem: Ich benötige Daten aus einer alten Joomla Webseite. Von dieser Webseite habe ich nur das komplette Verzeichnis vom ...

Monitoring
PC Monitoring Software?
TRON06Vor 1 TagFrageMonitoring9 Kommentare

Gibt es eine Monitoring Software (ähnlich wie HWiNFO) mit der man mehrere Computer überwachen kann (CPU auslastung, Festplatte, Temperatur Sensoren) und wo die Daten ...

Netzwerke
DHCP-Probleme nach Switch-Wechsel
gelöst sausi77Vor 1 TagFrageNetzwerke7 Kommentare

Folgendes Problem: - hab meinen Switch gewechselt: vom Zyxel GS1900-24E auf einen Zyxel XGS1930 Seitdem haben mobile Clients (insbesondere auf iOS und Windows-Basis Probleme) ...

Windows 10
Vom Homeoffice auf lokale Dateien zugreifen
SayllesVor 23 StundenFrageWindows 106 Kommentare

Guten Morgen, meine Frau ist im Homeoffice, ihr Arbeitgeber stellt ihr einen Access der unter Server 2016 lauft zur Verfügung. Dieser Remote zugriff funktioniert ...