Dieser Beitrag ist schon älter. Bitte vergewissern Sie sich, dass die Rahmenbedingungen oder der enthaltene Lösungsvorschlag noch dem aktuellen Stand der Technik entspricht.

Netzdrucker druckt unter XP SP1 nur mit Admin-Rechten

Mitglied: hera
Hallo,

das ist meine erste Frage nachdem ich etliche Beiträge zu diesem Thema gelesen habe.
Wir haben hier im Büro ein LAN mit WinXP SP1-Rechnern sowie einem KONICA 7013 Multifunktionsgerät.
Alle Rechner sind über einen Switsch verbunden und können über ICS sowohl korrekt ins Internet als auch
gegenseitig die freigegebenen Ordner erkennen und nutzen.
Der Konica ist direkt an einen der Rechner angeschlossen und im Netzwerk freigegeben. Treiber sollen und werden automatisch
verteilt, da ja alle das gleiche OS benutzen.
Ich kann auf den Clients den Drucker als Netzwerkdrucker installieren. Wird also auch im Netzwerk erkannt. Treiberinstallation erfolgt
auch ohne Probleme. Nach dem Drucken am Client passiert nichts weiter. Keine Fehlermeldung !! Der Drucker macht aber
absolut nichts.
Wenn ich vom Client als Admin drucke funktioniert es.
Die User dort sollen aber keine Admin-Rechte haben.

Wie kann mir geholfen werden ?

Danke!!

Content-Key: 6006

Url: https://administrator.de/contentid/6006

Ausgedruckt am: 24.07.2021 um 02:07 Uhr

Mitglied: Kirschi
Kirschi 24.01.2005 um 15:21:45 Uhr
Goto Top
Hallo,
wenn Du auf den Clients als Admin drucken kannst, checke mal die Rechte des Druckers (Rechtsklick > Eigenschaften > Sicherheit) Dort sollte der Benutzer "Jeder" auftauchen mit dem Recht zu drucken. Testweise kannst Du ja auch mal alle Rechte für "Jeder" freigeben.
Dann noch zwei Gedanken:
1. Du verwendest schon die richtige Software vom Hersteller?
2. Hat die Kiste einen Paralellport-Anschluß? Dann könntest Du einen "ordentlichen" Printserver verwenden...

Gruß Andreas
Mitglied: hera
hera 24.01.2005 um 17:20:02 Uhr
Goto Top
Hallo,
zunächst Dank für deine Antwort und den Willen zu helfen !

Da ich in Polen lebe und arbeite habe ich hier eine engl. WinXP-Version mit SP1 und allen
Updates außer dem SP2.
zu 1: es werden die offiziellen Treiber von Konica verwendet welche dem Gerät für XP beilagen. Funktionieren ja sonst auch einwandfrei.
zu 2: da der Drucker an einem etwas älteren P3 ohne USB hängt, wurde er extra mit Parallel-Port-Anschluß gekauft.

Mein eigentliches Problem: ich habe weder als Admin noch als anderer Nutzer einen Punkt "Sicherheit" ( dann natürlich engl. ) beim Drucker.

Wo kann ich das sonst finden ? Habe generell unter XP mit Nutzer- und Rechteverwaltung keine große Ahnung.


Noch eine Idee ??

Nochmals Danke!
Mitglied: Kirschi
Kirschi 24.01.2005 um 18:13:52 Uhr
Goto Top
Hallo hera,

Wenn der Punkt "Sicherheit" fehlt: vielleicht arbeitest Du dann mit Windows XP Home Edition? Zu Hause arbeite ich auch mit der Windows Druckerfreigabe (XP Home und Pro) auf meinen beiden Rechnern ohne Probleme.
Ist überall die Datei- und Druckerfreigabe installiert ( Netzwerk > Eigenschaften der jeweiligen Netzwerkverbindung/karte) und auch die ! Windowsfirewall ! konfiguriert? Leider habe ich schon SP 2 installiert, sodaß ich das jetzt nicht überprüfen kann, was man bei der XP-SP1 Firewall alles einstellen kann und muß.

In der Firma setzen wir fast überall Printserver ein. Schau mal hier http://www.seh.de/deutsch/products/ps3/ic105/ic105txt.htm
Es gibt natürlich auch noch andere Hersteller, auch bei eBay bekommt man diese Geräte günstiger.
Das "Ding" wird einfach am Parallelport des Druckers angeschlossen und an der anderen Seite ins Netzwerk gehängt (RJ45 Stecker). Meist weist man dann eine feste IP-Adresse zu und erstellt mit der mitgelieferten Software einen virtuellen Port (das muß auf jedem Client geschehen) und ordnet diesem Port den Druckertreiber zu. Damit hast Du den Vorteil, daß nicht immer der Rechner angeschalten sein muß, an dem jetzt der Drucker am Parallelport hängt.
Vielleicht helfen Dir diese Infos weiter, wenn nicht, melde Dich einfach wieder

Viele Grüße Andreas
Mitglied: hera
hera 25.01.2005 um 09:34:30 Uhr
Goto Top
Hallo Andreas,

wir haben hier in einem Büro 4 Rechner die alle XP Pro SP1 laufen haben und mit Admin-Rechten
benutzt werden, da es sonst mit einigen Progs wohl Probleme gibt. Alle an einem Switch. Zwei Netzwerkdrucker können so ohne Probleme genutzt werden. Sind an verschiedenen Rechnern angeschlossen ( 1x USB, 1x parallel ) und ganz normal freigegeben. Alles läuft.
Zwei weitere Rechner sind ebenfalls über diesen Switch angeschlossen, werden aber ausschließlich
von Außendienstmitarbeitern abwechselnd genutzt um ihren "Bürokram" zu erledigen.
Dazu wurden mehrere Benutzer eingerichtet. Man kann auch hier die Netzdrucker sehen und konfigurieren. Man kann auch aus Word heraus auf diese Drucker einen Job schicken.. Das war dann aber alles. Keine Fehlermeldung am Rechner - kein Ausdruck am Drucker.
Im Druckmanager bleibt allerdings der Auftrag ewig hängen.

Auf einem Laptop läuft XP Home. Dort funktioniert nach dem Anschließen ans Netz auch alles. Aber eben auch als Admin.

Noch eine Idee ???

Gruß Hera
Mitglied: Kirschi
Kirschi 25.01.2005 um 13:28:03 Uhr
Goto Top
....mhhh schwerer Fall
Funktioniert denn der Druck, wenn Du Dich als "Echter Admin" anmeldest (also 2 mal Strg+Alt+Entf) ?
Dan fällt mir noch die "Schnelle Benutzerumschaltung" ein, eventuell mal deaktivieren.
Habt ihr einen 2. Drucker zum Test?
Eventuell in PDF drucken?
Dann bin ich auch erstmal am Ende mit den Ideen... Vielleicht finde ich noch was bei Google...

Viele Grüße Andreas
Mitglied: Kirschi
Kirschi 25.01.2005 um 13:37:18 Uhr
Goto Top
Gerade noch eine Idee gehabt:
Ich habe mal testweise auch auf eine Freigabe gedruckt, als Port ist LPT1 eingestellt?

eventuell die bidirektionale Unterstützung deaktivieren

Druckprozessor (auf der Eigenschaften > Erweitert Seite des Druckers) ist bei mir
IMF-Print, was steht da bei Dir?

Andreas
Mitglied: hera
hera 25.01.2005 um 15:36:09 Uhr
Goto Top
Hallo Kirschi,

hab jetzt mal einen anderen "persönlichen" Drucker freigegeben. Die Einstellungen sind soweit
ich das sehen kann identisch. Ich habe hier als Druckprozessor übrigens "WinPrint - RAW".
Von IMF-Print keine Spur.
Dieser zweite Laserdrucker funktioniert auch für Nicht-Administratoren. Aber genau dieser Drucker hängt per USB am Chef-Laptop und ist damit nicht immer für alle zugänglich. Soll er
übrigens auch nicht sein - is halt vom Chef.
An beiden Druckern ist bidirektional eingeschaltet und Port ist korrekt auf LPT1.

Ich habe generell noch die Frage warum ich kein Tab "Sicherheit" sehe.

Mir gehen hier auch bald die Ideen aus.

Trotzdem Danke für alle Hilfe, vielleicht fällt dir noch was ein.

Hera
Mitglied: hera
hera 25.01.2005 um 15:50:39 Uhr
Goto Top
kleiner Nachtrag:

Hab also in einem funktionierenden LAN zwei lokal völlig korrekt laufende Drucker
freigegeben. Diese lassen sich an allen Client-Rechnern auch von normalen Benutzern
ganz normal einrichten. Sonst keine Einstellungen verändert. Treiber original vom Hersteller.

Einer druckt auch bei Nicht-Administartoren der andere eben nur bei Administratoren !!!

Kann das rein am Treiber liegen ???

Hera
Mitglied: Kirschi
Kirschi 26.01.2005 um 09:49:44 Uhr
Goto Top
Hallo Hera,

so langsam bin ich auch am Zweifeln: Als ich gestern auch mal eine Testumgebung aufgebaut habe, hatte ich Probleme beim Ausdrucken der Testseite. Erst kam gar nichts raus, wenn ich von einem anderen PC gedruckt habe, nachdem ich dann von Word aus ein Dokument mit Bildern in Auftrag gegeben habe kam das auch raus, aber der Rechner, an dem der Drucker angeschlossen ist, druckte nur wilde Zeichen, Stenchen, Smilies....
Danach habe ich den Origrinal-Treiber (es ist übrigens ein HP 1015) bzw. die komplette Software von HP runtergeschmissen und den Drucker mit dem Standalone Treiber von der HP-Webseite installiert und wieder freigegeben und siehe da, seitdem funktioniert das.

Was mich wirklich stutzig macht, daß bei Dir der Sicherheits-Reiter fehlt...
Ich versuch mal ein Bild hochzuladen, wie das aussehen sollte
http://akirsch.privat.t-online.de/bild/bild.jpg
(kann aber ne Weile dauern, bis das Bild oben ist, muß erstmal den Upload aus dem Firmennetz hinbekommen).
Sonst habe ich vorerst auch keine Idee weiter...
Viele Grüße
Andreas
Mitglied: hera
hera 26.01.2005 um 12:19:09 Uhr
Goto Top
Hi Andreas,

ich hoffe ich verbreite hier nicht zu viel Verwirrung.
Das Bild ist schon echt nett, mir aber leider VÖLLIG unbekannt. Hab ich definitiv auf keinem
der Rechner wo ein Drucker freigegeben ist.
Muß dazu auf diesem Rechner zwangsweise ein weiterer "normaler" Nutzer eingerichtet werden ?
So weit ich weiß, arbeiten die Kollegen hier jeweils als Admin am eigenen Rechner.
Wie schon geschrieben, nur an den zwei Clients für Außendienstler sind mehrere Nutzer
konfiguriert.

Setzt diese Rechteverwaltung irgendwelche besondere Installation oder Option vorraus ?
Es ist jeweils Win XP Prof. SP1.

Sehr merkwürdig......

Gruß
Hera
Mitglied: Kirschi
Kirschi 26.01.2005 um 14:51:02 Uhr
Goto Top
Hallo Hera,

neine das ist eine ganz normale XP Pro Installation, selbst wenn der Benutzer nicht mit Adminrechten drin ist, müßte der Reiter "Sicherheit" sichtbar (dann nicht editierbar) sein. Auch Ordner haben den Reiter "Sicherheit". Ich weiß nicht, ob mehrere Benutzer eingerichtet sein müssen, um diese Option zu Gesicht zu bekommen.
Was auch sein kann, daß ihr mit Gruppenrichtlinien arbeitet? Da kenne ich mich aber leider nicht aus, da wir das hier noch nicht nutzen (Novell-Server).
Wirklich sehr merkwürdig, mal sehen vielleicht fällt mir noch was ein...

Andreas
Mitglied: Kirschi
Kirschi 26.01.2005 um 15:32:35 Uhr
Goto Top
Lösung für das Register Sicherheit:

Explorer öffnen > Extras > Ordneroptionen > Ansicht: "Einfache Dateifreigabe verwenden" Häkchen raus !

Andreas
Mitglied: hera
hera 27.01.2005 um 12:29:19 Uhr
Goto Top
Hallo Andreas,

das mit dem Reiter "Sicherheit" hat jetzt wirklich funktioniert !
Ein Problem weniger.

Mit dem Drucker kann ich erst später wieder probieren.

Besten Dank!!!

Hera
Mitglied: fLeTCHeR
fLeTCHeR 28.01.2005 um 15:40:19 Uhr
Goto Top
hallo,

um das problem mit den admin rechten zu lösen kannste du wiefolgt tricksen. schreib dir eine batch datei (*.bat) in dem du ein Netzlaufwerk verbindest (DruckerPC) und gleich anschließend wieder trennst, oder auch auch nicht, überlass ich dir. Mit dem Netzlaufwerk verbindest du dich als Admin (Name und PW in der Batchdatei!!!) dann lädts du diese batch beim anmelden jeden users, (eintrag registry). Richte aber bitte einen lokalen Admin auf dem DruckerPC ein. Dann hast du keine probleme mehr...

Vorsicht! Allerdings ist der Nachteil an dem Trick, dass ein user die batch datei finden kann und sich dann als admin auf dem druckerPC anmelden kann. Wenn das nichts weiter ausmacht, kannste das ja so machen. Meistens sitzen ja eh nur DAUs in einem Büro.

gruß fLeTCHeR
Heiß diskutierte Beiträge
general
Kosten nicht gerechtfertigt? Dienstleister stellt Kosten für "Troubleshooting" bei Neuanschaffung von HCI + CoreSwitchDirty2186Vor 1 TagAllgemeinZusammenarbeit17 Kommentare

Hallo Zusammen, ich interessiere mich für Eure Meinung zu dem Thema Leistungsnachweise von Systemhäusern und Dienstleistern und deren Berechnung von Leistungen. Da sich hier ja ...

question
RAM-Zugriff auf einem neuen High-Performance Server, teilweise um Welten langsamer als auf einer WorkstationMysticFoxDEVor 12 StundenFrageBenchmarks31 Kommentare

Moin Zusammen, mir ist gestern beim Optimieren eines neuen Servers eine Sonderheit aufgefallen, die ich mir so beim besten Willen, momentan absolut nicht erklären kann. ...

info
Phishing Mail mit schädlichen Images in freier Wildbahn (.IMG Datei)wolfbleVor 1 TagInformationViren und Trojaner12 Kommentare

Moin Moin an alle Gestern bekam ich eine EMail mit irgendwelchen komischen Sepa Einzugsankündigungen die man angeblich der angehängten Datei entnehmen kann. Ging so um ...

question
Listet Microsoft Default ACLs von Windows?DerWoWussteVor 1 TagFrageSicherheit18 Kommentare

Moin Kollegen. Nach dem Sicherheits-GAU "Hivenightmare" stellt sich mir die Frage, wie ich in Zukunft sicherstellen kann, dass die ACLs der Systemdateien in Windows korrekt ...

question
Erfahrungen mit CodeTwo Exchange Migration von 2016-2019dlohnierVor 1 TagFrageExchange Server18 Kommentare

Hallo, ich möchte unseren Exchange Server 2016 der noch auf WIndows 2016 läuft auf einen Server 2019 mit Exchange 2019 migrieren. Habe das Tool "CodeTwo ...

question
Doppelte A-Records in DNSBPeterVor 1 TagFrageWindows Server10 Kommentare

Hallo, unsere Windows Notebooks registrieren sich im DNS mit ihrer Lan- und Wlan Adresse. D.h. es gibt 2 gleiche Namen mit 2 unterschiedlichen IP-Adressen. Wie ...

question
AD-Domäne über VPN beitreten -Ist das möglich?EnrixkVor 1 TagFrageWindows Netzwerk9 Kommentare

Hallo, ich bräuchte mal einen Rat von einem Netzwerkprofi. Ich habe bei mir zuhause ein Heimnetzwerk mit AD-Domäne, entsprechenden Ordnerfreigaben, NAS und servergespeicherten Windows-Profilen. Wenn ...

question
Abschlussprojekt - FiSi gelöst VerbranntesHuhnVor 1 TagFrageWeiterbildung6 Kommentare

Hallo zusammen, ich bin derzeit auf der Suche nach einem Abschlussprojekt (max. 35 Stunden) - Abgabe des Antrags - Stichtag 02.08.2021. Ich weiß jedoch nicht ...