Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

nmbd stürzt reproduzierbar ab

Mitglied: 51dm

51dm (Level 1) - Jetzt verbinden

17.01.2007, aktualisiert 24.05.2007, 2594 Aufrufe, 1 Kommentar

moin helfende

es geht um einen fileserver mit suse 8.1 und samba 2.2.5
seitdem es im netzwerk einen neuen netzwerkdrucker (OKI C5700n) gibt, erscheint der fileserver bei den windows-clients nicht mehr in der arbeitsgruppe (kein domainnetz, da nur 8 clients).
bisherige fehleranalyse:
die ursache, dass der fileserver nicht mehr unter seinem namen und nur noch via IP erreichbar ist, ist der absturz des nmbd. dieser deamon ist zumindest nicht mehr aufgeführt wenn ich
ps auwwwx | grep nmbd
ausführe. um zu prüfen warum der nmbd abstürzt, habe ich ihn manuell mit
nmbd -d 9
(hohes debuglevel) neu gestartet.
nach analyse des logfiles (log.nmbd 75KB) scheint folgendes zu passieren:
- der nmbd schickt nach dem start eine broadcastmessage
- der drucker antwortet darauf (sichtbar an der ID im header des paketes)
- der nmbd stürzt ab
m.E. gibt es nur 2 mögliche ursachen oder es ist die kombination von beiden:
1. das antwortpaket des druckers ist fehlerhaft. dafür spricht, dass dieses nur aus aus dem header besteht und nicht wie pakete von anderen netzwerkteilnehmern aus header und answer und/oder question (siehe logfile).
2. die verarbeitung des nmbd von fehlerhaften paketen ist nicht ausreichend abgesichert.
das ganze ist im fünfminutentakt reproduzierbar
ein firmwareupdate für den drucker scheint es auch nicht zu geben. da ich diesen fileserver vor 4 jahren installiert habe und seitdem nix mehr mit linux zu tun hatte, scheue ich mich einfach drauf los den samba upzudaten, da ich weder weiß welche weiteren folgen das hat, noch wie man das bewerkstelligt.

ich hoffe das ganze ist als problembeschreibung ausführlich genug und ich bin für jede hilfe dankbar
Sommer, Sonne, Sonnenschein
Dirk
Mitglied: MahaGoni
24.05.2007 um 19:43 Uhr
Hallo Dirk,

leider kann ich Dir nur in sofern weiterhelfen, als daß ich das gleiche Problem habe. Auch der nmbd meiner SuSE 8.2 Kiste hängt sich alle paar Minuten weg. Auch ich habe seit kurzer Zeit einen OKI gleichen Modells im LAN.
Ich hatte ihn schon auch im Verdacht, wollte es aber irgendwie nicht glauben. Durch Deinen Beitrag
komme ich jetzt erst zu dem Zusammenhang, daß mein Problem immer so um die gleiche Zeit anfängt, wenn die ersten Benutzer ihre Geräte einschalten, darunter eben auch der OKI.

Alle meine Samba 3x Kisten bleiben davon unbeeindruckt und laufen stabil.

Falls ich auf meiner Seite eine Lösung finde, schreibe ich natürlich. Bis jetzt bin ich zu dem Schluß gekommen, daß ein Update des Samba wohl für mich die schnellste Lösung zu sein scheint.

Danke und Gruß,
Michael
Bitte warten ..
Neue Wissensbeiträge
Windows 10

Windows 10 - Programme laufen schneller, wenn Sie mit Administratorrechten ausgeführt werden !

Erfahrungsbericht von 1Werner1 vor 10 StundenWindows 106 Kommentare

Moin, das wollte ich erst nicht glauben, aber es ist so. Wenn Ihr ein Programm mit Administratorrechten unter Windows ...

Sicherheits-Tools
Putty hat heftige Bugs korrigiert!
Information von Lochkartenstanzer vor 1 TagSicherheits-Tools5 Kommentare

Moin, Wie man aus herauslesen kann, sind in den Versionen vor 0.71 gravierende Bugs, die es angeraten erscheinen lassen, ...

Off Topic
Sachen die die Welt nicht braucht - Platz 1
Tipp von brammer vor 4 TagenOff Topic21 Kommentare

Hallo, ich habs als Tipp angelegt als Erfahrungsbericht nein Danke brammer

Humor (lol)
Spirit of Health-Kongress in Berlin
Information von AnkhMorpork vor 4 TagenHumor (lol)6 Kommentare

tgif! Beim dritten Spirit of Health-Kongress trafen sich am Wochenende Alternativmediziner und Naturheilkundler im Maritim Hotel Berlin, um sich ...

Heiß diskutierte Inhalte
Hardware
Telefonanlagen - Welche gibt es
Frage von Xaero1982Hardware18 Kommentare

Nabend Zusammen, ich suche eine neue TK Anlage und mein Auftraggeber will jetzt was völlig neues - State of ...

Windows Server
Eingeschränkte Gruppen - Spezielle Benutzergruppe hinzufügen
Frage von killtecWindows Server17 Kommentare

Hallo, ich möchte gerne folgendes Realisieren: Ich habe bei mir Eingeschränkte Gruppen via GPO aktiv und möchte nun der ...

LAN, WAN, Wireless
Intel(R) PRO Wireless 3945ABG
gelöst Frage von Leon509LAN, WAN, Wireless15 Kommentare

Hallo, habe ein Laptop Fujitsu (Intel, 4GB, 2GHz, Windos10, Intel(R) PRO/Wireless 3945ABG ) ein O2 DSL Anschluss Home50. Leider ...

Microsoft Office
Videodateien auf Windows Server 2008 R2 öffnen schlägt fehl
Frage von SchroediMicrosoft Office14 Kommentare

Hallo zusammen, wir haben das Problem das embedded Videos in PowerPoint (O365) auf unserer Citrix Farm (6.5) nicht abgespielt ...