Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Kann Pakete senden aber nicht empfangen!

Mitglied: Assimilator

Assimilator (Level 1) - Jetzt verbinden

12.03.2008, aktualisiert 18.10.2012, 9651 Aufrufe, 4 Kommentare

Hallo,

ich habe folgendes Problem:

Konfiguration:
- Rechner: ASUS P5E-VM DO Motherboard mit Onboard-Gigabit-LAN
- auf dem MB sind 2 PCI-Steckplätze, in beiden Steckplätze befindet sich eine weitere Netzwerkkarte (habe mehrere unterschiedliche ausprobiert und getauscht, immer dasselbe Ergebnis!)
- OS ist Linux (openSuSE 10.3 und Ubuntu habe ich getestet - immer dasselbe Ergebnis!)
- Die PCI-Netzwerkkarten hängen an einem Hub, an dem sonst nur noch ein Test-Notebook hängt und während der Pingvorgänge den Datenverkehr sniffert.

Zusätzliche Infos:
- Ich möchte kein Routing zwischen den Netzen bzw. NIC.
- Sämtliche Firewalls sind nachweislich inaktiv

Nun zum Problem:
Die Onboard-Schnittstelle funktioniert fehlerfrei.
Die PCI-Schnittstellen lassen sich einwandfrei konfigurieren und werden problemlos vom OS erkannt. Der Sniffer verrät mir, dass beide NIC zwar Datenpakete senden, aber nur ganz sporradisch mal ein ankommendes Paket empfangen, obwohl es fehlerfrei auf der Leitung liegt.

Kennt jemand das Problem, dass eine Netzwerkkarte fehlerfrei sendet, aber nur gelegentlich mal ein Paket empfängt?!?
Mitglied: iVirusYx
12.03.2008 um 22:46 Uhr
Defektes Netzwerkkabel wäre zu denken.
Du benutzt ja auch ein normales Straight-Through Kabel un dein Cross?

Erm... du sagst HUB... meinst du wirklich ein echter alter HUB oder nicht doch ein Switch, denn da gibt es in der Informatiwelt unterschiede, wenn du dich mit PCs auskennst dann weisst du das ja
Denn mit einem HUB könnte ich mir denken dass es zu Kollisionen kommen kann.

Hast du mal ein normal PAN-Netz versucht? Also PC auf PC ?
Bitte warten ..
Mitglied: brammer
12.03.2008 um 22:46 Uhr
Hallo,

was hast du den auf den Karten als default Gateway eingetragen?
Und, existiert das Problem immer oder nur wenn beide Karten gleichzeitig aktiv sind?

brammer
Bitte warten ..
Mitglied: Assimilator
12.03.2008 um 23:19 Uhr
@BlackFear:
Ich kenn' den Unterschied HUB vs. Switch . Es ist tatsächlich ein HUB. Dort kann man zumindest den gesamten Verkehr problemlos sniffern... . Es handelt sich um einen 8-Port-HUB, an dem nur der Rechner und das Notebook angeschlossen ist (Testaufbau), daher glaube ich nicht, dass es zu (übermäßige) Probleme mit Kollisionen kommt.
Ich hab' hier leider kein Crossed-Kabel zur Hand; daher habe ich die direkte Verbindung nicht explizit getestet.

@brammer:
Das Problem besteht jederzeit; egal wieviele und welche Karten eingebaut sind.
Ich will drei, von einander getrennte Netze betreiben (ohne Routen untereinander):
192.168.0.xxx
192.168.1.xxx
192.168.2.xxx
Nur im ersten Netzwerk gibt es ein Gateway (192.168.0.1); das ist auch so eingetragen.

Ich vermute, dass es evtl. zu einem Interrupt-Konflikt kommt. Bei "ifconfig" wird beim Onboard-NIC kein Interrupt angezeigt, bei 1. PCI-NIC IRQ 10, bei PCI-NIC IRQ 11. Sämtliche Konfigs scheinen OK zu sein. Da die Onboard-Schnittstelle keinerlei Probleme macht und der Unterschied zu den anderen NIC die Anbindung via PCI ist, denke ich, dass es irgendwo daran liegt...
Bitte warten ..
Mitglied: aqui
14.03.2008, aktualisiert 18.10.2012
Achtung dies ist ein Doppel zu:

https://www.administrator.de/forum/opensuse-10.3-keine-netzwerkverbindun ...


Ob das ein Interrupt Konflikt ist kannst du ja ganz einfach mal testen, indem du die Karte ohne Interrupt Zuweisung einmal ziehst und dann nochmal testest was ein Ping sagt...
Bitte warten ..
Ähnliche Inhalte
Exchange Server

"Send on Behalf anstelle" von "Send as"

gelöst Frage von arduinoExchange Server3 Kommentare

Hallo Wir haben auf unserem Exchange 2010 verschiedene Shared Mailboxen, die von Usern mit der Send-as Berechtigung genutzt werden. ...

Netzwerkmanagement

Plink cant send yes?

gelöst Frage von q16marvinNetzwerkmanagement5 Kommentare

i want to use plink for a batch ssh like this: mac_auth_anschalten.cmd: but it stops here: so how can ...

LAN, WAN, Wireless

TCP IP Paket einschleusen

gelöst Frage von pd.edvLAN, WAN, Wireless10 Kommentare

Hallo. Ich habe einen relativ einfachen Server und einen kleinen Sniffer geschrieben, der auf die Pakete lauscht und dann ...

Netzwerkgrundlagen

Funktionsprinzip: Ethernetframe u. IP-Paket

Frage von anrivaxdNetzwerkgrundlagen3 Kommentare

Hallo Leute, Ich möchte grob verstehen, wie ein Ethernetframe (auf einem PC) von wem, wie erstellt wird, welche Prozeduren ...

Neue Wissensbeiträge
iOS
WatchChat für Whatsapp
Tipp von Criemo vor 1 TagiOS3 Kommentare

Ziemlich coole App für WhatsApp User in Verbindung mit der Apple Watch. Gibts für iOS sowohl als auch für ...

iOS
IOS hat nen Cursor !!!
Tipp von Criemo vor 2 TageniOS5 Kommentare

Nette Funktion im iOS. iPhone-Mauszeiger aktivieren „Nichts ist nerviger, als bei einem Tippfehler zu versuchen, den iOS-Cursor an die ...

Off Topic
Avengers 4: Endgame - Erster Trailer
Information von Frank vor 4 TagenOff Topic2 Kommentare

Ich weiß es ist Off Topic, aber ich freue mich auf diesen Film und vielleicht geht es anderen hier ...

Webbrowser
Microsoft bestätigt Edge mit Chromium-Kern
Information von Frank vor 4 TagenWebbrowser5 Kommentare

Microsoft hat nun in seinem Blog bestätigt, dass die nächste Edge Version kein EdgeHTML mehr für die Darstellung benutzen ...

Heiß diskutierte Inhalte
Windows Netzwerk
Kerio. Kann keine Mails empfangen aber senden. Wer ist schuld. Kerio oder Windows domäne?
gelöst Frage von frosch2Windows Netzwerk33 Kommentare

Hallo, es existiert ein Problem bei uns mit dem mailen. Alle bestehenden Nutzer können mailen. Raus wie rein. Neuen ...

LAN, WAN, Wireless
WLAN und Ausmessung - Eine Glaubensfrage?
Frage von ptr2brainLAN, WAN, Wireless23 Kommentare

Liebe Experten, als Sys-Admin habe ich mir schon öfter die Frage gestellt, ob es sich beim Thema WLAN und ...

Hosting & Housing
VMware VM mit über 1TB RAM für S4HANA
Frage von Leo-leHosting & Housing22 Kommentare

Hallo zusammen, wer hat Erfahrng und kann mir einen Tipp zum sizing von S4HANA Systemen geben? Wir möchten, zunächst ...

Virtualisierung
Gebrauchte Server Hardware als Virtualisierungs-"Spielwiese"?
Frage von NixVerstehenVirtualisierung19 Kommentare

Einen wunderschönen guten Morgen zusammen, ich möchte mich gerne etwas tiefer mit dem Thema Virtualisierung beschäftigen und dazu ein ...